VisioWave SDK: Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
XVWDISPLAYLib::_IVWActiveXComponentEvents | Interface for the VWActiveXComponent ActiveX events
VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents | Interface for the VWAudioOutputCtrl ActiveX events
VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents | Interface for the VWAudioSvrCtrl ActiveX events
XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents | Interface for the VWConnectionCtrl ActiveX events
VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents | Interface for the VWDigitalInputCtrl ActiveX events
VWEVENTCONTROLLERLib::_IVWEventCtrlEvents | Interface for the VWEventCtrl ActiveX events
VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events | Interface for the VWMobCamSvrCtrl2 ActiveX events
VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events | Interface for the VWMonitorManagerCtrl2 ActiveX events
VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents | Interface for the VWRelayOutputCtrl ActiveX events
VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents | Interface for the VWRemoteMonitoringCtrl ActiveX events
VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents | Interface for the VWStorageAccessCtrl ActiveX events
VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents | Interface for the VWStorageManagerCtrl ActiveX events
XVWTIMELINELib::_IVWTimeLineEvents | Interface for the VWTimeLine ActiveX events
VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents | Interface for the VWVideoEquipmentManagerCtrl ActiveX events
VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events | Interface for the VWVideoSvrCtrl2 ActiveX events
XVWDISPLAYLib::IVWActiveXComponent | This ActiveX control allows to decode in software audio and video flows either streamed from the network, captured locally or taken from a VisioWave encoded file. It also allows to redirect those flows onto a VisioWave codec output channel in order to display it on an analog monitor as well as to store the flows locally. It can also display video processing plugin output (for example, activity regions in the motion detector plugin). See the VWActiveXComponent_VC6 sample for a small example in Visual C++ on how to use it
VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl | This ActiveX control allows to remote control audio playback on equipments with preconfigured audio outputs. The ActiveX control can establish playback of either audio sources captured in real time by VisioWave equipments located anywhere on the network, MP3 files local to the equipment or playback of previously recorded audio content again anywhere on the network (using the VWStorageAccessController and XVWTimeLine ActiveX controls). It can also be used to capture and stream audio locally in respect to the ActiveX control. See the VWAudioOutputCtrl_VB sample for a small example in Visual Basic on how to use it
VWSERVERCONTROLLERLib::IVWAudioSvrCtrl | This ActiveX control allows to remotely query real time audio capture parameters as the bandwidth configured, the bandwidth used,... on equipments with preconfigured audio inputs. See the VWAudioSvrCtrl_VB sample for a small example in Visual Basic on how to use it
XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl | This ActiveX control presents a simple GUI which can be used to unify the connection establishment GUI for all of the examples. In order to connect it to a given VisioWave SDK ActiveX control, call the control's GetId() method and pass its return value to this control's SetId() method
VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl | This ActiveX control allows to remote control digital inputs on equipments equipped with digital I/O cards. It allows to query the state of the digital inputs. See the VWDigitalInputCtrl_VB sample for a small example in Visual Basic on how to use it
VWEVENTCONTROLLERLib::IVWEventCtrl | This ActiveX control allows to send and receive event notifications available on VisioWave Security Networks. Events can be used to initiate various actions as switching audio and/or video outputs to predefined sources, start or end storages or for private messaging purposes. A predefined set of system events is available in order to be notified of important system events, as for example the loss of synchronization on a video input, health monitoring values out of range (for example system temperature) or the detection of movement throught the Motion Detector video processing plugin. See the VWEventCtrl_VB sample for a small example in Visual Basic on how to use it
VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2 | This ActiveX control allows to remote control digital PTZ cameras
VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2 | This ActiveX control allows to remote control analog video playback on equipments with preconfigured analog video outputs. equipments with preconfigured audio outputs. The ActiveX control can establish playback of either video sources captured in real time by VisioWave equipments located anywhere on the network, VisioWave encoded video files local to the equipment or playback of previously recorded video content (using the VWStorageAccessController and XVWTimeLine ActiveX controls) again anywhere on the network. It supports the notion of cycles which allows the user to program predefined sequences of sources which will rotate in the given order. Also supported is to configure backup sources in case of network failure, that is when the network connection to the primary source is lost. It also allows control over the analog On Screen Display (OSD) in order to display for example the source's name, the local time and date, or when streaming previously recorded content the video's capture time and date. See the VWMonitorManagerCtrl2_VB sample for a small example in Visual Basic on how to use it
VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl | This ActiveX control allows to remote control digital relay outputs on equipments equipped with digital I/O cards. It allows to query and set the state of the digital relays. See the VWRelayOutputCtrl_VB sample for a small example in Visual Basic on how to use it
VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl | This ActiveX control allows to remotely query the state of various system health probes (e.g. temperature, fan speeds, core voltages,...) on equipments with preconfigured and installed power supply monitoring. It also allows the adjust each system probe's alarm thresholds. See the VWRemoteMonitoringCtrl_VB sample for a small example in Visual Basic on how to use it
VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl | This ActiveX control allows to remotely query the equipment's storage database for recorded audio and video content. Queries can be restricted by various parameters as a date interval, minimum framerate, source name's, on alarm recordings. It also supports to protect given time intervals against erasure through the automatic time and space based storage garbage collector, as well as the remote extraction of audio and video content. See the VWAlarmStreamer_VB sample for an example in Visual Basic on how to use it
VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl | This ActiveX control allows to remotely start and stop audio and video storages and query information about these. See the VWStorageManagerCtrl_VB6 sample for an example in Visual Basic on how to use it
XVWTIMELINELib::IVWTimeLine This ActiveX control allows to remote control streaming of recorded audio and video content. It offers a simple timeline like GUI which allows to position the playback cursor on the selected sources, or it can be used in non graphical mode to remote control the streaming of audio and video. It is normally used in conjunction with the VWStorageAccessController. See the VWAlarmStreamer_VB sample for an example in Visual Basic on how to use it.ActiveX control allowing the management of a group of audio/video on-demand streams.
Remarks:
For performance reasons, only the audio and video sources that need to be streamed should be added to this control.

All the date/time strings returned by methods of this interface or passed to methods of this interface have or must have the following format: "mm/dd/yyyy hh:mm:ss.ssssssUTC" (without the quotes). An undefined date/time will be converted to an null- sized string.

All the dates/times returned by methods of this interface or passed to methods of this interface are or must be between January 1, 1970 00:00:00 (included) and January 19, 2038 03:14:08 (not included).

The GUI accepts the following actions:

  • left click in the visible range zone: moves the visible range
  • left click in the sources zone: sets the position of the left and right markers
  • left click on the timeline: moves the visible range
  • right click: zooms to the zone defined by the left and right markers
  • right click + shift key pressed: zooms out
  • mouse wheel: zooms in/out

The methods of this control can return the following error codes:

  • VW_NO_ERROR 0
  • VW_INVALID_PARAMETER -1
  • VW_INVALID_ID -2
  • VW_NO_SOURCES -3
  • VW_RPC_CALL_ERROR -4
  • VW_NO_MORE_TIME_SPANS -5
  • VW_COULD_NOT_CREATE_SERVER -6 The specific meaning of these errors is explained for each method
VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl | This ActiveX control allows to query generic system information as installed network adapters, hard drivers, VisioWave coded boards and their channel configurations,... If running on Power Systems, motherboard health statistics as fan speeds, core voltages equipments with preconfigured audio outputs. It also allows to manage system alarms, that is to query their status and to acknowledge them in case they are set. See the VWVideoEquipmentManagerCtrl_VB6 sample for a small example in Visual Basic on how to use it
VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2 | This ActiveX control allows to remotely query and control real time video capture parameters as the bandwidth configured, the bandwidth used, the framerate,... on equipments with preconfigured video inputs. See the VWVideoSvrCtrl2 sample for a small example in Visual Basic on how to use it
Generated on Tue Oct 3 18:24:19 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: XVWDISPLAYLib::_IVWActiveXComponentEvents Interface Reference

XVWDISPLAYLib::_IVWActiveXComponentEvents

XVWDISPLAYLib::_IVWActiveXComponentEvents Interface Reference

Interface for the VWActiveXComponent ActiveX events. More...

import "XVWDisplay.idl";

List of all members.

Public Member Functions

void | Char ([in] short cKey)
void | Connect ([in] long lSourceId,[in] short sType)
void | DisplayModes ([in] long lMode)
void | DropFiles ([in] long lCount,[in] long lIndex,[in] BSTR bstrFile,[in] long lxPos,[in] long lyPos)
void | Eof ()
void | EraseBkgnd ()
void | Error ([in] long lCode,[in] long lSourceId,[in] short sType)
void | Frame ()
void | KeyDown ([in] short cKey)
void | KeyUp ([in] short cKey)
void | LButtonDblClk ([in] short sFlag,[in] long lxPos,[in] long lyPos)
void | LButtonDown ([in] short sFlag,[in] long lxPos,[in] long lyPos)
void | LButtonUp ([in] short sFlag,[in] long lxPos,[in] long lyPos)
void | MButtonDblClk ([in] short sFlag,[in] long lxPos,[in] long lyPos)
void | MButtonDown ([in] short sFlag,[in] long lxPos,[in] long lyPos)
void | MButtonUp ([in] short sFlag,[in] long lxPos,[in] long lyPos)
void | MouseMove ([in] short sFlag,[in] long lxPos,[in] long lyPos)
void | MouseWheel ([in] short sFlag,[in] long lxPos,[in] long lyPos,[in] short sRot)
void | RButtonDblClk ([in] short sFlag,[in] long lxPos,[in] long lyPos)
void | RButtonDown ([in] short sFlag,[in] long lxPos,[in] long lyPos)
void | RButtonUp ([in] short sFlag,[in] long lxPos,[in] long lyPos)
void | SysKeyDown ([in] short cKey)
void | SysKeyUp ([in] short cKey)

Detailed Description

Interface for the VWActiveXComponent ActiveX events.

Member Function Documentation

void XVWDISPLAYLib::_IVWActiveXComponentEvents::Char ( [in] short cKey )

This event is fired when the user presses a key while the control window has the keyboard focus.

Parameters:
cKey Character code of the key.
See also:
KeyDown

void XVWDISPLAYLib::_IVWActiveXComponentEvents::Connect | ( | [in] long | lSourceId,
 |  | [in] short | sType
 | ) |

This event is fired at an asynchronous source connection.

Parameters:
SourceId Source identifier for wich this event was fired.
sType Type of the source for wich this event was fired:
  • 1 if the audio has just connected
  • 2 if the video has just connected.
See also:
Connect

void XVWDISPLAYLib::_IVWActiveXComponentEvents::DisplayModes ( [in] long lMode )

This event is fired when the GetInfo function is called with the command line "displaymodes".

Parameters:
lMode Display modes. The first 8 bits represent the bits per color pixel (8, 16, 24 or 32), the following 12 bits the vertical resolution and the last 12 ones the horizontal resolution (for example 0x40030020 corresponds to 1024x768x32).
See also:
IVWActiveXComponent::GetInfo

void XVWDISPLAYLib::_IVWActiveXComponentEvents::DropFiles | ( | [in] long | lCount,
 |  | [in] long | lIndex,
 |  | [in] BSTR | bstrFile,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when files are dropped on the component (if the component accepts dropped files).

Parameters:
lCount | Number of dropped files.
lIndex | Dropped file index. Ranges from zero to one less than lCount.
bstrFile | Dropped file name.
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
See also:
IVWActiveXComponent::DragAcceptFiles

void XVWDISPLAYLib::_IVWActiveXComponentEvents::Eof ( )

This event is fired when the active file source has reached its last field with its looping flag set to false.

See also:
IVWActiveXComponent::Loop

void XVWDISPLAYLib::_IVWActiveXComponentEvents::EraseBkgnd ( )

This event is fired when the control window background must be erased (when its size changed for example).

void XVWDISPLAYLib::_IVWActiveXComponentEvents::Error | ( | [in] long | lCode,
 |  | [in] long | lSourceId,
 |  | [in] short | sType
 | ) |

This event is fired when an asynchronous error occured, for instance a disconnection.

Parameters:
SourceId Source identifier for wich this event was fired.
sType Type of the source for wich this event was fired:
  • 0 means general error
  • 1 if the audio has caused an error
  • 2 if the video has caused an error.
See also:
Error

void XVWDISPLAYLib::_IVWActiveXComponentEvents::Frame ( )

will not be documented

void XVWDISPLAYLib::_IVWActiveXComponentEvents::KeyDown ( [in] short cKey )

This event is fired when the user presses a non-system key while the control window has the keyboard focus.

Parameters:
cKey Virtual-key code of the non-system key.
See also:
KeyUp

void XVWDISPLAYLib::_IVWActiveXComponentEvents::KeyUp ( [in] short cKey )

This event is fired when the user releases a non-system key while the control window has the keyboard focus.

Parameters:
cKey Virtual-key code of the non-system key.
See also:
KeyDown

void XVWDISPLAYLib::_IVWActiveXComponentEvents::LButtonDblClk | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when the user double-clicks the left mouse button while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
See also:
LButtonUp

LButtonDown

void XVWDISPLAYLib::_IVWActiveXComponentEvents::LButtonDown | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when the user presses the left mouse button while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
See also:
LButtonUp

LButtonDblClk

void XVWDISPLAYLib::_IVWActiveXComponentEvents::LButtonUp | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when the user releases the left mouse button while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
See also:
LButtonDown

LButtonDblClk

void XVWDISPLAYLib::_IVWActiveXComponentEvents::MButtonDblClk | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when the user double-clicks the middle mouse button while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
See also:
MButtonUp

MButtonDown

void XVWDISPLAYLib::_IVWActiveXComponentEvents::MButtonDown | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when the user presses the middle mouse button while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
See also:
MButtonUp

MButtonDblClk

void XVWDISPLAYLib::_IVWActiveXComponentEvents::MButtonUp | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when the user releases the middle mouse button while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
See also:
MButtonDown

MButtonDblClk

void XVWDISPLAYLib::_IVWActiveXComponentEvents::MouseMove | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when the mouse moves while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.

void XVWDISPLAYLib::_IVWActiveXComponentEvents::MouseWheel | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos,
 |  | [in] short | sRot
 | ) |

This event is fired when the mouse wheel is rotated while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
sRot | Indicates the step the wheel was rotated. Positive value means forward rotation and negative backward rotation.

void XVWDISPLAYLib::_IVWActiveXComponentEvents::RButtonDblClk | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when the user double-clicks the right mouse button while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
See also:
RButtonUp

RButtonDown

void XVWDISPLAYLib::_IVWActiveXComponentEvents::RButtonDown | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when the user presses the right mouse button while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
See also:
RButtonUp

RButtonDblClk

void XVWDISPLAYLib::_IVWActiveXComponentEvents::RButtonUp | ( | [in] short | sFlag,
 |  | [in] long | lxPos,
 |  | [in] long | lyPos
 | ) |

This event is fired when the user releases the right mouse button while the mouse is over the control window.

Parameters:
sFlag Indicates whether virtual keys were down and others mouse buttons pressed. Possibles values:
  • 1 (left mouse button down)
  • 2 (right mouse button down)
  • 4 (SHIFT key down)
  • 8 (CTRL key down)
  • 16 (Middle mouse button down)
  • 32 (Windows 2000/XP: first X button dowwn)
  • 64 (Windows 2000/XP: second X button dowwn).
lxPos | X-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
lyPos | Y-coordinate of the mouse pointer, relative to the upper-left corner of the control window.
See also:
RButtonDown

RButtonDblClk

void XVWDISPLAYLib::_IVWActiveXComponentEvents::SysKeyDown ( [in] short cKey )

This event is fired when the user presses the F10 key (which activates the client ActiveX menu), or when a key is pressed while the Alt key is down.

Parameters:
cKey Virtual key code of the non-system key.
See also:
SysKeyUp

void XVWDISPLAYLib::_IVWActiveXComponentEvents::SysKeyUp ( [in] short cKey )

This event is fired when the user releases a key while the Alt key was held down.

Parameters:
cKey Virtual key code of the non-system key.
See also:
SysKeyDown

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents Interface Reference

VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents

VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents Interface Reference

Interface for the VWAudioOutputCtrl ActiveX events. More...

import "VWAudioOutputController.idl";

List of all members.

Public Member Functions

HRESULT | LinkDown ([in] BSTR Name,[in] BSTR TextError)
HRESULT | LinkUp ([in] BSTR Name)

Detailed Description

Interface for the VWAudioOutputCtrl ActiveX events.

Member Function Documentation

HRESULT VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents::LinkDown | ( | [in] BSTR | Name,
 |  | [in] BSTR | TextError
 | ) |

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

Parameters:
TextError | Disconnection reason
Name | Name of the Controller that got disconnected such as "remotehost:remoteport"
Remarks:
A Controller's name strongly binds it conceptually to the Manager it is connected to. As a matter of fact, an Audio Group is a group of Managers; on client side, an audio group is implemented by a Group of Controllers, whose names correspond to the remote Manager they are connected to.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents::LinkUp ( [in] BSTR Name )

Fired when a non-blocking connection gets established.

Parameters:
Name Name of the Controller that got connected such as "remotehost:remoteport"
Remarks:
A Controller's name strongly binds it conceptually to the Manager it is connected to. As a matter of fact, an Audio Group is a group of Managers; on client side, an audio group is implemented by a Group of Controllers, whose names correspond to the remote Manager they are connected to.


VisioWave SDK: VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents Interface Reference

VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents

VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents Interface Reference

Interface for the VWAudioSvrCtrl ActiveX events. More...

import "VWServerController.idl";

List of all members.

Public Member Functions

void | LinkDown ()
void | LinkUp ()

Detailed Description

Interface for the VWAudioSvrCtrl ActiveX events.

Member Function Documentation

void VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents::LinkDown ( )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

void VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents::LinkUp ( )

Fired when a non-blocking connection gets established.

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents Interface Reference

XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents

XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents Interface Reference

Interface for the VWConnectionCtrl ActiveX events. More...

import "XVWConnectionController.idl";

List of all members.

Public Member Functions

void | Connect (BOOL bBlocking)
void | Disconnect ()

Detailed Description

Interface for the VWConnectionCtrl ActiveX events.

Member Function Documentation

void XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents::Connect ( BOOL bBlocking )

Fired when the "Connect" button is clicked. When this event is fired, it is guaranteed that the Connect method of the attached control has already been called.

Parameters:
bBlocking connection mode
See also:
SetConnectionMode

void XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents::Disconnect ( )

Fired when the "Disconnect" button is clicked. When this event is fired, it is guaranteed that the Disconnect method of the attached control has already been called.

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents Interface Reference

VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents

VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents Interface Reference

Interface for the VWDigitalInputCtrl ActiveX events. More...

import "VWDigitalIOController.idl";

List of all members.

Public Member Functions

void | LinkDown ([in] BSTR TextError)
void | LinkUp ()

Detailed Description

Interface for the VWDigitalInputCtrl ActiveX events.

Member Function Documentation

void VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents::LinkDown ( [in] BSTR TextError )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

Parameters:
TextError Disconnection reason

void VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents::LinkUp ( )

Fired when a non-blocking connection gets established.


VisioWave SDK: VWEVENTCONTROLLERLib::_IVWEventCtrlEvents Interface Reference

VWEVENTCONTROLLERLib::_IVWEventCtrlEvents

VWEVENTCONTROLLERLib::_IVWEventCtrlEvents Interface Reference

Interface for the VWEventCtrl ActiveX events. More...

import "VWEventController.idl";

List of all members.

Public Member Functions

void | Event ([in] BSTR bstrEvent)
void | EventEx ([in] BSTR bstrEvent,[in] BSTR bstrData)
void | LinkDown ([in] BSTR TextError)
void | LinkUp ()

Detailed Description

Interface for the VWEventCtrl ActiveX events.

Member Function Documentation

void VWEVENTCONTROLLERLib::_IVWEventCtrlEvents::Event ( [in] BSTR bstrEvent )

Fired when an event is received. The control must be subscribed to an event to receive it. To retrieve extra information about an event, use EventEx.

Parameters:
bstrEvent Event name
See also:
EventEx

void VWEVENTCONTROLLERLib::_IVWEventCtrlEvents::EventEx | ( | [in] BSTR | bstrEvent,
 |  | [in] BSTR | bstrData
 | ) |

Fired when an event is received. The control must be subscribed to an event to receive it. For events sent by the Video Equipment Manager and Power Supply Monitors, the following values are available as extra data (extractable with ExtractString and ExtractInteger):

  • equipmentName: name of the equipment, as defined in the Central Configuration
  • equipmentAddress: address of the equipment

For events sent by the Video Equipment Manager:

  • videoEquipmentManagerTcpPort: TCP port of the Video Equipment Manager

For events sent by a Power Supply Monitor:

  • powerSupplyMonitorName: name of the Power Supply Monitor, as defined in the Central Configuration
  • powerSupplyMonitorTcpPort: TCP port of the Power Supply Monitor

For events related to a video input:

  • videoInputName: name of the video input, as defined in the Central Configuration
  • videoInputTcpPort: TCP port of the video input
  • videoInputChannel: channel number of the video input

For events related to a video output:

  • videoOutputName: name of the video output, as defined in the Central Configuration
  • videoOutputTcpPort: TCP port of the video output
  • videoOutputChannel: channel number of the video output

For events related to an audio input:

  • audioInputName: name of the audio input, as defined in the Central Configuration
  • audioInputTcpPort: TCP port of the audio input
  • audioInputChannel: channel number of the audio input

For events related to an audio output:

  • audioOutputName: name of the audio output, as defined in the Central Configuration
  • audioOutputTcpPort: TCP port of the audio output
  • audioOutputChannel: channel number of the audio output

For events related to a digital input:

  • digitalInputName: name of the digital input, as defined in the Central Configuration
  • digitalInputTcpPort: TCP port of the digital input
  • digitalInputNumber: input number of the digital input

For events related to a disk space:

  • diskSpaceName: name of the disk space, as defined in the Central Configuration

Parameters:
bstrEvent | Event name
bstrData | Additionnal data
See also:
ExtractString

ExtractInteger

void VWEVENTCONTROLLERLib::_IVWEventCtrlEvents::LinkDown ( [in] BSTR TextError )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

Parameters:
TextError Disconnection reason

void VWEVENTCONTROLLERLib::_IVWEventCtrlEvents::LinkUp ( )

Fired when a non-blocking connection gets established.


VisioWave SDK: VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events Interface Reference

VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events

VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events Interface Reference

Interface for the VWMobCamSvrCtrl2 ActiveX events. More...

import "VWServerController.idl";

List of all members.

Public Member Functions

void | Connect ()
HRESULT | LinkDown (BSTR TextError)
void | LinkUp ()
void | TimedOut ([in] BOOL bStatus)

Detailed Description

Interface for the VWMobCamSvrCtrl2 ActiveX events.

Member Function Documentation

void VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events::Connect ( )

Fired when a non-blocking connection gets established.

HRESULT VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events::LinkDown ( BSTR TextError )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

Parameters:
TextError Disconnection reason

void VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events::LinkUp ( )

Fired when a non-blocking connection gets established.

void VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events::TimedOut ( [in] BOOL bStatus )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events Interface Reference

VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events

VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events Interface Reference

Interface for the VWMonitorManagerCtrl2 ActiveX events. More...

import "VWMonitorManagerController.idl";

List of all members.

Public Member Functions

void | Connect ()
void | LinkDown ()
void | LinkUp ()
void | TimedOut ()

Detailed Description

Interface for the VWMonitorManagerCtrl2 ActiveX events.

Member Function Documentation

void VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events::LinkDown ( )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

void VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events::LinkUp ( )

Fired when a non-blocking connection gets established.


VisioWave SDK: VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents Interface Reference

VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents

VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents Interface Reference

Interface for the VWRelayOutputCtrl ActiveX events. More...

import "VWDigitalIOController.idl";

List of all members.

Public Member Functions

void | LinkDown ([in] BSTR TextError)
void | LinkUp ()

Detailed Description

Interface for the VWRelayOutputCtrl ActiveX events.

Member Function Documentation

void VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents::LinkDown ( [in] BSTR TextError )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

Parameters:
TextError Disconnection reason

void VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents::LinkUp ( )

Fired when a non-blocking connection gets established.


VisioWave SDK: VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents Interface Reference

VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents

VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents Interface Reference

Interface for the VWRemoteMonitoringCtrl ActiveX events. More...

import "VWRemoteMonitoringController.idl";

List of all members.

Public Member Functions

void | LinkDown ([in] BSTR TextError)
void | LinkUp ()

Detailed Description

Interface for the VWRemoteMonitoringCtrl ActiveX events.

Member Function Documentation

void VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents::LinkDown ( [in] BSTR TextError )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

Parameters:
TextError Disconnection reason

void VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents::LinkUp ( )

Fired when a non-blocking connection gets established.

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents Interface Reference

VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents

VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents Interface Reference

Interface for the VWStorageAccessCtrl ActiveX events. More...

import "VWStorageAccessController.idl";

List of all members.

Public Member Functions

HRESULT | LinkDown (BSTR TextError)
HRESULT | LinkUp ()

Detailed Description

Interface for the VWStorageAccessCtrl ActiveX events.

Member Function Documentation

HRESULT VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents::LinkDown ( BSTR TextError )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

Parameters:
TextError Disconnection reason

HRESULT VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents::LinkUp ( )

Fired when a non-blocking connection gets established.

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents Interface Reference

VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents

VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents Interface Reference

Interface for the VWStorageManagerCtrl ActiveX events. More...

import "VWStorageController.idl";

List of all members.

Public Member Functions

void | LinkDown ([in] BSTR TextError)
void | LinkUp ()

Detailed Description

Interface for the VWStorageManagerCtrl ActiveX events.

Member Function Documentation

void VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents::LinkDown ( [in] BSTR TextError )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

Parameters:
TextError Disconnection reason

void VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents::LinkUp ( )

Fired when a non-blocking connection gets established.

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: XVWTIMELINELib::_IVWTimeLineEvents Interface Reference

XVWTIMELINELib::_IVWTimeLineEvents

XVWTIMELINELib::_IVWTimeLineEvents Interface Reference

Interface for the VWTimeLine ActiveX events. More...

import "XVWTimeLine.idl";

List of all members.

Public Member Functions

HRESULT | LeftMarkerReached ([in] BSTR LeftMarker)
HRESULT | RightMarkerReached ([in] BSTR RightMarker)

Detailed Description

Interface for the VWTimeLine ActiveX events.

Member Function Documentation

HRESULT XVWTIMELINELib::_IVWTimeLineEvents::LeftMarkerReached ( [in] BSTR LeftMarker )

Event fired when the left marker is reached.

Parameters:
LeftMarker position reached in UTC time

HRESULT XVWTIMELINELib::_IVWTimeLineEvents::RightMarkerReached ( [in] BSTR RightMarker )

Event fired when the right marker is reached.

Parameters:
RightMarker position reached in UTC time

Generated on Tue Oct 3 18:24:22 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents Interface Reference

VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents

VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents Interface Reference

Interface for the VWVideoEquipmentManagerCtrl ActiveX events. More...

import "VWVideoEquipmentManagerController.idl";

List of all members.

Public Member Functions

void | LinkDown ([in] BSTR TextError)
void | LinkUp ()

Detailed Description

Interface for the VWVideoEquipmentManagerCtrl ActiveX events.

Member Function Documentation

void VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents::LinkDown ( [in] BSTR TextError )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

Parameters:
TextError Disconnection reason

void VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents::LinkUp ( )

Fired when a non-blocking connection gets established.

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events Interface Reference

VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events

VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events Interface Reference

Interface for the VWVideoSvrCtrl2 ActiveX events. More...

import "VWServerController.idl";

List of all members.

Public Member Functions

void | Connect ()
void | LinkDown ()
void | LinkUp ()
void | TimedOut ()

Detailed Description

Interface for the VWVideoSvrCtrl2 ActiveX events.

Member Function Documentation

void VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events::LinkDown ( )

Fired when an established connection goes down or when a non-blocking connection attempt fails (that is, no answer was received from the manager for the amount of time set by the TimeOut property).

void VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events::LinkUp ( )

Fired when a non-blocking connection gets established.

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: XVWDISPLAYLib::IVWActiveXComponent Interface Reference

XVWDISPLAYLib::IVWActiveXComponent

XVWDISPLAYLib::IVWActiveXComponent Interface Reference

This ActiveX control allows to decode in software audio and video flows either streamed from the network, captured locally or taken from a VisioWave encoded file. It also allows to redirect those flows onto a VisioWave codec output channel in order to display it on an analog monitor as well as to store the flows locally. It can also display video processing plugin output (for example, activity regions in the motion detector plugin). See the VWActiveXComponent_VC6 sample for a small example in Visual C++ on how to use it. More...

import "XVWDisplay.idl";

Inherits IDispatch.

List of all members.

Methods

HRESULT | AddSource ([in] BSTR bstrURL,[out, retval] long *plSourceId)
HRESULT | AttachSoundSourceId ([in] long lVideoSourceId,[in] long lSoundSourceId,[out, retval] long *plError)
HRESULT | AttachSourceOsdId ([in] long lVideoSourceId,[in] long lOsdSourceId,[out, retval] long *plError)
HRESULT | BufferingRecordOn ([in] long lSourceId,[in] short sType,[in] double RealFPS,[in] BSTR bstrName,[in] BSTR bstrFormat,[in] long lNBuffers,[in] long lBuffersSize,[out, retval] long *plError)
HRESULT | CaptureScreen ([in] BSTR bstrPath,[in] BSTR bstrName,[in] BSTR bstrFormat,[in] short sQuality,[out, retval] long *plError)
HRESULT | CenterZoom ([out, retval] long *plError)
HRESULT | ClearOsd ([in] short sNumber)
HRESULT | ConnectId ([in] long lSourceId,[in] short sType,[in] BOOL bBlocking,[in] long lTimeOut,[out, retval] long *plError)
HRESULT | DetachSoundSourceId ([in] long lVideoSourceId,[in] long lSoundSourceId,[out, retval] long *plError)
HRESULT | DetachSourceOsdId ([in] long lSourceId,[out, retval] long *plError)
HRESULT | DisconnectId ([in] long lSourceId,[in] short sType,[out, retval] long *plError)
HRESULT | DisplayOsd ([in] BSTR bstrText,[in] long lX,[in] long lY,[in] OLE_COLOR TextClr,[in] OLE_COLOR BackClr,[in] short sAlpha,[in] short sNumber,[out, retval] long *plOsdId)
HRESULT | DragAcceptFiles ([in] BOOL bAccept,[out, retval] BOOL *pWasAccepted)
HRESULT | EnumSourcesIdsBegin ([out, retval] long *plSourcesIdsCount)
HRESULT | EnumSourcesIdsEnd (void)
HRESULT | EnumSourcesIdsNext ([out, retval] long *plSourceId)
HRESULT | FreezeEvents ([in] BOOL bFreeze,[out, retval] long *plError)
HRESULT | FullScreenOff ([out, retval] long *plError)
HRESULT | FullScreenOn ([in] short sMode,[in] BOOL bSync,[in] short iWidth,[in] short iHeight,[in] short iFreq,[out, retval] long *plError)
HRESULT | GetActiveSourceId ([out, retval] long *pVal)
HRESULT | GetAttachedCount ([in] long lSourceId,[out, retval] long *plSources)
HRESULT | GetBitsPerSample ([in] long lSourceId,[out, retval] short *pnBitsPerSample)
HRESULT | GetChannels ([in] long lSourceId,[out, retval] short *pnChannels)
HRESULT | GetChunk ([in] long lSourceId,[out, retval] short *pnChunk)
HRESULT | GetDC ([out, retval] long *plDC)
HRESULT | GetErrorText ([in] long lErrorCode,[out, retval] BSTR *pbstrErrorText)
HRESULT | GetFields ([in] long lSourceId,[out, retval] short *pnFields)
HRESULT | GetFPS ([in] long lSourceId,[out, retval] short *psFPS)
HRESULT | GetFrame ([out, retval] long *plFrame)
HRESULT | GetFrameSize ([in] long lSourceId,[out, retval] short *pnFS)
HRESULT | GetFramesLost ([out, retval] long *plFL)
HRESULT | GetFramesLostEx ([in] long lSourceId,[out, retval] long *plFL)
HRESULT | GetInfo ([in] BSTR bstrCommand,[out, retval] long *psInfo)
Get various system information.
HRESULT | GetLastError ([out, retval] long *plLastErrori)
HRESULT | GetMaxFrameSize ([in] long lSourceId,[out, retval] short *pnMFS)
HRESULT | GetMaxRate ([in] long lSourceId,[out, retval] long *plMaxRate)
HRESULT | GetPropertyBag ([in] long lSourceId,[in] short sType,[out, retval] BSTR *pbstrProperties)
HRESULT | GetQuality ([in] long lSourceId,[out, retval] short *pnQuality)
HRESULT | GetRate ([out, retval] long *plRate)
HRESULT | GetRateEx ([in] long lSourceId,[out, retval] long *plRate)
HRESULT | GetRealFPS ([out, retval] float *pfRealFPS)
HRESULT | GetSampleRate ([in] long lSourceId,[out, retval] long *plSampleRate)
HRESULT | GetSkippedFields ([in] long lSourceId,[out] long *plVFields,[out] long *plAFields,[out, retval] long *plError)
HRESULT | GetSoundInfo ([in] long lSourceId,[out] long *plSampleRate,[out] short *pnChannels,[out] short *pnBitsPerSample,[out] short *pnChunk,[out, retval] long *plError)
HRESULT | GetSource ([in] long lSourceId,[in] short sSource,[out, retval] long *plSourceId)
HRESULT | GetSourceCategory ([in] short sType,[in] long lSourceId,[out, retval] short *psSourceCat)
HRESULT | GetSourcePort ([in] short sType,[in] long lSourceId,[out, retval] short *pPort)
HRESULT | GetSourceProtocol ([in] short sType,[in] long lSourceId,[out, retval] short *psSourceProto)
HRESULT | GetSourceType ([in] long lSourceId,[out, retval] short *psSourceType)
HRESULT | GetSourceURL ([in] long lSourceId,[out, retval] BSTR *pVal)
HRESULT | GetSourceURLEx ([in] short sType,[in] long lSourceId,[out, retval] BSTR *pBSTR)
HRESULT | GetTemporalLevel ([in] long lSourceId,[out, retval] short *pnTemporalLevel)
HRESULT | GetTime ([out, retval] float *pfTime)
HRESULT | GetTotalBytes ([in] long lSourceId,[out, retval] long *plBytes)
HRESULT | GetTotalFrames ([out, retval] long *plFrames)
HRESULT | GetTotalFramesEx ([in] long lSourceId,[out, retval] long *plFrames)
HRESULT | GetTotalTime ([out, retval] float *pfTime)
HRESULT | GetTotalTimeEx ([in] long lSourceId,[out, retval] float *pfTime)
HRESULT | GetVideoFormat ([in] long lSourceId,[out, retval] short *pnVf)
HRESULT | GetVideoInfo ([in] long lSourceId,[out] short *pnVidX,[out] short *pnVidY,[out] short *pnVf,[out] short *pnFps,[out] short *pnFields,[out, retval] long *plError)
HRESULT | GetVidX ([in] long lSourceId,[out, retval] short *pnVidX)
HRESULT | GetVidY ([in] long lSourceId,[out, retval] short *pnVidY)
HRESULT | GetVWBoards ([out, retval] short *psNumber)
HRESULT | GetWindow ([out, retval] long *plWindow)
HRESULT | GetZoom ([out, retval] float *pfZoom)
HRESULT | HasSync ([in] short nNumber,[out, retval] short *pnHasSync)
HRESULT | IsAttached ([in] long lSourceId,[out, retval] long *plSources)
HRESULT | IsConnected ([in] long lSourceId,[out, retval] short *piConnected)
HRESULT | IsFullScreen ([out, retval] short *psMode)
HRESULT | IsLooping ([out, retval] BOOL *pbLooping)
HRESULT | IsPlayingVWBoard ([in] short sNumber,[out, retval] long *plSourceId)
HRESULT | IsRecording ([in] long lSourceId,[out, retval] short *piRecording)
HRESULT | IsValidId ([in] long lSourceId,[out, retval] BOOL *pbValid)
HRESULT | LoadPicture ([in] BSTR bstrURL,[out, retval] long *plError)
HRESULT | LoadWinSock2 (void)
HRESULT | Loop ([in] BOOL bLoop)
HRESULT | MoveZoom ([in] long lxPos,[in] long lyPos,[out, retval] long *plError)
HRESULT | NextSource ([out, retval] long *lSourceId)
HRESULT | OutputToVWBoardOff ([in] short sNumber,[out, retval] long *plSourceId)
HRESULT | OutputToVWBoardOn ([in] long lSourceId,[in] short sNumber,[out, retval] long *plError)
HRESULT | OutputToVWBoardOnEx ([in] long lSourceId,[in] short sNumber,[in] short nVideoFormat,[out, retval] long *plError)
HRESULT | Pause ([in] short sType,[out, retval] long *plError)
HRESULT | PreviousSource ([out, retval] long *lSourceId)
HRESULT | PrintScreen ([in] long lDisplaySetup,[in] BSTR bstrDocName,[out, retval] long *plError)
HRESULT | RecordOff ([in] long lSourceId,[out, retval] long *plError)
HRESULT | RecordOn ([in] long lSourceId,[in] short sType,[in] double RealFPS,[in] BSTR bstrName,[out, retval] long *plError)
HRESULT | RecordOnEx ([in] long lSourceId,[in] short sType,[in] double RealFPS,[in] BSTR bstrName,[in] BSTR bstrFormat,[out, retval] long *plError)
HRESULT | Refresh (void)
HRESULT | ReleaseDC ([in] long lDC,[out, retval] long *plError)
HRESULT | RemoveOsd ([in] long lOsdId)
HRESULT | RemoveSourceId ([in] long lSourceId,[out, retval] long *plError)
HRESULT | RemoveText ([in] long lTextId)
HRESULT | Resume ([in] short sType,[out, retval] long *plError)
HRESULT | SeekFrame ([in] long lFrame,[out, retval] long *plError)
HRESULT | SeekTime ([in] float fTime,[out, retval] long *plError)
HRESULT | SetActiveSourceId ([in] long newVal,[out, retval] long *plError)
HRESULT | SetLastError ([in] long lLastError)
HRESULT | SetQuality ([in] long lSourceId,[in] short nQuality,[out, retval] long *plError)
HRESULT | SetQueue ([in] long lSourceId,[in] short sType,[in] short sQueue,[out, retval] long *plError)
HRESULT | SetRate ([in] float fRate,[out, retval] long *plError)
HRESULT | SetVideoFormat ([in] long lSourceId,[in] short nVf,[out, retval] long *plError)
HRESULT | ShowCursor ([in] BOOL bShow)
HRESULT | Start ([in] short sType,[out, retval] long *plError)
HRESULT | Stop ([in] short sType,[out, retval] long *plError)
HRESULT | Synchronize ([in] BOOL bSync,[out, retval] long *plError)
HRESULT | TextOut ([in] BSTR bstrText,[in] long lX,[in] long lY,[in] OLE_COLOR BackClr,[in] OLE_COLOR TextClr,[out, retval] long *plTextId)
HRESULT | TextOutEx ([in] BSTR bstrText,[in] long lX,[in] long lY,[in] OLE_COLOR BackClr,[in] OLE_COLOR TextClr,[in, defaultvalue("")] BSTR bstrFontName,[in, defaultvalue(0)] long lPointSize,[in, defaultvalue(FALSE)] BOOL bBold,[in, defaultvalue(FALSE)] BOOL bItalic,[in, defaultvalue(FALSE)] BOOL bUnderline,[in, defaultvalue(FALSE)] BOOL bStrikeOut,[out, retval] long *plTextId)
HRESULT | UnloadWinSock2 (void)
HRESULT | UpdateOsd ([in] long lOsdId,[in] BSTR bstrText,[in] OLE_COLOR TextClr,[in] OLE_COLOR BackClr,[in] short sAlpha)
HRESULT | Zoom ([in] float fScale,[out, retval] long *plError)

Display Properties

HRESULT | AutoSize ([in]VARIANT_BOOL vbool)
HRESULT | AutoSize ([out, retval]VARIANT_BOOL *pbool)
The controls's auto resize behaviour.
HRESULT | BackColor ([in] OLE_COLOR newVal)
HRESULT | BackColor ([out, retval] OLE_COLOR *pVal)
The controls's background color of the control.
HRESULT | Picture ([out, retval]IPictureDisp **ppPicture)
HRESULT | Picture ([in]IPictureDisp *pPicture)
HRESULT | Picture ([in]IPictureDisp *pPicture)
The controls background picture.
HRESULT | VideoMode ([in] long newVal)
HRESULT | VideoMode ([out, retval] long *pVal)
The control's video display mode.
HRESULT | VideoZoom ([in] long newVal)
HRESULT | VideoZoom ([out, retval] long *pVal)
The control's zoom settings.

Decoding Properties

HRESULT | DecoderColorMode ([in] long newVal)
HRESULT | DecoderColorMode ([out, retval] long *pVal)
The decoder's color mode settings.
HRESULT | DecoderMode ([in] long newVal)
HRESULT | DecoderMode ([out, retval] long *pVal)
The decoder's decoding mode settings.
HRESULT | DecoderParity ([in] long newVal)
HRESULT | DecoderParity ([out, retval] long *pVal)
The decoder's parity settings.
HRESULT | DecoderSize ([in] long newVal)
HRESULT | DecoderSize ([out, retval] long *pVal)
The decoder's size settings.

Source Properties

HRESULT | Running ([out, retval] short *pVal)
The active source's play status.
HRESULT | VideoHeight ([out, retval] short *pVal)
The active source's video height.
HRESULT | VideoWidth ([out, retval] short *pVal)
The active source's video width.

Detailed Description

This ActiveX control allows to decode in software audio and video flows either streamed from the network, captured locally or taken from a VisioWave encoded file. It also allows to redirect those flows onto a VisioWave codec output channel in order to display it on an analog monitor as well as to store the flows locally. It can also display video processing plugin output (for example, activity regions in the motion detector plugin). See the VWActiveXComponent_VC6 sample for a small example in Visual C++ on how to use it.

Member Function Documentation

HRESULT XVWDISPLAYLib::IVWActiveXComponent::AddSource | ( | [in] BSTR | bstrURL,
 |  | [out, retval] long * | plSourceId
 | ) |

Adds a source to the control.

Parameters:
bstrURL URL that specifies the source to connect. The following syntax must be respected.
  • network sources: <protocol>://<host_name>:<video_port>{,<audio_port>|<protocol>://<host_name>:<audio_port>}
  • file sources: file://<file_name.(asf|avi|wav|mp3)>.
Returns:
Source identifier if successful, -1 otherwise. Call the GetLastError function to get further information. Possible error codes: VWERR_SOURCEALREADYEXIST if the source was previously added (for file sources). VWERR_INVALIDURL for a syntax error. VWERR_HEADERCORRUPTED if the header is corrupted (for file sources).
See also:
RemoveSourceId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::AttachSoundSourceId | ( | [in] long | lVideoSourceId,
 |  | [in] long | lSoundSourceId,
 |  | [out, retval] long * | plError
 | ) |

For internal purpose only, must not be used by developpers.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::AttachSourceOsdId | ( | [in] long | lVideoSourceId,
 |  | [in] long | lOsdSourceId,
 |  | [out, retval] long * | plError
 | ) |

Displays plug-in information when the specified video source is set as the active source.

Parameters:
lVideoSourceId | Video source identifier to be attached.
lOsdSourceId | Associated plug-in source identifier to attach.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_SOURCENOTFOUND | The given source identifiers are not valid.
VWERR_UNCOMPATIBLESOURCE | The given sources must be video sources.
Remarks:
Plug-in sources are special video sources. They can be added to the control by following the video AddSource syntax. Plug-i sources should be connected to Video Processing Managers using ConnectId function with sType parameter set to 2 as video sources.
See also:
DetachSourceOsdId

AddSource

ConnectId

HRESULT XVWDISPLAYLib::IVWActiveXComponent::AutoSize ( [out, retval] VARIANT_BOOL * pbool )

The controls's auto resize behaviour.

Property[R|W] : Allows/Disallows the control to resize itself to the actual video size.

Value | Description
True(0) | Resize
False(-1) | Don't Resize

HRESULT XVWDISPLAYLib::IVWActiveXComponent::BackColor ( [out, retval] OLE_COLOR * pVal )

The controls's background color of the control.

Property[R|W] : Allows custom settings of the control's background color .

Note:
See your development platform's documentation on creating an instance of type OLE_COLOR.
This property will be mapped in different ways depending on development platform.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::BufferingRecordOn | ( | [in] long | lSourceId,
 |  | [in] short | sType,
 |  | [in] double | RealFPS,
 |  | [in] BSTR | bstrName,
 |  | [in] BSTR | bstrFormat,
 |  | [in] long | lNBuffers,
 |  | [in] long | lBuffersSize,
 |  | [out, retval] long * | plError
 | ) |

Starts the recording of a specified source to a file using specified caching parameters.

Parameters:
lSourceId | Source identifier returned by the AddSource function.
sType Source type:
  • 1 for audio recording
  • 2 for video recording
  • 3 for audio and video recording (if applicable).
RealFPS | Fiels pers second (ex: 12.5 or 6.0).
bstrName | File name.
bstrFormat | File format (asf, avi, wav or mp3).
lNBuffers | Number of caching buffers.
lBuffersSize | Buffer caching size in Kilo Bytes.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_SOURCENOTFOUND | The given source id is not valid.
VWERR_INVALIDPARAMS | Invalid parameters were passed to the function.
VWERR_NOTAUDIOSOURCE | The user asks for audio recording (sType=1) while the given source is a video source.
VWERR_NOTVIDEOSOURCE | The user asks for video recording (sType=2) while the given source is an audio source.
VWERR_SOURCENOTCONNECTED | The given source must be connected.
VWERR_ALREADYPLAYING | The given source is already being recorded.
VWERR_TOOMANYVIDEOSOURCES | The component was not able to allocate resources for this operation.
VWERR_TOOMANYAUDIOSOURCES | The component was not able to allocate resources for this operation.
VWERR_OUTOFMEMORY | The component was not able to allocate resources for this operation.
Remarks:
By default, the component uses a few Mega Bytes (~4 MB) of RAM per storage to avoid frames loss.

Disconnection of the source (audio and/or video part) will stop the recording.

See also:
RecordOn

HRESULT XVWDISPLAYLib::IVWActiveXComponent::CaptureScreen | ( | [in] BSTR | bstrPath,
 |  | [in] BSTR | bstrName,
 |  | [in] BSTR | bstrFormat,
 |  | [in] short | sQuality,
 |  | [out, retval] long * | plError
 | ) |

Captures the field being currently displayed by the component and saves it in a file.

Parameters:
bstrPath | Path to where the capture will be saved. If not specified, the capture will be saved in the temporary folder.
bstrName | Name of the capture. If not specified, the name will be automatically generated using different source parameters.
bstrFormat | Format of the capture. Must be "bmp".
sQuality | Bits per pixel for the bitmap: 24, 16(RGB 555) or 8 (gray scale).
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected with SetActiveSourceId.
VWERR_NOTVIDEOSOURCE | THe active source must be a video source.
VWERR_INVALIDPARAMS | Some of the input parameters are invalid.
Remarks:
If the file name is not specified, the control will use the source name and the capture number to generate a file name. The capture number is an internal counter incremented after each call to the CaptureScreen function. IF the source URL is "udp://server1:5001, the two first captures will be named "server1_5001_1.bmp" and "server1_5001_2.bmp".
See also:
SetActiveSourceId

HRESULT XVWDISPLAYLib::IVWActiveXComponent::CenterZoom ( [out, retval] long * plError )

Resets the zoom to 1:1.

Returns:
Operation result.
Return values:
VWERR_NOERROR Success.
See also:
Zoom

MoveZoom

GetZoom

HRESULT XVWDISPLAYLib::IVWActiveXComponent::ClearOsd ( [in] short sNumber )

Deletes all OSDs for the given channel.

Parameters:
sNumber Video channel number.
See also:
DisplayOsd

UpdateOsd

RemoveOsd

HRESULT XVWDISPLAYLib::IVWActiveXComponent::ConnectId | ( | [in] long | lSourceId,
 |  | [in] short | sType,
 |  | [in] BOOL | bBlocking,
 |  | [in] long | lTimeOut,
 |  | [out, retval] long * | plError
 | ) |

Connects a source.

Parameters:
lSourceId | Source identifier returned by the AddSource function.
sType Source type:
  • 1 to connect audio
  • 2 to connect video
  • 3 to connect audio and video.
bBlocking | To choose a blocking (0) or non-blocking (1) connection.
lTimeOut | Timeout interval. At timeout, an error is generated.
Returns:
It depends on bBlocking parameter:
  • blocking connection: VWERR_NOERROR if successful, a code otherwise. Its code depends on which part of the source was set in sType. If sType is 1 or 2, the return value is an error code, if sType is 3, the return value indicates which part of the source (audio or/and video) failed, call GetLastError function for more information.
  • non-blocking connection: VWERR_NOERROR is returned. If the connection succeeds a Connect event is fired, an Error event otherwise.
See also:
AddSource

_IVWActiveXComponentEvents::Connect

_IVWActiveXComponentEvents::Error

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::DecoderColorMode ( [out, retval] long * pVal )

The decoder's color mode settings.

Property[R|W] : Gets/Sets the color mode for the wavelet decoder

Tag | Value | Description
VW_DCM_BW | 0 | Black & White
VW_DCM_HALF | 1 | Sub samples one color line out of two
VW_DCM_RESERVED | 2 | Reserved
VW_DCM_NORMAL | 3 | Normal

HRESULT XVWDISPLAYLib::IVWActiveXComponent::DecoderMode ( [out, retval] long * pVal )

The decoder's decoding mode settings.

Property[R|W] : Chooses the decoder's internal mode.

Tag | Value | Description
VW_DM_AUTO | 0 | Chooses automatically the most appropriate decoding mode
VW_DM_MMX | 1 | Uses MMX and KNI instructions to decode
VW_DM_FLOATS | 2 | Uses floating point numbers to decode
VW_DM_FIXED | 3 | Uses fixed numbers to decode

HRESULT XVWDISPLAYLib::IVWActiveXComponent::DecoderParity ( [out, retval] long * pVal )

The decoder's parity settings.

Property[R|W] : Chooses which fields to decode.

Tag | Value | Description
VW_DP_INTERLACED | 0 | Decode odd and even fields with interlacing
VW_DP_ODD | 1 | Decode odd lines only
VW_DP_EVEN | 2 | Decode even lines only
VW_DP_NONINTERLACED> | 3 | Decode odd and even fields without interlacing

Note:
It is only interesting to enable interlacing for video streams at 50(PAL) or 59.94 (NTSC) frames per second and at FULL video size (Due to the interlaced nature of the analog PAL/NTSC input signal, that is 50 half images per second where each half image contains either even or odd lines, video streams at lower framerates contain only odd or even fields but never both)

Interlacing is computationally intensive, so at least a Pentium III 500 type of processor is recommended.

In case of temporal compression, the value of DecoderParity should always be VW_DP_NONINTERLACED.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::DecoderSize ( [out, retval] long * pVal )

The decoder's size settings.

Property[R|W] : Chooses the decompression size.

Tag | Value | Description
VW_DS_FULL | 0 | Height/2 (FULL)
VW_DS_CIF | 1 | Height/2 and Width/2 (CIF)
VW_DS_QCIF | 2 | Height/4 and Width/4 (QCIF)
VW_DS_QQCIF | 3 | Height/8 and Width /8 (QQCIF)
VW_DS_QQQCIF | 4 | Height/16 and Width/16 (QQQCIF)

Note:
Note that the wavelet algorithms allow bigger decompression than compression sizes, e.g. a source encoded in QQQCIF can be decoded in FULL. This will result in performance losses without improvement of image quality.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::DetachSoundSourceId | ( | [in] long | lVideoSourceId,
 |  | [in] long | lSoundSourceId,
 |  | [out, retval] long * | plError
 | ) |

For internal purpose only, must not be used by developpers.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::DetachSourceOsdId | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plError
 | ) |

Removes specified video source plug-in informatin from the screen.

Parameters:
lSourceId Video source identifier to be attached.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_SOURCENOTFOUND | The given source identifier is not valid.
See also:
AttachSourceOsdId

HRESULT XVWDISPLAYLib::IVWActiveXComponent::DisconnectId | ( | [in] long | lSourceId,
 |  | [in] short | sType,
 |  | [out, retval] long * | plError
 | ) |

Disconnects a source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
sType Source type:
  • 1 to connect audio
  • 2 to connect video
  • 3 to connect audio and video.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_SOURCENOTFOUND | The given source id is not valid.
VWERR_NOTVIDEOSOURCE | sType parameter mismatches with the source type.
VWERR_NOTAUDIOSOURCE | sType parameter mismatches with the source type.
VWERR_SOURCENOTCONNECTED | The source is already disconnected.
Remarks:
If the source is a file, disconnect it means closing it. If the file is an audio-video file, disconnect the audio part will just stop playing audio. To disconnect an audio-video file, disconnect video.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::DisplayOsd | ( | [in] BSTR | bstrText,
 |  | [in] long | lX,
 |  | [in] long | lY,
 |  | [in] OLE_COLOR | TextClr,
 |  | [in] OLE_COLOR | BackClr,
 |  | [in] short | sAlpha,
 |  | [in] short | sNumber,
 |  | [out, retval] long * | plOsdId
 | ) |

Writes the given OSD (On Screen Display) text on the selected video channel.

Parameters:
bstrText | OSD text.
lX | Reference horizontal coordinate of the text to write in pixels.
lY | Reference vertical coordinate of the text to write in pixels.
TextClr | Text color.
BackClr | Background color.
sAlpha Alpha component for background transparency. Possibles values:
  • 0x60 ( 0% transparency)
  • 0x40 ( 75% transparency)
  • 0x20 ( 50% transparancy)
  • 0x00 ( 25% transparancy)
  • 0x80 (100% transparancy).
sNumber | Video channel number.
Returns:
OSD Id to pass to UpdateOsd and RemoveOsd functions.
Return values:
-1 Call GetLastError for further information. Possible error codes:
  • VWERR_NOVWPCIBOARD (no VisioWave driver found or not started).
Remarks:
The VisioWave Codec board on which the OSD will be displayed must have OSD capabilitites.
See also:
UpdateOsd

RemoveOsd

ClearOsd

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::DragAcceptFiles | ( | [in] BOOL | bAccept,
 |  | [out, retval] BOOL * | pWasAccepted
 | ) |

Registers whether the control accepts dropped files.

Parameters:
bAccept Flag indicating whether dropped files are accepted.
Returns:
Previous control dragging status.
Return values:
true | The control was accepting dropped files.
false | The control was not accepting dropped files.
Remarks:
When files are dropped on the component, the DropFiles event is generated.

By default, the component does not accept dropped files.

See also:
_IVWActiveXComponentEvents::DropFiles

HRESULT XVWDISPLAYLib::IVWActiveXComponent::EnumSourcesIdsBegin ( [out, retval] long * plSourcesIdsCount )

Initiates a sources IDs enumeration.

Returns:
Count of sources IDs.
See also:
EnumSourcesIdsNext

EnumSourcesIdsEnd

HRESULT XVWDISPLAYLib::IVWActiveXComponent::EnumSourcesIdsEnd ( void )

Function called after a previous call to EnumSourcesIdsBegin to free allocated resources.

See also:
EnumSourcesIdsBegin

EnumSourcesIdsNext

HRESULT XVWDISPLAYLib::IVWActiveXComponent::EnumSourcesIdsNext ( [out, retval] long * plSourceId )

Function called after a previous call to "EnumSourcesIdsBegin" to retrieve the current source ID.

Returns:
Current source ID.
Return values:
-1 No more source ID available.
See also:
EnumSourcesIdsBegin

EnumSourcesIdsEnd

HRESULT XVWDISPLAYLib::IVWActiveXComponent::FreezeEvents | ( | [in] BOOL | bFreeze,
 |  | [out, retval] long * | plError
 | ) |

Freezes events fired by the control.

Parameters:
bFreeze True increments the internal counter, False decrements it.
Returns:
Operation result.
Return values:
VWERR_NOERROR Success.
Remarks:
There is no way to know the value of this internal counter.

The Connect, Error, Eof and DisplayModes events are not affected.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::FullScreenOff ( [out, retval] long * plError )

Enables exit of the full screen mode by resetting the display device hardware mode.

Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_NOTINFULLSCREEN | The control has not previously switched to full screen.
See also:
FullScreenOn

HRESULT XVWDISPLAYLib::IVWActiveXComponent::FullScreenOn | ( | [in] short | sMode,
 |  | [in] BOOL | bSync,
 |  | [in] short | iWidth,
 |  | [in] short | iHeight,
 |  | [in] short | iFreq,
 |  | [out, retval] long * | plError
 | ) |

Switches the display device hardware mode to full screen mode.

Parameters:
sMode New modes:
  • 1 Uses current monitor settings (iWidth, iHeight and iFreq must be set to 0)
  • 2 Changes the monitor settings according to the iWidth, iHeight and iFreq parameter values.
bSync | If non 0, the control will synchronise the display with the monitor vertical refresh rate.
iWidth | Width of the new mode.
iHeight | Height of the new mode.
iFreq | Refresh frequency of the new mode.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_INVALIDPARAMS | Some of the parameters given to the function are invalid.
VWERR_ALREADYINFULLSCREEN | The control has already switched to full screen.
VWERR_UNSUPPORTEDVIDEOMODE | The current video mode in full screen is not supported.
See also:
FullScreenOff

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetActiveSourceId ( [out, retval] long * pVal )

Gets the identifier of the selected source.

Returns:
Source identifier returned by the AddSource function.
See also:
SetActiveSourceId

AddSource

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetAttachedCount | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plSources
 | ) |

For internal purpose only, must not be used by developpers.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetBitsPerSample | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnBitsPerSample
 | ) |

Retrieves the bits per sample of the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Bits per sample if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTAUDIOSOURCE The given source must be a audio source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
See also:
GetSoundInfo

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetChannels | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnChannels
 | ) |

Retrieves the channels number of the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Number of channels if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTAUDIOSOURCE The given source must be a audio source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
See also:
GetSoundInfo

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetChunk | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnChunk
 | ) |

Retrieves the samples number per sound buffer of the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Samples number per sound buffer if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTAUDIOSOURCE The given source must be a audio source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
See also:
GetSoundInfo

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetDC ( [out, retval] long * plDC )

Gets the Device Context for the client area of the control. This DC is often used in GDI functions.

Returns:
DC if successful, -1 otherwise. Call the GetLastError function for further information.
Remarks:
This method can be used in full screen mode.
See also:
ReleaseDC

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetErrorText | ( | [in] long | lErrorCode,
 |  | [out, retval] BSTR * | pbstrErrorText
 | ) |

Returns associated error text to the given error code.

Parameters:
lErrorCode Error code.
Returns:
Associated error text.
Remarks:
The text begins with a lower case character and neither '.' nor 'CRLF' are appended to the text.
See also:
GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetFields | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnFields
 | ) |

Retrieves the fields parity of the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Return values:
-1 Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE The given source must be a video source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
See also:
GetVideoInfo

GetLastError

AddSource

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetFPS | ( | [in] long | lSourceId,
 |  | [out, retval] short * | psFPS
 | ) |

Gets the number of fields per second for the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
The number of fields per second, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE Works only with video sources
  • VWERR_SOURCENOTCONNECTED The source must be connected to retrieve the fields per second.
Remarks:
To get the actual number of fields, divide the result by 100 (eg 2500 means 25 fields per second).
See also:
GetRate

GetRateEx

GetMaxRate

AddSource

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetFrame ( [out, retval] long * plFrame )

Gets the current field number when a file is selected as the active source.

Returns:
Current field if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_NOSOURCESELECTED No source was selected with SetActiveSourceId
  • VWERR_NOTVIDEOSOURCE The active source must be a video source
  • VWERR_SOURCENOTCONNECTED The active source must be connected.
Remarks:
This function only applies to file sources.
See also:
GetTotalFrames

GetTotalFramesEx

SeekFrame

SetActiveSourceId

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetFrameSize | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnFS
 | ) |

Gets the momentary field size of a video source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Momentary field size in Kilo Bytes if successful, -1 otherwise. Call GetLastError for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE The gigen source must be a video source
  • VWERR_UNCOMPATIBLESOURCE The gigen source must be a network source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
Remarks:
This function applies only on network sources.
See also:
GetRate

GetMaxFrameSize

AddSource

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetFramesLost ( [out, retval] long * plFL )

Gets the total number of lost fields for the active source since the connection was established.

Returns:
Number of fields lost if successful, -1 otherwise. Call GetLastError for further information. Possible error codes:
  • VWERR_NOSOURCESELECTED No source was selected by calling SetActiveSourceId function.
Remarks:
A source must be active to be able to call this method.

This function can only be applied to network sources.

See also:
GetFramesLostEx

SetActiveSourceId

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetFramesLostEx | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plFL
 | ) |

Gets the total number of lost fields for the specified source since the connection was established.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Number of fields lost if successful, -1 otherwise. Call GetLastError for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE The gigen source must be a video source.
See also:
GetFramesLostEx

AddSource

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetInfo | ( | [in] BSTR | bstrCommand,
 |  | [out, retval] long * | psInfo
 | ) |

Get various system information.

Parameters:
bstrCommand
Pass one of the following strings:

"videomode" to get supported video modes

"cpuspeed" to get the processor frequency

"soundcapabilities" to get the sound capabilities

"minoverlaystretchfactor" and "maxoverlaystretch-factor" to get the stretch factors for the overlay mode

"diskfreespacehigh:X:\" and "diskfreespace-low:X:\" to get the space available on a disk volume

"actualdisplaymode" to get the current display mode

"displaymodes" to get the supported display modes

Returns:
Depending on entered command line as follows:
"videomode": test the five least significant bits to get the supported video modes:
  • ...00001 : GDI (slower)
  • ...00010 : DirectDraw RGB32
  • ...00100 : DirectDraw YUV
  • ...01000 : Overlay RGB32
  • ...10000 : Overlay YUV (faster)

"cpuspeed": returns the processor frequency in Mhz

"soundcapabilities": 0 means no sound driver found,non 0 otherwise

"minoverlaystretchfactor" or "maxoverlaystretchfactor": Overlay stretch factors, divide by 1,000 to get the factor, 1300 means 1.3

"diskfreespacehigh:X:\" and "diskfreespacelow:X:\": Space available on the X volume. Call the GetInfo function with the command line "diskfreespacehigh:X:\" to know if there is at least 4 GByte of space available.

"actualdisplaymode" : the first 8 bits are the bits per pixel (8, 16, 24 or 32), the following 12 bits are the vertical resolution and the last 12 bits are the horizontal resolution (0x40030020 means 1024x768x32).

"displaymodes": the DisplayModes event will be fired for each supported mode. See the DisplayModes event for further information

Note:
Don't forget that the function returns a signed number, so the space available returned could be interpreted as a negative value in languages such as Basic, BasicScript and JavaScript.
See also:
_IVWActiveXComponentEvents::DisplayModes

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetLastError ( [out, retval] long * plLastErrori )

Returns the last error.

Returns:
Last error code.
See also:
SetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetMaxFrameSize | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnMFS
 | ) |

Gets the maximum field size of a video source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Maximum field size in Kilo Bytes if successful, -1 otherwise. Call GetLastError for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE The gigen source must be a video source
  • VWERR_UNCOMPATIBLESOURCE The gigen source must be a network source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
Remarks:
This function applies only on network sources.

The Access Manager bandwidth control mode must be set to constant bandwidth.

See also:
GetMaxRate

GetFrameSize

AddSource

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetMaxRate | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plMaxRate
 | ) |

Gets the maximum bandwidth of a video source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Maximum bandwidth in Kilo Bytes/sec if successful, -1 otherwise. Call GetLastError for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE The gigen source must be a video source
  • VWERR_UNCOMPATIBLESOURCE The gigen source must be a network source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
Remarks:
This function applies only on network sources.

The Access Manager bandwidth control mode must be set to constant bandwidth.

See also:
GetRate

GetMaxFrameSize

AddSource

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetPropertyBag | ( | [in] long | lSourceId,
 |  | [in] short | sType,
 |  | [out, retval] BSTR * | pbstrProperties
 | ) |

Retrieves extended file's properties as a single string: "propety1=value1,...,propertyn=valuen". Since the v. 2.2 sp3, additionnal datas have been added to files generated by the Storage Manager of the Security Service. Available properties:

  • authoringApp : name of the executable (e.g. vwservice in most case) that generated the file.
  • equipment : name of the equipment where this file was generated.
  • sourceName : name of the input source that this file captured.
  • startTimeStamp: first field time stamp (remote copy only, see Storage Access ActiveX for further information).
  • endTimeStamp : last field time stamp (remote copy only, see Storage Access ActiveX for further information).

Parameters:
lSourceId Source identifier returned by the AddSource function.
sType Source type:
  • 1 for audio properties
  • 2 for video properties
Returns:
Additionnal file properties.
Return values:
Comma separated file properties if successful.
"" if error, call GetLastError to get extended information.
Remarks:
This function applies only on files.

This function should be used on files generated by the Storage Manager. Please see the Security Service documentation.

See also:
GetLastError

IVWStorageAccessCtrl

ExtractString

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetQuality | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnQuality
 | ) |

Gets the current quality for a specified video source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Video stream quality if successful, -1 otherwise. Call GetLastError for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE The gigen source must be a video source
  • VWERR_UNCOMPATIBLESOURCE The gigen source must be a network source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
Remarks:
This function applies only on network sources.

The Access Manager bandwidth control mode must be set to constant quality.

See also:
GetRateEx

AddSource

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetRate ( [out, retval] long * plRate )

Gets the instant bandwidth (network sources) or the average bandwidth (file sources) used by the active source.

Returns:
Bandwidth in Kilo Bytes if successful, -1 otherwise. Call the GetLastError function for further information: Possible error codes:
  • VWERR_NOSOURCESELECTED No source was selected with SetActiveSourceId
  • VWERR_UNCOMPATIBLESOURCE The active source must be a video source
  • VWERR_SOURCENOTCONNECTED The active source must be connected.
See also:
GetRateEx

GetFrameSize

SetActiveSourceId

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetRateEx | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plRate
 | ) |

Gets the instant bandwidth (network sources) or the average bandwidth (file sources) used by the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Bandwidth in Kilo Bytes if successful, -1 otherwise. Call the GetLastError function for further information: Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_SOURCENOTCONNECTED The given source must be connected
  • VWERR_UNCOMPATIBLESOURCE The gigen source must be a video source.
See also:
GetRate

AddSource

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetRealFPS ( [out, retval] float * pfRealFPS )

Gets the average number of fields per second displayed by the control.

Returns:
Number of fields per second displayed by the control.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetSampleRate | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plSampleRate
 | ) |

Retrieves the sample rate of the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Sample rate if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTAUDIOSOURCE The given source must be a audio source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
See also:
GetSoundInfo

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetSkippedFields | ( | [in] long | lSourceId,
 |  | [out] long * | plVFields,
 |  | [out] long * | plAFields,
 |  | [out, retval] long * | plError
 | ) |

Gets the skipped audio or/and video fields during recording.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Operation result.
Return values:
0 Success:
  • plVFields: will contain video skipped fields
  • plAFields: will contain audio skipped fields.
VWERR_SOURCENOTFOUND | The given source id is not valid.
VWERR_NOTPLAYING | The given source is not being recorded.
See also:
RecordOn

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetSoundInfo | ( | [in] long | lSourceId,
 |  | [out] long * | plSampleRate,
 |  | [out] short * | pnChannels,
 |  | [out] short * | pnBitsPerSample,
 |  | [out] short * | pnChunk,
 |  | [out, retval] long * | plError
 | ) |

Gets information about an audio source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Sound information:
  • plSampleRate : sample rate
  • pnChannels : number of channels, 1 means mono and 2 strereo
  • pnBitsPerSample: bits per sample
  • pnChunk : samples number per sound buffer.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected with SetActiveSourceId.
VWERR_NOTAUDIOSOURCE | The given source must be an audio source.
VWERR_SOURCENOTCONNECTED | The given source must be connected.
See also:
GetBitsPerSample

GetChannels

GetChunk

GetSampleRate

GetVideoInfo

AddSource

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetSource | ( | [in] long | lSourceId,
 |  | [in] short | sSource,
 |  | [out, retval] long * | plSourceId
 | ) |

For internal purpose only, must not be used by developpers.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetSourceCategory | ( | [in] short | sType,
 |  | [in] long | lSourceId,
 |  | [out, retval] short * | psSourceCat
 | ) |

Retrieves the category for the specified source.

Parameters:
sType | Must be 0.
lSourceId | Source identifier returned by the AddSource function.
Returns:
Source category.
Return values:
1 | File source.
2 | Network source.
-1 Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_INVALIDPARAMS sType must be set to 0.
See also:
GetSourcePort

GetSourceProtocol

GetSourceType

GetSourceURL

GetSourceURLEx

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetSourcePort | ( | [in] short | sType,
 |  | [in] long | lSourceId,
 |  | [out, retval] short * | pPort
 | ) |

Retrieves the port of a network source.

Parameters:
sType Source type:
  • 1 to retrieve audio source port
  • 2 to retrieve video source port.
lSourceId Source identifier returned by the AddSource function.
Returns:
Source port if successful, -1 otherwise. Call GetLastError for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTAUDIOSOURCE The gigen source type mismatches with the sType parameter
  • VWERR_NOTVIDEOSOURCE The gigen source type mismatches with the sType parameter
  • VWERR_UNCOMPATIBLESOURCE The gigen source must be a network source
  • VWERR_INVALIDPARAMS The sType parameter is invalid.
See also:
GetSourceCategory

GetSourceProtocol

GetSourceType

GetSourceURL

GetSourceURLEx

AddSource

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetSourceProtocol | ( | [in] short | sType,
 |  | [in] long | lSourceId,
 |  | [out, retval] short * | psSourceProto
 | ) |

Retrieves the protocol for the specified source.

Parameters:
sType Source type:
  • 1 to retrieve audio protocol
  • 2 to retrieve video protocol
  • 3 to retrieve audio-video protocols (if applicable).
lSourceId Source identifier returned by the AddSource function.
Returns:
Source protocol.
Return values:
1 | File.
2 | UDP.
3 | IPM.
4 | SVC.
-1 Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_INVALIDPARAMS sType is invalid
  • VWERR_NOTAUDIOSOURCE The given source type mismatches with the sType parameter
  • VWERR_NOTVIDEOSOURCEThe given source type mismatches with the sType parameter.
See also:
GetSourceCategory

GetSourcePort

GetSourceType

GetSourceURL

GetSourceURLEx

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetSourceType | ( | [in] long | lSourceId,
 |  | [out, retval] short * | psSourceType
 | ) |

Retrieves the type for the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
The source type if successful.
Return values:
1 | Audio source.
2 | Video source.
3 | Audio-video source.
-1 Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid.
See also:
AddSource

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetSourceURL | ( | [in] long | lSourceId,
 |  | [out, retval] BSTR * | pVal
 | ) |

Retrieves the URL for the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
The source URL if successful, "Error" otherwise. Call GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid.
Remarks:
The returned URL respects the following AddSource function syntax:
  • network sources: <protocol>://<host_name>:<video_port>{,<audio_port>|<protocol>://<host_name>:<audio_port>}
  • file sources: file://<file_name.(asf|avi|wav|mp3)>.
See also:
GetSourceCategory

GetSourcePort

GetSourceProtocol

GetSourceType

GetSourceURLEx

AddSource

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetSourceURLEx | ( | [in] short | sType,
 |  | [in] long | lSourceId,
 |  | [out, retval] BSTR * | pBSTR
 | ) |

Retrieves the formatted URL for the specified source.

Parameters:
sType Source type:
  • 1 to retrieve audio url
  • 2 to retrieve video url
  • 3 to retrieve audio-video url.
lSourceId Source identifier returned by the AddSource function.
Returns:
The formatted source URL if successful, "Error" otherwise. Call GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid. If successful:
  • network sources: returns the host name
  • file sources : returns the file name.
Remarks:
To get the entire URL using the AddSource function syntax, call GetSourceURL.

If sType is set to 3, GetSourceURL will be called.

If the source is a file source, sType will be ignored and the method will return the entire file name.

See also:
GetSourceCategory

GetSourcePort

GetSourceProtocol

GetSourceType

GetSourceURL

AddSource

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetTemporalLevel | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnTemporalLevel
 | ) |

Gets temporal redundancy level of the video source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Temporal redundancy if successful:
  • 0: non temporal redundancy
  • 2: 4 fields temporal redundancy. Returns -1 otherwise, call GetLastError for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE The gigen source must be a video source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
See also:
AddSource

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetTime ( [out, retval] float * pfTime )

Retrieves the playback elapsed time for a the active source.

Returns:
The elapsed time if sucessful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_NOSOURCESELECTED No source was selected with SetActiveSourceId
  • VWERR_UNCOMPATIBLESOURCE The active source must be a file source
  • VWERR_SOURCENOTCONNECTED The active source must be connected.
Remarks:
This function only applies to file sources.
See also:
GetTotalTime

GetTotalTimeEx

SeekTime

SetActiveSourceId

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetTotalBytes | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plBytes
 | ) |

Retrieves the number of bytes written on the disk since the beginning of the recording for the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Number of Kilo Bytes written on the disk if sucessful, -1 otherwise. Call the GetLastError function for further information: Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTPLAYING The given source is not being recorded.
See also:
RecordOn

ReconrdOnEx

BufferingRecordOn

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetTotalFrames ( [out, retval] long * plFrames )

Retrieves the number of fields for the active source.

Returns:
The number of fields in file if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_NOSOURCESELECTED No source was selected with SetActiveSourceId
  • VWERR_SOURCENOTCONNECTED The active source must be connected
  • VWERR_NOTVIDEOSOURCE The active source must be a video source
  • VWERR_UNCOMPATIBLESOURCE The active source must be a file source.
Remarks:
This function applies only on files.
See also:
GetTotalFramesEx

SeekFrame

GetFrame

SetActiveSourceId

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetTotalFramesEx | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plFrames
 | ) |

Retrieves the number of fields for the spcified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
The number of fields in file if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid.
  • VWERR_SOURCENOTCONNECTED The given source must be connected
  • VWERR_NOTVIDEOSOURCE The given source must be a video source
  • VWERR_UNCOMPATIBLESOURCE The given source must be a file source.
Remarks:
This function applies only on files.
See also:
GetTotalFrames

AddSource

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetTotalTime ( [out, retval] float * pfTime )

Retrieves the duration of the active source.

Returns:
The file duration if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_NOSOURCESELECTED No source was selected with SetActiveSourceId
  • VWERR_SOURCENOTCONNECTED The active source must be connected
  • VWERR_NOTVIDEOSOURCE The active source must be a video source
  • VWERR_UNCOMPATIBLESOURCE The active source must be a file source.
Remarks:
This function applies only on files.
See also:
GetTotalTimeEx

SeekTime

GetTime

SetActiveSourceId

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetTotalTimeEx | ( | [in] long | lSourceId,
 |  | [out, retval] float * | pfTime
 | ) |

Retrieves the duration for the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
The file duration if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid.
  • VWERR_SOURCENOTCONNECTED The given source must be connected
  • VWERR_NOTVIDEOSOURCE The given source must be a video source
  • VWERR_UNCOMPATIBLESOURCE The given source must be a file source.
Remarks:
This function applies only on files.
See also:
GetTotalTime

AddSource

ConnectId

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetVideoFormat | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnVf
 | ) |

Retrieves the video format of the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Source video format.
Return values:
0x2100 | VIDEO_FORMAT_NTSC_M.
0x1100 | VIDEO_FORMAT_NTSC_N.
0x2102 | VIDEO_FORMAT_NTSC_443.
0x2103 | VIDEO_FORMAT_NTSC_JP.
0x2105 | VIDEO_FORMAT_BW_60.
0x1206 | VIDEO_FORMAT_PAL_BGHI.
0x1207 | VIDEO_FORMAT_PAL_N.
0x2208 | VIDEO_FORMAT_PAL_M.
0x2209 | VIDEO_FORMAT_PAL_443.
0x220A | VIDEO_FORMAT_PAL_D.
0x120B | VIDEO_FORMAT_BW_50.
0x130C | VIDEO_FORMAT_SECAM_L.
-1 Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE The given source must be a video source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
See also:
GetVideoInfo

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetVideoInfo | ( | [in] long | lSourceId,
 |  | [out] short * | pnVidX,
 |  | [out] short * | pnVidY,
 |  | [out] short * | pnVf,
 |  | [out] short * | pnFps,
 |  | [out] short * | pnFields,
 |  | [out, retval] long * | plError
 | ) |

Retrieves video information from the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Video information:
  • pnVidX : video width in pixels
  • pnVidY : video height in pixels
  • pnVf : video format
  • pnFps : fields per second (multiplied by 100 eg 5000 means 50)
  • pnFields: field parity, 0 for odd and even fields with interlacing, 1 for odd fields only, 2 for even fields only and 3 for odd and even fields without interlacing.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected with SetActiveSourceId.
VWERR_NOTVIDEOSOURCE | The given source must be a video source.
VWERR_SOURCENOTCONNECTED | The given source must be connected.
See also:
GetFields

GetVideoFormat

GetVidX

GetVidY

GetSoundInfo

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetVidX | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnVidX
 | ) |

Retrieves the image width of the specified video source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Width in pixels if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE The given source must be a video source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
See also:
GetVideoInfo

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetVidY | ( | [in] long | lSourceId,
 |  | [out, retval] short * | pnVidY
 | ) |

Retrieves the image height of the specified video source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Height in pixels if successful, -1 otherwise. Call the GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid
  • VWERR_NOTVIDEOSOURCE The given source must be a video source
  • VWERR_SOURCENOTCONNECTED The given source must be connected.
See also:
GetVideoInfo

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetVWBoards ( [out, retval] short * psNumber )

Retrieves the number of VisioWave Codec boards available in the system.

Returns:
Number of VW Codec boards opened.
Remarks:
When the XVWDisplay Active X is launched, it will open all the VW Codec boards in the system unless a specified key is set in the registry: Software\VisioWave\ActiveXControl\XVWDisplay\NumberOfRejectedChannels where NumberOfRejectedChannels indicates to the XVWDisplay the numbers of VW Codec boards to ignore.

If a XVWDisplay is launched and has opened all the VW Codec boards in the system, other XVWDisplay launched will not have access to the driver eg they will not able to play video output to a monitor.

See also:
OutputToVWBoardOn

OutputToVWBoardOnEx

IsPlayingVWBoard

OutputToVWBoardOff

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetWindow ( [out, retval] long * plWindow )

Gets the control window handle.

Returns:
Control window handle.
Remarks:
This handle can be used with Microsoft(r) GDI functions.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::GetZoom ( [out, retval] float * pfZoom )

Gets the current zooming factor.

Returns:
Zooming factor.
See also:
Zoom

CenterZoom

MoveZoom

HRESULT XVWDISPLAYLib::IVWActiveXComponent::HasSync | ( | [in] short | nNumber,
 |  | [out, retval] short * | pnHasSync
 | ) |

For internal purpose only, must not be used by developpers.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::IsAttached | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plSources
 | ) |

For internal purpose only, must not be used by developpers.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::IsConnected | ( | [in] long | lSourceId,
 |  | [out, retval] short * | piConnected
 | ) |

Gets the connection status for the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Connection status.
Return values:
0 | Not connected.
1 | Audio is connected.
2 | Video is connected.
4 | Audio is connecting.
8 | Video is connecting.
-1 Call GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid.
See also:
ConnectId

DisconnectId

GetLastError

AddSource

HRESULT XVWDISPLAYLib::IVWActiveXComponent::IsFullScreen ( [out, retval] short * psMode )

Gets the full screen status.

Returns:
Full screen status.
Return values:
0 | Not in full screen.
1 | FullScreenOn function was called with parameter sMode set to 1.
2 | FullScreenOn function was called with parameter sMode set to 2.
See also:
FullScreenOn

FullScreenOff

HRESULT XVWDISPLAYLib::IVWActiveXComponent::IsLooping ( [out, retval] BOOL * pbLooping )

Determines whether the active source will loop automatically at the last field.

Returns:
Looping mode:
  • 0 the file will loop
  • non 0 the file won't loop.
Remarks:
This function applies only on file sources.

A source must have been selected using SetActiveSourceId function.

The active must have been connected using ConnectId function.

A file set to looping mode by calling Loop(true) will remain looping until Loop(false) is called.

See also:
Loop

SetActiveSourceId

ConnectId

HRESULT XVWDISPLAYLib::IVWActiveXComponent::IsPlayingVWBoard | ( | [in] short | sNumber,
 |  | [out, retval] long * | plSourceId
 | ) |

Determines if a source is redirected to a specified VisioWave Codec board.

Parameters:
sNumber VW Codec board number. Starts from 1.
Returns:
VisioWave Codec board status: 0 if no source is played, the source identifier of the redirected source or -1 otherwise. Call GetLastError for further information.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::IsRecording | ( | [in] long | lSourceId,
 |  | [out, retval] short * | piRecording
 | ) |

Determines if the specified source is being recorded.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Whether the source is being recorded or not.
Return values:
0 | Not being recorded.
1 | Audio part of the source is being recorded.
2 | Video part of the source is being recorded.
3 | Audio and video parts of the source are being recorded.
-1 Call GetLastError function for further information. Possible error codes:
  • VWERR_SOURCENOTFOUND The given source id is not valid.
See also:
RecordOn

ReconrdOnEx

BufferingRecordOn

RecordOff

GetTotalBytes

GetLastError

AddSource

HRESULT XVWDISPLAYLib::IVWActiveXComponent::IsValidId | ( | [in] long | lSourceId,
 |  | [out, retval] BOOL * | pbValid
 | ) |

Determines whether the specified source identifier exists or not.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Source identifier validity:
  • 0 if not valid
  • non 0 if valid.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::LoadPicture | ( | [in] BSTR | bstrURL,
 |  | [out, retval] long * | plError
 | ) |

Loads and displays background picture from given URL.

Parameters:
bstrURL URL from which the picture will be loaded. It must respect the following syntax:
  • http://host_name[:host_port]/.../image.bmp(jpg,gif) for remote image
  • file://X:/.../image.bmp(jpg,gif) for local image.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_FILECORRUPTED | The file is corrupted or its format not supported.
VWERR_ACCESSDENIED | The host was not found, refused the connection or is down.
VWERR_FILENOTFOUND | Then the file was not found on the local hardrive or on the remote server.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::LoadWinSock2 ( void )

Initiates use of the windows network dll by the control.

Remarks:
To connect network sources, this method should be called before any connection.

If the dll is already in use, this method will not perform any action.

See also:
UnloadWinSock2

HRESULT XVWDISPLAYLib::IVWActiveXComponent::Loop ( [in] BOOL bLoop )

Sets the looping flag for a source file.

Parameters:
bLoop 0 for false and non 0 for true.
Remarks:
The default flag is true.

When the last field is reached and if the looping flag is set to false, the Eof event is fired.

If the SetRate function was called with a negative playback speed or greater than 1.0, the file won't loop even if the looping flag was set to true.

See also:
IsLooping

SetRate

_IVWActiveXComponentEvents::Eof

HRESULT XVWDISPLAYLib::IVWActiveXComponent::MoveZoom | ( | [in] long | lxPos,
 |  | [in] long | lyPos,
 |  | [out, retval] long * | plError
 | ) |

Centers the zoom on the given set of control window coordinates.

Parameters:
lxPos | New center x-coordinate.
lyPos | New center y-coordinate.
Returns:
Operation result.
Return values:
VWERR_NOERROR Success.
Remarks:
The coordinates use the same coordinates system than the XXXButtonXXX and MouseXXX events.
See also:
Zoom

CenterZoom

GetZoom

HRESULT XVWDISPLAYLib::IVWActiveXComponent::NextSource ( [out, retval] long * lSourceId )

Activates the next source in the list.

Returns:
New active source identifier if successful, -1 otherwise. Call GetLastError for further information. Possible error codes:
  • VWERR_NOSOURCESELECTED No source was selected by calling SetActiveSourceId function.
Remarks:
A source must be active to be able to call this method.
See also:
SetActiveSourceId

PreviousSource

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::OutputToVWBoardOff | ( | [in] short | sNumber,
 |  | [out, retval] long * | plSourceId
 | ) |

Stops redirection of video output to a specified board.

Parameters:
sNumber VW Codec board number. Starts from 1.
Returns:
Source identifier being played to monitor, -1 otherwise. Call GetLastError function for further information. Possible error codes:
  • VWERR_NOVWPCIBOARD No VW Codec found by the control
  • VWERR_NOTPLAYING The control is not playing the specified source.
See also:
GetVWBoards

OutputToVWBoardOn

OutputToVWBoardOnEx

IsPlayingVWBoard

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::OutputToVWBoardOn | ( | [in] long | lSourceId,
 |  | [in] short | sNumber,
 |  | [out, retval] long * | plError
 | ) |

Starts redirection of video output to a specified board.

Parameters:
lSourceId | Source identifier returned by the AddSource function.
sNumber | VW Codec board number. Starts from 1.
Returns:
Operatoin result.
Return values:
VWERR_NORERROR | Success.
VWERR_NOVWPCIBOARD | No VW Codec found by the control.
VWERR_SOURCENOTFOUND | The given source id is not valid.
VWERR_NOTVIDEOSOURCE | The given source must be a video source.
VWERR_SOURCENOTCONNECTED | The given source must be connected.
Remarks:
To be able to redirect video the VW Codec driver must be installed on the system.
See also:
GetVWBoards

OutputToVWBoardOnEx

IsPlayingVWBoard

OutputToVWBoardOff

HRESULT XVWDISPLAYLib::IVWActiveXComponent::OutputToVWBoardOnEx | ( | [in] long | lSourceId,
 |  | [in] short | sNumber,
 |  | [in] short | nVideoFormat,
 |  | [out, retval] long * | plError
 | ) |

Starts redirection of video output to a specified channel with the option to change the output video format.

Parameters:
lSourceId | Source identifier returned by the AddSource function.
sNumber | Channel number (starts from 1).
nVideoFormat Output video format. Set it to -1 to use the source's video format, or one of the possible values otherwise:
  • 0x2100 (VIDEO_FORMAT_NTSC_M)
  • 0x1100 (VIDEO_FORMAT_NTSC_N)
  • 0x2105 (VIDEO_FORMAT_BW_60)
  • 0x1206 (VIDEO_FORMAT_PAL_BGHI)
  • 0x2208 (VIDEO_FORMAT_PAL_M)
  • 0x220A (VIDEO_FORMAT_PAL_D)
  • 0x120B (VIDEO_FORMAT_BW_50).
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_UNCOMPATIBLESOURCE | The given source is an audio source but the VisioWave Codec board in the system has no capabilities to play audio output (ex: VisioWave 1).
VWERR_SOURCENOTCONNECTED | The given source must be connected.
VWERR_NOVWPCIBOARD | No VisioWave driver found or not started.
See also:
OutputToVWBoardOn

OutputToVWBoardOff

IsPlayingVWBoard

AddSource

HRESULT XVWDISPLAYLib::IVWActiveXComponent::Pause | ( | [in] short | sType,
 |  | [out, retval] long * | plError
 | ) |

Pauses the current playback of the active source.

Parameters:
sType Source type:
  • 1 to connect audio
  • 2 to connect video
  • 3 to connect audio and video.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected by calling SetActiveSourceId function.
VWERR_INVALIDPARAMS | sType is invalid.
VWERR_SOURCENOTCONNECTED | The source must be connected to be played.
VWERR_NOTPLAYING | The source was not resumed by calling Resume function.
See also:
SetActiveSourceId

Resume

HRESULT XVWDISPLAYLib::IVWActiveXComponent::Picture ( [in] IPictureDisp * pPicture )

The controls background picture.

Property[R|W] : Sets the default background picture displayed by the control.

Note:
See your development platform's documentation on creating a PICTURE instance implementing the the COM interface IPictureDisp.
This property will be mapped in different ways depending on development platform.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::PreviousSource ( [out, retval] long * lSourceId )

Activates the previous source in the list.

Returns:
New active source identifier if successful, -1 otherwise. Call GetLastError for further information. Possible error codes:
  • VWERR_NOSOURCESELECTED No source was selected by calling SetActiveSourceId function.
Remarks:
A source must be active to be able to call this method.
See also:
SetActiveSourceId

NextSource

GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::PrintScreen | ( | [in] long | lDisplaySetup,
 |  | [in] BSTR | bstrDocName,
 |  | [out, retval] long * | plError
 | ) |

Prints the current field displayed by the control.

Parameters:
lDisplaySetup | If non zero, displays the printer setup dialog box, use the default parameters otherwise.
bstrDocName | Document title.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_UNKNOWNERROR | Printer error.
Remarks:
Uses the control decoder size property to print the current video field.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::RecordOff | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plError
 | ) |

Stops the recording of a specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_SOURCENOTFOUND | The given source id is not valid.
VWERR_NOTPLAYING | The control is not recording the specified source.
See also:
RecordOn

ReconrdOnEx

BufferingRecordOn

IsRecording

GetTotalBytes

AddSource

HRESULT XVWDISPLAYLib::IVWActiveXComponent::RecordOn | ( | [in] long | lSourceId,
 |  | [in] short | sType,
 |  | [in] double | RealFPS,
 |  | [in] BSTR | bstrName,
 |  | [out, retval] long * | plError
 | ) |

Starts the recording of a specified source to a file.

Parameters:
lSourceId | Source identifier returned by the AddSource function.
sType Source type:
  • 1 for audio recording
  • 2 for video recording
  • 3 for audio and video recording (if applicable).
RealFPS | Fiels pers second (ex: 12.5 or 6.0).
bstrName | File name (asf, avi, wav or mp3).
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_SOURCENOTFOUND | The given source id is not valid.
VWERR_INVALIDPARAMS | Invalid parameters were passed to the function.
VWERR_NOTAUDIOSOURCE | The user asks for audio recording (sType=1) while the given source is a video source.
VWERR_NOTVIDEOSOURCE | The user asks for video recording (sType=2) while the given source is an audio source.
VWERR_SOURCENOTCONNECTED | The given source must be connected.
VWERR_ALREADYPLAYING | The given source is already being recorded.
VWERR_TOOMANYVIDEOSOURCES | The component was not able to allocate resources for this operation.
VWERR_TOOMANYAUDIOSOURCES | The component was not able to allocate resources for this operation.
VWERR_OUTOFMEMORY | The component was not able to allocate resources for this operation.
Remarks:
By default, the component uses a few Mega Bytes (~4 MB) of RAM per storage to avoid frames loss.

Disconnection of the source (audio and/or video part) will stop the recording.

See also:
RecordOnEx

IsRecording

RecordOff

BufferingRecordOn

GetTotalBytes

GetSkippedFields

AddSource

ConnectId

HRESULT XVWDISPLAYLib::IVWActiveXComponent::RecordOnEx | ( | [in] long | lSourceId,
 |  | [in] short | sType,
 |  | [in] double | RealFPS,
 |  | [in] BSTR | bstrName,
 |  | [in] BSTR | bstrFormat,
 |  | [out, retval] long * | plError
 | ) |

Starts the recording of a specified source to a file.

Parameters:
lSourceId | Source identifier returned by the AddSource function.
sType Source type:
  • 1 for audio recording
  • 2 for video recording
  • 3 for audio and video recording (if applicable).
RealFPS | Fiels pers second (ex: 12.5 or 6.0).
bstrName | File name.
bstrFormat | File format (asf, avi, wav or mp3).
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_SOURCENOTFOUND | The given source id is not valid.
VWERR_INVALIDPARAMS | Invalid parameters were passed to the function.
VWERR_NOTAUDIOSOURCE | The user asks for audio recording (sType=1) while the given source is a video source.
VWERR_NOTVIDEOSOURCE | The user asks for video recording (sType=2) while the given source is an audio source.
VWERR_SOURCENOTCONNECTED | The given source must be connected.
VWERR_ALREADYPLAYING | The given source is already being recorded.
VWERR_TOOMANYVIDEOSOURCES | The component was not able to allocate resources for this operation.
VWERR_TOOMANYAUDIOSOURCES | The component was not able to allocate resources for this operation.
VWERR_OUTOFMEMORY | The component was not able to allocate resources for this operation.
Remarks:
By default, the component uses a few Mega Bytes (~4 MB) of RAM per storage to avoid frames loss.

Disconnection of the source (audio and/or video part) will stop the recording.

See also:
RecordOn

HRESULT XVWDISPLAYLib::IVWActiveXComponent::Refresh ( void )

Forces the control to update its window.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::ReleaseDC | ( | [in] long | lDC,
 |  | [out, retval] long * | plError
 | ) |

Releases the DC that was fetched with the GetDC function.

Parameters:
lDC DC returned by GetDC function.
Returns:
Operation result.
Return values:
VWERR_NOERROR Success.
Remarks:
A DC fetched while in full screen must be released in full screen. The same goes for a DC fetched in windowed mode.
See also:
GetDC

HRESULT XVWDISPLAYLib::IVWActiveXComponent::RemoveOsd ( [in] long lOsdId )

Deletes given OSD.

Parameters:
lOsdId OSD Id returned by the DisplayOsd function.
See also:
DisplayOsd

UpdateOsd

ClearOsd

HRESULT XVWDISPLAYLib::IVWActiveXComponent::RemoveSourceId | ( | [in] long | lSourceId,
 |  | [out, retval] long * | plError
 | ) |

Disconnect and remove the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_SOURCENOTFOUND | The given source id is not valid.
Remarks:
If SourceId is set to -1, all the sources will be removed.
See also:
AddSource

HRESULT XVWDISPLAYLib::IVWActiveXComponent::RemoveText ( [in] long lTextId )

Removes a text from the screen.

Parameters:
lTextId Text identifier.
Remarks:
To remove all the texts displayed using TextOut function, set lTextId to -1.
See also:
TextOut

TextOutEx

HRESULT XVWDISPLAYLib::IVWActiveXComponent::Resume | ( | [in] short | sType,
 |  | [out, retval] long * | plError
 | ) |

Plays the active source.

Parameters:
sType Source type:
  • 1 to connect audio
  • 2 to connect video
  • 3 to connect audio and video.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected by calling SetActiveSourceId function (sType set to 1 or 2).
VWERR_INVALIDPARAMS | sType is invalid.
VWERR_SOURCENOTCONNECTED | The source must be connected to be played (sType set to 1 or 2).
VWERR_ALREADYPLAYING | The source was previously resumed (sType set to 1 or 2).
1 | Audio has failed (sType set to 3).
2 | Video has failed (sType set to 3).
3 | Audio and video have failed (sType set to 3).
Remarks:
In case of an error, make sur the sources are properly connected.

An internal activation counter is incremented by this method. It is therefore necessary to call Pause function as many times as the Resume function.

See also:
SetActiveSourceId

Pause

HRESULT XVWDISPLAYLib::IVWActiveXComponent::Running ( [out, retval] short * pVal )

The active source's play status.

Property[R] : Indicates if the current source is playing or paused.

Tag | Value | Description
VW_ST_RESERVED | 0 | The source is paused
VW_ST_AUDIO | 1 | The source is playing audio
VW_ST_VIDEO | 2 | The source is playing video
VW_ST_AUDIOVIDEO | 3 | The source is playing audio and video

HRESULT XVWDISPLAYLib::IVWActiveXComponent::SeekFrame | ( | [in] long | lFrame,
 |  | [out, retval] long * | plError
 | ) |

Jumps to a specific field.

Parameters:
lFrame Field number.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected with SetActiveSourceId.
VWERR_SOURCENOTCONNECTED | The active source must be connected.
VWERR_NOTVIDEOSOURCE | The active source must be a video source.
VWERR_INVALIDPARAMS | lFrame is invalid, please see remarks for network sources.
Remarks:
The first field has the number 0.

If the specified source is a network source, a call to SeekFrame while source is playing has no effect.

If the specified source is a network source, a call to SeekFrame with lFrame set to -1 while playback is paused will just decode the current image.

See also:
GetTotalFrames

GetTotalFramesEx

GetFrame

SetActiveSourceId

ConnectId

HRESULT XVWDISPLAYLib::IVWActiveXComponent::SeekTime | ( | [in] float | fTime,
 |  | [out, retval] long * | plError
 | ) |

Jumps to a specific time.

Parameters:
fTime Field time.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected with SetActiveSourceId.
VWERR_SOURCENOTCONNECTED | The active source must be connected.
VWERR_NOTVIDEOSOURCE | The active source must be a video source.
VWERR_UNCOMPATIBLESOURCE | The active source must be a file source.
See also:
GetTotalTime

GetTotalTimeEx

GetTime

SetActiveSourceId

ConnectId

HRESULT XVWDISPLAYLib::IVWActiveXComponent::SetActiveSourceId | ( | [in] long | newVal,
 |  | [out, retval] long * | plError
 | ) |

Activates the specified source.

Parameters:
lSourceId Source identifier returned by the AddSource function.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_SOURCENOTFOUND | The given source id is not valid.
See also:
GetActiveSourceId

AddSource

HRESULT XVWDISPLAYLib::IVWActiveXComponent::SetLastError ( [in] long lLastError )

Initiates the last error.

Parameters:
lLastError Error code.
See also:
GetLastError

HRESULT XVWDISPLAYLib::IVWActiveXComponent::SetQuality | ( | [in] long | lSourceId,
 |  | [in] short | nQuality,
 |  | [out, retval] long * | plError
 | ) |

For internal purpose only, must not be used by developpers.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::SetQueue | ( | [in] long | lSourceId,
 |  | [in] short | sType,
 |  | [in] short | sQueue,
 |  | [out, retval] long * | plError
 | ) |

Sets the internal buffers queue for the specified source.

Parameters:
lSourceId | Source identifier returned by the AddSource function.
sType Source type:
  • 1 for audio queue
  • 2 for video queue.
sQueue | Buffers queue, must be equal or between 1 and 29.
Returns:
Operation result.
Return values:
VWERR_SOURCENOTFOUND | The given source id is not valid.
VWERR_INVALIDPARAMS | The sQueue parameter is not valid.
VWERR_NOTAUDIOSOURCE | The given source type mismatches with the sType parameter.
VWERR_NOTVIDEOSOURCE | The given source type mismatches with the sType parameter.
VWERR_SOURCENOTCONNECTED | The given source must be connected.
See also:
AddSource

ConnectId

HRESULT XVWDISPLAYLib::IVWActiveXComponent::SetRate | ( | [in] float | fRate,
 |  | [out, retval] long * | plError
 | ) |

Set the playback speed for the active source.

Parameters:
fRate Playback speed (1.0 means normal speed).
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected with SetActiveSourceId.
VWERR_SOURCENOTCONNECTED | The active source must be connected.
VWERR_NOTVIDEOSOURCE | The active source must be a video source.
VWERR_UNCOMPATIBLESOURCE | The active source must be a file source.
Remarks:
This function only applies to file sources.

For playback speeds greater than 1.0, SetRate must be called after Resume otherwise they will not be taken into account.

When the playback speed is between 0.0 and 1.0, the file will loop if looping mode was set to true, otherwise, whatever the looping mode was set or not, the file will stop at the end or the beginning of the file and the Eof event will be fired. To loop, just wait for this event, call SeekFrame to go back at the beginning or the end of the file and call Resume.

To play the file backward from the end (with a negative playback speed), seek to the GetTotalFrames()-2 (GetTotalFrames()-3 for a temporal file) frame and call SetRate and at last Resume.

See also:
GetRate

SetActiveSourceId

ConnectId

Loop

SeekFrame

Resume

HRESULT XVWDISPLAYLib::IVWActiveXComponent::SetVideoFormat | ( | [in] long | lSourceId,
 |  | [in] short | nVf,
 |  | [out, retval] long * | plError
 | ) |

For internal purpose only, must not be used by developpers.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::ShowCursor ( [in] BOOL bShow )

Shows or hides the mouse cursor.

Parameters:
bShow True to show the cursor, false to hide it.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::Start | ( | [in] short | sType,
 |  | [out, retval] long * | plError
 | ) |

Connects (blocking connection) and plays the active source.

Parameters:
sType Source type:
  • 1 to connect audio
  • 2 to connect video
  • 3 to connect audio and video.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected by calling SetActiveSourceId function.
VWERR_WINSOCKNOTLOADED | To connect network sources, the windows network dll must be loaded.
VWERR_NOTVIDEOSOURCE | sType parameter mismatches with the source type.
VWERR_NOTAUDIOSOURCE | sType parameter mismatches with the source type.
VWERR_INVALIDPARAMS | sType is invalid.
VWERR_SOURCEALREADYCONNECTED | The source is already connected.
See also:
SetActiveSourceId

LoadWinSock2

ConnectId

Resume

HRESULT XVWDISPLAYLib::IVWActiveXComponent::Stop | ( | [in] short | sType,
 |  | [out, retval] long * | plError
 | ) |

Pauses and disconnects the active source.

Parameters:
sType Source type:
  • 1 to connect audio
  • 2 to connect video
  • 3 to connect audio and video.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected by calling SetActiveSourceId function.
VWERR_NOTVIDEOSOURCE | sType parameter mismatches with the source type.
VWERR_NOTAUDIOSOURCE | sType parameter mismatches with the source type.
VWERR_INVALIDPARAMS | sType is invalid.
VWERR_SOURCENOTCONNECTED | The source must be connected to be stopped.
See also:
SetActiveSourceId

DisconnectId

Pause

Start

HRESULT XVWDISPLAYLib::IVWActiveXComponent::Synchronize | ( | [in] BOOL | bSync,
 |  | [out, retval] long * | plError
 | ) |

For internal purpose only, must not be used by developpers.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::TextOut | ( | [in] BSTR | bstrText,
 |  | [in] long | lX,
 |  | [in] long | lY,
 |  | [in] OLE_COLOR | BackClr,
 |  | [in] OLE_COLOR | TextClr,
 |  | [out, retval] long * | plTextId
 | ) |

Displays a text on the screen.

Parameters:
bstrText | Text to display.
lX | Text horizontal coordinate.
lY | Text vertical coordinate.
BackClr | Text background color.
TextClr | Text color.
Returns:
Text identifier.
See also:
TextOutEx

RemoveText

HRESULT XVWDISPLAYLib::IVWActiveXComponent::TextOutEx | ( | [in] BSTR | bstrText,
 |  | [in] long | lX,
 |  | [in] long | lY,
 |  | [in] OLE_COLOR | BackClr,
 |  | [in] OLE_COLOR | TextClr,
 |  | [in, defaultvalue("")] BSTR | bstrFontName,
 |  | [in, defaultvalue(0)] long | lPointSize,
 |  | [in, defaultvalue(FALSE)] BOOL | bBold,
 |  | [in, defaultvalue(FALSE)] BOOL | bItalic,
 |  | [in, defaultvalue(FALSE)] BOOL | bUnderline,
 |  | [in, defaultvalue(FALSE)] BOOL | bStrikeOut,
 |  | [out, retval] long * | plTextId
 | ) |

Displays a text on the screen.

Parameters:
bstrText | Text to display.
lX | Text horizontal coordinate.
lY | Text vertical coordinate.
BackClr | Text background color.
TextClr | Text color.
bstrFontName | Typeface name of the font to use (can be a null-length string for default font).
lPointSize | Height in points of the font to use (can be null for default height).
bBold | Specifies if the text must be bold.
bItalic | Specifies if the text must be italic.
bUnderline | Specifies if the text must be underlined.
bStrikeOut | Specifies if the text must be striked out.
Returns:
Text identifier.
See also:
RemoveText

HRESULT XVWDISPLAYLib::IVWActiveXComponent::UnloadWinSock2 ( void )

Terminates use of the windows network dll by the control.

Remarks:
If the dll is already unloaded, this method will not perform any action.
See also:
LoadWinSock2

HRESULT XVWDISPLAYLib::IVWActiveXComponent::UpdateOsd | ( | [in] long | lOsdId,
 |  | [in] BSTR | bstrText,
 |  | [in] OLE_COLOR | TextClr,
 |  | [in] OLE_COLOR | BackClr,
 |  | [in] short | sAlpha
 | ) |

Updates given OSD.

Parameters:
lOsdId | OSD Id returned by the DisplayOsd function.
bstrText | OSD text.
TextClr | Text color.
BackClr | Background color.
sAlpha Alpha component for background transparency. Possibles values:
  • 0x60 ( 0% transparency)
  • 0x40 ( 75% transparency)
  • 0x20 ( 50% transparancy)
  • 0x00 ( 25% transparancy)
  • 0x80 (100% transparancy).
See also:
DisplayOsd

RemoveOsd

ClearOsd

HRESULT XVWDISPLAYLib::IVWActiveXComponent::VideoHeight ( [out, retval] short * pVal )

The active source's video height.

Property[R] : The active source's decompressed video height.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::VideoMode ( [out, retval] long * pVal )

The control's video display mode.

Property[R|W] : Chooses the control's video display mode.

Tag | Value | Description
VW_VM_AUTO | 0 | Chooses automatically the most appropriate video mode
VW_VM_GDI | 1 | Uses Windows GDI functions
VW_VM_DDRAW_RGB | 2 | Uses the 2D library of DirectX DirectDraw in RGB mode
VW_VM_DDRAW_YUY2 | 3 | Uses the 2D library of DirectX DirectDraw in YUV mode
VW_VM_OVERLAY_RGB | 4 | Uses an Overlay in RGB mode
VW_VM_OVERLAY_YUY2 5 Uses an Overlay in YUY2 mode

Note:
Use the GetInfo method to get information about supported video modes. The GDI mode is the slowest mode because of its non hardware-accelerated architecture but works on all display devices.
Video artifacts can appear if the control dimensions are smaller than the video dimensions.

Few video devices support Overlay in Windows NT. As in GDI mode, video artifacts can appear in Overlay mode if the control dimensions are smaller than the video dimensions. If the device driver does not support negative mode, the video will freeze.

Use GetInfo to get information about the video device's zooming factors in Overlay mode. In general, display devices can only create one single Overlay.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::VideoWidth ( [out, retval] short * pVal )

The active source's video width.

Property[R] : The active source's decompressed video width.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::VideoZoom ( [out, retval] long * pVal )

The control's zoom settings.

Property[R|W] : Allows/Disallows the control to stretch the video to the control's windows size.

Tag | Value | Description
VW_VZ_CENTERED | 0 | Displays the decompressed video without stretching effects
VW_VZ_BESTFITS | 1 | Adapts the video to the height of the window
VW_VZ_WIDESCREEN | 2 | Adapts the video to the width of the window
VW_VZ_MAX 3 Zooms the video to the entire control window

Note:
The VW_VZ_WIDESCREEN mode may loose some of the upper and lower lines of the video depending on the components's proportions.

HRESULT XVWDISPLAYLib::IVWActiveXComponent::Zoom | ( | [in] float | fScale,
 |  | [out, retval] long * | plError
 | ) |

Zooms the control video display in or out.

Parameters:
fScale Zoom factor.
Returns:
Operation result.
Return values:
VWERR_NOERROR | Success.
VWERR_NOSOURCESELECTED | No source was selected to be displayed using SetActiveSourceId.
VWERR_NOTVIDEOSOURCE | This function only applies to video sources.
See also:
CenterZoom

MoveZoom

GetZoom

SetActiveSourceId

Generated on Tue Oct 3 18:24:22 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl Interface Reference

VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl

VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl Interface Reference

This ActiveX control allows to remote control audio playback on equipments with preconfigured audio outputs. The ActiveX control can establish playback of either audio sources captured in real time by VisioWave equipments located anywhere on the network, MP3 files local to the equipment or playback of previously recorded audio content again anywhere on the network (using the VWStorageAccessController and XVWTimeLine ActiveX controls). It can also be used to capture and stream audio locally in respect to the ActiveX control. See the VWAudioOutputCtrl_VB sample for a small example in Visual Basic on how to use it. More...

import "VWAudioOutputController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | AddToGroupAndConnect ([out, retval] long *Result)
HRESULT | Blocking ([in] BOOL Blocking)
HRESULT | Blocking ([out, retval] BOOL *Blocking)
HRESULT | CloseLocalAAM ()
HRESULT | DeleteFromGroup ([in] BSTR Name,[out, retval] long *Result)
HRESULT | ExtractBoolean ([in] BSTR Parameter,[in] BSTR Params,[out, retval] BOOL *Value)
HRESULT | ExtractInteger ([in] BSTR Parameter,[in] BSTR Params,[out, retval] long *Value)
HRESULT | ExtractNumber ([in] BSTR Parameter,[in] BSTR Params,[out, retval] double *Value)
HRESULT | ExtractString ([in] BSTR Parameter,[in] BSTR Params,[out, retval] BSTR *Value)
HRESULT | FlushGroup ()
HRESULT | GetId ([out, retval] long *pInterface)
HRESULT | GetParamsOf ([in] BSTR Name,[out, retval] BSTR *Params)
HRESULT | GetStatOf ([in] BSTR bstrName,[out, retval] BSTR *Params)
HRESULT | GetStatusOf ([in] BSTR Name,[out, retval] long *Result)
HRESULT | LocalAAMBoard ([out, retval] long *LocalBoard)
HRESULT | LocalAAMPort ([out, retval] long *LocalPort)
HRESULT | OpenLocalAAM ([in] long Port,[in] BSTR Connector,[in] long Board,[in] long TargetRate,[in] BSTR Id,[out, retval] long *Result)
HRESULT | Port ([in] long Port)
HRESULT | Port ([out, retval] long *Port)
HRESULT | Rehash ([in] BSTR Name,[out, retval] long *Result)
HRESULT | RehashGroup ()
HRESULT | ResetGroup ()
HRESULT | ResetSource ()
HRESULT | Server ([in] BSTR Hostname)
HRESULT | Server ([out, retval] BSTR *Hostname)
HRESULT | SetFileSource ([in] BSTR FileSource)
HRESULT | SetHardSource ([in] long CardNumber,[in] BSTR Connector,[out, retval] long *Result)
HRESULT | SetLocalAAM_AtmConfig ([in] BOOL Available,[in] BOOL Multicast,[in] BSTR QOS,[in] long OfInterface,[in] long Chunk,[out, retval] long *Result)
HRESULT | SetLocalAAM_IpmConfig ([in] BOOL Available,[in] long OfInterface,[in] long Precedence,[in] BSTR Addr,[in] long Port,[in] long TTL,[in] long MTU,[out, retval] long *Result)
HRESULT | SetLocalAAM_UdpConfig ([in] BOOL Available,[in] long OfInterface,[in] long Precedence,[in] long SourcePort,[in] long MTU,[out, retval] long *Result)
HRESULT | SetNetSource ([in] BSTR Proto,[in] BSTR Host,[in] long Port,[out, retval] long *Result)
HRESULT | SetParams ([in] BSTR Params)
HRESULT | SetParamsOf ([in] BSTR Name,[in] BSTR Params,[out, retval] long *Result)
HRESULT | StreamFiles ([in] BSTR Files,[in] BOOL Looping,[out, retval] long *Result)
HRESULT | StreamMic ([out, retval] long *Result)
HRESULT | TimeOut ([in] long Timeout)
HRESULT | TimeOut ([out, retval] long *Timeout)

Detailed Description

This ActiveX control allows to remote control audio playback on equipments with preconfigured audio outputs. The ActiveX control can establish playback of either audio sources captured in real time by VisioWave equipments located anywhere on the network, MP3 files local to the equipment or playback of previously recorded audio content again anywhere on the network (using the VWStorageAccessController and XVWTimeLine ActiveX controls). It can also be used to capture and stream audio locally in respect to the ActiveX control. See the VWAudioOutputCtrl_VB sample for a small example in Visual Basic on how to use it.

Member Function Documentation

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::AddToGroupAndConnect ( [out, retval] long * Result )

A new Controller is added to the group. It tries to connect to the target AOM described by current property values (Server, Port, Blocking, TimeOut), henceforth adding this AOM to the Dynamic Audio Group.

Returns:
Operation status if Connection Mode is Blocking
Return values:
0 | Connection Succeeded (or Non-Blocking mode)
-1 | Connection Failure (Controller is immediatly removed)
Remarks:
In Blocking mode, the new AOC is not added to the Group in case of connection failure (since it's immediatly deleted)

Automatically gives the newly added Controller a name such as "remotehost:remoteport"

A Controller's name strongly binds it conceptually to the Manager it is connected to. As a matter of fact, an Audio Group is a group of Managers; on client side, an audio group is implemented by a Group of Controllers, whose names correspond to the remote Manager they are connected to.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::Blocking ( [in] BOOL Blocking )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::Blocking ( [out, retval] BOOL * Blocking )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::CloseLocalAAM ( )

Shuts down the local Audio Access Manager

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::DeleteFromGroup | ( | [in] BSTR | Name,
 |  | [out, retval] long * | Result
 | ) |

Removes a named Controller from the group, henceforth deleting the AOM it controls from the Dynamic Audio Group.

Parameters:
Name the name of the Controller to be removed such as "remotehost:remoteport"
Returns:
operation result
Return values:
0 | Success
-2 | Name not found
Remarks:
A Controller's name strongly binds it conceptually to the Manager it is connected to. As a matter of fact, an Audio Group is a group of Managers; on client side, an audio group is implemented by a Group of Controllers, whose names correspond to the remote Manager they are connected to.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::ExtractBoolean | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Params,
 |  | [out, retval] BOOL * | Value
 | ) |

Extracts a boolean value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | Comma-separated list of name=value pairs
Returns:
boolean value of the parameter

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::ExtractInteger | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Params,
 |  | [out, retval] long * | Value
 | ) |

Extracts an integer value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | Comma-separated list of name=value pairs
Returns:
integer value of the parameter

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::ExtractNumber | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Params,
 |  | [out, retval] double * | Value
 | ) |

Extracts a floating-point value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
floating-point value of the parameter

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::ExtractString | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Params,
 |  | [out, retval] BSTR * | Value
 | ) |

Extracts a string value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
string value of the parameter

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::FlushGroup ( )

Flushes the whole group Waits until all Remote Procedure Call have been processed.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::GetId ( [out, retval] long * pInterface )

Should be used only by VisioWave engineers.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::GetParamsOf | ( | [in] BSTR | Name,
 |  | [out, retval] BSTR * | Params
 | ) |

Gets the Params of a named Controller among the group

Parameters:
Name Name of the Controller to lookup such as "remotehost:remoteport"
Returns:
String of params to retrieve Syntax for the retrieved string is: "param1=value, [param2=value, ...]" Available parameters are:
  • Volume [integer ranging from -114 to +12 for PCI2/CPCI4-II cards and 0 to 100 for regular soundcards]
  • Mute [boolean]
  • Balance [integer ranging from -100 to +100]
  • BassBoost [integer ranging from 0 to 100]
  • AutoVolumeCorrection [boolean]
  • PreAmplificationGain (PCI2 only) [integer, see remark below for range]
Return values:
"" Failure
Remarks:
Although the PreAmplificationGain gain always ranges from 0 to 15, such a span is mapped to a different dB range, depending on the input connector:
  • If the input connector is LINE_IN, the corresponding dB range is [-3 +19.5].
  • If the input connector is MIC_IN, the corresponding dB range is [+21 +43.5]. Hence in both cases each of the 16 available values correspond to a step of 1.5 dB.

A Controller's name strongly binds it conceptually to the Manager it is connected to. As a matter of fact, an Audio Group is a group of Managers; on client side, an audio group is implemented by a Group of Controllers, whose names correspond to the remote Manager they are connected to.

Params can easily be extracted out of the string thanks to the various extractxxx functions provided by this interface.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::GetStatOf | ( | [in] BSTR | bstrName,
 |  | [out, retval] BSTR * | Params
 | ) |

Gets statistics for the connected AudioOutputManager

Returns:
String of params retrieved Syntax for the retrieved string is: "param1=value, [param2=value, ...]" Available parameters are:
  • QuasiPeakLeft [integer ranging from -90 to 0] Representing the quasi peak value of the left channel in dBfs
  • QuasiPeakRight [integer ranging from -90 to 0] Representing the quasi peak value of the left channel in dBfs
Return values:
"" Failure

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::GetStatusOf | ( | [in] BSTR | Name,
 |  | [out, retval] long * | Result
 | ) |

Gets the connection status of a named Controller among the group

Parameters:
Name Name of the Controller to lookup such as "remotehost:remoteport"
Returns:
Connection Status of the specified Controller
Return values:
0 | Not connected to the remote Manager
1 | Connecting to the remote Manager
2 | Connected to the remote Manager
-2 | Name not found
Remarks:
A Controller's name strongly binds it conceptually to the Manager it is connected to. As a matter of fact, an Audio Group is a group of Managers; on client side, an audio group is implemented by a Group of Controllers, whose names correspond to the remote Manager they are connected to.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::LocalAAMBoard ( [out, retval] long * LocalBoard )

Returns:
Local Audio Access Manager board number
Return values:
-1 No Audio Access manager

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::LocalAAMPort ( [out, retval] long * LocalPort )

Returns:
Local Audio Access Manager port
Return values:
-1 No Audio Access manager

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::OpenLocalAAM | ( | [in] long | Port,
 |  | [in] BSTR | Connector,
 |  | [in] long | Board,
 |  | [in] long | TargetRate,
 |  | [in] BSTR | Id,
 |  | [out, retval] long * | Result
 | ) |

Opens a local Audio Access Manager, for sound streaming purpose.

Parameters:
Port | Local port the AAM service is running on
Connector | Board type and channel, to be chosen among wavein_line_in, wavein_mic_in, pci2_line_in, pci2_mic_in, and pci2_spdif_in
Board | Board number
TargetRate | Compression rate
Id | Server name
Returns:
operation status
Return values:
0 | Success
-1 | Server creation failure

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::Port ( [in] long Port )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::Port ( [out, retval] long * Port )

Returns:
the TCP port number of the remote manager

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::Rehash | ( | [in] BSTR | Name,
 |  | [out, retval] long * | Result
 | ) |

Rehashes a named Controller among the group

Parameters:
Name name of Controller to lookup such as "remotehost:remoteport"
Returns:
Operation result
Return values:
0 | Success
-2 | Name not found
Remarks:
A Controller's name strongly binds it conceptually to the Manager it is connected to. As a matter of fact, an Audio Group is a group of Managers; on client side, an audio group is implemented by a Group of Controllers, whose names correspond to the remote Manager they are connected to.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::RehashGroup ( )

Rehashes the whole group

Remarks:
all reconnections are non-blocking. You don't want a zillion of simultaneous blocking reconnections, do you ?

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::ResetGroup ( )

Resets group

Remarks:
Concretely, it deletes the group of Controllers implementing the audio group on client side

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::ResetSource ( )

Stops the source being played by the Audio Group.

Remarks:
The Remote Procedure Call is asynchronous. That is, it is posted to a threaded message queue, and execution keeps going.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::Server ( [in] BSTR Hostname )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::Server ( [out, retval] BSTR * Hostname )

Returns:
the host name or IP address of the remote manager

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::SetFileSource ( [in] BSTR FileSource )

Sets a file (or a list of file) to be played by the Audio group (that is, the AOMs our Controllers are connected to)

Parameters:
FileSource file location (or list of files separated by commas)
Remarks:
The Remote Procedure Call is asynchronous. That is, it is posted to a threaded message queue, and execution keeps going.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::SetHardSource | ( | [in] long | CardNumber,
 |  | [in] BSTR | Connector,
 |  | [out, retval] long * | Result
 | ) |

Sets an audio hard source to be played by the Audio group (that is, the AOMs our Controllers are connected to)

Parameters:
CardNumber | Local (to the AOM) card number
Connector | Board type and channel, to be chosen among wavein_line_in, wavein_mic_in, pci2_line_in, pci2_mic_in, and pci2_spdif_in.
Returns:
Operation result
Return values:
0 | Message sent
-1 | Wrong card number (must be > 0)
-2 | Wrong connector name
Remarks:
The Remote Procedure Call is asynchronous. That is, it is posted to a threaded message queue, and execution keeps going.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::SetLocalAAM_AtmConfig | ( | [in] BOOL | Available,
 |  | [in] BOOL | Multicast,
 |  | [in] BSTR | QOS,
 |  | [in] long | OfInterface,
 |  | [in] long | Chunk,
 |  | [out, retval] long * | Result
 | ) |

Sets the ATM/SVC params of the local audio server. Must be called before opening the server.

Parameters:
Available | Enable/disable ATM streaming
Multicast | enable/disable ATM multicast
QOS | Quality of Service
OfInterface | Network card number (usually 0)
Chunk | Chunk size in bytes
Returns:
Operation result
Return values:
-1 | local server already running. Close it, set the SVC params and relaunch it.
-2 | Bad params
0 | Success

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::SetLocalAAM_IpmConfig | ( | [in] BOOL | Available,
 |  | [in] long | OfInterface,
 |  | [in] long | Precedence,
 |  | [in] BSTR | Addr,
 |  | [in] long | Port,
 |  | [in] long | TTL,
 |  | [in] long | MTU,
 |  | [out, retval] long * | Result
 | ) |

Sets the IPM params of the local audio server. Must be called before opening the server.

Parameters:
Available | Enable/disable IPM streaming
OfInterface | Network card number (usually 0)
Precedence | Packets precedence
Addr | Multicast address
Port | Port
TTL | Packets' Time to Live
MTU | MTU
Returns:
Operation result
Return values:
-1 | local server already running. Close it, set the UDP params and relaunch it.
-2 | Bad params
0 | Success

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::SetLocalAAM_UdpConfig | ( | [in] BOOL | Available,
 |  | [in] long | OfInterface,
 |  | [in] long | Precedence,
 |  | [in] long | SourcePort,
 |  | [in] long | MTU,
 |  | [out, retval] long * | Result
 | ) |

Sets the UDP params of the local audio server. Must be called before opening the server.

Parameters:
Available | Enable/disable UDP streaming
OfInterface | Network card number (usually 0)
Precedence | UDP Packets precedence
SourcePort | UDP source port (0 = Let the kernel pick)
MTU | MTU
Returns:
Operation result
Return values:
-1 | local server already running. Close it, set the UDP params and relaunch it.
-2 | Bad params
0 | Success

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::SetNetSource | ( | [in] BSTR | Proto,
 |  | [in] BSTR | Host,
 |  | [in] long | Port,
 |  | [out, retval] long * | Result
 | ) |

Sets an audio net source to be played by the Audio group (that is, the AOMs our Controllers are connected to)

Parameters:
Proto | Network protocol to be used for sound streaming
Host | Source sound server (AAM) hostname
Port | Source sound server (AAM) port
Returns:
Operation result
Return values:
0 | Message sent
-1 | Wrong protocol (neither udp, ipm nor svc)
-2 | Wrong port number (must be > 0 and < 65536)
Remarks:
The Remote Procedure Call is asynchronous. That is, it is posted to a threaded message queue, and execution keeps going.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::SetParams ( [in] BSTR Params )

Sets the Params for the whole Audio Group (that is, the AOMs our Controllers are connected to) Syntax for the input string is: "param1=value, [param2=value, ...]" Available parameters are:

  • Volume [integer ranging from -114 to +12 for PCI2/CPCI4-II cards and 0 to 100 for regular soundcards]
  • Mute [boolean]
  • Balance [integer ranging from -100 to +100]
  • BassBoost [integer ranging from 0 to 100]
  • AutoVolumeCorrection [boolean]
  • PreAmplificationGain (PCI2 only) [integer, see remark below for range]
    Parameters:
    Params string of params
    Remarks:
    Although the PreAmplificationGain gain always ranges from 0 to 15, such a span is mapped to a different dB range, depending on the input connector: If the input connector is LINE_IN, the corresponding dB range is [-3 +19.5]. If the input connector is MIC_IN, the corresponding dB range is [+21 +43.5]. Hence in both cases each of the 16 available values correspond to a step of 1.5 dB.

    The Remote Procedure Call is asynchronous. That is, it is posted to a threaded message queue, and execution keeps going.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::SetParamsOf | ( | [in] BSTR | Name,
 |  | [in] BSTR | Params,
 |  | [out, retval] long * | Result
 | ) |

Sets the Params of a named Controller among the group

Parameters:
Name | Name of the Controller to lookup such as "remotehost:remoteport"
Params The string of params to set Syntax for the params string is: "param1=value, [param2=value, ...]" Available parameters are:
  • Volume [integer ranging from -114 to +12 for PCI2/CPCI4-II cards and 0 to 100 for regular soundcards]
  • Mute [boolean]
  • Balance [integer ranging from -100 to +100]
  • BassBoost [integer ranging from 0 to 100]
  • AutoVolumeCorrection [boolean]
  • PreAmplificationGain (PCI2 only) [integer, see remark below for range]
Params | string of params
Returns:
Operation result
Return values:
0 | Success
-1 | Failure
-2 | Name not found
Remarks:
Although the PreAmplificationGain gain always ranges from 0 to 15, such a span is mapped to a different dB range, depending on the input connector:
  • If the input connector is LINE_IN, the corresponding dB range is [-3 +19.5].
  • If the input connector is MIC_IN, the corresponding dB range is [+21 +43.5]. Hence in both cases each of the 16 available values correspond to a step of 1.5 dB.

A Controller's name strongly binds it conceptually to the Manager it is connected to. As a matter of fact, an Audio Group is a group of Managers; on client side, an audio group is implemented by a Group of Controllers, whose names correspond to the remote Manager they are connected to.

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::StreamFiles | ( | [in] BSTR | Files,
 |  | [in] BOOL | Looping,
 |  | [out, retval] long * | Result
 | ) |

Sets the local audio server to stream MP3 files

Parameters:
Files | file pathes to be streamed, separated by commas
Looping | enable/disable file playing in a loop
Returns:
operation result
Return values:
-1 | No opened local server
-2 | Cannot read MP3 file
0 | Success
Remarks:
Once the files finished to play (and if looping is off), the server gets back to "live" mode (that is, it streams what it was set to capture on its creation).

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::StreamMic ( [out, retval] long * Result )

Sets the local audio server to stream its default source (as specified with OpenLocalAAM).

Returns:
operation result
Return values:
-1 | No opened local server
0 | Success
See also:
OpenLocalAAM

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::TimeOut ( [in] long Timeout )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl::TimeOut ( [out, retval] long * Timeout )

Returns:
the connection time-out in milliseconds


VisioWave SDK: VWSERVERCONTROLLERLib::IVWAudioSvrCtrl Interface Reference

VWSERVERCONTROLLERLib::IVWAudioSvrCtrl

VWSERVERCONTROLLERLib::IVWAudioSvrCtrl Interface Reference

This ActiveX control allows to remotely query real time audio capture parameters as the bandwidth configured, the bandwidth used,... on equipments with preconfigured audio inputs. See the VWAudioSvrCtrl_VB sample for a small example in Visual Basic on how to use it. More...

import "VWServerController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | Blocking ([in] BOOL Blocking)
HRESULT | Blocking ([out, retval] BOOL *Blocking)
HRESULT | Connect ([out, retval] long *Result)
HRESULT | Disconnect ()
HRESULT | ExtractBoolean ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] long *Result)
HRESULT | ExtractInteger ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] long *Result)
HRESULT | ExtractNumber ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] float *Result)
HRESULT | ExtractString ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BSTR *Result)
HRESULT | GetId ([out, retval] long *Result)
HRESULT | GetParams ([in, defaultvalue(-1)] long SourceId,[out, retval] BSTR *Result)
HRESULT | GetStat ([in, defaultvalue(-1)] long SourceId,[out, retval] BSTR *Result)
HRESULT | Port ([in] long Port)
HRESULT | Port ([out, retval] long *Port)
HRESULT | Rehash ([out, retval] long *Result)
HRESULT | Server ([in] BSTR Hostname)
HRESULT | Server ([out, retval] BSTR *Hostname)
HRESULT | SetParams ([in] BSTR Params,[in, defaultvalue(-1)] long SourceId,[out, retval] long *Result)
HRESULT | Status ([out, retval] long *Status)
HRESULT | TimeOut ([in] long Timeout)
HRESULT | TimeOut ([out, retval] long *Timeout)

Detailed Description

This ActiveX control allows to remotely query real time audio capture parameters as the bandwidth configured, the bandwidth used,... on equipments with preconfigured audio inputs. See the VWAudioSvrCtrl_VB sample for a small example in Visual Basic on how to use it.

Member Function Documentation

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::Blocking ( [in] BOOL Blocking )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::Blocking ( [out, retval] BOOL * Blocking )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::Connect ( [out, retval] long * Result )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::ExtractBoolean | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] long * | Result
 | ) |

Extracts a boolean value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
boolean value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::ExtractInteger | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] long * | Result
 | ) |

Extracts an integer value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
integer value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::ExtractNumber | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] float * | Result
 | ) |

Extracts a floating-point value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
floating-point value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::ExtractString | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] BSTR * | Result
 | ) |

Extracts a string value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
string value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::GetId ( [out, retval] long * Result )

Should be used only by VisioWave engineers.

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::GetParams | ( | [in, defaultvalue(-1)] long | SourceId,
 |  | [out, retval] BSTR * | Result
 | ) |

Gets the audio server parameters. The values of the parameters can be extracted with ExtractInteger, ExtractBoolean, and ExtractString. The following parameters are available:

  • UdpSourcePort [integer]
  • UdpInterface [integer]
  • UdpPrecedence [integer]
  • UdpEnable [boolean]
  • IpmGroupAddress [string]
  • IpmTtl [integer]
  • IpmInterface [integer]
  • IpmPrecedence [integer]
  • IpmEnable [boolean]
  • AtmMtu [integer]
  • AtmInterface [integer]
  • AtmQosClass [string]
  • AtmMulticastEnabled [boolean]
  • AtmEnable [boolean]
  • InputConnector [string, "PCI2_LINEIN", "PCI2_MICIN", "PCI2_SPDIFIN", "WAVEIN_LINEIN", or "WAVEIN_MICIN"; cannot be set, if PCI2 input; can only be set to "WAVEIN_LINEIN" or "WAVEIN_MICIN", if WAVEIN input]
  • PolarizationVoltage [boolean; PCI2 input only; cannot be set]
  • AutomaticGainControl [boolean; PCI2 input only; cannot be set]
  • PreAmplificationGain [integer, 0 to 15; PCI2 input only]
  • InputVolume [integer, 0 to 100; WAVEIN input only]
  • Compression [string, "MP3" or "PCM"]
  • Id [string]
  • Channel [integer]
  • AudioClass [string, one of 'consumer','semipro' or 'pro'; cannot be set] Preamplification offset gain

Parameters:
SourceId source ID of the audio server (0 or -1 for the default server)
Returns:
a comma-separated list of name=value pairs (audio server parameters).
See also:
SetParams

ExtractInteger

ExtractString

ExtractBoolean

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::GetStat | ( | [in, defaultvalue(-1)] long | SourceId,
 |  | [out, retval] BSTR * | Result
 | ) |

Gets the audio server statistics. The values of the statistics can be extracted with ExtractInteger and ExtractString. The following statistics are available:

  • Bandwidth [integer]
  • InputVolume [integer, 0 to 100]
  • QuasiPeakLeft [integer, -90 to 0] Input Gain in dbFS on left channel.
  • QuasiPeakRight [integer, -90 to 0] Input Gain in dbFS on right channel.
  • AudioOutputCount [integer] Number of audio outputs currently redirecting this audio input. The index of the five following values goes from 0 to AudioOutputCount - 1.
  • AudioOutputEquipmentName[i] [string] Name of the equipment on which the (i+1)-th redirection is done.
  • AudioOutputEquipmentAddress[i] [string] Address of the equipment on which the (i+1)-th redirection is done.
  • AudioOutputName[i] [string] Name of the (i+1)-th redirecting audio output.
  • AudioOutputChannel[i] [integer] Channel of the (i+1)-th redirecting audio output.
  • AudioOutputTcpPort[i] [integer] TCP port of the (i+1)-th redirecting audio output.

Parameters:
SourceId source ID of the audio server (0 or -1 for the default server)
Returns:
a comma-separated list of name=value pairs (audio server statistics).
See also:
ExtractInteger

ExtractString

ExtractBoolean

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::Port ( [in] long Port )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::Port ( [out, retval] long * Port )

Returns:
the TCP port number of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::Server ( [in] BSTR Hostname )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::Server ( [out, retval] BSTR * Hostname )

Returns:
the host name or IP address of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::SetParams | ( | [in] BSTR | Params,
 |  | [in, defaultvalue(-1)] long | SourceId,
 |  | [out, retval] long * | Result
 | ) |

Sets the audio server parameters.

Parameters:
Params | a comma-separated list of parameters ("par1=val1,par2=val2,par3=val3...")
SourceId | source ID of the audio server (0 or -1 for the default server)
Returns:
error code
Return values:
0 | no error
-1 | invalid source ID
See also:
GetParams

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::Status ( [out, retval] long * Status )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::TimeOut ( [in] long Timeout )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWSERVERCONTROLLERLib::IVWAudioSvrCtrl::TimeOut ( [out, retval] long * Timeout )

Returns:
the connection time-out in milliseconds

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl Interface Reference

XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl

XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl Interface Reference

This ActiveX control presents a simple GUI which can be used to unify the connection establishment GUI for all of the examples. In order to connect it to a given VisioWave SDK ActiveX control, call the control's GetId() method and pass its return value to this control's SetId() method. More...

import "XVWConnectionController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | ForbidBlocking ()
HRESULT | SetConnectionMode ([in] BOOL Blocking)
HRESULT | SetId ([in] long Id)
HRESULT | SetPort ([in] long Port)
HRESULT | SetServer ([in] BSTR Server)
HRESULT | SetTimeout ([in] long TimeOut)
HRESULT | UpdateStatus ()

Detailed Description

This ActiveX control presents a simple GUI which can be used to unify the connection establishment GUI for all of the examples. In order to connect it to a given VisioWave SDK ActiveX control, call the control's GetId() method and pass its return value to this control's SetId() method.

Member Function Documentation

HRESULT XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl::ForbidBlocking ( )

Calling this method greys the Blocking connection check box, hence forbidding blocking mode for the RPC connection (usually the best way to handle connections).

HRESULT XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl::SetConnectionMode ( [in] BOOL Blocking )

Checks / Unchecks the Blocking Connection check box of the GUI. That is to say it sets the connection mode of the RPC connection between the attached controller and the remote manager, that will be tried upon clicking on the connect button.

Parameters:
Blocking True = Blocking Connection (Hand is not given back to the user until the connection attempt either succeeds or times out). False = Non-blocking Connection (Hand is immediatly given back to the user, and a LinkUp or LinkDown event is fired by the attached controller upon connection success or time out).
Remarks:
Typically used to set default values.

HRESULT XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl::SetId ( [in] long Id )

Attaches the GUI to the controller whose Id is passed as a parameter

Parameters:
Id Id of the controller to attach to the GUI.
Remarks:
Use the controller's GetId method to retrieve its Id. All the controllers that can be attached to a XVWConnectionController GUI have a GetId method.

HRESULT XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl::SetPort ( [in] long Port )

Sets the Port field of the GUI, that is to say the port of the manager we want to connect the attached controller to.

Parameters:
Port Remote Manager port
Remarks:
Typically used to set default values.

HRESULT XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl::SetServer ( [in] BSTR Server )

Sets the Server field of the GUI, that is to say the hostname or ip of the manager we want to connect the attached controller to.

Parameters:
Server server hostname
Remarks:
Typically used to set default values.

HRESULT XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl::SetTimeout ( [in] long TimeOut )

Sets the TimeOut field of the GUI, that is to say the time out parameter of the RPC connection between the attached controller and the remote manager, that will be tried upon clicking on the connect button.

Parameters:
TimeOut RPC connection time out.
Remarks:
Typically used to set default values.

HRESULT XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl::UpdateStatus ( )

Update the connection status displayed within the GUI. Typically this is used in scripting languages such as VB upon reception of LinkDown or LinkUp events from the controller to keep the displayed status up to date.

Remarks:
The status is updated automatically when the LinkDown and LinkUp events are received, so this method shouldn't be needed. It is provided for compatibility reasons.

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl Interface Reference

VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl

VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl Interface Reference

This ActiveX control allows to remote control digital inputs on equipments equipped with digital I/O cards. It allows to query the state of the digital inputs. See the VWDigitalInputCtrl_VB sample for a small example in Visual Basic on how to use it. More...

import "VWDigitalIOController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | Blocking ([in] BOOL Blocking)
HRESULT | Blocking ([out, retval] BOOL *Blocking)
HRESULT | Connect ([out, retval] long *Result)
HRESULT | DigitalInputStatus ([out, retval] long *DigitalInputStatus)
HRESULT | Disconnect ()
HRESULT | GetId ([out, retval] long *pInterface)
HRESULT | Port ([in] long Port)
HRESULT | Port ([out, retval] long *Port)
HRESULT | Rehash ([out, retval] long *Result)
HRESULT | Server ([in] BSTR Hostname)
HRESULT | Server ([out, retval] BSTR *Hostname)
HRESULT | SetGoingHighEvent ([in] BSTR EventName,[out, retval] long *Result)
HRESULT | SetGoingLowEvent ([in] BSTR EventName,[out, retval] long *Result)
HRESULT | Status ([out, retval] long *Status)
HRESULT | TimeOut ([in] long Timeout)
HRESULT | TimeOut ([out, retval] long *Timeout)

Detailed Description

This ActiveX control allows to remote control digital inputs on equipments equipped with digital I/O cards. It allows to query the state of the digital inputs. See the VWDigitalInputCtrl_VB sample for a small example in Visual Basic on how to use it.

Member Function Documentation

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::Blocking ( [in] BOOL Blocking )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::Blocking ( [out, retval] BOOL * Blocking )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::Connect ( [out, retval] long * Result )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::DigitalInputStatus ( [out, retval] long * DigitalInputStatus )

Returns:
remote Digital Input status
Return values:
0 | LOW
1 | HIGH
-1 | Undetermined

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::GetId ( [out, retval] long * pInterface )

Should be used only by VisioWave engineers.

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::Port ( [in] long Port )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::Port ( [out, retval] long * Port )

Returns:
the TCP port number of the remote manager

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::Server ( [in] BSTR Hostname )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::Server ( [out, retval] BSTR * Hostname )

Returns:
the host name or IP address of the remote manager

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::SetGoingHighEvent | ( | [in] BSTR | EventName,
 |  | [out, retval] long * | Result
 | ) |

Sets an event that will be "sent" by the remote Digital Input Manager's Event Controller when state goes High

Parameters:
EventName event name
Returns:
operation result
Return values:
0 | event successfully set
-1 | failed to set event

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::SetGoingLowEvent | ( | [in] BSTR | EventName,
 |  | [out, retval] long * | Result
 | ) |

Sets an event that will be "sent" by the remote Digital Input Manager's Event Controller when state goes Low

Parameters:
EventName event name
Returns:
operation result
Return values:
0 | event successfully set
-1 | failed to set event

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::Status ( [out, retval] long * Status )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::TimeOut ( [in] long Timeout )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl::TimeOut ( [out, retval] long * Timeout )

Returns:
the connection time-out in milliseconds


VisioWave SDK: VWEVENTCONTROLLERLib::IVWEventCtrl Interface Reference

VWEVENTCONTROLLERLib::IVWEventCtrl

VWEVENTCONTROLLERLib::IVWEventCtrl Interface Reference

This ActiveX control allows to send and receive event notifications available on VisioWave Security Networks. Events can be used to initiate various actions as switching audio and/or video outputs to predefined sources, start or end storages or for private messaging purposes. A predefined set of system events is available in order to be notified of important system events, as for example the loss of synchronization on a video input, health monitoring values out of range (for example system temperature) or the detection of movement throught the Motion Detector video processing plugin. See the VWEventCtrl_VB sample for a small example in Visual Basic on how to use it. More...

import "VWEventController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | Blocking ([in] BOOL newVal)
HRESULT | Blocking ([out, retval] BOOL *pVal)
HRESULT | Connect ([out, retval] long *pResult)
HRESULT | Disconnect ()
HRESULT | ExtractBoolean ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BOOL *Result)
HRESULT | ExtractInteger ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] long *Result)
HRESULT | ExtractNumber ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] double *Result)
HRESULT | ExtractString ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BSTR *Result)
HRESULT | GetId ([out, retval] long *pInterface)
HRESULT | Port ([in] long newVal)
HRESULT | Port ([out, retval] long *pVal)
HRESULT | Rehash ([out, retval] long *pResult)
HRESULT | Server ([in] BSTR newVal)
HRESULT | Server ([out, retval] BSTR *pVal)
HRESULT | Signal ([in] BSTR bstrEvent)
HRESULT | SignalEx ([in] BSTR bstrEvent,[in] BSTR bstrData)
HRESULT | Status ([out, retval] long *pVal)
HRESULT | Subscribe ([in] BSTR bstrEvent,[out, retval] long *plEventId)
HRESULT | SubscribeEx ([in] BSTR bstrEvent,[in] BSTR bstrHost,[out, retval] long *plEventId)
HRESULT | TimeOut ([in] long newVal)
HRESULT | TimeOut ([out, retval] long *pVal)
HRESULT | Unsubscribe ([in] long lEventId)

Detailed Description

This ActiveX control allows to send and receive event notifications available on VisioWave Security Networks. Events can be used to initiate various actions as switching audio and/or video outputs to predefined sources, start or end storages or for private messaging purposes. A predefined set of system events is available in order to be notified of important system events, as for example the loss of synchronization on a video input, health monitoring values out of range (for example system temperature) or the detection of movement throught the Motion Detector video processing plugin. See the VWEventCtrl_VB sample for a small example in Visual Basic on how to use it.

Member Function Documentation

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Blocking ( [in] BOOL newVal )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Blocking ( [out, retval] BOOL * pVal )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Connect ( [out, retval] long * pResult )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::ExtractBoolean | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] BOOL * | Result
 | ) |

Extracts a boolean value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
boolean value of the parameter

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::ExtractInteger | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] long * | Result
 | ) |

Extracts an integer value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | Comma-separated list of name=value pairs
Returns:
integer value of the parameter

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::ExtractNumber | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] double * | Result
 | ) |

Extracts a floating-point value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
floating-point value of the parameter

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::ExtractString | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] BSTR * | Result
 | ) |

Extracts a string value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
string value of the parameter

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::GetId ( [out, retval] long * pInterface )

Should be used only by VisioWave engineers.

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Port ( [in] long newVal )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Port ( [out, retval] long * pVal )

Returns:
the TCP port number of the remote manager

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Server ( [in] BSTR newVal )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Server ( [out, retval] BSTR * pVal )

Returns:
the host name or IP address of the remote manager

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Signal ( [in] BSTR bstrEvent )

Signals an event to all subscribed clients.

Parameters:
bstrEvent Event name to signal.
See also:
SignalEx

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::SignalEx | ( | [in] BSTR | bstrEvent,
 |  | [in] BSTR | bstrData
 | ) |

Signals an event and sends additionnal datas to all subscribed clients.

Parameters:
bstrEvent | Event name to signal.
bstrData | Additionnal data to send to subscribed clients.
See also:
Signal

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Status ( [out, retval] long * pVal )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Subscribe | ( | [in] BSTR | bstrEvent,
 |  | [out, retval] long * | plEventId
 | ) |

Subscribes to an event handled by the Event Manager.

Parameters:
bstrEvent Event name.
Returns:
Unique subscription id. This id allows several clients to subscribe to the same event using the same VWEventCtrl component.
Remarks:
Use this id to unsubscribe to the event.
See also:
Unsubscribe

SubscribeEx

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::TimeOut ( [in] long newVal )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::TimeOut ( [out, retval] long * pVal )

Returns:
the connection time-out in milliseconds

HRESULT VWEVENTCONTROLLERLib::IVWEventCtrl::Unsubscribe ( [in] long lEventId )

Unsubscribes from the event defined by the subscription id.

Parameters:
lEventId Unique id of subscription.
See also:
Subscribe

SubscribeEx

Generated on Tue Oct 3 18:24:19 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2 Interface Reference

VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2

VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2 Interface Reference

This ActiveX control allows to remote control digital PTZ cameras. More...

import "VWServerController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | Blocking ([in] BOOL newVal)
HRESULT | Blocking ([out, retval] BOOL *pVal)
HRESULT | CallMCLFunction ([in] BSTR FunctionName,[in] BSTR Parameters,[out, retval] BSTR *Result)
HRESULT | CameraId ([in] short newCameraId)
HRESULT | CameraId ([out, retval] short *pCameraId)
HRESULT | Connect ([out, retval] long *pnRet)
HRESULT | Disconnect ()
HRESULT | Down ([out, retval] long *pnRet)
HRESULT | DownLeft ([out, retval] long *pnRet)
HRESULT | DownRight ([out, retval] long *pnRet)
HRESULT | ExtractBoolean ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BOOL *Result)
HRESULT | ExtractInteger ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] long *Result)
HRESULT | ExtractNumber ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] double *Result)
HRESULT | ExtractString ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BSTR *Result)
HRESULT | FocusAuto ([out, retval] long *pnRet)
HRESULT | FocusFar ([out, retval] long *pnRet)
HRESULT | FocusManual ([out, retval] long *pnRet)
HRESULT | FocusNear ([out, retval] long *pnRet)
HRESULT | GetId ([out, retval] long *pInterface)
HRESULT | GetNumberPrepos ([out, retval] long *pnRet)
HRESULT | GetPanSpeed ([out, retval] long *pnRet)
HRESULT | GetSpeed ([out, retval] short *pnRet)
HRESULT | GetTiltSpeed ([out, retval] long *pnRet)
HRESULT | GetZoomSpeed ([out, retval] long *pnRet)
HRESULT | Home ([out, retval] long *pnRet)
HRESULT | Iris ([in] short vIris,[out, retval] long *pnRet)
HRESULT | IrisAuto ([out, retval] long *pnRet)
HRESULT | IrisClose ([out, retval] long *pnRet)
HRESULT | IrisOpen ([out, retval] long *pnRet)
HRESULT | Left ([out, retval] long *pnRet)
HRESULT | MonitorId ([in] short newMonitorId)
HRESULT | MonitorId ([out, retval] short *pMonitorId)
HRESULT | Move ([in] short vPan,[in] short vTilt,[out, retval] long *pnRet)
HRESULT | Move2 ([in] short vPan,[in] short vTilt,[in] short vZoom,[out, retval] long *pnRet)
HRESULT | Port ([in] long newVal)
HRESULT | Port ([out, retval] long *pVal)
HRESULT | RawEnd ([in] BSTR bstrCommand)
HRESULT | RawInstant ([in] BSTR bstrCommand)
HRESULT | RawStart ([in] BSTR bstrCommand)
HRESULT | RecallMemory ([in] short nPos,[out, retval] long *pnRet)
HRESULT | Right ([out, retval] long *pnRet)
HRESULT | Server ([in] BSTR newVal)
HRESULT | Server ([out, retval] BSTR *pVal)
HRESULT | SetBackLight ([out, retval] long *pnRet)
HRESULT | SetFocusSpeed ([in] short vFocus)
HRESULT | SetIrisSpeed ([in] short vIris)
HRESULT | SetPanSpeed ([in] short vPan)
HRESULT | SetSpeed ([in] short vPan,[in] short vTilt)
HRESULT | SetTiltSpeed ([in] short vTilt)
HRESULT | SetZoomSpeed ([in] short vZoom)
HRESULT | Status ([out, retval] BOOL *pVal)
HRESULT | StepByStep ([in] BOOL newStepByStep)
HRESULT | StepByStep ([out, retval] BOOL *pStepByStep)
HRESULT | StopFocus ([out, retval] long *pnRet)
HRESULT | StopIris ([out, retval] long *pnRet)
HRESULT | StopMvt ([out, retval] long *pnRet)
HRESULT | StopZoom ([out, retval] long *pnRet)
HRESULT | StoreMemory ([in] short nPos,[out, retval] long *pnRet)
HRESULT | StringToParam ([in] BSTR String,[out, retval] BSTR *Result)
HRESULT | TimeOut ([in] short newVal)
HRESULT | TimeOut ([out, retval] short *pVal)
HRESULT | UnsetBackLight ([out, retval] long *pnRet)
HRESULT | Up ([out, retval] long *pnRet)
HRESULT | UpLeft ([out, retval] long *pnRet)
HRESULT | UpRight ([out, retval] long *pnRet)
HRESULT | Version ([out, retval] BSTR *version)
HRESULT | Zoom ([in] short nStep,[in] short nDir)
HRESULT | Zoom2 ([in] short vZoom,[out, retval] long *pnRet)
HRESULT | ZoomIn ([out, retval] long *pnRet)
HRESULT | ZoomOut ([out, retval] long *pnRet)

Detailed Description

This ActiveX control allows to remote control digital PTZ cameras.

Remarks:
The methods of this control can return the following error codes:
  • CAM_OK 0 No error occured
  • CAM_ERROR -1 General error
  • CAM_BADPARAM -2 Supplied parameters out of range
  • CAM_UNSUPPORTED -3 Command not supported
  • CAM_CONNECTION_LOST -4 Server connection lost See the VWMobCamSvrCtrl2_JS sample for a small example in Java Script on how to use it.

Member Function Documentation

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Blocking ( [in] BOOL newVal )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Blocking ( [out, retval] BOOL * pVal )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::CallMCLFunction | ( | [in] BSTR | FunctionName,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] BSTR * | Result
 | ) |

Calls a mobile camera language function. This method returns the following values:

  • value [the value returned by the MCL function]
  • vtype [string, the type of the value returned by the MCL function: "value", "byte", "message", "table", "bool", "noreturn" or "unknown"]
  • errcode [integer, an error code (CAM_OK, CAM_UNSUPPORTED, etc.); CAM_BADPARAM is returned if there is a syntax error in the parameters string or if the number of parameters is wrong; CAM_UNSUPPORTED is returned if the name of the MCL function is wrong; the other error codes have the same meaning as in the other functions]

These values can be extracted with ExtractNumber, ExtractInteger, etc. vtype must be extracted with ExtractString. errcode must be extracted with ExtractInteger. If vtype is "value" or "byte", the returned value must be extracted with ExtractInteger. If vtype is "message" or "table", the returned value must be extracted with ExtractString. If vtype is "bool", the returned value must be extracted with ExtractBool.

Parameters:
FunctionName | function name
Parameters | parameter values (string format: "value0,value1,value2..."); a string value must be converted with StringToParam before being concatenated with the other values, because it can contain special characters, quotes, etc.
Returns:
a comma-separated list of name=value pairs.
See also:
ExtractInteger

ExtractString

ExtractBoolean

ExtractNumber

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Connect ( [out, retval] long * pnRet )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Down ( [out, retval] long * pnRet )

Initiates a downward camera movement at the previously defined speed, default is 50%.

Returns:
0 if successful or a negative error code
Remarks:
Call the StopMvt method to stop the movement.
See also:
StopMvt

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::DownLeft ( [out, retval] long * pnRet )

Initiates a down- and leftward camera movement at the previously defined speed, default is 50%.

Returns:
0 if successful or a negative error code
Remarks:
Call the StopMvt method to stop the movement.
See also:
StopMvt

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::DownRight ( [out, retval] long * pnRet )

Initiates a down- and rightward camera movement at the previously defined speed, default is 50%.

Returns:
0 if successful or a negative error code
Remarks:
Call the StopMvt method to stop the movement.
See also:
StopMvt

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::ExtractBoolean | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] BOOL * | Result
 | ) |

Extracts a boolean value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
boolean value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::ExtractInteger | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] long * | Result
 | ) |

Extracts an integer value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
integer value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::ExtractNumber | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] double * | Result
 | ) |

Extracts a floating-point value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
floating-point value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::ExtractString | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] BSTR * | Result
 | ) |

Extracts a string value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
string value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::FocusAuto ( [out, retval] long * pnRet )

Sets automatic focus.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::FocusFar ( [out, retval] long * pnRet )

Initiates far focusing at the previously set focus speed.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::FocusManual ( [out, retval] long * pnRet )

Sets manual focus.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::FocusNear ( [out, retval] long * pnRet )

Initiates near focusing at the previously set focus speed.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::GetId ( [out, retval] long * pInterface )

Should be used only by VisioWave engineers.

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::GetNumberPrepos ( [out, retval] long * pnRet )

Retrieves the number of available prepositions supported by the camera.

Returns:
the number of available prepositions if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::GetPanSpeed ( [out, retval] long * pnRet )

Retrieves the pan speed.

Returns:
the currently set pan speed

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::GetSpeed ( [out, retval] short * pnRet )

Retrieves the tilt and pan speeds.

Returns:
a 2-byte integer including the tilt speed in its most significant byte and the pan speed in its least significant byte

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::GetTiltSpeed ( [out, retval] long * pnRet )

Retrieves the tilt speed.

Returns:
the currently set tilt speed

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::GetZoomSpeed ( [out, retval] long * pnRet )

Retrieves the zoom speed.

Returns:
the currently set zoom speed

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Home ( [out, retval] long * pnRet )

Resets the camera to its original position.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Iris | ( | [in] short | vIris,
 |  | [out, retval] long * | pnRet
 | ) |

Initiates opening or closing of the iris at given speed.

Parameters:
vIris Iris closing/opening speed. A positive value opens the iris and a negative value closes it.
Returns:
0 if successful or a negative error code
Remarks:
Some cameras do not support opening of the iris at variable speed or do not support opening at all, will be indicated by the CAM_NOTSUPPORTED error message.

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::IrisAuto ( [out, retval] long * pnRet )

Sets automatic iris adjustment.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::IrisClose ( [out, retval] long * pnRet )

Initiates closing of the iris at the previously specified speed, default is 50%.

Returns:
0 if successful or a negative error code
Remarks:
Some cameras do not support opening of the iris at variable speed or do not support opening at all, will be indicated by the CAM_NOTSUPPORTED error message

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::IrisOpen ( [out, retval] long * pnRet )

Initiates opening of the iris at the previously specified speed, default is 50%.

Returns:
0 if successful or a negative error code
Remarks:
Some cameras do not support opening of the iris at variable speed or do not support opening at all, will be indicated by the CAM_NOTSUPPORTED error message

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Left ( [out, retval] long * pnRet )

Initiates a leftward camera movement at the previously specified speed, default is 50%.

Returns:
0 if successful or a negative error code
Remarks:
Call the StopMvt method to stop the movement.
See also:
StopMvt

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Move2 | ( | [in] short | vPan,
 |  | [in] short | vTilt,
 |  | [in] short | vZoom,
 |  | [out, retval] long * | pnRet
 | ) |

Initiates a camera movement at given pan speed, in given direction and at given zoom speed.

Parameters:
vPan | Pan speed in percent. A positive value means "turn right". A negative value means "turn left".
vTilt | Tilt speed in percent. A positive value means "look up". A negative value means "look down".
vZoom | Zoom speed in percent. A positive value means "zoom in". A negative value means "zoom out".
Returns:
0 if successful or a negative error code
Remarks:
Call the StopMvt method to stop the movement.
See also:
StopMvt

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Port ( [in] long newVal )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Port ( [out, retval] long * pVal )

Returns:
the TCP port number of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::RecallMemory | ( | [in] short | nPos,
 |  | [out, retval] long * | pnRet
 | ) |

Recalls a position previously stored at the given memory location in the camera and repositions the camera to that position.

Parameters:
nPos Memory location where the position is stored.
Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Right ( [out, retval] long * pnRet )

Initiates a rightward camera movement at the previously defined speed, default is 50%.

Returns:
0 if successful or a negative error code
Remarks:
Call the StopMvt method to stop the movement.
See also:
StopMvt

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Server ( [in] BSTR newVal )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Server ( [out, retval] BSTR * pVal )

Returns:
the host name or IP address of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::SetBackLight ( [out, retval] long * pnRet )

Increases the light intensity of the camera.

Returns:
0 if successful or a negative error code
Remarks:
Call the UnsetBacklight method to reset the light intensity.
See also:
UnsetBacklight

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::SetFocusSpeed ( [in] short vFocus )

Sets the speed to be used for the next focus movement.

Parameters:
vFocus Focus speed in percent. A positive value means "zoom in" and a negative value "zoom out".

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::SetIrisSpeed ( [in] short vIris )

Sets the iris opening/closing speed to be used for the next iris movement.

Parameters:
vIris Iris closing/opening speed in percent. A positive value opens the iris and a negative value closes it.

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::SetPanSpeed ( [in] short vPan )

Sets the pan speed to be used for the next movement.

Parameters:
vPan Pan speed in percent. A positive value means "turn right". A negative value means "turn left".

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::SetSpeed | ( | [in] short | vPan,
 |  | [in] short | vTilt
 | ) |

Sets the pan and tilt speed to be used at the next camera movement.

Parameters:
vPan | Pan speed in percent. A positive value means "turn right". A negative value means "turn left".
vTilt | Tilt speed in percent. A positive value means "look up". A negative value means "look down".

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::SetTiltSpeed ( [in] short vTilt )

Sets the tilt speed to be used for the next movement.

Parameters:
vTilt Tilt speed in percent. A positive value means "look up". A negative value means "look down".

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::SetZoomSpeed ( [in] short vZoom )

Sets the zoom speed to be used for the next zoom movement.

Parameters:
vZoom Zoom speed in percent. A positive value means "zoom in". A negative value means "zoom out".

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Status ( [out, retval] BOOL * pVal )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::StopFocus ( [out, retval] long * pnRet )

Stops the current focus movement.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::StopIris ( [out, retval] long * pnRet )

Stops the current iris movement.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::StopMvt ( [out, retval] long * pnRet )

Stops the current camera movement.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::StopZoom ( [out, retval] long * pnRet )

Stops the current camera zoom movement.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::StoreMemory | ( | [in] short | nPos,
 |  | [out, retval] long * | pnRet
 | ) |

Stores the current camera position at specified camera memory location.

Parameters:
nPos Camera memory location.
Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::StringToParam | ( | [in] BSTR | String,
 |  | [out, retval] BSTR * | Result
 | ) |

Converts a string into a string compatible with CallMCLFunction.

Parameters:
String the input string
Returns:
a string compatible with CallMCLFunction
See also:
CallMCLFunction

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::TimeOut ( [in] short newVal )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::TimeOut ( [out, retval] short * pVal )

Returns:
the connection time-out in milliseconds

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::UnsetBackLight ( [out, retval] long * pnRet )

Resets the light intensity of the camera.

Returns:
0 if successful or a negative error code

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Up ( [out, retval] long * pnRet )

Initiates an upward camera movement at the previously defined speed, default is 50% .

Returns:
0 if successful or a negative error code
Remarks:
Call the StopMvt method to stop the movement.
See also:
StopMvt

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::UpLeft ( [out, retval] long * pnRet )

Initiates an up- and leftward camera movement at the previously defined speed, default is 50% .

Returns:
0 if successful or a negative error code
Remarks:
Call the StopMvt method to stop the movement.
See also:
StopMvt

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::UpRight ( [out, retval] long * pnRet )

Initiates an up- and rightward camera movement at the previously defined speed, default is 50% .

Returns:
0 if successful or a negative error code
Remarks:
Call the StopMvt method to stop the movement.
See also:
StopMvt

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Version ( [out, retval] BSTR * version )

Retrieves the camera protocol version.

Returns:
Protocol version in case of success, "Unknown" in case of error.
Remarks:
In case of error, make sure the control is properly connected.

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::Zoom2 | ( | [in] short | vZoom,
 |  | [out, retval] long * | pnRet
 | ) |

Initiates zooming at given speed.

Parameters:
vZoom Zoom speed in percent. A positive value means "zoom in" and a negative value "zoom out".
Returns:
0 if successful or a negative error code
Remarks:
Call the StopZoom method to stop the zooming.
See also:
StopZoom

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::ZoomIn ( [out, retval] long * pnRet )

Initiates zooming in at the previously defined speed, default is 50%.

Returns:
0 if successful or a negative error code
Remarks:
Call the StopZoom method to stop the zooming.
See also:
StopZoom

HRESULT VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2::ZoomOut ( [out, retval] long * pnRet )

Initiates zooming out at the previously defined speed, default is 50%.

Returns:
0 if successful or a negative error code
Remarks:
Call the StopZoom method to stop the zooming.
See also:
StopZoom

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2 Interface Reference

VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2

VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2 Interface Reference

This ActiveX control allows to remote control analog video playback on equipments with preconfigured analog video outputs. equipments with preconfigured audio outputs. The ActiveX control can establish playback of either video sources captured in real time by VisioWave equipments located anywhere on the network, VisioWave encoded video files local to the equipment or playback of previously recorded video content (using the VWStorageAccessController and XVWTimeLine ActiveX controls) again anywhere on the network. It supports the notion of cycles which allows the user to program predefined sequences of sources which will rotate in the given order. Also supported is to configure backup sources in case of network failure, that is when the network connection to the primary source is lost. It also allows control over the analog On Screen Display (OSD) in order to display for example the source's name, the local time and date, or when streaming previously recorded content the video's capture time and date. See the VWMonitorManagerCtrl2_VB sample for a small example in Visual Basic on how to use it. More...

import "VWMonitorManagerController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | AddFileSource ([in] BSTR bstrFileName,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime)
HRESULT | AddHardSource ([in] long lCard,[in, defaultvalue(0x1206)] long lVideoFormat,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime)
HRESULT | AddHardSourceEx ([in] long lCard, BSTR bstrVideoFormat,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime)
HRESULT | AddNetworkSource ([in] BSTR bstrProto,[in] BSTR bstrHost,[in] long lPort,[in, defaultvalue(5000)] long lTimeOut,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime)
HRESULT | AddSource ([in] BSTR bstrProto,[in] short nCard,[in] long lTime,[in] BSTR bstrName,[in] BSTR bstrServer,[in] long lPort,[out, retval] short *pnRet)
HRESULT | AddSourceId ([in] long lId,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime)
HRESULT | AddSourceOSD ([in] BSTR bstrText,[in, defaultvalue(0)] BOOL bAlert)
HRESULT | AddSourceOSD2 ([in] BSTR bstrText,[in, defaultvalue(0)] BOOL bAlert,[in, defaultvalue(18)] long lTextSize)
HRESULT | AddSourceOSD3 ([in] long lX,[in] long lY,[in] BSTR bstrText,[in] long lTextColor,[in] long lBackgroundColor,[in, defaultvalue(18)] long lTextSize,[out, retval] long *plResult)
HRESULT | AddSourceOSDAtIndex ([in] long lSourceIndex,[in] BOOL bMainSource,[in] long lX,[in] long lY,[in] BSTR bstrText,[in] long lTextColor,[in] long lBackColor,[in] long lBackTransparency,[in] long lTextSize,[out, retval] long *plError)
HRESULT | AddSourceOSDEx ([in] long lX,[in] long lY,[in] BSTR bstrText,[in] long lTextColor,[in] long lTextFlags)
HRESULT | AddSourceOSDEx2 ([in] long lX,[in] long lY,[in] BSTR bstrText,[in] long lTextColor,[in] long lTextFlags,[in, defaultvalue(18)] long lTextSize)
HRESULT | BeginCustomCycle ([in] BSTR bstrCycleMode,[in, defaultvalue(0)] long lNoAutoSwitch)
HRESULT | Blocking ([in] BOOL newBlocking)
HRESULT | Blocking ([out, retval] BOOL *pBlocking)
HRESULT | ClearSourceOSD ()
HRESULT | ClearSourceOSDAtIndex ([in] long lSourceIndex,[in] BOOL bMainSource,[out, retval] long *plError)
HRESULT | Connect ([out, retval] short *pnRet)
HRESULT | Disconnect ()
HRESULT | EndCustomCycle ()
HRESULT | ExtractBoolean ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue)
HRESULT | ExtractInteger ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue)
HRESULT | ExtractNumber ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] float *pfValue)
HRESULT | ExtractString ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BSTR *pbstrValue)
HRESULT | GetCardsCount ([out, retval] short *pnCount)
HRESULT | GetConfigsList ([out, retval] BSTR *pbstrCfgs)
HRESULT | GetCycleItemInfo ([in] long lSourceIndex,[out, retval] BSTR *pbstrCycleItem)
HRESULT | GetId ([out, retval] long *pInterface)
HRESULT | GetLastError ([out, retval] long *plLastError)
HRESULT | GetNumberOfCycleItems ([out, retval] long *plNumberOfCycleItems)
HRESULT | GetOSD ([in] short nCard,[out, retval] BSTR *pbstrOSD)
HRESULT | GetSourcesList ([in] short nCard,[out, retval] short *pnRet)
HRESULT | GetStat ([out, retval] BSTR *pbstrStat)
HRESULT | LoadConfig ([in] BSTR bstrName,[out, retval] short *pnRet)
HRESULT | LoadCustomCycle ()
HRESULT | LoadCycle ([in] BSTR bstrCycleName)
HRESULT | Pause ()
HRESULT | Port ([in] long newPort)
HRESULT | Port ([out, retval] long *pPort)
HRESULT | Rehash ()
HRESULT | ResetCard ([in] short nCard,[out, retval] short *pnRet)
HRESULT | ResetCardAndSetOSD ([in] short nCard,[in] BSTR bstrText,[out, retval] long *plError)
HRESULT | ResetMonitor ()
HRESULT | Resume ()
HRESULT | SaveConfig ([in] BSTR bstrName,[out, retval] short *pnRet)
HRESULT | SaveCycle ([in] BSTR bstrCycleName,[in, defaultvalue(0)] long lAsDefault)
HRESULT | Server ([in] BSTR newServer)
HRESULT | Server ([out, retval] BSTR *pServer)
HRESULT | SetBackupSourceId ([in] long lId)
HRESULT | SetDynamicOSD ([in] BSTR bstrProto,[in] BSTR bstrHost,[in] long lPort,[in, defaultvalue(0)] long lPriorityThreshold,[in, defaultvalue(5000)] long lTimeOut,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime)
HRESULT | SetFileBackupSource ([in] BSTR bstrFileName,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime)
HRESULT | SetHardBackupSource ([in] long lCard,[in, defaultvalue(0x1206)] long lVideoFormat,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime)
HRESULT | SetLastError ([in] long lLastError)
HRESULT | SetMonitorOSD ([in] BSTR bstrOSD)
HRESULT | SetNetworkBackupSource ([in] BSTR bstrProto,[in] BSTR bstrHost,[in] long lPort,[in, defaultvalue(5000)] long lTimeOut,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime)
HRESULT | SetOSD ([in] short nCard,[in] long lXPos,[in] long lYPos,[in] short lfR,[in] short lfG,[in] short lfB,[in] short lbR,[in] short lbG,[in] short lbB,[in] BSTR bstrText,[out, retval] long *plLastError)
HRESULT | SetOSDFormat ([in] long lX,[in] long lY,[in] BSTR bstrText,[in] long lTextColor,[in] long lBackgroundColor,[in, defaultvalue(18)] long lTextSize,[out, retval] long *plResult)
HRESULT | SetSource ([in] BSTR bstrProto,[in] short nCard,[in] long lTime,[in] BSTR bstrName,[in] BSTR bstrServer,[in] long lPort,[out, retval] short *pnRet)
HRESULT | SetSourceEx ([in] short nCard,[in] long lTime,[in] BSTR bstrName,[in] BSTR bstrVideoProto,[in] BSTR bstrVideoServer,[in] long lVideoPort,[in] BSTR bstrAudioProto,[in] BSTR bstrAudioServer,[in] long lAudioPort,[out, retval] short *pnRet)
HRESULT | Status ([out, retval] long *pStatus)
HRESULT | SwitchToNextSource ([in, defaultvalue(FALSE)] BOOL bBlocking,[out, retval] long *plStatus)
HRESULT | SwitchToPreviousSource ([in, defaultvalue(FALSE)] BOOL bBlocking,[out, retval] long *plStatus)
HRESULT | SwitchToSource ([in] long lSourceIndex,[in, defaultvalue(FALSE)] BOOL bBlocking,[out, retval] long *plStatus)
HRESULT | TimeOut ([in] long newTimeOut)
HRESULT | TimeOut ([out, retval] long *pTimeOut)

Detailed Description

This ActiveX control allows to remote control analog video playback on equipments with preconfigured analog video outputs. equipments with preconfigured audio outputs. The ActiveX control can establish playback of either video sources captured in real time by VisioWave equipments located anywhere on the network, VisioWave encoded video files local to the equipment or playback of previously recorded video content (using the VWStorageAccessController and XVWTimeLine ActiveX controls) again anywhere on the network. It supports the notion of cycles which allows the user to program predefined sequences of sources which will rotate in the given order. Also supported is to configure backup sources in case of network failure, that is when the network connection to the primary source is lost. It also allows control over the analog On Screen Display (OSD) in order to display for example the source's name, the local time and date, or when streaming previously recorded content the video's capture time and date. See the VWMonitorManagerCtrl2_VB sample for a small example in Visual Basic on how to use it.

Member Function Documentation

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::AddFileSource | ( | [in] BSTR | bstrFileName,
 |  | [in, defaultvalue(-1)] long | lTimeAlive,
 |  | [in, defaultvalue(0)] long | lSwitchingTime
 | ) |

Adds a display item, whose source is a file source, to the current custom sequence/cycle.

Parameters:
bstrFileName | Name of the file to display.
lTimeAlive | Display time in ms.-1 means infinite.
lSwitchingTime | Switching time in ms between current display item and the next.Only used in case the switching mode is OVERLAP. Not implemented yet, must be set to 0.
See also:
BeginCustomCycle

EndCustomCycle

LoadCustomCycle

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::AddHardSource | ( | [in] long | lCard,
 |  | [in, defaultvalue(0x1206)] long | lVideoFormat,
 |  | [in, defaultvalue(-1)] long | lTimeAlive,
 |  | [in, defaultvalue(0)] long | lSwitchingTime
 | ) |

Adds a display item, whose source is a video channel accessed via the network, to the current custom sequence/cycle.

Parameters:
lCard | Visiowave channel number.
lVideoFormat | One of the following video format used for capture: 0x2100 (VIDEO_FORMAT_NTSC_M) or 0x09, 0x1100 (VIDEO_FORMAT_NTSC_N), 0x2102 (VIDEO_FORMAT_NTSC_443), 0x2103 (VIDEO_FORMAT_NTSC_JP), 0x2105 (VIDEO_FORMAT_BW_60), 0x1206 (VIDEO_FORMAT_PAL_BGHI) or 0x11, 0x1207 (VIDEO_FORMAT_PAL_N), 0x2208 (VIDEO_FORMAT_PAL_M), 0x2209 (VIDEO_FORMAT_PAL_443), 0x220A (VIDEO_FORMAT_PAL_D), 0x120B (VIDEO_FORMAT_BW_50), 0x130C (VIDEO_FORMAT_SECAM_L) or 0x19.
lTimeAlive | Display time in ms.-1 means infinite.
lSwitchingTime | Switching time in ms between current display item and the next.Only used in case the switching mode is OVERLAP. Not implemented yet, must be set to 0.
See also:
BeginCustomCycle

EndCustomCycle

LoadCustomCycle

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::AddHardSourceEx | ( | [in] long | lCard,
 |  | BSTR | bstrVideoFormat,
 |  | [in, defaultvalue(-1)] long | lTimeAlive,
 |  | [in, defaultvalue(0)] long | lSwitchingTime
 | ) |

Adds a display item, whose source is a video channel accessed via the network, to the current custom sequence/cycle.

Parameters:
lCard | Visiowave channel number.
lVideoFormat | One of the following video format used for capture: "VIDEO_FORMAT_NTSC_M" or "NTSC", "VIDEO_FORMAT_NTSC_N", "VIDEO_FORMAT_NTSC_443", "VIDEO_FORMAT_NTSC_JP", "VIDEO_FORMAT_BW_60", "VIDEO_FORMAT_PAL_BGHI" or "PAL", "VIDEO_FORMAT_PAL_N", "VIDEO_FORMAT_PAL_M", "VIDEO_FORMAT_PAL_443", "VIDEO_FORMAT_PAL_D", "VIDEO_FORMAT_BW_50", "VIDEO_FORMAT_SECAM_L" or "SECAM".
lTimeAlive | Display time in ms.-1 means infinite.
lSwitchingTime | Switching time in ms between current display item and the next.Only used in case the switching mode is OVERLAP. Not implemented yet, must be set to 0.

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::AddNetworkSource | ( | [in] BSTR | bstrProto,
 |  | [in] BSTR | bstrHost,
 |  | [in] long | lPort,
 |  | [in, defaultvalue(5000)] long | lTimeOut,
 |  | [in, defaultvalue(-1)] long | lTimeAlive,
 |  | [in, defaultvalue(0)] long | lSwitchingTime
 | ) |

Adds a display item, whose source is a video channel accessed via the network, to the current custom sequence/cycle.

Parameters:
bstrProto | Network protocol ("udp", "ipm" or "svc").
bstrHost | Name of the server that hosts the source.
lPort | TCP control socket port number.
lTimeOut | Time interval in ms the control will wait for a server message.
lTimeAlive | Display time in ms.-1 means infinite.
lSwitchingTime | Switching time in ms between current display item and the next.Only used in case the switching mode is OVERLAP. Not implemented yet, must be set to 0.
See also:
BeginCustomCycle

EndCustomCycle

LoadCustomCycle

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::AddSourceOSD | ( | [in] BSTR | bstrText,
 |  | [in, defaultvalue(0)] BOOL | bAlert
 | ) |

Adds an OSD to a source within a custom sequence/cycle.

Parameters:
bstrText | Text string to display.
bAlert | If set to false the text will appear on the top left corner as white text over blue background, if set to true the text will appear on the bottom left corner as red text over blue background.
Remarks:
This function overrides the normal OSD behavior defined by the Monitor Manager OSD format section in the Visiowave Central Configuration Server interface.
See also:
AddSourceOSD2

AddSourceOSDEx

AddSourceOSDEx2

AddSourceOSD3

AddSourceOSDAtIndex

SetOSDFormat

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::AddSourceOSD2 | ( | [in] BSTR | bstrText,
 |  | [in, defaultvalue(0)] BOOL | bAlert,
 |  | [in, defaultvalue(18)] long | lTextSize
 | ) |

Adds an OSD to a source within a custom sequence/cycle.

Parameters:
bstrText | Text string to display.
bAlert | If set to false the text will appear on the top left corner as white text over blue background, if set to true the text will appear on the bottom left corner as red text over blue background.
lTextSize | Size of the font in 1/64th of dots (for a 72 dpi screen, there are 72 dots per inch).
Remarks:
This function overrides the normal OSD behavior defined by the Monitor Manager OSD format section in the Visiowave Central Configuration Server interface.
See also:
AddSourceOSD

AddSourceOSDEx

AddSourceOSDEx2

AddSourceOSD3

AddSourceOSDAtIndex

SetOSDFormat

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::AddSourceOSD3 | ( | [in] long | lX,
 |  | [in] long | lY,
 |  | [in] BSTR | bstrText,
 |  | [in] long | lTextColor,
 |  | [in] long | lBackgroundColor,
 |  | [in, defaultvalue(18)] long | lTextSize,
 |  | [out, retval] long * | plResult
 | ) |

Adds an OSD to a source within a custom sequence/cycle.

Parameters:
lX | Horizontal alignment. Only 3 positions are available: 0 = LEFT, 1 = CENTERED, 2 = RIGHT
lY | Vertical alignment. Ranges from 0 (top) to 100 (bottom)
bstrText | Text string to display.
lTextColor | Color used to display text on screen. Only two values are available: 0 = WHITE, 1 = RED.
lBackgroundColor | Color of the OSD background. 0 = NONE, 1 = BLUE.
lTextSize | Size of the font in 1/64th of dots (for a 72 dpi screen, there are 72 dots per inch).
Returns:
Operation result.
Return values:
0 | Success.
-1 | Failure (parameter out of range).
Remarks:
This function overrides the normal OSD behavior defined by the Monitor Manager OSD format section in the Visiowave Central Configuration Server interface.
See also:
AddSourceOSD

AddSourceOSD2

AddSourceOSDEx

AddSourceOSDEx2

AddSourceOSDAtIndex

SetOSDFormat

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::AddSourceOSDAtIndex | ( | [in] long | lSourceIndex,
 |  | [in] BOOL | bMainSource,
 |  | [in] long | lX,
 |  | [in] long | lY,
 |  | [in] BSTR | bstrText,
 |  | [in] long | lTextColor,
 |  | [in] long | lBackColor,
 |  | [in] long | lBackTransparency,
 |  | [in] long | lTextSize,
 |  | [out, retval] long * | plError
 | ) |

Associates an OSD text with the given source in the current cycle. The text can contain the following fields:

  • s: source's name
  • d: current date
  • t: current time
  • v: current frame's capture date
  • c: current frame's capture time
  • %%: percent character

Parameters:
lCycleItemIndex | Zero-based index of the source in the current cycle or -1 for the current source.
bMainSource | True/false depending on if the OSD must be changed for the main source or the backup source.
lX | Horizontal alignment (0 = LEFT, 1 = CENTERED, 2 = RIGHT).
lY | Vertical alignment, from 0 (top) to 100 (bottom).
bstrText | Text string to display.
lTextColor | Text color (0 = DARK GRAY, 1 = GRAY, 2 = LIGHT GRAY, 3 = WHITE, 4 = MEDIUM RED, 5 = RED, 6 = BLUE, 7 = BLACK)
lBackColor | Background color (0 = DARK GRAY, 1 = GRAY, 2 = LIGHT GRAY, 3 = WHITE, 4 = MEDIUM RED, 5 = RED, 6 = BLUE, 7 = BLACK). $param lBackTransparency Background transparency, from 0 (opaque) to 100 (invisible).
lTextSize | Size of the font in 1/64th of dots (for a 72 dpi screen, there are 72 dots per inch).
Returns:
Error status.
Return values:
0 | success.
-2 | failure (not connected to the Monitor Manager).
-1 | failure (Connection to the Monitor Manager failed).
Remarks:
This function overrides the normal OSD behavior defined by the Monitor Manager. OSD format section in the Visiowave Central Configuration Server interface.
See also:
AddSourceOSD

AddSourceOSD2

AddSourceOSDEx

AddSourceOSDEx2

AddSourceOSD3

SetOSDFormat

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::AddSourceOSDEx | ( | [in] long | lX,
 |  | [in] long | lY,
 |  | [in] BSTR | bstrText,
 |  | [in] long | lTextColor,
 |  | [in] long | lTextFlags
 | ) |

Adds an OSD to a source within a custom sequence/cycle.

Parameters:
lX | Horizontal position. Ignored if alignment bits of the lTextFlags parameter are used, see remarks for more details.
lY | Vertical position. Ignored if alignment bits of the lTextFlags parameter are used, see remarks for more details.
bstrText | Text string to display.
lTextColor | Color used to display text on screen. Only two values are available: 0 = WHITE, 1 = RED.
lTextFlags Alignment and background bits mask. Only the seven least significant bits are taken into account: the three first ones are used to align text horizontally, the next three bits are used to align text vertically and the seventh one is used to set the background available or not. Alignment bits mask:
  • for left aligned: LSB (Least Significant Bit) must be set e.g. ...????001 (...+1).
  • for horizontally centered: second bit set e.g. ...????010 (...+2).
  • for right alignment: third bit set e.g. ...????100 (...+4).
  • for top aligned: fourth bit set e.g. ...?001??? (...+8).
  • for vertically centered: fifth bit set e.g. ...?010??? (...+16).
  • for bottom aligned: sixth bit set e.g. ...?100??? (...+32). Background bits mask:
  • for blue background: seventh bit set e.g. ...1?????? (...+64).
Remarks:
To align text, at least one bit of the seven alignment bits must be set, otherwise the lX and lY positions will be used (e.g. lTextFlags=...?000000).

This function overrides the normal OSD behavior defined by the Monitor Manager OSD format section in the Visiowave Central Configuration Server interface.

See also:
AddSourceOSD

AddSourceOSD2

AddSourceOSDEx2

AddSourceOSD3

AddSourceOSDAtIndex

SetOSDFormat

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::AddSourceOSDEx2 | ( | [in] long | lX,
 |  | [in] long | lY,
 |  | [in] BSTR | bstrText,
 |  | [in] long | lTextColor,
 |  | [in] long | lTextFlags,
 |  | [in, defaultvalue(18)] long | lTextSize
 | ) |

Adds an OSD to a source within a custom sequence/cycle.

Parameters:
lX | Horizontal position. Ignored if alignment bits of the lTextFlags parameter are used, see remarks for more details.
lY | Vertical position. Ignored if alignment bits of the lTextFlags parameter are used, see remarks for more details.
bstrText | Text string to display.
lTextColor | Color used to display text on screen. Only two values are available: 0 = WHITE, 1 = RED.
lTextFlags Alignment and background bits mask. Only the seven least significant bits are taken into account: the three first ones are used to align text horizontally, the next three bits are used to align text vertically and the seventh one is used to set the background available or not. Alignment bits mask:
  • for left aligned: LSB (Least Significant Bit) must be set e.g. ...????001 (...+1).
  • for horizontally centered: second bit set e.g. ...????010 (...+2).
  • for right alignment: third bit set e.g. ...????100 (...+4).
  • for top aligned: fourth bit set e.g. ...?001??? (...+8).
  • for vertically centered: fifth bit set e.g. ...?010??? (...+16).
  • for bottom aligned: sixth bit set e.g. ...?100??? (...+32). Background bits mask:
  • for blue background: seventh bit set e.g. ...1?????? (...+64).
lTextSize | Size of the font in 1/64th of dots (for a 72 dpi screen, there are 72 dots per inch).
Remarks:
To align text, at least one bit of the seven alignment bits must be set, otherwise the lX and lY positions will be used (e.g. lTextFlags=...?000000).

This function overrides the normal OSD behavior defined by the Monitor Manager OSD format section in the Visiowave Central Configuration Server interface.

See also:
AddSourceOSD

AddSourceOSD2

AddSourceOSDEx

AddSourceOSD3

AddSourceOSDAtIndex

SetOSDFormat

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::BeginCustomCycle | ( | [in] BSTR | bstrCycleMode,
 |  | [in, defaultvalue(0)] long | lNoAutoSwitch
 | ) |

Call this method to start defining a new custom sequence/cycle.

Parameters:
bstrCycleMode | switching mode (SEQUENTIAL or OVERLAP).
lNoAutoSwitch | When set to 0, the sources of this sequence/cycle. will switch automatically, depending on their time alive / switching time. Otherwise (set to 1) switching to a source is manual (ie users must call SwitchToSource()). Notice that in this case, only the first source is loaded.
See also:
AddNetworkSource

AddHardSource

AddHardSourceEx

AddFileSource

EndCustomCycle

LoadCuctomCycle

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Blocking ( [in] BOOL newBlocking )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Blocking ( [out, retval] BOOL * pBlocking )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::ClearSourceOSDAtIndex | ( | [in] long | lSourceIndex,
 |  | [in] BOOL | bMainSource,
 |  | [out, retval] long * | plError
 | ) |

Removes all OSD texts associated with the given source in the current cycle.

Parameters:
lCycleItemIndex | Zero-based index of the source in the current cycle or -1 for the current item.
bMainSource | True/false depending on if the OSD must be changed for the main source or the backup source.
Returns:
Error status.
Return values:
0 | success.
-2 | failure (not connected to the Monitor Manager).
-1 | failure (Connection to the Monitor Manager failed).

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Connect ( [out, retval] short * pnRet )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::EndCustomCycle ( )

Ends a custom display sequence/cycle after previous calls to BeginCustomCycle and AddXXXSource.

See also:
BeginCustomCycle

AddNetworkSource

AddHardSource

AddHardSourceEx

AddFileSource

LoadCuctomCycle

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::ExtractBoolean | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] long * | plValue
 | ) |

Extracts a boolean value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
boolean value of the parameter

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::ExtractInteger | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] long * | plValue
 | ) |

Extracts an integer value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
integer value of the parameter

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::ExtractNumber | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] float * | pfValue
 | ) |

Extracts a floating-point value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
floating-point value of the parameter

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::ExtractString | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] BSTR * | pbstrValue
 | ) |

Extracts a string value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
string value of the parameter

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::GetCycleItemInfo | ( | [in] long | lSourceIndex,
 |  | [out, retval] BSTR * | pbstrCycleItem
 | ) |

Returns information about a source in the current cycle. The information is returned as a comma-separated list of name=value pairs. The following information is available:

  • cycle [string]: cycle name as specified in the central configuration server or with SaveCycle/LoadCycle.
  • main_type [integer]: main source's type (0 = LOCAL, 1 = NETWORK, 2 = FILE).
  • main_channel [integer]: main source's channel, if applicable.
  • main_proto [integer]: main source's network protocol, if applicable (0 = UDP, 1 = SVC, 2 = IPM).
  • main_host [string]: main sources's hostname, if applicable.
  • main_port [integer]: main source's TCP port, if applicable.
  • main_file [string]: main source's filename, if applicable.
  • backup_type [integer]: backup source's type (0 = LOCAL, 1 = NETWORK, 2 = FILE, -1 = no backup source).
  • backup_channel [integer]: backup source's channel, if applicable.
  • backup_proto [integer]: backup source's network protocol, if applicable (0 = UDP, 1 = SVC, 2 = IPM).
  • backup_host [string]: backup sources's hostname, if applicable.
  • backup_port [integer]: backup source's TCP port, if applicable.
  • backup_file [string]: backup source's filename, if applicable.
  • status [integer]: last known connection status (see below).
  • index [integer]: source's zero-based index in the cycle.
  • default [boolean]: true/false depending on if this is the central configuration server default cycle or not.
  • sources [integer]: total number of sources in the current cycle.

The connection status can be one of the following values:

  • 0: the item has not been accessed yet.
  • 1: connection to both the main and backup sources failed.
  • 2: connecting to the main source.
  • 3: connected to the main source.
  • 4: connecting to the backup source.
  • 5: connected to the backup source.

Parameters:
lSourceIndex Zero-based index of the source in the current cycle or -1 for the current source.
Returns:
A comma-separated list of name=value pairs.
Return values:
"" failure (connection to the Monitor Manager failed).
See also:
ExtractBoolean

ExtractNumber

ExtractString

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::GetId ( [out, retval] long * pInterface )

Should be used only by VisioWave engineers.

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::GetNumberOfCycleItems ( [out, retval] long * plNumberOfCycleItems )

Retrieves the number of items in the current sequence/cycle.

Returns:
the number of items in the current cycle or a negative value if an error occured.
Return values:
-1 failure (connection to the Monitor Manager failed).

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::GetStat ( [out, retval] BSTR * pbstrStat )

This function gets information about the current active sequence/cycle. To extract a particular parameter's value, use the ExtractXXX methods.

Returned parameters:

  • cycle [string]: sequence/cycle name.If it was created with Begin/EndCustomCycle, this value will be set to "custom".
  • sources [integer]: the amount of sources countained in the current sequence/cycle.
  • current [integer]: the index of the currently being displayed. Indexes start at 0, thus if there are 3 sources in the current cycle, the sources indexes vary from 0 to 2.
  • default [boolean]: if this sequence/cycle has been set to be the default.
  • type[index] [string]: the source type of the source with index [index]. This may be "network" for a network source, "file" for a file source, "local" for a local hard source and "soft" for a soft source. For example, if the third source in the sequence/cycle is a file source, "type2" will be set to "file".

Network source information:

  • host[index] [string]: network source's server hostname.
  • port[index] [integer]: network source's server port.
  • proto[index] [string]: network source's protocol ("udp", "ipm" or "svc").

File source information:

  • filename[index] [string]: file name of the video file.

Hard source information:

  • driver[index] [string]: driver name for this Visiowave video board.
  • board[index] [integer]: video channel's number.
  • connector[index] [integer]: "svideo" or "composite" for VisioWave 1 and VisioWave PCI2 codec boards, "compositea" or "compositeb" or "compositec" for VisioWave CPCI4 and CPCI4-b codec boards.

Returns:
String containing all the sequence/cycle informations.
Return values:
"" Failure (connection to the Monitor Manager failed).
See also:
ExtractInteger

ExtractString

ExtractBoolean

ExtractNumber

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::LoadCustomCycle ( )

Activates the previously custom display sequence/cycle defined using the Begin/EndCustomCycle.

See also:
BeginCustomCycle

AddNetworkSource

AddHardSource

AddHardSourceEx

AddFileSource

EndCustomCycle

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::LoadCycle ( [in] BSTR bstrCycleName )

Loads and activates a display sequence, or cycle, previously defined in the Sequences part of the VisioWave Central Configuration Server interface.

Parameters:
bstrCycleName Name of the display sequence/cycle to be loaded

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Pause ( )

Pauses the current sequence/cycle.The current sequence/cycle will be locked at the current source until Resume is called. This function has no effect if the sequence/cycle consists of one single source only.

See also:
Resume

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Port ( [in] long newPort )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Port ( [out, retval] long * pPort )

Returns:
the TCP port number of the remote manager

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::ResetMonitor ( )

Resets the ouput video channel and displayed the default sequence/cycle as configured in the Visiowave Central Configuration Server interface.

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Resume ( )

Resumes the current sequence/cycle previously paused with Pause.This function has no effect if the current sequence/cycle is not paused.

See also:
Pause

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Server ( [in] BSTR newServer )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Server ( [out, retval] BSTR * pServer )

Returns:
the host name or IP address of the remote manager

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::SetDynamicOSD | ( | [in] BSTR | bstrProto,
 |  | [in] BSTR | bstrHost,
 |  | [in] long | lPort,
 |  | [in, defaultvalue(0)] long | lPriorityThreshold,
 |  | [in, defaultvalue(5000)] long | lTimeOut,
 |  | [in, defaultvalue(-1)] long | lTimeAlive,
 |  | [in, defaultvalue(0)] long | lSwitchingTime
 | ) |

Adds a dynamic OSD to the current source of the current cycle. The dynamic OSD parameters are streamed on the network by a Dynamic OSD Server of some sort, such as a Video Plugin Manager.

Parameters:
bstrProto | Network protocol ("udp", "ipm" or "svc").
bstrHost | Hostname of the Dynamic Osd Server.
lPort | Port of the Dynamic Osd Server.
lPriorityThreshold | Only dynamic OSD items whose priority tag is equal or higher than this threshold will be actually displayed on the monitor. Such a tag currently varies from 0 (LOW) to 3 (HIGH).
lTimeOut | Time interval in ms the control will wait for a server message.
lTimeAlive | Display time in ms.-1 means infinite.
lSwitchingTime | Switching time in ms between current display item and the next.Only used in case the switching mode is OVERLAP. Not implemented yet, must be set to 0.

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::SetFileBackupSource | ( | [in] BSTR | bstrFileName,
 |  | [in, defaultvalue(-1)] long | lTimeAlive,
 |  | [in, defaultvalue(0)] long | lSwitchingTime
 | ) |

Sets file backup source for the previously added source.

Parameters:
bstrFileName | Name of the file to display.
lTimeAlive | Display time in ms.-1 means infinite.
lSwitchingTime | Switching time in ms between current display item and the next.Only used in case the switching mode is OVERLAP. Not implemented yet, must be set to 0.
See also:
AddNetworkSource

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::SetHardBackupSource | ( | [in] long | lCard,
 |  | [in, defaultvalue(0x1206)] long | lVideoFormat,
 |  | [in, defaultvalue(-1)] long | lTimeAlive,
 |  | [in, defaultvalue(0)] long | lSwitchingTime
 | ) |

Sets local backup source for the previously added source.

Parameters:
lCard | Visiowave channel number.
lVideoFormat | One of the following video format used for capture: 0x2100 (VIDEO_FORMAT_NTSC_M) or 0x09, 0x1100 (VIDEO_FORMAT_NTSC_N), 0x2102 (VIDEO_FORMAT_NTSC_443), 0x2103 (VIDEO_FORMAT_NTSC_JP), 0x2105 (VIDEO_FORMAT_BW_60), 0x1206 (VIDEO_FORMAT_PAL_BGHI) or 0x11, 0x1207 (VIDEO_FORMAT_PAL_N), 0x2208 (VIDEO_FORMAT_PAL_M), 0x2209 (VIDEO_FORMAT_PAL_443), 0x220A (VIDEO_FORMAT_PAL_D), 0x120B (VIDEO_FORMAT_BW_50), 0x130C (VIDEO_FORMAT_SECAM_L) or 0x19.
lTimeAlive | Display time in ms.-1 means infinite.
lSwitchingTime | Switching time in ms between current display item and the next.Only used in case the switching mode is OVERLAP. Not implemented yet, must be set to 0.
See also:
AddNetworkSource

AddHardSource

AddHardSourceEx

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::SetMonitorOSD ( [in] BSTR bstrOSD )

Changes the Monitor Manager OSD name section of the Visiowave Central Configuration Server interface.

Parameters:
bstrOSD OSD text string to display.
Remarks:
This OSD is displayed when no sequence/cycle is launched, and this function does not modify the OSD format section.
See also:
SetOSDFormat

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::SetNetworkBackupSource | ( | [in] BSTR | bstrProto,
 |  | [in] BSTR | bstrHost,
 |  | [in] long | lPort,
 |  | [in, defaultvalue(5000)] long | lTimeOut,
 |  | [in, defaultvalue(-1)] long | lTimeAlive,
 |  | [in, defaultvalue(0)] long | lSwitchingTime
 | ) |

Sets network backup source for the previously added network source.

Parameters:
bstrProto | Network protocol ("udp", "ipm" or "svc").
bstrHost | Name of the server that hosts the source.
lPort | TCP control socket port number.
lTimeOut | Time interval in ms the control will wait for a server message.
lTimeAlive | Display time in ms.-1 means infinite.
lSwitchingTime | Switching time in ms between current display item and the next.Only used in case the switching mode is OVERLAP. Not implemented yet, must be set to 0.
See also:
AddNetworkSource

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::SetOSDFormat | ( | [in] long | lX,
 |  | [in] long | lY,
 |  | [in] BSTR | bstrText,
 |  | [in] long | lTextColor,
 |  | [in] long | lBackgroundColor,
 |  | [in, defaultvalue(18)] long | lTextSize,
 |  | [out, retval] long * | plResult
 | ) |

Changes the monitor OSD format defined in the VisioWave Central Configuration Server interface.

Parameters:
lX | Horizontal alignement. Only 3 positions are available: 0 = LEFT, 1 = CENTERED, 2 = RIGHT
lY | Vertical alignement. Ranges from 0 (top) to 100 (bottom)
bstrText | Text string to display.
lTextColor | 0 = WHITE, 1 = RED
lBackgroundColor | OSD background color: 0 = NONE, 1 = BLUE
lTextSize | Size of the font in 1/64th of dots (for a 72 dpi screen, there are 72 dots per inch).
Returns:
Operation result.
Return values:
0 | Success.
-1 | Failure (parameter out of range).

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::Status ( [out, retval] long * pStatus )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::SwitchToNextSource | ( | [in, defaultvalue(FALSE)] BOOL | bBlocking,
 |  | [out, retval] long * | plStatus
 | ) |

Switches to the next source in the current cycle. If the current source is the last source in the cycle, then switches to the first source in the current cycle. This method can be blocking or non-blocking. In non-blocking mode, the connection status can be retrieved with GetCycleItemInfo and the return value must be interpreted only if it is a negative value (i.e. if an error occured). In blocking mode, the connection status is returned directly.

Parameters:
bBlocking | True if the method must block until the connection has succeeded or failed.
plStatus | In blocking mode, indicates if the connection was successful or not.
Returns:
The connection status (in blocking mode) or a negative value if an error occured.
Return values:
-2 | failure (not connected to the Monitor Manager).
-1 | failure (Connection to the Monitor Manager failed).
0 | connection to both the main and backup sources failed (or non-blocking mode).
1 | connected to the main source.
2 | connected to the backup source.
See also:
GetCycleItemInfo

SwitchToSource

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::SwitchToPreviousSource | ( | [in, defaultvalue(FALSE)] BOOL | bBlocking,
 |  | [out, retval] long * | plStatus
 | ) |

Switches to the previous source in the current cycle. If the current source is the first source in the cycle, then switches to the last source in the current cycle. This method can be blocking or non-blocking. In non-blocking mode, the connection status can be retrieved with GetCycleItemInfo and the return value must be interpreted only if it is a negative value (i.e. if an error occured). In blocking mode, the connection status is returned directly.

Parameters:
bBlocking | True if the method must block until the connection has succeeded or failed.
plStatus | In blocking mode, indicates if the connection was successful or not.
Returns:
The connection status (in blocking mode) or a negative value if an error occured.
Return values:
-2 | failure (not connected to the Monitor Manager).
-1 | failure (Connection to the Monitor Manager failed).
0 | connection to both the main and backup sources failed (or non-blocking mode).
1 | connected to the main source.
2 | connected to the backup source.
See also:
GetCycleItemInfo

SwitchToSource

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::SwitchToSource | ( | [in] long | lSourceIndex,
 |  | [in, defaultvalue(FALSE)] BOOL | bBlocking,
 |  | [out, retval] long * | plStatus
 | ) |

Switches to the source which index in the current cycle is given as a parameter. This method can be blocking or non-blocking. In non-blocking mode, the connection status can be retrieved with GetCycleItemInfo and the return value must be interpreted only if it is a negative value (i.e. if an error occured). In blocking mode, the connection status is returned directly.

Parameters:
lSourceIndex | Index of the source to switch to within the current cycle, starting from 0 (ie, first source defined gets index number 0).
bBlocking | True if the method must block until the connection has succeeded or failed.
plStatus | In blocking mode, indicates if the connection was successful or not.
Returns:
The connection status (in blocking mode) or a negative value if an error occured.
Return values:
-3 | failure (bad source index).
-2 | failure (not connected to the Monitor Manager).
-1 | failure (Connection to the Monitor Manager failed).
0 | connection to both the main and backup sources failed (or non-blocking mode).
1 | connected to the main source.
2 | connected to the backup source.
See also:
GetCycleItemInfo

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::TimeOut ( [in] long newTimeOut )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2::TimeOut ( [out, retval] long * pTimeOut )

Returns:
the connection time-out in milliseconds

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl Interface Reference

VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl

VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl Interface Reference

This ActiveX control allows to remote control digital relay outputs on equipments equipped with digital I/O cards. It allows to query and set the state of the digital relays. See the VWRelayOutputCtrl_VB sample for a small example in Visual Basic on how to use it. More...

import "VWDigitalIOController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | Blocking ([in] BOOL Blocking)
HRESULT | Blocking ([out, retval] BOOL *Blocking)
HRESULT | Connect ([out, retval] long *Result)
HRESULT | Disconnect ()
HRESULT | GetId ([out, retval] long *pInterface)
HRESULT | Port ([in] long Port)
HRESULT | Port ([out, retval] long *Port)
HRESULT | Rehash ([out, retval] long *Result)
HRESULT | RelayOutputStatus ([in] long state)
HRESULT | RelayOutputStatus ([out, retval] long *state)
HRESULT | Server ([in] BSTR Hostname)
HRESULT | Server ([out, retval] BSTR *Hostname)
HRESULT | Status ([out, retval] long *Status)
HRESULT | TimeOut ([in] long Timeout)
HRESULT | TimeOut ([out, retval] long *Timeout)

Detailed Description

This ActiveX control allows to remote control digital relay outputs on equipments equipped with digital I/O cards. It allows to query and set the state of the digital relays. See the VWRelayOutputCtrl_VB sample for a small example in Visual Basic on how to use it.

Member Function Documentation

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::Blocking ( [in] BOOL Blocking )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::Blocking ( [out, retval] BOOL * Blocking )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::Connect ( [out, retval] long * Result )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::GetId ( [out, retval] long * pInterface )

Should be used only by VisioWave engineers.

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::Port ( [in] long Port )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::Port ( [out, retval] long * Port )

Returns:
the TCP port number of the remote manager

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::RelayOutputStatus ( [in] long state )

Sets the state of the remote Relay Output.

Parameters:
state state value (0 = CLOSED or 1 = OPEN)

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::RelayOutputStatus ( [out, retval] long * state )

Gets the state of the remote Relay Output.

Returns:
state of the relay output
Return values:
0 | CLOSED
1 | OPEN
2 | UNDEFINED

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::Server ( [in] BSTR Hostname )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::Server ( [out, retval] BSTR * Hostname )

Returns:
the host name or IP address of the remote manager

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::Status ( [out, retval] long * Status )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::TimeOut ( [in] long Timeout )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl::TimeOut ( [out, retval] long * Timeout )

Returns:
the connection time-out in milliseconds


VisioWave SDK: VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl Interface Reference

VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl

VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl Interface Reference

This ActiveX control allows to remotely query the state of various system health probes (e.g. temperature, fan speeds, core voltages,...) on equipments with preconfigured and installed power supply monitoring. It also allows the adjust each system probe's alarm thresholds. See the VWRemoteMonitoringCtrl_VB sample for a small example in Visual Basic on how to use it. More...

import "VWRemoteMonitoringController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | AcknowledgeSoftAlarm ([in] BSTR BstrAlarmName,[out, retval] long *plErrorCode)
HRESULT | Blocking ([in] BOOL newVal)
HRESULT | Blocking ([out, retval] BOOL *pVal)
HRESULT | Connect ([out, retval] long *pResult)
HRESULT | Disconnect ()
HRESULT | ExtractBoolean ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BOOL *pbValue)
HRESULT | ExtractInteger ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue)
HRESULT | ExtractNumber ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] double *pdValue)
HRESULT | ExtractString ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BSTR *pbstrValue)
HRESULT | GetId ([out, retval] long *pInterface)
HRESULT | GetModuleInfos ([out, retval] BSTR *bstrModuleInfos)
HRESULT | GetSoftAlarms ([out, retval] BSTR *pBstrAlarms)
HRESULT | GetSoftAlarmThresholds ([out, retval] BSTR *pBstrAlarmThresholds)
HRESULT | GetStats ([out, retval] BSTR *pBstrStats)
HRESULT | GetSystemID ([out, retval] BSTR *pBstrSystemID)
HRESULT | GetTime ([out, retval] BSTR *pBstrTime)
HRESULT | Port ([in] long newVal)
HRESULT | Port ([out, retval] long *pVal)
HRESULT | Reboot ([out, retval] long *plErrorCode)
HRESULT | Rehash ([out, retval] long *pResult)
HRESULT | Server ([in] BSTR newVal)
HRESULT | Server ([out, retval] BSTR *pVal)
HRESULT | SetBoardID ([in] long lBoardID,[out, retval] long *plErrorCode)
HRESULT | SetSoftAlarmEnabled ([in] BSTR BstrAlarmName,[in] long lEnabled,[out, retval] long *plErrorCode)
HRESULT | SetSoftAlarmThresholds ([in] BSTR bstrAlarmName,[in] double dMinVal,[in] double dMaxVal,[out, retval] long *plErrorCode)
HRESULT | SetSystemID ([in] BSTR bstrSystemID,[out, retval] long *plErrorCode)
HRESULT | SetTime ([in] long lYear,[in] long lMonth,[in] long lDay,[in] long lHour,[in] long lMinute,[out, retval] long *plErrorCode)
HRESULT | Status ([out, retval] long *pVal)
HRESULT | TimeOut ([in] long newVal)
HRESULT | TimeOut ([out, retval] long *pVal)

Detailed Description

This ActiveX control allows to remotely query the state of various system health probes (e.g. temperature, fan speeds, core voltages,...) on equipments with preconfigured and installed power supply monitoring. It also allows the adjust each system probe's alarm thresholds. See the VWRemoteMonitoringCtrl_VB sample for a small example in Visual Basic on how to use it.

Member Function Documentation

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::AcknowledgeSoftAlarm | ( | [in] BSTR | BstrAlarmName,
 |  | [out, retval] long * | plErrorCode
 | ) |

Acknowledges an active alarm

Parameters:
BstrAlarmName The alarm's name that is to be acknowledged
Returns:
Errorcode
Return values:
0 | No Error
-1 | Not connected to remote Manager
-2 | Call failed.

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::Blocking ( [in] BOOL newVal )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::Blocking ( [out, retval] BOOL * pVal )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::Connect ( [out, retval] long * pResult )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::ExtractBoolean | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] BOOL * | pbValue
 | ) |

Extracts a boolean value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
boolean value of the parameter

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::ExtractInteger | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] long * | plValue
 | ) |

Extracts an integer value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
integer value of the parameter

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::ExtractNumber | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] double * | pdValue
 | ) |

Extracts a floating-point value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
floating-point value of the parameter

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::ExtractString | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] BSTR * | pbstrValue
 | ) |

Extracts a string value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
string value of the parameter

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::GetId ( [out, retval] long * pInterface )

Should be used only by VisioWave engineers.

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::GetModuleInfos ( [out, retval] BSTR * bstrModuleInfos )

Gets various information about the power supply module

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false or "Serial link down" if the monitoring equipment cannot communicate with the power supply Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

Return values:
Key | "szHardwareRevision" The power supplies Hardware revision string
Key | "szFirmwareRevision"

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::GetSoftAlarms ( [out, retval] BSTR * pBstrAlarms )

Gets for each sensor it's current state. Possible states are "Off" for a configured but not triggered alarm, "On" for a configured an triggrered alarm, "Disabled" for a disabled alarm

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false or "Serial link down" if the monitoring equipment cannot communicate with the power supply Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

SetSoftAlarmEnabled

Return values:
Serial link down If the monitoring equipment cannot communicate with the power supply over the serial link the string "Serial link down" is returned
Remarks:
This function returns for each configured sensor 1 key value pair {alarm_name} = {state}, for example for the alarm temp[1] it would be temp[1]="Off" if the alarm is enabled but hasn't been triggered. For a list of sensors see SetSoftAlarmEnabled

This function also returns two values, fan_count and temp_count, to indicate the number of values of the form fan[i] and temp[i].

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::GetSoftAlarmThresholds ( [out, retval] BSTR * pBstrAlarmThresholds )

Gets for each alarm it's currently configured lower and upper bound.

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false or "Serial link down" if the monitoring equipment cannot communicate with the power supply Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

SetSoftAlarmEnabled

Return values:
Serial link down If the monitoring equipment cannot communicate with the power supply over the serial link the string "Serial link down" is returned
Remarks:
This function returns for each configured alarm 2 key value pairs {alarm_name}_LowLimit and {alarm_name}_HighLimit for example for the alarm temp[1] it would be temp[1]_HighLimit=50 and temp[1]_LowLimit=15 For a list of sensors see SetSoftAlarmEnabled

This function also returns two values, fan_count and temp_count, to indicate the number of values of the form fan[i] and temp[i].

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::GetStats ( [out, retval] BSTR * pBstrStats )

Gets for each sensor it's current value.

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false or "Serial link down" if the monitoring equipment cannot communicate with the power supply Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

SetSoftAlarmEnabled

Return values:
Serial link down If the monitoring equipment cannot communicate with the power supply over the serial link the string "Serial link down" is returned
Remarks:
This function returns for each configured sensor 1 key value pair {alarm_name} = {value}, for example for the sensor temp[1] it will return temp[1]=35. For a list of sensors see SetSoftAlarmEnabled

This function also returns two values, fan_count and temp_count, to indicate the number of values of the form fan[i] and temp[i].

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::GetSystemID ( [out, retval] BSTR * pBstrSystemID )

Gets the Power Supply's internal ID.

Returns:
String with the internal ID "Serial link down" if the monitoring equipment cannot communicate with the power supply
Return values:
Serial link down If the monitoring equipment cannot communicate with the power supply over the serial link the string "Serial link down" is returned

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::GetTime ( [out, retval] BSTR * pBstrTime )

Gets the Power Supply's internal clock.

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false or "Serial link down" if the monitoring equipment cannot communicate with the power supply Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

Return values:
Serial link down | If the monitoring equipment cannot communicate with the power supply over the serial link the string "Serial link down" is returned
iYear | Number key iYear. The year.
iMonth | Number key iMonth. The month.
iDay | Number key iDay. The month.
iHour | Number key iHour. The hour.
iMinute | Number key iMinute. The minute.

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::Port ( [in] long newVal )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::Port ( [out, retval] long * pVal )

Returns:
the TCP port number of the remote manager

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::Reboot ( [out, retval] long * plErrorCode )

Reboots the Evolution28HD

Returns:
Errorcode
Return values:
0 | No Error
-1 | Not connected to remote Manager
-2 | Call failed.
-3 | Method failed.
-4 | This method is not available on this model
Warning:
An Evolution28 running VWService cannot reboot itself.

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::Server ( [in] BSTR newVal )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::Server ( [out, retval] BSTR * pVal )

Returns:
the host name or IP address of the remote manager

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::SetBoardID | ( | [in] long | lBoardID,
 |  | [out, retval] long * | plErrorCode
 | ) |

Sets the power supply's internal ID

Parameters:
lBoardID The power supply ID
Returns:
Errorcode
Return values:
0 | No Error
-1 | Not connected to remote Manager
-2 | Call failed.

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::SetSoftAlarmEnabled | ( | [in] BSTR | BstrAlarmName,
 |  | [in] long | lEnabled,
 |  | [out, retval] long * | plErrorCode
 | ) |

Enables or disables an alarm

Parameters:
BstrAlarmName | The alarm's name that is to be enabled or disabled
lEnabled | 0 to disable, 1 to enable
Returns:
Errorcode
Return values:
0 | No Error
-1 | Not connected to remote Manager
-2 | Call failed.

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::SetSoftAlarmThresholds | ( | [in] BSTR | bstrAlarmName,
 |  | [in] double | dMinVal,
 |  | [in] double | dMaxVal,
 |  | [out, retval] long * | plErrorCode
 | ) |

Sets the minimum and maximum admissible value for a sensor

Parameters:
bstrAlarmName | The sensor's name
dMinVal | The minimum value
dMaxVal | The maximum value
Returns:
Errorcode
Return values:
0 | No Error
-1 | Not connected to remote Manager
-2 | Call failed.
Remarks:
If the sensor's value is not within these bounds, the associated alarm will be fired.
See also:
GetStats

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::SetSystemID | ( | [in] BSTR | bstrSystemID,
 |  | [out, retval] long * | plErrorCode
 | ) |

Sets the Power Supply's internal name

Parameters:
bstrSystemId The name
Returns:
Errorcode
Return values:
0 | No Error
-1 | Not connected to remote Manager
-2 | Call failed.

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::SetTime | ( | [in] long | lYear,
 |  | [in] long | lMonth,
 |  | [in] long | lDay,
 |  | [in] long | lHour,
 |  | [in] long | lMinute,
 |  | [out, retval] long * | plErrorCode
 | ) |

Sets the Power Supply's internal clock

Parameters:
lYear
lMonth
lDay
lHour
lMinute
Returns:
Errorcode
Return values:
0 | No Error
-1 | Not connected to remote Manager
-2 | Call failed.

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::Status ( [out, retval] long * pVal )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::TimeOut ( [in] long newVal )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl::TimeOut ( [out, retval] long * pVal )

Returns:
the connection time-out in milliseconds

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl Interface Reference

VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl

VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl Interface Reference

This ActiveX control allows to remotely query the equipment's storage database for recorded audio and video content. Queries can be restricted by various parameters as a date interval, minimum framerate, source name's, on alarm recordings. It also supports to protect given time intervals against erasure through the automatic time and space based storage garbage collector, as well as the remote extraction of audio and video content. See the VWAlarmStreamer_VB sample for an example in Visual Basic on how to use it. More...

import "VWStorageAccessController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | AddFile ([in] BSTR FileName,[in] BSTR DiskSpaceName,[in] BSTR SourceName,[in] BSTR AlarmName,[in] BSTR StartDate,[out, retval] long *ErrorCode)
HRESULT | Alarm ([in] BSTR SourceName,[in] long Fps,[in] BSTR AlarmName,[in] BSTR AlarmIncidentDate,[in] BSTR AlarmIntervalStart,[in] BSTR AlarmIntervalEnd,[out, retval] long *Res)
HRESULT | AlarmLogQuery ([in] BSTR SourceName,[in] long Fps,[out, retval] long *QueryId)
HRESULT | AlarmNamesQuery ([out, retval] long *QueryId)
HRESULT | Blocking ([in] BOOL Blocking)
HRESULT | Blocking ([out, retval] BOOL *Blocking)
HRESULT | Connect ([out, retval] long *Result)
HRESULT | DatabaseQuery ([in] BSTR Criteria,[out, retval] long *QueryId)
HRESULT | Disconnect ()
HRESULT | Erase ([in] BSTR SourceName,[in] long Fps,[in] BSTR EraseIntervalStart,[in] BSTR EraseIntervalEnd,[out, retval] long *Res)
HRESULT | ExtractInteger ([in] BSTR Parameter,[in] BSTR Params,[out, retval] long *Value)
HRESULT | ExtractString ([in] BSTR Parameter,[in] BSTR Params,[out, retval] BSTR *Value)
HRESULT | GetId ([out, retval] long *pInterface)
HRESULT | GetLastError ([out, retval] BSTR *LastError)
HRESULT | GetNext ([in] long QueryId,[out, retval] BSTR *Item)
HRESULT | LocalCopy ([in] BSTR SourceName,[in] long Fps,[in] BSTR BackupPath,[in] BSTR BackupStartDate,[in] BSTR BackupEndDate,[out, retval] long *Result)
HRESULT | Port ([in] long Port)
HRESULT | Port ([out, retval] long *Port)
HRESULT | Protect ([in] BSTR SourceName,[in] long Fps,[in] BSTR ProtectedIntervalStart,[in] BSTR ProtectedIntervalEnd,[in] BSTR ValidityIntervalStart,[in] BSTR ValidityIntervalEnd,[in] BSTR Details,[out, retval] long *Res)
HRESULT | ProtectedLogQuery ([in] BSTR SourceName,[in] long Fps,[out, retval] long *QueryId)
HRESULT | Rehash ([out, retval] long *Result)
HRESULT | ReleaseQuery ([in] long QueryId)
HRESULT | RemoteCopy ([in] BSTR SourceName,[in] long Fps,[in] BSTR BackupPath,[in] BSTR BackupStartDate,[in] BSTR BackupEndDate,[out, retval] long *Result)
HRESULT | RemoveAlarmByDate ([in] BSTR SourceName,[in] long Fps,[in] BSTR AlarmName,[in] BSTR AlarmIncidentDate,[out, retval] long *Res)
HRESULT | RemoveAlarmByInterval ([in] BSTR SourceName,[in] long Fps,[in] BSTR AlarmName,[in] BSTR AlarmIntervalStart,[in] BSTR AlarmIntervalEnd,[out, retval] long *Res)
HRESULT | Server ([in] BSTR Hostname)
HRESULT | Server ([out, retval] BSTR *Hostname)
HRESULT | SourcesQuery ([out, retval] long *QueryId)
HRESULT | Status ([out, retval] long *Status)
HRESULT | TimeOut ([in] long Timeout)
HRESULT | TimeOut ([out, retval] long *Timeout)
HRESULT | Unprotect ([in] BSTR SourceName,[in] long Fps,[in] BSTR ProtectedIntervalStart,[in] BSTR ProtectedIntervalEnd,[out, retval] long *Res)

Detailed Description

This ActiveX control allows to remotely query the equipment's storage database for recorded audio and video content. Queries can be restricted by various parameters as a date interval, minimum framerate, source name's, on alarm recordings. It also supports to protect given time intervals against erasure through the automatic time and space based storage garbage collector, as well as the remote extraction of audio and video content. See the VWAlarmStreamer_VB sample for an example in Visual Basic on how to use it.

Remarks:
All the date/time strings returned by methods of this interface or passed to methods of this interface have or must have the following format: "mm/dd/yyyy hh:mm:ss.ssssssUTC" (without the quotes). An undefined date/time will be converted to an null- sized string.

All the dates/times returned by methods of this interface or passed to methods of this interface are or must be between January 1, 1970 00:00:00 (included) and January 19, 2038 03:14:08 (not included).

Member Function Documentation

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::AddFile | ( | [in] BSTR | FileName,
 |  | [in] BSTR | DiskSpaceName,
 |  | [in] BSTR | SourceName,
 |  | [in] BSTR | AlarmName,
 |  | [in] BSTR | StartDate,
 |  | [out, retval] long * | ErrorCode
 | ) |

Add a new file to the database of the remote Storage Access Manager. The file must be located in the upload directory of the disk space passed as a parameter (this directory is configured in the Central Configuration) and the parameters SourceName and StartDate must be chosen in such a way that the file won't overlap with other files already in the database. If the call succeeds, the file will be moved to another location and the alarm name can be used to retrieve the full date of the first and last frames in the file (see AlarmLogQuery method). The file can then be added to the VWTimeLine control and streamed like any other file created by the VisioWave service (see AddQueryTimeSpan method).

Parameters:
FileName | File name (without any path, e.g. "file.mp3" or "file.avi").
DiskSpaceName | Disk space name, as defined in the Central Configuration Server.
SourceName | Source name associated with the file.
AlarmName | Alarm name associated with the file.
StartDate | Full UTC date of the first frame in the file (must follow this format: mm/dd/yyyy hh:mm:ss.usUTC). If the file already contains the right timestamps, then this string can be empty.
Returns:
operation result
Return values:
0 | success
-1 | failure (use GetLastError() to retrieve the error)
See also:
AlarmLogQuery

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Alarm | ( | [in] BSTR | SourceName,
 |  | [in] long | Fps,
 |  | [in] BSTR | AlarmName,
 |  | [in] BSTR | AlarmIncidentDate,
 |  | [in] BSTR | AlarmIntervalStart,
 |  | [in] BSTR | AlarmIntervalEnd,
 |  | [out, retval] long * | Res
 | ) |

Adds an alarm span on a given Archive Unit (an Archive Unit is the set of all records corresponding to a single source and fps). Files belonging to alarm spans are protected against time based deletion (MaxMinutes parameter), but will be deleted when the storage's maximum space is reached.

Parameters:
SourceName | Along with the Fps param, identifies the Archive Unit.
Fps | FPS Along with the SourceName param, identifies the Archive Unit.
AlarmName | The name of the alarm.
AlarmIncidentDate | Ntp date of the alarm's incident date.
AlarmIntervalStart | Ntp start date of the alarm interval
AlarmIntervalEnd | Ntp end date of the alarm interval
Remarks:
These ntp dates must be expressed in a UTC formated form. UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC
Returns:
operation result
Return values:
0 | success
-1 | failure (use GetLastError() to retrieve the error)

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::AlarmLogQuery | ( | [in] BSTR | SourceName,
 |  | [in] long | Fps,
 |  | [out, retval] long * | QueryId
 | ) |

Retrieves the Alarm Log of a specific Archive Unit (an Archive Unit is the set of all records corresponding to a single source and fps).

Parameters:
SourceName | Along with the Fps param, identifies the Archive Unit we want to query
Fps | FPS Along with the SourceName param, identifies the Archive Unit we want to query
Returns:
Id of the processed query. One can retrieve the Alarm Log by calling GetNext(QueryId). GetNext will return the next alarm log record in the log until reaching the end of the set (then it returns an empty string).
Return values:
0 Error (use GetLastError() to retrieve the error)
Remarks:
An alarm log record consists in a string of the form: "field1=value1, field2=value2, ..." Available fields are:
  • Name : String. Name of the alarm.
  • SpanStartDate : String. Ntp start date of the records corresponding to the alarm
  • SpanEndDate : String. Ntp end date of the records corresponding to the alarm
  • AlarmDate : String. Ntp date when the alarm occured

These ntp dates must be expressed in a UTC formated form. UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::AlarmNamesQuery ( [out, retval] long * QueryId )

Asks the archive database of the remote Storage Access Manager to list all recorded alarm names.

Returns:
Id of the processed query. One can retrieve the set of alarm names by calling GetNext(QueryId). GetNext will return the next alarm name in the list until reaching the end of the set (then it returns an empty string).
Return values:
0 Error (use GetLastError() to retrieve the error)

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Blocking ( [in] BOOL Blocking )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Blocking ( [out, retval] BOOL * Blocking )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Connect ( [out, retval] long * Result )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::DatabaseQuery | ( | [in] BSTR | Criteria,
 |  | [out, retval] long * | QueryId
 | ) |

Queries the archive database of the remote Storage Access Manager. A query is forged out of the various criteria passed as parameters. The query is processed by the Storage Access Manager, and a set of timespans matching all the criteria of the query is returned.

Parameters:
Criteria String of parameters, on the form: "criterion1=value1, criterion2=value2, ..." Available criteria are:
- SourceName : String. Restricts the query to the given source. Wildcards are allowed. Default is \*.

- Fps : Integer. Restricts the query to the given Fps. Note: 0 restricts the search to audio files only. There is 0 frame per second in an audio file, isn't it ?

- MinFps : Integer

  • MaxFps : Integer Those two criteria allow to restrict the query to a given Fps span.

- FileType : String Restricts the query to the given filetype ("Any", "Audio", "Video", or "MetaData")

- StartDate : String

  • EndDate : String These two criteria allow to restrict the query to a given time span. Note that these ntp dates must be expressed in a UTC formated form.

- AlarmName : String Restricts the query to the time spans recorded on the given alarm occurence.

- RequireAlarm : Boolean Restricts the query to time spans recorded on triggered alarms.

- RequireProtected : Boolean Restricts the query to Protected time spans.

Returns:
Id of the processed query. One can retrieve the set of result items by calling GetNext(QueryId). GetNext will return the next result item until reaching the end of the set (then it returns an empty string).
Return values:
0 Error (use GetLastError() to retrieve the error)
Remarks:
: a result item corresponds to a time span of contiguous records matching all the criteria of the query, with additional info. Each result item corresponds to a single source, filetype and Fps. Practically, it is a string of the form: "field1=value1, field2=value2, ..." Available fields are:
  • Sourcename : String. Records covered by the item are coming from this source.
  • Fps : Integer. Fps of the records within the time span covered by the item.
  • Filetype : Integer (). File type of the records within the time span covered by the item.
  • StartDate : String. Ntp start date of the time span covered by the item.
  • EndDate : String. Ntp end date of the time span covered by the item.

UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Erase | ( | [in] BSTR | SourceName,
 |  | [in] long | Fps,
 |  | [in] BSTR | EraseIntervalStart,
 |  | [in] BSTR | EraseIntervalEnd,
 |  | [out, retval] long * | Res
 | ) |

Schedules all files contained within the given Archive Unit (an Archive Unit is the set of all records corresponding to a single source and fps) time span for erasure.

Parameters:
SourceName | Along with the Fps param, identifies the Archive Unit.
Fps | FPS Along with the SourceName param, identifies the Archive Unit.
EraseIntervalStart | Ntp start date of the interval to erase.
EraseIntervalEnd | Ntp end date of the interval to erase.
Remarks:
These ntp dates must be expressed in a UTC formated form. UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC
Returns:
operation result
Return values:
0 | success
-1 | failure (use GetLastError() to retrieve the error)

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::ExtractInteger | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Params,
 |  | [out, retval] long * | Value
 | ) |

Extracts an integer value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
integer value of the parameter

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::ExtractString | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Params,
 |  | [out, retval] BSTR * | Value
 | ) |

Extracts a string value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
string value of the parameter

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::GetId ( [out, retval] long * pInterface )

Should be used only by VisioWave engineers.

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::GetLastError ( [out, retval] BSTR * LastError )

Allows users to get the last error on the error stack generated by the controller's methods. Errors can be pulled out the stack until there is no more remaining; the method then returns an empty string.

Returns:
LastError Explicit string that describes the last error that occured when calling one of this controller's methods.
Return values:
"" No error pending

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::GetNext | ( | [in] long | QueryId,
 |  | [out, retval] BSTR * | Item
 | ) |

Get next result item of the query given in parameter. Basically, the user can do 4 different kind of queries:

  • DatabaseQuery
  • AlarmNamesQuery
  • SourcesQuery
  • ProtectedLogQuery
  • AlarmLogQuery Each of these queries return a QueryId that the user will use to call GetNext() on the corresponding set of result items. Usually, a result item is a string beholding various fields, of the form "field1=value, field2=value, ...". Once GetNext() has reached the end of the result set, it returns an empty string, as if the query didn't exist.
    Parameters:
    QueryId Id of the query we want to get the results of.
    Returns:
    Next (or first if called for the first time on this QueryId) item in the result set corresponding to the QueryId.
    See also:
    DatabaseQuery

    AlarmNamesQuery

    SourcesQuery

    ProtectedLogQuery

    AlarmLogQuery

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::LocalCopy | ( | [in] BSTR | SourceName,
 |  | [in] long | Fps,
 |  | [in] BSTR | BackupPath,
 |  | [in] BSTR | BackupStartDate,
 |  | [in] BSTR | BackupEndDate,
 |  | [out, retval] long * | Result
 | ) |

Performs a local backup of the requested time span. "Local backup" means local to the Manager we are connected to, not to the controller. Hence, the span of video or audio information is copied on the same machine as it has been recorded originally, but on the form of a single file as specified by the BackupPath argument.

Parameters:
SourceName | Name of the source to backup
Fps | Fps to backup, among those recorded by the source
BackupPath | Name of the file to backup the span to, with full path. Usually an .asf file (or .mp3 for audio information)
BackupStartDate | Start date of the time span to backup
BackupEndDate | End date of the time span to backup
Remarks:
These ntp dates must be expressed in a UTC formated form. UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC

The backup can take a lot of time depending on the amount of data to transfer. To prevent the control from firing a LinkDown event, the TimeOut property can momentarily be set to -1 (infinite).

The time interval is limited to three days.

Returns:
operation result
Return values:
0 | success
-1 | failure (use GetLastError() to retrieve the error)

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Port ( [in] long Port )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Port ( [out, retval] long * Port )

Returns:
the TCP port number of the remote manager

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Protect | ( | [in] BSTR | SourceName,
 |  | [in] long | Fps,
 |  | [in] BSTR | ProtectedIntervalStart,
 |  | [in] BSTR | ProtectedIntervalEnd,
 |  | [in] BSTR | ValidityIntervalStart,
 |  | [in] BSTR | ValidityIntervalEnd,
 |  | [in] BSTR | Details,
 |  | [out, retval] long * | Res
 | ) |

Protects a span of records from automatic deletion on a given Archive Unit. (an Archive Unit is the set of all records corresponding to a single source and fps). Note that files belonging to protected time spans will not be deleted (neither by time nor space based deletion) until they are unprotected, so protecting a too large time span might cause a storage to grow larger than its MaxSpace parameter.

Parameters:
SourceName | Along with the Fps param, identifies the Archive Unit.
Fps | FPS Along with the SourceName param, identifies the Archive Unit.
ProtectedIntervalStart | Ntp start date of the interval to protect
ProtectedIntervalEnd | Ntp end date of the interval to protect
ValidityIntervalStart | Ignored
ValidityIntervalEnd | Ignored
Details | Additional info
Remarks:
These ntp dates must be expressed in a UTC formated form. UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC
Returns:
operation result
Return values:
0 | success
-1 | failure (use GetLastError() to retrieve the error)

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::ProtectedLogQuery | ( | [in] BSTR | SourceName,
 |  | [in] long | Fps,
 |  | [out, retval] long * | QueryId
 | ) |

Retrieves the Protected Log of a specific Archive Unit (an Archive Unit is the set of all records corresponding to a single source and fps).

Parameters:
SourceName | Along with the Fps param, identifies the Archive Unit we want to query
Fps | FPS Along with the SourceName param, identifies the Archive Unit we want to query
Returns:
Id of the processed query. One can retrieve the Protected Log by calling GetNext(QueryId). GetNext will return the next protected log record in the log until reaching the end of the set (then it returns an empty string).
Return values:
0 Error (use GetLastError() to retrieve the error)
Remarks:
A protected log record consists in a string of the form: "field1=value1, field2=value2, ..." Available fields are:
  • ProtectedStartDate : String. Ntp start date of the protected interval
  • ProtectedEndDate : String. Ntp end date of the protected interval
  • ValidityStartDate : String. Ntp start of the validity span for this protection
  • ValidityEndDate : String. Ntp end of the validity span for this protection
  • Details : String. Additional info

These ntp dates must be expressed in a UTC formated form. UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::ReleaseQuery ( [in] long QueryId )

Frees the set of result items corresponding to the QueryId given in parameter.

Parameters:
QueryId of the result set to release.
Remarks:
This has not to be called if one called GetNext(QueryId) until it reaches the end of the set (in this case the set is automatically cleared).

In other cases, it must be called when one doesn't need the result set of this QueryId anymore, since no garbage collecting is done on result sets.

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::RemoteCopy | ( | [in] BSTR | SourceName,
 |  | [in] long | Fps,
 |  | [in] BSTR | BackupPath,
 |  | [in] BSTR | BackupStartDate,
 |  | [in] BSTR | BackupEndDate,
 |  | [out, retval] long * | Result
 | ) |

Performs a remote backup of the requested time span. "Remote backup" means local to the controller, not to the Manager we are connected to. Hence, the span of video or audio information is sent over the network from machine on which it has been recorded originally to the machine the controller is living, and saved on the form of a single file as specified by the BackupPath argument.

Parameters:
SourceName | Name of the source to backup
Fps | Fps to backup, among those recorded by the source
BackupPath | Name of the file to backup the span to, with full path. Usually an .asf file (or .mp3 for audio information)
BackupStartDate | Start date of the time span to backup
BackupEndDate | End date of the time span to backup
Remarks:
These ntp dates must be expressed in a UTC formated form. UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC

The backup can take a lot of time depending on the amount of data to transfer. To prevent the control from firing a LinkDown event, the TimeOut property can momentarily be set to -1 (infinite).

The time interval is limited to three days.

Returns:
operation result
Return values:
0 | success
-1 | failure (use GetLastError() to retrieve the error)

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::RemoveAlarmByDate | ( | [in] BSTR | SourceName,
 |  | [in] long | Fps,
 |  | [in] BSTR | AlarmName,
 |  | [in] BSTR | AlarmIncidentDate,
 |  | [out, retval] long * | Res
 | ) |

Remove all alarms whose name and incident date match on a given Archive Unit, those therefore being able to be automaticaly deleted. (an Archive Unit is the set of all records corresponding to a single source and fps).

Parameters:
SourceName | Along with the Fps param, identifies the Archive Unit.
Fps | FPS Along with the SourceName param, identifies the Archive Unit.
AlarmName | The name of the alarm that can contains wildcard characters.
AlarmIncidentDate | Ntp date of the alarm's incident date.
Remarks:
These ntp dates must be expressed in a UTC formated form. UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC
Returns:
operation result
Return values:
0 | success
-1 | failure (use GetLastError() to retrieve the error)

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::RemoveAlarmByInterval | ( | [in] BSTR | SourceName,
 |  | [in] long | Fps,
 |  | [in] BSTR | AlarmName,
 |  | [in] BSTR | AlarmIntervalStart,
 |  | [in] BSTR | AlarmIntervalEnd,
 |  | [out, retval] long * | Res
 | ) |

Remove all alarms whose name and interval match on a given Archive Unit, those therefore being able to be automaticaly deleted. (an Archive Unit is the set of all records corresponding to a single source and fps).

Parameters:
SourceName | Along with the Fps param, identifies the Archive Unit.
Fps | FPS Along with the SourceName param, identifies the Archive Unit.
AlarmName | The name of the alarm that can contains wildcard characters.
AlarmIntervalStart | Ntp start date of the alarm interval
AlarmIntervalEnd | Ntp end date of the alarm interval
Remarks:
These ntp dates must be expressed in a UTC formated form. UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC

Up to version R2.2 SP5 of the Security SDK, this method could only remove an alarm previously added by the Alarm method or by the Security Service. It is now possible to remove any alarm or only a part of an alarm.

Returns:
operation result
Return values:
0 | success
-1 | failure (use GetLastError() to retrieve the error)

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Server ( [in] BSTR Hostname )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Server ( [out, retval] BSTR * Hostname )

Returns:
the host name or IP address of the remote manager

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::SourcesQuery ( [out, retval] long * QueryId )

Asks the archive database of the remote Storage Access Manager to list all source names and the available FPS's on each of them.

Returns:
Id of the processed query. One can retrieve the set of sources by calling GetNext(QueryId). GetNext will return the next source item in the list until reaching the end of the set (then it returns an empty string).
Return values:
0 Error (use GetLastError() to retrieve the error)
Remarks:
A source item is a string of the form: "SourceName="name",Fps="4,25,50""

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Status ( [out, retval] long * Status )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::TimeOut ( [in] long Timeout )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::TimeOut ( [out, retval] long * Timeout )

Returns:
the connection time-out in milliseconds

HRESULT VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl::Unprotect | ( | [in] BSTR | SourceName,
 |  | [in] long | Fps,
 |  | [in] BSTR | ProtectedIntervalStart,
 |  | [in] BSTR | ProtectedIntervalEnd,
 |  | [out, retval] long * | Res
 | ) |

Unprotects a span of records on a given Archive Unit, those therefore being able to be automaticaly deleted. (an Archive Unit is the set of all records corresponding to a single source and fps).

Parameters:
SourceName | Along with the Fps param, identifies the Archive Unit.
Fps | FPS Along with the SourceName param, identifies the Archive Unit.
ProtectedIntervalStart | Ntp start date of the interval to unprotect
ProtectedIntervalEnd | Ntp end date of the interval to unprotect
Remarks:
These ntp dates must be expressed in a UTC formated form. UTC formated dates have the following format: mm/dd/yyyy hh:mm:ss.usUTC Example: 10/09/2002 09:38:00.855552UTC

Up to version R2.2 SP5 of the Security SDK, this method could only remove a protection previously added by the Protect method. It is now possible to remove any protected interval or only a part of a protected interval.

Returns:
operation result
Return values:
0 | success
-1 | failure (use GetLastError() to retrieve the error)

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl Interface Reference

VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl

VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl Interface Reference

This ActiveX control allows to remotely start and stop audio and video storages and query information about these. See the VWStorageManagerCtrl_VB6 sample for an example in Visual Basic on how to use it. More...

import "VWStorageController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | AddStorage ([in] BSTR Parameters,[out, retval] long *Result)
HRESULT | BeginHardStorages ([in] BSTR Source,[in] long Channel,[in] BSTR Parameters,[out, retval] long *Result)
HRESULT | BeginNetworkStorages ([in] BSTR Protocol,[in] BSTR Hostname,[in] long Port,[in] long TimeOut,[out, retval] long *Result)
HRESULT | Blocking ([in] BOOL Blocking)
HRESULT | Blocking ([out, retval] BOOL *Blocking)
HRESULT | Connect ([out, retval] long *Result)
HRESULT | Disconnect ()
HRESULT | EndStorages ([out, retval] long *Result)
HRESULT | ExtractBoolean ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BOOL *Result)
HRESULT | ExtractInteger ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] long *Result)
HRESULT | ExtractNumber ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] double *Result)
HRESULT | ExtractString ([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BSTR *Result)
HRESULT | GetConfig ([out, retval] BSTR *Result)
HRESULT | GetId ([out, retval] long *Result)
HRESULT | GetStat ([out, retval] BSTR *Stat)
HRESULT | Port ([in] long Port)
HRESULT | Port ([out, retval] long *Port)
HRESULT | Rehash ([out, retval] long *Result)
HRESULT | Server ([in] BSTR Server)
HRESULT | Server ([out, retval] BSTR *Server)
HRESULT | StartStorages ([out, retval] BSTR *Result)
HRESULT | Status ([out, retval] long *Status)
HRESULT | StopStorages ([in] BSTR Ids,[out, retval] BSTR *Result)
HRESULT | TimeOut ([in] long TimeOut)
HRESULT | TimeOut ([out, retval] long *TimeOut)

Detailed Description

This ActiveX control allows to remotely start and stop audio and video storages and query information about these. See the VWStorageManagerCtrl_VB6 sample for an example in Visual Basic on how to use it.

Member Function Documentation

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::AddStorage | ( | [in] BSTR | Parameters,
 |  | [out, retval] long * | Result
 | ) |

Adds a storage associated with a network source previously defined with a call to BeginNetworkStorages or with a hardware source defined with a call to BeginHardStorages. The following parameters must be provided:

  • Alias [string]: alias of the disk space to use (between quotes, since it is a string!)
  • Skip [integer]: number of fields to skip
  • MaxSpace [integer]: maximum number of megabytes to use for this storage)
  • MaxMinutes [integer]: (optional) maximum duration in minutes during which the storage will be kept
  • Path [string]: (optional) if this string is set, then it will be used to compute the full path in which the files will be stored (this value must be surrounded by quotes, since it is a string!)

The full path is computed as follows:

  • if Path is not set and BeginNetworkStorages was called: disk space path + "\" + [protocol]_[host]_[port] + "\" + [FPS]
  • if Path is not set and BeginHardStorages was called: disk space path + "\" + [driver]_[channel] + "\" + [FPS]
  • if Path is set: disk space path + "\" + Path + "\" + [FPS] The disk space path is defined in the central configuration. The optional Path cannot contain any backslash or slash (i.e. it must be a simple path). The FPS is an integer value equal to the real FPS multiplied by 100 (eg. 5000, for 50 fps). In the audio case, the FPS part is not added to the full path.

Parameters:
Parameters the string containing all the parameters and their values ("param0=value0,param1=value1,...")
Returns:
error code
Return values:
0 | no error
-1 | one of the parameters was bad

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::BeginHardStorages | ( | [in] BSTR | Source,
 |  | [in] long | Channel,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] long * | Result
 | ) |

Starts a BeginHardStorages - AddStorage - EndStorages sequence. All future calls to AddStorage are associated with the hardware source specified with BeginHardStorages until EndStorages is called.

Additional parameters can be specified in the last parameter of this method. The following additional parameters are available:

  • Connector [string] : for compatibility with 2.1, it is possible to specify the connector (see Source for possible values) in the parameters list, but in this case the Source parameter will be ignored
  • FrameSize [integer]: in the video case, this parameter specifies the frame size in KB; if this parameter is not specified, a default value (5) is used; in the audio case, this parameter is ignored

Parameters:
Source | in the video case, this parameter specifies the video connector and must be one of the following values: "composite" (composite input, if only one available), "compositeA" (composite input A, if several available), "compositeB" (composite input B, if several available), "compositeC" (composite input C, if several available), or "svideo" (SVideo input); in the audio case, this parameter specifies the audio source and must be one of the following values: "wavein_line_in" (soundboard, line input), "wavein_mic_in" (soundboard, microphone), "pci2_line_in" (PCI2, line input), "pci2_mic_in" (PCI2, microphone), "pci2_spdif_in" (PCI2, S/PDIF input)
Channel | channel number (1, 2, 3, etc.)
Parameters | additional parameters given as a comma-separated list of name=value pairs ("param0=value0,param1=value1,...")
Returns:
error code
Return values:
0 | no error
-1 | one of the parameters was bad
Note:
this method is still compatible with the same method in the version 2.1 of the SDK

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::BeginNetworkStorages | ( | [in] BSTR | Protocol,
 |  | [in] BSTR | Hostname,
 |  | [in] long | Port,
 |  | [in] long | TimeOut,
 |  | [out, retval] long * | Result
 | ) |

Starts a BeginNetworkStorages - AddStorage - EndStorages sequence. All future calls to AddStorage are associated with the network source specified with BeginNetworkStorages until EndStorages is called.

Parameters:
Protocol | protocol ("udp", "ipm" or "svc")
Hostname | hostname
Port | port number
TimeOut | time-out value in milliseconds
Returns:
error code
Return values:
0 | no error
-1 | one of the parameters was bad

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::Blocking ( [in] BOOL Blocking )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::Blocking ( [out, retval] BOOL * Blocking )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::Connect ( [out, retval] long * Result )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::EndStorages ( [out, retval] long * Result )

Ends a BeginNetworkStorages - AddStorage - EndStorages sequence or a BeginHardStorages - AddStorage - EndStorages sequence.

Returns:
error code
Return values:
0 no error

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::ExtractBoolean | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] BOOL * | Result
 | ) |

Extracts a boolean value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
boolean value of the parameter

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::ExtractInteger | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] long * | Result
 | ) |

Extracts an integer value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
integer value of the parameter

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::ExtractNumber | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] double * | Result
 | ) |

Extracts a floating-point value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
floating-point value of the parameter

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::ExtractString | ( | [in] BSTR | Parameter,
 |  | [in] BSTR | Parameters,
 |  | [out, retval] BSTR * | Result
 | ) |

Extracts a string value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
string value of the parameter

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::GetConfig ( [out, retval] BSTR * Result )

Retrieves the configuration of the storage manager. The values of the parameters can be extracted with ExtractInteger and ExtractString. The following parameters are available:

  • Aliases [integer]: number of disk spaces defined in the central configuration
  • AliasX [string]: alias of disk space number X
  • AliasPathX [string]: path associated with disk space number X
  • AliasUploadDirectoryX [string]: upload directory associated with disk space number X
  • AliasTotalSpaceX [integer]: total space in bytes allocated for disk space number X
  • AliasCurrentSpaceX [integer]: space in bytes already reserved for storages on disk space number X

where X is a number between 0 and the number of disk spaces minus one.

Returns:
a comma-separated list of name=value pairs (storage manager configuration).
See also:
ExtractInteger

ExtractString

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::GetId ( [out, retval] long * Result )

Should be used only by VisioWave engineers.

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::GetStat ( [out, retval] BSTR * Stat )

Returns a list of all the storages currently defined on the server. GetStat returns a string containing a comma-separated list of parameter-value pairs ("parameter=value,parameter=value,..."). The value of each parameter can be extracted with ExtractInteger, ExtractString, ExtractBoolean or ExtractNumber.

The following parameters are returned:

  • Storages [integer]: number of storages
  • IdX [integer]: ID of storage X (or -1 if the storage is defined in the central configuration)
  • StateX [boolean]: true if storage X is currently active
  • TypeX [integer]: 0, for a network storage, and 1, for a hardware storage
  • ProtocolX [integer]: (only available if TypeX = 0) 1 for UDP, 2 for SVC, 3 for PVC, and 4 for IPM
  • HostnameX [string]: (only available if TypeX = 0) host name
  • PortX [integer]: (only available if TypeX = 0) port number
  • ChannelX [integer]: (only available if TypeX = 1) board/channel number
  • AliasX [string]: disk space alias used by storage X
  • SkipX [integer]: skip value used by storage X
  • MaxSpaceX [integer or float]: max space in megabytes allocated to storage X (or negative value, if not specified)
  • MaxMinutesX [integer or float]: max duration in minutes during which storage X will be kept (or negative value, if not specified)
  • SpaceUsedX [integer of float]: physical space used on disk by storage files.

where X is a number between 0 and the number of storages minus one.

Returns:
a comma-separated list of parameter-value pairs
See also:
BeginNetworkStorages

BeginHardStorages

AddStorage

ExtractInteger

ExtractString

ExtractBoolean

ExtractNumber

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::Port ( [in] long Port )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::Port ( [out, retval] long * Port )

Returns:
the TCP port number of the remote manager

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::Server ( [in] BSTR Server )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::Server ( [out, retval] BSTR * Server )

Returns:
the host name or IP address of the remote manager

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::StartStorages ( [out, retval] BSTR * Result )

Starts the storages defined in a previous BeginNetworkStorages - AddStorage - EndStorages sequence or BeginHardStorages - AddStorage - EndStorages sequence. For each storage, this method returns an ID (or 0, if the storage could not be started). The ID's can be extracted with the ExtractInteger method.

If a custom storage with the same disk space (Alias parameter in AddStorage) and the same Skip value already exists, a null ID will be returned.

Returns:
comma-separated list of ID's ("Id0=value0,[Error0=error],...,Idn=valuen,[Errorn=error]")
Return values:
Id[i] | non 0 means that the storage has started successfully
Id[i] | set to 0 means that an error occured and the storage has not started. Check Error[i] for further information.
Error=message | means that a general error occured.
See also:
ExtractInteger

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::Status ( [out, retval] long * Status )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::StopStorages | ( | [in] BSTR | Ids,
 |  | [out, retval] BSTR * | Result
 | ) |

Stops storages started with a call to StartStorages. For each storage, this method returns a status ("OK", if the storage was stopped successfully, or "FAILED", if the storage could not be stopped). The statuses can be extracted with the ExtractString method. The input list of ID's does not need to contain all the ID's returned by StartStorages, but the parameter names must always follow the following format: "Id0=value,Id1=value,Id2=value...". The following input list, for example, is wrong: "Id0=value,Id2=value,Id3=value" (the "Id1" parameter name is missing).

Parameters:
Ids ID's of the storages to stop ("Id0=value,Id1=value,...")
Returns:
comma-separated list of statuses associated with each storage ("Id0=status,Id1=status,...")
See also:
ExtractInteger

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::TimeOut ( [in] long TimeOut )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl::TimeOut ( [out, retval] long * TimeOut )

Returns:
the connection time-out in milliseconds

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: XVWTIMELINELib::IVWTimeLine Interface Reference

XVWTIMELINELib::IVWTimeLine

XVWTIMELINELib::IVWTimeLine Interface Reference

This ActiveX control allows to remote control streaming of recorded audio and video content. It offers a simple timeline like GUI which allows to position the playback cursor on the selected sources, or it can be used in non graphical mode to remote control the streaming of audio and video. It is normally used in conjunction with the VWStorageAccessController. See the VWAlarmStreamer_VB sample for an example in Visual Basic on how to use it.ActiveX control allowing the management of a group of audio/video on-demand streams.
Remarks:
For performance reasons, only the audio and video sources that need to be streamed should be added to this control.

All the date/time strings returned by methods of this interface or passed to methods of this interface have or must have the following format: "mm/dd/yyyy hh:mm:ss.ssssssUTC" (without the quotes). An undefined date/time will be converted to an null- sized string.

All the dates/times returned by methods of this interface or passed to methods of this interface are or must be between January 1, 1970 00:00:00 (included) and January 19, 2038 03:14:08 (not included).

The GUI accepts the following actions:

  • left click in the visible range zone: moves the visible range
  • left click in the sources zone: sets the position of the left and right markers
  • left click on the timeline: moves the visible range
  • right click: zooms to the zone defined by the left and right markers
  • right click + shift key pressed: zooms out
  • mouse wheel: zooms in/out

The methods of this control can return the following error codes:

  • VW_NO_ERROR 0
  • VW_INVALID_PARAMETER -1
  • VW_INVALID_ID -2
  • VW_NO_SOURCES -3
  • VW_RPC_CALL_ERROR -4
  • VW_NO_MORE_TIME_SPANS -5
  • VW_COULD_NOT_CREATE_SERVER -6 The specific meaning of these errors is explained for each method.
More...

import "XVWTimeLine.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | AddQueryResults ([in] BSTR Host,[in] long Port,[in] long QueryId,[out, retval] long *Error)
HRESULT | AddQueryTimeSpan ([in] BSTR Host,[in] long Port,[in] BSTR Name,[in] long FPS,[in, defaultvalue("")] BSTR Start,[in, defaultvalue("")] BSTR End,[out, retval] long *Result)
HRESULT | Clear ()
HRESULT | GetAlarmName ([in] long TimeSpanId,[in] long AlarmNumber,[out, retval] BSTR *AlarmName)
HRESULT | GetCurrentPosition ([out, retval] BSTR *CurrentPosition)
HRESULT | GetEnd ([in] long Id,[out, retval] BSTR *End)
HRESULT | GetFirstTimeSpan ([in] long SourceId,[in, defaultvalue("")] BSTR Start,[in, defaultvalue("")] BSTR End,[out, retval] long *Result)
HRESULT | GetFPS ([in] long SourceId,[out, retval] long *FPS)
HRESULT | GetHost ([in] long SourceId,[out, retval] BSTR *Host)
HRESULT | GetLeftMarker ([out, retval] BSTR *LeftMarker)
HRESULT | GetMaxEnd ([out, retval] BSTR *MaxEnd)
HRESULT | GetMinStart ([out, retval] BSTR *MinStart)
HRESULT | GetName ([in] long SourceId,[out, retval] BSTR *Name)
HRESULT | GetNextTimeSpan ([in] long TimeSpanId,[out, retval] long *Error)
HRESULT | GetNumberOfAlarms ([in] long TimeSpanId,[out, retval] long *NumberOfAlarms)
HRESULT | GetNumberOfSources ([out, retval] long *NumberOfSources)
HRESULT | GetPort ([in] long SourceId,[out, retval] long *Port)
HRESULT | GetRightMarker ([out, retval] BSTR *RightMarker)
HRESULT | GetSourceId ([in] long Source,[out, retval] long *Result)
HRESULT | GetStart ([in] long Id,[out, retval] BSTR *Start)
HRESULT | GetStream ([in] long SourceId,[out, retval] long *Stream)
HRESULT | GetType ([in] long SourceId,[out, retval] long *Type)
HRESULT | GetTypeEx ([in] long SourceId,[out, retval] long *Type)
HRESULT | GetVisibleRangeLeft ([out, retval] BSTR *VisibleRangeLeft)
HRESULT | GetVisibleRangeRight ([out, retval] BSTR *VisibleRangeRight)
HRESULT | GUI ([in] BOOL GUI)
HRESULT | GUI ([out, retval] BOOL *GUI)
HRESULT | IsHighlighted ([in] long TimeSpanId,[out, retval] BOOL *Highlighted)
HRESULT | IsPaused ([out, retval] BOOL *Paused)
HRESULT | IsProtected ([in] long TimeSpanId,[out, retval] BOOL *Protected)
HRESULT | LocalToUtc ([in] BSTR LocalTime,[out, retval] BSTR *UtcTime)
HRESULT | LoopPlayback ([in] BOOL LoopPlayback)
HRESULT | LoopPlayback ([out, retval] BOOL *LoopPlayback)
HRESULT | Pause ([out, retval] long *Error)
HRESULT | Play ([in, defaultvalue(TRUE)] BOOL Resume,[out, retval] long *Error)
HRESULT | Refresh ()
HRESULT | RemoveQueryTimeSpan ([in] long SourceId,[in, defaultvalue("")] BSTR Start,[in, defaultvalue("")] BSTR End,[out, retval] long *Error)
HRESULT | Seek ([in] BSTR Position,[out, retval] long *Error)
HRESULT | SetGUIParams ([in] BSTR Parameters,[out, retval] long *Error)
HRESULT | SetLatency ([in] long Latency,[out, retval] long *Error)
HRESULT | SetLeftMarker ([in] BSTR LeftMarker)
HRESULT | SetPlayRate ([in] long Numerator,[in] long Denominator,[out, retval] long *Error)
HRESULT | SetRightMarker ([in] BSTR RightMarker)
HRESULT | SetTimeOut ([in] long TimeOut)
HRESULT | SetVisibleRange ([in] BSTR Start,[in] BSTR End)
HRESULT | Step ([out, retval] long *Error)
HRESULT | SyncPlayback ([in] BOOL SyncPlayback)
HRESULT | SyncPlayback ([out, retval] BOOL *SyncPlayback)
HRESULT | TimeZone ([in] BSTR TimeZone)
HRESULT | TimeZone ([out, retval] BSTR *TimeZone)
HRESULT | UtcToLocal ([in] BSTR UtcTime,[out, retval] BSTR *LocalTime)
HRESULT | Zoom ([in] long ZoomFactor)

Detailed Description

This ActiveX control allows to remote control streaming of recorded audio and video content. It offers a simple timeline like GUI which allows to position the playback cursor on the selected sources, or it can be used in non graphical mode to remote control the streaming of audio and video. It is normally used in conjunction with the VWStorageAccessController. See the VWAlarmStreamer_VB sample for an example in Visual Basic on how to use it.ActiveX control allowing the management of a group of audio/video on-demand streams.
Remarks:
For performance reasons, only the audio and video sources that need to be streamed should be added to this control.

All the date/time strings returned by methods of this interface or passed to methods of this interface have or must have the following format: "mm/dd/yyyy hh:mm:ss.ssssssUTC" (without the quotes). An undefined date/time will be converted to an null- sized string.

All the dates/times returned by methods of this interface or passed to methods of this interface are or must be between January 1, 1970 00:00:00 (included) and January 19, 2038 03:14:08 (not included).

The GUI accepts the following actions:

  • left click in the visible range zone: moves the visible range
  • left click in the sources zone: sets the position of the left and right markers
  • left click on the timeline: moves the visible range
  • right click: zooms to the zone defined by the left and right markers
  • right click + shift key pressed: zooms out
  • mouse wheel: zooms in/out

The methods of this control can return the following error codes:

  • VW_NO_ERROR 0
  • VW_INVALID_PARAMETER -1
  • VW_INVALID_ID -2
  • VW_NO_SOURCES -3
  • VW_RPC_CALL_ERROR -4
  • VW_NO_MORE_TIME_SPANS -5
  • VW_COULD_NOT_CREATE_SERVER -6 The specific meaning of these errors is explained for each method.

Author:
Olivier Bruchez

Member Function Documentation

HRESULT XVWTIMELINELib::IVWTimeLine::AddQueryResults | ( | [in] BSTR | Host,
 |  | [in] long | Port,
 |  | [in] long | QueryId,
 |  | [out, retval] long * | Error
 | ) |

Adds all the results of a data base query done with the DatabaseQuery method of VWStorageAccessCtrl to the control.

Parameters:
Host | host on which the Storage Access Manager is running
Port | port on which the Storage Access manager is running
QueryId | query ID returned by the DatabaseQuery method of VWStorageAccessCtrl
Remarks:
this method can be used only if VWStorageAccessCtrl and XVWTimeLine share the same memory space (i.e. if both controls are instantiated in the same process)

a query ID is valid as long as all the results have not been parsed with the GetNext method of VWStorageAccessCtrl

For performance reasons, only the audio and video sources that need to be streamed should be added to this control.

Returns:
an error code
Return values:
VW_NO_ERROR | no error occured
VW_INVALID_ID | invalid query ID
VW_RPC_CALL_ERROR | RPC call error
VW_COULD_NOT_CREATE_SERVER | could not create the streaming server (no port available, source not found, etc.)

HRESULT XVWTIMELINELib::IVWTimeLine::AddQueryTimeSpan | ( | [in] BSTR | Host,
 |  | [in] long | Port,
 |  | [in] BSTR | Name,
 |  | [in] long | FPS,
 |  | [in, defaultvalue("")] BSTR | Start,
 |  | [in, defaultvalue("")] BSTR | End,
 |  | [out, retval] long * | Result
 | ) |

Adds a specific source to the control. If an interval is specified and if the GUI is visible, then this interval will be highlighted in the GUI. It is possible to call AddQueryTimeSpan several times with the same source, but different intervals. All the specified intervals will be highlighted in the GUI. If no interval is specified, then AddQueryTimeSpan should only be called once. One and only one streaming server is created on the server side for each source added to the control with this method or AddQueryResults.

Parameters:
Host | host on which the Storage Access Manager is running
Port | port on which the Storage Access manager is running
Name | name of the source
FPS | FPS value of the source (0, for a non-video source)
Start | start of a query interval (or empty string)
End | end of a query interval (or empty string)
Returns:
a positive source ID or a negative error code
Return values:
VW_INVALID_PARAMETER | invalid date/time
VW_RPC_CALL_ERROR | RPC call error
VW_COULD_NOT_CREATE_SERVER | could not create the streaming server (no port available, source not found, etc.)
Remarks:
if Start and End are empty strings, then no interval will be highlighted in the GUI, but all the intervals associated with the source will be added to the control

Start and End must have the following format: "mm/dd/yyyy hh:mm:ss.ssssssUTC"

only intervals returned by the DatabaseQuery method of VWStorageAccessCtrl can be passed to this method

For performance reasons, only the audio and video sources that need to be streamed should be added to this control.

See also:
IsHighlighted

HRESULT XVWTIMELINELib::IVWTimeLine::Clear ( )

Removes all the sources. Updates the graphical representation accordingly, if the GUI mode is enabled.

HRESULT XVWTIMELINELib::IVWTimeLine::GetAlarmName | ( | [in] long | TimeSpanId,
 |  | [in] long | AlarmNumber,
 |  | [out, retval] BSTR * | AlarmName
 | ) |

Parameters:
TimeSpanId | time span ID
AlarmNumber | an alarm number (must be smaller than the number of alarms associated with the given time span)
Returns:
the name of the (AlarmNumber + 1)-th alarm associated with the given time span
See also:
GetFirstTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetCurrentPosition ( [out, retval] BSTR * CurrentPosition )

Returns:
the current position (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")

HRESULT XVWTIMELINELib::IVWTimeLine::GetEnd | ( | [in] long | Id,
 |  | [out, retval] BSTR * | End
 | ) |

Parameters:
Id source ID or time span ID
Returns:
the end of a source or time span (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")
See also:
GetSourceId

AddQueryTimeSpan

GetFirstTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetFirstTimeSpan | ( | [in] long | SourceId,
 |  | [in, defaultvalue("")] BSTR | Start,
 |  | [in, defaultvalue("")] BSTR | End,
 |  | [out, retval] long * | Result
 | ) |

Retrieves the first time span associated with a source. If an interval is specified, then only the time spans contained in this interval are retrieved.

Parameters:
SourceId | source ID
Start | start of an interval (or empty string)
End | end of an interval (or empty string)
Returns:
a time span ID or a negative error code
Return values:
VW_INVALID_PARAMETER | invalid date/time
VW_INVALID_ID | invalid source ID
VW_RPC_CALL_ERROR | RPC call error
Remarks:
if Start and End are empty strings, then all the time spans associated with the source are retrieved

Start and End must have the following format: "mm/dd/yyyy hh:mm:ss.ssssssUTC"

See also:
GetSourceId

AddQueryTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetFPS | ( | [in] long | SourceId,
 |  | [out, retval] long * | FPS
 | ) |

Parameters:
SourceID source ID
Returns:
the FPS value of the source or a negative error code
Return values:
VW_INVALID_ID invalid source ID
See also:
GetSourceId

AddQueryTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetHost | ( | [in] long | SourceId,
 |  | [out, retval] BSTR * | Host
 | ) |

Parameters:
SourceID source ID
Returns:
host on which the streaming server is running
See also:
GetSourceId

AddQueryTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetLeftMarker ( [out, retval] BSTR * LeftMarker )

Returns:
the position of the left marker (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")
Remarks:
if the left and right markers have different positions, then XVWTimeLine will loop between these two positions if the LoopPlayback property is set to true
See also:
SetLeftMarker

LoopPlayback

HRESULT XVWTIMELINELib::IVWTimeLine::GetMaxEnd ( [out, retval] BSTR * MaxEnd )

Returns:
the latest end among all the sources added to the control (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")

HRESULT XVWTIMELINELib::IVWTimeLine::GetMinStart ( [out, retval] BSTR * MinStart )

Returns:
the earliest start among all the sources added to the control (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")

HRESULT XVWTIMELINELib::IVWTimeLine::GetName | ( | [in] long | SourceId,
 |  | [out, retval] BSTR * | Name
 | ) |

Parameters:
SourceID source ID
Returns:
the name of the source or an empty string in case of error
See also:
GetSourceId

AddQueryTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetNextTimeSpan | ( | [in] long | TimeSpanId,
 |  | [out, retval] long * | Error
 | ) |

Retrieves the next time span associated with a source.

Parameters:
TimeSpanId time span ID
Returns:
an error code
Return values:
VW_NO_ERROR | no error occured
VW_INVALID_ID | invalid time span ID
VW_NO_MORE_TIME_SPANS | all the time spans have been parsed
See also:
GetFirstTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetNumberOfAlarms | ( | [in] long | TimeSpanId,
 |  | [out, retval] long * | NumberOfAlarms
 | ) |

Parameters:
TimeSpanId time span ID
Returns:
the number of alarms associated with the given time span
See also:
GetFirstTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetNumberOfSources ( [out, retval] long * NumberOfSources )

Returns:
the number of sources added to the control

HRESULT XVWTIMELINELib::IVWTimeLine::GetPort | ( | [in] long | SourceId,
 |  | [out, retval] long * | Port
 | ) |

Parameters:
SourceID source ID
Returns:
port on which the streaming server is running
See also:
GetSourceId

AddQueryTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetRightMarker ( [out, retval] BSTR * RightMarker )

Returns:
the position of the right marker (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")
Remarks:
if the left and right markers have different positions, then XVWTimeLine will loop between these two positions if the LoopPlayback property is set to true
See also:
SetRightMarker

LoopPlayback

HRESULT XVWTIMELINELib::IVWTimeLine::GetSourceId | ( | [in] long | Source,
 |  | [out, retval] long * | Result
 | ) |

Parameters:
Source number between zero and the number of sources minus one; if the GUI is visible, this value is the zero-based position of the source in the GUI
Returns:
a positive source ID that will stay the same until the source is removed (even if other sources are removed before) or a negative error code
Return values:
VW_INVALID_PARAMETER invalid source number

HRESULT XVWTIMELINELib::IVWTimeLine::GetStart | ( | [in] long | Id,
 |  | [out, retval] BSTR * | Start
 | ) |

Parameters:
Id source ID or time span ID
Returns:
the beginning of a source or time span (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")
See also:
GetSourceId

AddQueryTimeSpan

GetFirstTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetStream | ( | [in] long | SourceId,
 |  | [out, retval] long * | Stream
 | ) |

Should be used only by VisioWave engineers.

Parameters:
SourceId source ID
Returns:
the address of the JStream instance used to stream the audio or video
Return values:
0 if the method failed
Remarks:
the address returned by this method can be used by XVWDisplay, but only if it shares the same memory space as the streaming server
See also:
GetSourceId

AddQueryTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetType | ( | [in] long | SourceId,
 |  | [out, retval] long * | Type
 | ) |

Parameters:
SourceID source ID
Returns:
a positive source type or a negative error code
Return values:
VW_INVALID_ID | invalid source ID
VW_RPC_CALL_ERROR | RPC call error
1 | video data
2 | audio data
Note:
Use GetTypeEx instead of this function to avoid naming conflicts in Visual Basic .NET
See also:
GetTypeEx

GetSourceId

AddQueryTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetTypeEx | ( | [in] long | SourceId,
 |  | [out, retval] long * | Type
 | ) |

Parameters:
SourceID source ID
Returns:
a positive source type or a negative error code
Return values:
VW_INVALID_ID | invalid source ID
VW_RPC_CALL_ERROR | RPC call error
1 | video data
2 | audio data
Note:
Use this function instead of GetType to avoid naming conflicts in Visual Basic .NET
See also:
GetType

GetSourceId

AddQueryTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::GetVisibleRangeLeft ( [out, retval] BSTR * VisibleRangeLeft )

Returns:
the position of the left of the visible range, if the GUI mode is enabled (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")
See also:
SetVisibleRange

HRESULT XVWTIMELINELib::IVWTimeLine::GetVisibleRangeRight ( [out, retval] BSTR * VisibleRangeRight )

Returns:
the position of the right of the visible range, if the GUI mode is enabled (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")
See also:
SetVisibleRange

HRESULT XVWTIMELINELib::IVWTimeLine::GUI ( [in] BOOL GUI )

Sets the GUI property. This property can be set anytime, but is is better to set it in design-time mode only.

Parameters:
GUI true if the GUI must be visible and false if the GUI must be invisible

HRESULT XVWTIMELINELib::IVWTimeLine::GUI ( [out, retval] BOOL * GUI )

Returns:
the GUI property
Return values:
false | the GUI of the control is invisible
true | the GUI of the control is visible

HRESULT XVWTIMELINELib::IVWTimeLine::IsHighlighted | ( | [in] long | TimeSpanId,
 |  | [out, retval] BOOL * | Highlighted
 | ) |

Parameters:
TimeSpanId time span ID
Returns:
true if the given time span is highlighted in the GUI
See also:
GetFirstTimeSpan

AddQueryTimeSpan

RemoveQueryTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::IsPaused ( [out, retval] BOOL * Paused )

Returns:
true if the sources are paused and false if they are playing
Remarks:
if no sources have been added to the control, this method returns true

HRESULT XVWTIMELINELib::IVWTimeLine::IsProtected | ( | [in] long | TimeSpanId,
 |  | [out, retval] BOOL * | Protected
 | ) |

Parameters:
TimeSpanId time span ID
Returns:
true if the given time span is protected against deletion
See also:
GetFirstTimeSpan

HRESULT XVWTIMELINELib::IVWTimeLine::LocalToUtc | ( | [in] BSTR | LocalTime,
 |  | [out, retval] BSTR * | UtcTime
 | ) |

Parameters:
LocalTime local date/time string ("mm/dd/yyyy hh:mm:ss.ssssss")
Returns:
UTC date/time string ("mm/dd/yyyy hh:mm:ss.ssssssUTC") or emptry string if the conversion could not be done
See also:
TimeZone

HRESULT XVWTIMELINELib::IVWTimeLine::LoopPlayback ( [in] BOOL LoopPlayback )

Sets the LoopPlayback property.

Parameters:
LoopPlayback true if the playback must loop between the left and right markers

HRESULT XVWTIMELINELib::IVWTimeLine::LoopPlayback ( [out, retval] BOOL * LoopPlayback )

Returns:
the LoopPlayback property
Return values:
true | playback will loop between the left and right markers if they have different positions
false | playback will never loop between the left and right markers

HRESULT XVWTIMELINELib::IVWTimeLine::Pause ( [out, retval] long * Error )

Pauses all the sources that have been added to the control.

Returns:
an error code
Return values:
VW_NO_ERROR | no error occured
VW_NO_SOURCES | no sources have been added to the control

HRESULT XVWTIMELINELib::IVWTimeLine::Play | ( | [in, defaultvalue(TRUE)] BOOL | Resume,
 |  | [out, retval] long * | Error
 | ) |

Plays all the sources that have been added to the control.

Parameters:
Resume FALSE if the sources must start playing where the left marker is located and TRUE if the sources must start playing at the current position
Returns:
an error code
Return values:
VW_NO_ERROR | no error occured
VW_NO_SOURCES | no sources have been added to the control

HRESULT XVWTIMELINELib::IVWTimeLine::Refresh ( )

Refreshes the list of time spans associated with each source. Updates the graphical representation accordingly, if the GUI mode is enabled.

HRESULT XVWTIMELINELib::IVWTimeLine::RemoveQueryTimeSpan | ( | [in] long | SourceId,
 |  | [in, defaultvalue("")] BSTR | Start,
 |  | [in, defaultvalue("")] BSTR | End,
 |  | [out, retval] long * | Error
 | ) |

Removes a specific source from the control. If an interval is specified and if the GUI is visible, then this interval will not be highlighted in the GUI anymore. When all the intervals have been removed, then the source itself will be removed from the control (and the streaming server on the server side will be destroyed). If no interval is specified, then RemoveQueryTimeSpan should only be called once.

Parameters:
SourceId | source ID
Start | start of a query interval (or empty string)
End | end of a query interval (or empty string)
Returns:
an error code
Return values:
VW_NO_ERROR | no error occured
VW_INVALID_PARAMETER | invalid date/time
VW_INVALID_ID | invalid source ID
Remarks:
if Start and End are empty strings, then the source will immediately be removed from the control and the streaming server on the server side will be destroyed

Start and End must have the following format: "mm/dd/yyyy hh:mm:ss.ssssssUTC"

only intervals returned by the DatabaseQuery method of VWStorageAccessCtrl can be passed to this method

See also:
IsHighlighted

HRESULT XVWTIMELINELib::IVWTimeLine::Seek | ( | [in] BSTR | Position,
 |  | [out, retval] long * | Error
 | ) |

If the sources are paused, then seeks the given position. Otherwise, this method does nothing.

Parameters:
Position position to seek (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")
Returns:
an error code
Return values:
VW_NO_ERROR | no error occured
VW_NO_SOURCES | no sources have been added to the control

HRESULT XVWTIMELINELib::IVWTimeLine::SetGUIParams | ( | [in] BSTR | Parameters,
 |  | [out, retval] long * | Error
 | ) |

Sets the GUI parameters. The parameters are given in a string as a comma-separated list of name=value pairs ("param0=value0,param1=value1,..."). A string value must be surrounded by double quotes ("..."). The following parameters are available:

  • BackgroundColor [integer]: 32-bit Windows GDI-compatible color of the GUI background
  • ZoomFactor [integer]: zoom factor in percents (in ]0, 100[); this factor determines how fast (big values) or slow (small values) the mouse wheel changes the zoom
  • MarkersColor [integer]: 32-bit Windows GDI-compatible color of the left and right markers
  • SourcesBackgroundColor [integer]: 32-bit Windows GDI-compatible color of the sources zone background
  • SourcesNormalTimeSpansColor [integer]: 32-bit Windows GDI-compatible color of the normal time spans (not associated with alarms) in the sources zone
  • SourcesAlarmTimeSpansColor [integer]: 32-bit Windows GDI-compatible color of the time spans associated with alarms in the sources zone
  • SourcesTextColor [integer]: 32-bit Windows GDI-compatible color of the text in the sources zone
  • SourcesLinesColor [integer]: 32-bit Windows GDI-compatible color of the lines separating the different sources
  • SourcesFontName [string]: name of the font used in the sources zone
  • SourcesMaxFontSize [integer]: maximum height of the text in the sources zone
  • TimeLineBackgroundColor [integer]: 32-bit Windows GDI-compatible color of the time line zone background
  • TimeLineTicsColor [integer]: 32-bit Windows GDI-compatible color of the tics in the time line zone
  • TimeLineTextColor [integer]: 32-bit Windows GDI-compatible color of the text in the time line zone
  • TimeLineDateMask [string]: format of the date in the time line zone where d represents the day, mo represents the month, and y represents the year (example: "%y/%mo/%d")
  • TimeLineTimeMask [string]: format of the time in the time line zone where h represents the hours, mi represents the minutes, s represents the seconds (including the milliseconds), and S represents the seconds (without the milliseconds) (example: "%h:%mi:%s")
  • TimeLineFontName [string]: name of the font used in the time line zone
  • TimeLineFontSize [integer]: height of the font used in the time line zone
  • InvisibleRangeColor [integer]: 32-bit Windows GDI-compatible color of the zone representing the invisible range(s) of the sources
  • VisibleRangeColor [integer]: 32-bit Windows GDI-compatible color of the zone representing the visible range of the sources All these parameters have a default value, so they don't need to be initialized.

Parameters:
Parameters comma-separated list of parameter-value pairs
Returns:
an error code
Return values:
VW_NO_ERROR | no error occured
VW_INVALID_PARAM | bad parameters syntax

HRESULT XVWTIMELINELib::IVWTimeLine::SetLatency | ( | [in] long | Latency,
 |  | [out, retval] long * | Error
 | ) |

Changes the latency.

Parameters:
Latency delay in ms between the call of a method and its execution on the server side
Returns:
an error code
Return values:
VW_NO_ERROR | no error occured
VW_NO_SOURCES | no sources have been added to the control

HRESULT XVWTIMELINELib::IVWTimeLine::SetLeftMarker ( [in] BSTR LeftMarker )

Sets the position of the left marker.

Parameters:
LeftMarker position of the left marker (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")
Remarks:
if the left and right markers have different positions, then XVWTimeLine will loop between these two positions if the LoopPlayback property is set to true
See also:
GetLeftMarker

LoopPlayback

HRESULT XVWTIMELINELib::IVWTimeLine::SetPlayRate | ( | [in] long | Numerator,
 |  | [in] long | Denominator,
 |  | [out, retval] long * | Error
 | ) |

Changes the play rate.

Parameters:
Numerator | play rate numerator
Denominator | play rate denominator
Returns:
an error code
Return values:
VW_NO_ERROR | no error occured
VW_INVALID_PARAMETER | numerator or denominator equal to zero
VW_NO_SOURCES | no sources have been added to the control

HRESULT XVWTIMELINELib::IVWTimeLine::SetRightMarker ( [in] BSTR RightMarker )

Sets the position of the right marker.

Parameters:
RightMarker position of the right marker (string format: "mm/dd/yyyy hh:mm:ss.ssssssUTC")
Remarks:
if the left and right markers have different positions, then XVWTimeLine will loop between these two positions if the LoopPlayback property is set to true
See also:
GetRightMarker

LoopPlayback

HRESULT XVWTIMELINELib::IVWTimeLine::SetTimeOut ( [in] long TimeOut )

Sets the time-out value used to connect to servers.

Parameters:
TimeOut time-out value in milliseconds

HRESULT XVWTIMELINELib::IVWTimeLine::SetVisibleRange | ( | [in] BSTR | Start,
 |  | [in] BSTR | End
 | ) |

Sets the visible range, if the GUI mode is enabled. Using this method, it is possible to display only a portion of time, i.e. to zoom in or out.

Parameters:
Start | start of the visible range
End | end of the visible range
Remarks:
Start and End must have the following format: "mm/dd/yyyy hh:mm:ss.ssssssUTC"
See also:
GetVisibleRangeLeft

GetVisibleRangeRight

HRESULT XVWTIMELINELib::IVWTimeLine::Step ( [out, retval] long * Error )

If the sources are paused, then skips one frame. Otherwise, this method does nothing.

Returns:
an error code
Return values:
VW_NO_ERROR | no error occured
VW_NO_SOURCES | no sources have been added to the control

HRESULT XVWTIMELINELib::IVWTimeLine::SyncPlayback ( [in] BOOL SyncPlayback )

Sets the SyncPlayback property. This property can be set anytime, but it will be taken into account only the next time Play is called.

Parameters:
SyncPlayback true in order to use sychronized playback between multiple sources. Please note that this supposes synchronization of allservers' and clients' clocks through NTP

HRESULT XVWTIMELINELib::IVWTimeLine::SyncPlayback ( [out, retval] BOOL * SyncPlayback )

Returns:
the SyncPlayback property
Return values:
true | if synchronized playback is used
false | no synchronization between multiple sources will be used

HRESULT XVWTIMELINELib::IVWTimeLine::TimeZone ( [in] BSTR TimeZone )

Sets the TimeZone property.

Parameters:
TimeZone standard time zone to be used by the GUI and the conversion methods
Remarks:
the TimeZone parameter can take the following values:
  • Africa/Abidjan
  • Africa/Accra
  • Africa/Addis Ababa
  • Africa/Algiers
  • Africa/Asmera
  • Africa/Bamako
  • Africa/Bangui
  • Africa/Banjul
  • Africa/Bissau
  • Africa/Blantyre
  • Africa/Brazzaville
  • Africa/Bujumbura
  • Africa/Cairo
  • Africa/Casablanca
  • Africa/Ceuta
  • Africa/Conakry
  • Africa/Dakar
  • Africa/Dar es Salaam
  • Africa/Djibouti
  • Africa/Douala
  • Africa/El Aaiun
  • Africa/Freetown
  • Africa/Gaborone
  • Africa/Harare
  • Africa/Johannesburg
  • Africa/Kampala
  • Africa/Khartoum
  • Africa/Kigali
  • Africa/Kinshasa
  • Africa/Lagos
  • Africa/Libreville
  • Africa/Lome
  • Africa/Luanda
  • Africa/Lubumbashi
  • Africa/Lusaka
  • Africa/Malabo
  • Africa/Maputo
  • Africa/Maseru
  • Africa/Mbabane
  • Africa/Mogadishu
  • Africa/Monrovia
  • Africa/Nairobi
  • Africa/Ndjamena
  • Africa/Niamey
  • Africa/Nouakchott
  • Africa/Ouagadougou
  • Africa/Porto-Novo
  • Africa/Sao Tome
  • Africa/Timbuktu
  • Africa/Tripoli
  • Africa/Tunis
  • Africa/Windhoek
  • America/Adak
  • America/Anchorage
  • America/Anguilla
  • America/Antigua
  • America/Araguaina
  • America/Aruba
  • America/Asuncion
  • America/Barbados
  • America/Belem
  • America/Belize
  • America/Boa Vista
  • America/Bogota
  • America/Boise
  • America/Buenos Aires
  • America/Cambridge Bay
  • America/Cancun
  • America/Caracas
  • America/Catamarca
  • America/Cayenne
  • America/Cayman
  • America/Center
  • America/Chicago
  • America/Chihuahua
  • America/Cordoba
  • America/Costa Rica
  • America/Cuiaba
  • America/Curacao
  • America/Danmarkshavn
  • America/Dawson
  • America/Dawson Creek
  • America/Denver
  • America/Detroit
  • America/Dominica
  • America/Edmonton
  • America/Eirunepe
  • America/El Salvador
  • America/Fortaleza
  • America/Glace Bay
  • America/Godthab
  • America/Goose Bay
  • America/Grand Turk
  • America/Grenada
  • America/Guadeloupe
  • America/Guatemala
  • America/Guayaquil
  • America/Guyana
  • America/Halifax
  • America/Havana
  • America/Hermosillo
  • America/Indianapolis
  • America/Inuvik
  • America/Iqaluit
  • America/Jamaica
  • America/Jujuy
  • America/Juneau
  • America/Knox
  • America/La Paz
  • America/Lima
  • America/Los Angeles
  • America/Louisville
  • America/Maceio
  • America/Managua
  • America/Manaus
  • America/Marengo
  • America/Martinique
  • America/Mazatlan
  • America/Mendoza
  • America/Menominee
  • America/Merida
  • America/Mexico City
  • America/Miquelon
  • America/Monterrey
  • America/Montevideo
  • America/Monticello
  • America/Montreal
  • America/Montserrat
  • America/Nassau
  • America/New York
  • America/Nipigon
  • America/Nome
  • America/Noronha
  • America/Panama
  • America/Pangnirtung
  • America/Paramaribo
  • America/Phoenix
  • America/Port of Spain
  • America/Port-au-Prince
  • America/Porto Velho
  • America/Puerto Rico
  • America/Rainy River
  • America/Rankin Inlet
  • America/Recife
  • America/Regina
  • America/Rio Branco
  • America/Santiago
  • America/Santo Domingo
  • America/Sao Paulo
  • America/Scoresbysund
  • America/Shiprock
  • America/St Johns
  • America/St Kitts
  • America/St Lucia
  • America/St Thomas
  • America/St Vincent
  • America/Swift Current
  • America/Tegucigalpa
  • America/Thule
  • America/Thunder Bay
  • America/Tijuana
  • America/Tortola
  • America/Vancouver
  • America/Vevay
  • America/Whitehorse
  • America/Winnipeg
  • America/Yakutat
  • America/Yellowknife
  • Antarctica/Casey
  • Antarctica/Davis
  • Antarctica/DumontDUrville
  • Antarctica/Mawson
  • Antarctica/McMurdo
  • Antarctica/Palmer
  • Antarctica/Rothera
  • Antarctica/South Pole
  • Antarctica/Syowa
  • Antarctica/Vostok
  • Arctic/Longyearbyen
  • Asia/Aden
  • Asia/Almaty
  • Asia/Amman
  • Asia/Anadyr
  • Asia/Aqtau
  • Asia/Aqtobe
  • Asia/Ashgabat
  • Asia/Baghdad
  • Asia/Bahrain
  • Asia/Baku
  • Asia/Bangkok
  • Asia/Beirut
  • Asia/Bishkek
  • Asia/Brunei
  • Asia/Calcutta
  • Asia/Choibalsan
  • Asia/Chongqing
  • Asia/Colombo
  • Asia/Damascus
  • Asia/Dhaka
  • Asia/Dili
  • Asia/Dubai
  • Asia/Dushanbe
  • Asia/Gaza
  • Asia/Harbin
  • Asia/Hong Kong
  • Asia/Hovd
  • Asia/Irkutsk
  • Asia/Istanbul
  • Asia/Jakarta
  • Asia/Jayapura
  • Asia/Jerusalem
  • Asia/Kabul
  • Asia/Kamchatka
  • Asia/Karachi
  • Asia/Kashgar
  • Asia/Katmandu
  • Asia/Krasnoyarsk
  • Asia/Kuala Lumpur
  • Asia/Kuching
  • Asia/Kuwait
  • Asia/Macau
  • Asia/Magadan
  • Asia/Makassar
  • Asia/Manila
  • Asia/Muscat
  • Asia/Nicosia
  • Asia/Novosibirsk
  • Asia/Omsk
  • Asia/Oral
  • Asia/Phnom Penh
  • Asia/Pontianak
  • Asia/Pyongyang
  • Asia/Qatar
  • Asia/Qyzylorda
  • Asia/Rangoon
  • Asia/Riyadh
  • Asia/Saigon
  • Asia/Sakhalin
  • Asia/Samarkand
  • Asia/Seoul
  • Asia/Shanghai
  • Asia/Singapore
  • Asia/Taipei
  • Asia/Tashkent
  • Asia/Tbilisi
  • Asia/Tehran
  • Asia/Thimphu
  • Asia/Tokyo
  • Asia/Ulaanbaatar
  • Asia/Urumqi
  • Asia/Vientiane
  • Asia/Vladivostok
  • Asia/Yakutsk
  • Asia/Yekaterinburg
  • Asia/Yerevan
  • Atlantic/Azores
  • Atlantic/Bermuda
  • Atlantic/Canary
  • Atlantic/Cape Verde
  • Atlantic/Faeroe
  • Atlantic/Jan Mayen
  • Atlantic/Madeira
  • Atlantic/Reykjavik
  • Atlantic/South Georgia
  • Atlantic/St Helena
  • Atlantic/Stanley
  • Australia/Adelaide
  • Australia/Brisbane
  • Australia/Broken Hill
  • Australia/Darwin
  • Australia/Hobart
  • Australia/Lindeman
  • Australia/Lord Howe
  • Australia/Melbourne
  • Australia/Perth
  • Australia/Sydney
  • Etc/GMT
  • Etc/GMT+0
  • Etc/GMT+1
  • Etc/GMT+10
  • Etc/GMT+11
  • Etc/GMT+12
  • Etc/GMT+2
  • Etc/GMT+3
  • Etc/GMT+4
  • Etc/GMT+5
  • Etc/GMT+6
  • Etc/GMT+7
  • Etc/GMT+8
  • Etc/GMT+9
  • Etc/GMT-0
  • Etc/GMT-1
  • Etc/GMT-10
  • Etc/GMT-11
  • Etc/GMT-12
  • Etc/GMT-13
  • Etc/GMT-14
  • Etc/GMT-2
  • Etc/GMT-3
  • Etc/GMT-4
  • Etc/GMT-5
  • Etc/GMT-6
  • Etc/GMT-7
  • Etc/GMT-8
  • Etc/GMT-9
  • Etc/GMT0
  • Etc/Greenwich
  • Etc/UCT
  • Etc/UTC
  • Etc/Universal
  • Etc/Zulu
  • Europe/Amsterdam
  • Europe/Andorra
  • Europe/Athens
  • Europe/Belfast
  • Europe/Belgrade
  • Europe/Berlin
  • Europe/Bratislava
  • Europe/Brussels
  • Europe/Bucharest
  • Europe/Budapest
  • Europe/Chisinau
  • Europe/Copenhagen
  • Europe/Dublin
  • Europe/Gibraltar
  • Europe/Helsinki
  • Europe/Istanbul
  • Europe/Kaliningrad
  • Europe/Kiev
  • Europe/Lisbon
  • Europe/Ljubljana
  • Europe/London
  • Europe/Luxembourg
  • Europe/Madrid
  • Europe/Malta
  • Europe/Minsk
  • Europe/Monaco
  • Europe/Moscow
  • Europe/Nicosia
  • Europe/Oslo
  • Europe/Paris
  • Europe/Prague
  • Europe/Riga
  • Europe/Rome
  • Europe/Samara
  • Europe/San Marino
  • Europe/Sarajevo
  • Europe/Simferopol
  • Europe/Skopje
  • Europe/Sofia
  • Europe/Stockholm
  • Europe/Tallinn
  • Europe/Tirane
  • Europe/Uzhgorod
  • Europe/Vaduz
  • Europe/Vatican
  • Europe/Vienna
  • Europe/Vilnius
  • Europe/Warsaw
  • Europe/Zagreb
  • Europe/Zaporozhye
  • Europe/Zurich
  • Indian/Antananarivo
  • Indian/Chagos
  • Indian/Christmas
  • Indian/Cocos
  • Indian/Comoro
  • Indian/Kerguelen
  • Indian/Mahe
  • Indian/Maldives
  • Indian/Mauritius
  • Indian/Mayotte
  • Indian/Reunion
  • Pacific/Apia
  • Pacific/Auckland
  • Pacific/Chatham
  • Pacific/Easter
  • Pacific/Efate
  • Pacific/Enderbury
  • Pacific/Fakaofo
  • Pacific/Fiji
  • Pacific/Funafuti
  • Pacific/Galapagos
  • Pacific/Gambier
  • Pacific/Guadalcanal
  • Pacific/Guam
  • Pacific/Honolulu
  • Pacific/Johnston
  • Pacific/Kiritimati
  • Pacific/Kosrae
  • Pacific/Kwajalein
  • Pacific/Majuro
  • Pacific/Marquesas
  • Pacific/Midway
  • Pacific/Nauru
  • Pacific/Niue
  • Pacific/Norfolk
  • Pacific/Noumea
  • Pacific/Pago Pago
  • Pacific/Palau
  • Pacific/Pitcairn
  • Pacific/Ponape
  • Pacific/Port Moresby
  • Pacific/Rarotonga
  • Pacific/Saipan
  • Pacific/Tahiti
  • Pacific/Tarawa
  • Pacific/Tongatapu
  • Pacific/Truk
  • Pacific/Wake
  • Pacific/Wallis
  • Pacific/Yap
See also:
UtcToLocal

LocalToUtc

HRESULT XVWTIMELINELib::IVWTimeLine::TimeZone ( [out, retval] BSTR * TimeZone )

Returns:
the TimeZone property.

HRESULT XVWTIMELINELib::IVWTimeLine::UtcToLocal | ( | [in] BSTR | UtcTime,
 |  | [out, retval] BSTR * | LocalTime
 | ) |

Parameters:
UtcTime UTC date/time string ("mm/dd/yyyy hh:mm:ss.ssssssUTC")
Returns:
local date/time string ("mm/dd/yyyy hh:mm:ss.ssssss") or emptry string if the conversion could not be done
See also:
TimeZone

HRESULT XVWTIMELINELib::IVWTimeLine::Zoom ( [in] long ZoomFactor )

Zooms in or out, if the GUI mode is enabled.

Parameters:
ZoomFactor if zero, zooms out to the maximum extent; if positive, zooms in (the higher the value, the more this method will zoom in); if negative, zooms out (the lower the value, the more this method will zoom out)

Generated on Tue Oct 3 18:24:23 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl Interface Reference

VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl

VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl Interface Reference

This ActiveX control allows to query generic system information as installed network adapters, hard drivers, VisioWave coded boards and their channel configurations,... If running on Power Systems, motherboard health statistics as fan speeds, core voltages equipments with preconfigured audio outputs. It also allows to manage system alarms, that is to query their status and to acknowledge them in case they are set. See the VWVideoEquipmentManagerCtrl_VB6 sample for a small example in Visual Basic on how to use it. More...

import "VWVideoEquipmentManagerController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | AcknowledgeAlarm ([in] BSTR BstrAlarmName,[out, retval] long *plErrorCode)
HRESULT | Blocking ([in] BOOL newVal)
HRESULT | Blocking ([out, retval] BOOL *pVal)
HRESULT | Connect ([out, retval] long *pResult)
HRESULT | Disconnect ()
HRESULT | ExtractBoolean ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BOOL *pbValue)
HRESULT | ExtractInteger ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue)
HRESULT | ExtractNumber ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] double *pdValue)
HRESULT | ExtractString ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BSTR *pbstrValue)
HRESULT | GetAlarms ([out, retval] BSTR *pBstrAlarms)
HRESULT | GetAlarmThresholds ([out, retval] BSTR *pBstrAlarmThresholds)
HRESULT | GetAudioPortsStats ([out, retval] BSTR *pBstrAudioPortsStats)
HRESULT | GetDiskInfos ([out, retval] BSTR *pBstrDiskInfos)
HRESULT | GetId ([out, retval] long *pInterface)
HRESULT | GetNetworkAdapterInfos ([out, retval] BSTR *pBstrNetworkAdapterInfos)
HRESULT | GetNetworkAdapterStats ([in] long lIndex,[out, retval] BSTR *pBstrNetworkAdapterStats)
HRESULT | GetPluginInfos ([in]BSTR bstrPluginId,[out, retval] BSTR *pBstrPluginInfos)
HRESULT | GetRaidStatus ([in] long lIndex,[out, retval] BSTR *pBstrRaidStatus)
HRESULT | GetSmartStatus ([in] long lIndex,[out, retval] BSTR *pBstrSmartStatus)
HRESULT | GetSystemHealthStats ([out, retval] BSTR *pBstrSystemHealthStats)
HRESULT | GetSystemInfos ([out, retval] BSTR *pBstrSystemInfos)
HRESULT | GetUptime ([out, retval] BSTR *pBstrUptime)
HRESULT | GetVideoCircuits ([out, retval] BSTR *pBstrVideoCircuits)
HRESULT | GetVideoPortsStats ([out, retval] BSTR *pBstrVideoPortsStats)
HRESULT | ListPlugins ([out, retval] BSTR *pBstrPlugins)
HRESULT | Port ([in] long newVal)
HRESULT | Port ([out, retval] long *pVal)
HRESULT | Rehash ([out, retval] long *pResult)
HRESULT | SelectMonitoredChannel ([in] long lEnabled,[out, retval] BOOL *pbSuccess)
HRESULT | Server ([in] BSTR newVal)
HRESULT | Server ([out, retval] BSTR *pVal)
HRESULT | SetAlarmEnabled ([in] BSTR BstrAlarmName,[in] long lEnabled,[out, retval] long *plErrorCode)
HRESULT | SetAlarmThresholds ([in] BSTR BstrAlarmName,[in] double dMinVal,[in] double dMaxVal,[out, retval] long *plErrorCode)
HRESULT | SoftReboot ([out, retval] BOOL *pbSuccess)
HRESULT | Status ([out, retval] long *pVal)
HRESULT | TimeOut ([in] long newVal)
HRESULT | TimeOut ([out, retval] long *pVal)

Detailed Description

This ActiveX control allows to query generic system information as installed network adapters, hard drivers, VisioWave coded boards and their channel configurations,... If running on Power Systems, motherboard health statistics as fan speeds, core voltages equipments with preconfigured audio outputs. It also allows to manage system alarms, that is to query their status and to acknowledge them in case they are set. See the VWVideoEquipmentManagerCtrl_VB6 sample for a small example in Visual Basic on how to use it.

Member Function Documentation

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::AcknowledgeAlarm | ( | [in] BSTR | BstrAlarmName,
 |  | [out, retval] long * | plErrorCode
 | ) |

Acknowledges a fired alarm for a given sensor

Parameters:
BstrAlarmName The sensor's name
Returns:
Errorcode

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::Blocking ( [in] BOOL newVal )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::Blocking ( [out, retval] BOOL * pVal )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::Connect ( [out, retval] long * pResult )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::ExtractBoolean | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] BOOL * | pbValue
 | ) |

Extracts a boolean value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
boolean value of the parameter

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::ExtractInteger | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] long * | plValue
 | ) |

Extracts an integer value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
integer value of the parameter

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::ExtractNumber | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] double * | pdValue
 | ) |

Extracts a floating-point value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
floating-point value of the parameter

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::ExtractString | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] BSTR * | pbstrValue
 | ) |

Extracts a string value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
string value of the parameter

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetAlarms ( [out, retval] BSTR * pBstrAlarms )

Gets for each sensor it's current state. Possible states are "Off" for a configured but not triggered alarm, "On" for a configured an triggrered alarm, "Disabled" for a disabled alarm

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false or "Serial link down" if the monitoring equipment cannot communicate with the power supply Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

SetAlarmEnabled

Remarks:
This function returns for each configured sensor 1 key value pair {alarm_name} = {state}, for example for the alarm network_media_disconnected[1] it would be network_media_disconnected[1]="Off" if the alarm is enabled but hasn't been triggered. For a list of sensors see SetAlarmEnabled

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetAlarmThresholds ( [out, retval] BSTR * pBstrAlarmThresholds )

Gets for each alarm it's currently configured lower and upper bound.

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

SetAlarmEnabled

Remarks:
This function returns for each configured alarm 2 key value pairs {alarm_name}_LowLimit and {alarm_name}_HighLimit for example for the alarm temp[1] it would be temp[1]_HighLimit=50 and temp[1]_LowLimit=15 For a list of sensors see SetAlarmEnabled

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetAudioPortsStats ( [out, retval] BSTR * pBstrAudioPortsStats )

Get audio port stats Not documented yet

Remarks:
indexes go from 1 to nAudioPortCount

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetDiskInfos ( [out, retval] BSTR * pBstrDiskInfos )

Gets information about installed hardisk drives

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false. Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

Return values:
physicalDiskCount | Integer value indicating the number of physical installed hard drives
pdDiskSize[i] | Integer value representing the ith disk drive's total space in KBytes
pdInterfaceType[i] | String value representing the ith disk drive's connector type, possible values are "SCSI" and "IDE"
pdModelName[i] | String value representing the disk drives model name
pdPartitionCount[i] | Integer value indicating the number of logical volumes on disk drive i
pdStatus[i] | String value representing the disk drive's status, possible values are "OK", "PREDFAIL", "ERROR", "DEGRADED", "STARTING", "STOPPING", "STRESSED", "NONRECOVER", "NOCONTACT", "LOSTCOMM" and "UNKNOWN"
pdUID[i] | String value representing the ith's disk VID
pdRaidIndex[i] | Integer value indicating the index of the monitored RAID chassis associated with the ith physical drive (or a negative value if the physical drive is not associated with any RAID chassis)
logicalDiskCount | Integer value indicating the total amount of logical volumes in the system
ldDeviceName[i] | String value representing the ith logical volume's name, e.g. "A:"...
ldDiskNumber[i] | Integer value representing the ith logical volume's order on the physical disk
ldFileSystem[i] | String value representing the ith logical volume's file system
ldFreeSpace[i] | Integer value representing the ith logical volume's free space in MBytes
ldPartitionNumber[i] | Integer value representing the ith logical volume's partition number
ldPath[i] | String value representing the current path for the ith logical volume
ldSerialNumber[i] | String value representing the ith logical volume's serial number
ldTotalSpace[i] | Integer value representing the ith logical volume's free space
ldType[i] | String value representing the ith logical volume's type, possible values are "REMOVABLE", "LOCAL", "CDROM", "RAID", "NETWORK", "RAMDISK" and "UNKNOWN"
ldVolumeName[i] | String value representing the ith logical volume's label name
raidCount | Integer value indicating the number of monitored RAID chassis
Remarks:
indexes go from 0 to physicalDiskCount - 1 for values related to physical disks and from 0 to logicalDiskCount - 1 for values related to logical disks

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetId ( [out, retval] long * pInterface )

Should be used only by VisioWave engineers.

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetNetworkAdapterInfos ( [out, retval] BSTR * pBstrNetworkAdapterInfos )

Gets information about installed network adapters

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false. Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

Return values:
type[i] | String value representing the ith network adapter's type, possible values are "ETHERNET", "TokenRing", "FDDI", "WAN", "LocalTalk", "ATM", "Wireless", "Infrared", "IEEE1394" and "UNKNOWN"
name[i] | String value representing the ith network adapter's name
ipAddress[i] | String value representing the ith network adapter's ip address
gateway[i] | String value representing the ith network adapter's default gateway's ip address
subnetMask[i] | String value representing the ith network adapter's subnet mask
macAddress[i] | String value representing the ith network adapter's MAC address
networkAdapterCount | Integer value representing the number of installed network adapters
Remarks:
indexes go from 0 to networkAdapterCount - 1

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetNetworkAdapterStats | ( | [in] long | lIndex,
 |  | [out, retval] BSTR * | pBstrNetworkAdapterStats
 | ) |

Gets information about installed network adapters

Parameters:
lIndex Index of the network adapter (from 0 to networkAdapterCount - 1, where networkAdapterCount is the value returned by GetNetworkAdapterInfos)
Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false. Use ExtractString/Number/Boolean to get the value for a key.
See also:
GetNetworkAdapterInfos

ExtractString

ExtractNumber

ExtractBoolean

Return values:
mediaConnected | Boolean value indicating the network adapter's cable state
linkSpeed | Integer value indicating the the network adapter's link speed

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetPluginInfos | ( | [in] BSTR | bstrPluginId,
 |  | [out, retval] BSTR * | pBstrPluginInfos
 | ) |

Lists all active plugins.

Parameters:
bstrPluginId Plugin Id (CCS) of the plugin for which information should be retrieved.
Returns:
a comma-separated list of name=value pairs
Return values:
PluginId[i] | Plugin id in CCS.
PluginFileName[i] | File name of the plugin.
ConfigFileName[i] | Configuration file name.
VideoSourceId[i] | Video port id in CCS.
VideoSourceHostName[i] | Hostname /ip of the machine hosting the video source.
VideoSourceUrl[i] | Full URL for local and file sources
VideoSourceTcpPort[i] | Tcp port of the video port.
list | of key=value pairs dependant on the plugin. This pairs include: value, max threshold and min threshold.
See also:
ExtractInteger

ExtractString

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetRaidStatus | ( | [in] long | lIndex,
 |  | [out, retval] BSTR * | pBstrRaidStatus
 | ) |

Gets information about a monitored RAID chassis.

Parameters:
lIndex Index of the RAID chassis (from 1 to raidCount, where raidCount is the value returned by GetDiskInfos)
Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false. Use ExtractString/Integer/Number/Boolean to get the value for a key.
See also:
GetDiskInfos

ExtractString

ExtractInteger

ExtractNumber

ExtractBoolean

Return values:
bRaidConnected | Boolean value indicating if the other values are available, i.e. if the RAID chassis is successfully monitored
nHardDriveSlotCount | Integer value indicating the number of hard drive slots
bHardDriveSlotFailed | Boolean value indicating if one of the hard drive slots at least failed
hardDriveSlotStatus[i] | Integer value indicating the status of hard drive slot number i
hardDriveSlotDescription[i] | Description string for hard drive slot number i
nPowerSupplyCount | Integer value indicating the number of power supplies
bPowerSupplyFailed | Boolean value indicating if one of the power supplies at least failed
powerSupplyStatus[i] | Integer value indicating the status of power supply number i
powerSupplyDescription[i] | Description string for power supply number i
nFanCount | Integer value indicating the number of fans
bFanFailed | Boolean value indicating if one of the fans at least failed
fanStatus[i] | Integer value indicating the status of fan number i
bFanCurrentValueAvailable[i] | Boolean value indicating if the current value (speed) for fan number i is available
fanCurrentValue[i] | If bFanCurrentValueAvailable[i] is true, floating- point value indicating the current value (speed) of fan number i
fanDescription[i] | Description string for fan number i
nTemperatureSensorCount | Integer value indicating the number of temperature sensors
bTemperatureSensorFailed | Boolean value indicating if one of the temperature sensors at least failed
temperatureSensorStatus[i] | Integer value indicating the status of temperature sensor number i
bTemperatureSensorCurrentValueAvailable[i] | Boolean value indicating if the current value for temperature sensor number i is available
temperatureSensorCurrentValue[i] | If bTemperatureSensorCurrentValueAvailable[i] is true, floating-point value indicating the current value of temperature sensor number i
temperatureSensorDescription[i] | Description string for temperature sensor number i
nVoltageSensorCount | Integer value indicating the number of voltage sensors
bVoltageSensorFailed | Boolean value indicating if one of the voltage sensors at least failed
voltageSensorStatus[i] | Integer value indicating the status of voltage sensor number i
bVoltageSensorReferenceValueAvailable[i] | Boolean value indicating if a reference value for voltage sensor number i is available
voltageSensorReferenceValue[i] | If bVoltageSensorReferenceValueAvailable[i] is true, floating-point value indicating a reference value for voltage sensor number i
bVoltageSensorCurrentValueAvailable[i] | Boolean value indicating if the current value for voltage sensor number i is available
voltageSensorCurrentValue[i] | If bVoltageSensorCurrentValueAvailable[i] is true, floating-point value indicating the current value for voltage sensor number i
voltageSensorDescription[i] | Description string for voltage sensor number i
nUpsCount | Integer value indicating the number of UPS's
bUpsFailed | Boolean value indicating if one of the UPS's at least failed
upsStatus[i] | Integer value indicating the status of UPS number i
upsDescription[i] | Description string for UPS number i
nBackupBatteryCount | Integer value indicating the number of backup batteries
bBackupBatteryFailed | Boolean value indicating if one of the backup batteries at least failed
backupBatteryStatus[i] | Integer value indicating the status of backup battery number i
backupBatteryDescription[i] | Description string for backup battery number i
Remarks:
Indexes (represented above by the letter i) are all 1-based

The meaning of the statuses is the following:

  • 0, status unknown
  • 1, device functioning optimally / hard drive slot contains good drive
  • 2, hard drive slot contains bad drive or hard drive missing from slot
  • 3, no drive installed in hard drive slot
  • 4, device (power supply, fan, UPS, or backup battery) or device sensor (hard drive slot, temperature, or voltage sensors) malfunctioning
  • 5, monitored value (fan speed, temperature or voltage) out-of-range

A monitored device (hard drive slot, power supply, etc.) is considered failing if its status is not 1 (device functioning optimally / hard drive slot contains good drive)

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetSmartStatus | ( | [in] long | lIndex,
 |  | [out, retval] BSTR * | pBstrSmartStatus
 | ) |

Gets the predicted S.M.A.R.T status (only for IDE drives)

Parameters:
lIndex Index of the physical disk (from 0 to physicalDiskCount - 1, where physicalDiskCount is the value returned by GetDiskInfos)
Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false. Use ExtractString/Number/Boolean to get the value for a key.
See also:
GetDiskInfos

ExtractString

ExtractNumber

ExtractBoolean

Return values:
predictionAvailable | Boolean value indicating if S.M.A.R.T is available
predictFailure | Boolean value indicating if a failure is predicted

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetSystemHealthStats ( [out, retval] BSTR * pBstrSystemHealthStats )

Gets information about motherboard sensors None activated on Evolution chassis thus not documented (there are many...)

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetSystemInfos ( [out, retval] BSTR * pBstrSystemInfos )

Gets information about installed visiowave video boards

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false. Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

Return values:
bCPUFan | Boolean fan indicating if there is a CPU fan connected to the motherboard
nFanCount | Integer value representing the number of fans connected to the motherboard
nMemorySize | Integer value representing the amount of RAM in KBytes installed on the system
nModuleChannelCount[i] | Integer value representing the number of video channels on the ith board
nModuleCount | Integer value representing the number of visiowave boards installed on the system
nModuleSlotNumber[i] | Integer value indicating the ith visiowave board's slot number
nPowerSupplyCount | Integer value indicating the number of power supplies present in the system
szHardwareRevision | String value representing the hardware revision number
szModelName | String value representing the model name, possible values are "EVOLUTION 8", "EVOLUTION 28" and "POWER PLUS"
szModuleDescription[i] | String value representing the ith visiowave boards description
szModuleFabDetails[i] | String value representing the ith visiowave boards fabrication details
szModuleManufacturingDate[i] | String value representing the ith visiowave boards manufacturing date
szModulePartNumber[i] | String value representing the ith visiowave boards part number
szModuleRevision[i] | String value representing the ith visiowave boards hardware revision number
szModuleSerialNumber[i[ | String value representing the ith visiowave boards hardware serial number
szModuleSubType[i] | String value representing the ith visiowave boards hardware subtype
szModuleTestDetails[i] | String value representing the ith visiowave boards test details
szModuleType[i] | String value representing the ith visiowave boards multimedia type
szSerialNumber | String value representing the ith visiowave equipments serial number
Remarks:
indexes go from 1 to nModuleCount

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetUptime ( [out, retval] BSTR * pBstrUptime )

Retrieves the number of seconds elapsed since the service started (in the "uptime" parameter - a floating point value) and the date/time at which the service started (in the "starttime" parameter - a string following this format: "mm/dd/yyyy hh:mm:ss.ssssssUTC").

Returns:
a comma-separated list of name=value pairs
See also:
ExtractNumber

ExtractString

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetVideoCircuits ( [out, retval] BSTR * pBstrVideoCircuits )

Gets real time information about the incoming network video connections

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false. Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

Return values:
nCircuitsCount | Integer value representing the amount of active connections
connType[i] | String value representing the ith connection's source type, possible values are "SVC" for ATM "IPM" for IP UDP multicast "UDP" for IP UDP
cycle[i] | String value representing the ith connection's cycle name
destination[i] | String value representing the ith connection's destination video port
direction[i] | String value representing the ith connection's direction
source[i] | String value representing the ith connection's source IP address
Remarks:
indexes go from 1 to nCircuitsCount

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::GetVideoPortsStats ( [out, retval] BSTR * pBstrVideoPortsStats )

Gets video channel settings

Returns:
String containing key value pairs in the following format: 'key1="StringValue1", key2=NumericalValue2, key3=BooleanValue', BooleanValue being a string either true or false. Use ExtractString/Number/Boolean to get the value for a key.
See also:
ExtractString

ExtractNumber

ExtractBoolean

Return values:
nVideoPortCount | Integer value representing the number of video channels known to the system
vpBandwidth[i] | Integer value representing the configured Bitrate in kbit/s,
vpDirection[i] | String value representing the ith video channel's input/output configuration, "INPUT" channel is capture mode "OUTPUT" channel is in output mode "IDLE" channel is in idle mode
vpImageSize[i] | String value representing the ith video channel's video size "FULL" full image size "CIF" CIF image size "QCIF" QCIF image size "QQCIF" QQCIF image size "QQQCIF" QQQCIF image size "UNKNOWN" non standard image size
vpLabel[i] | String value representing the ith video channel's central configuration name
vpPortNumber[i] | Integer value representing the ith video channel's physical port number on the video card
vpStatus[i] | Integer value representing the ith video channel's real time status 0 video port idle 1 video port inactive 2 video port active 3 video port output
vpTcpPort[i] | Integer value representing the ith video channel's TCP control port
vpTemporal[i] | Integer value representing the ith video channel's compression level 0 Non temporal compression 2 Temporal compression
vpTermination[i] | Boolean value indicating if the ith video channel is terminated
vpVideoFormat[i] | String value representing the ith video channels video format following formats are supported: "NTSC_M", "NTSC_N", "NTSC_443", "NTSC_JP", "BW_60", "PAL_BGHI", "PAL_N", "PAL_M", "PAL_443", "PAL_D", "BW_50", "SECAM_L" or "UNKNOWN"
Remarks:
indexes go from 1 to nVideoPortCount

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::ListPlugins ( [out, retval] BSTR * pBstrPlugins )

Lists all active plugins.

Returns:
a comma-separated list of name=value pairs
Return values:
PluginId[i] | Plugin id in CCS.
PluginFileName[i] | File name of the plugin.
Remarks:
indexes start at 0
See also:
ExtractString

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::Port ( [in] long newVal )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::Port ( [out, retval] long * pVal )

Returns:
the TCP port number of the remote manager

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::SelectMonitoredChannel | ( | [in] long | lEnabled,
 |  | [out, retval] BOOL * | pbSuccess
 | ) |

Selects the channel that has to be monitored by the video output connector of the VMT3U-VSP.

The VMT3U-VSP board has got a video output connector that can directly monitor one of the video input (it is a direct analog link, without compression). This connector has been designed for connectivity test purpose.

Parameters:
lInputChannel the 1-based index of the input channel we want to monitor.
Returns:
Error code

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::Server ( [in] BSTR newVal )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::Server ( [out, retval] BSTR * pVal )

Returns:
the host name or IP address of the remote manager

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::SetAlarmEnabled | ( | [in] BSTR | BstrAlarmName,
 |  | [in] long | lEnabled,
 |  | [out, retval] long * | plErrorCode
 | ) |

Enables or disables an alarm

Parameters:
BstrAlarmName | The alarm's name that is to be enabled or disabled
lEnabled | 0 to disable, 1 to enable
Remarks:
Sensor names are "network_media_disconnected[i], "video_input_inactive[i]", "smart_failure_prediction[i]" and "disk_write_error"

indexes start at 1

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::SetAlarmThresholds | ( | [in] BSTR | BstrAlarmName,
 |  | [in] double | dMinVal,
 |  | [in] double | dMaxVal,
 |  | [out, retval] long * | plErrorCode
 | ) |

Sets the minimum and maximum admissible value for a sensor

Parameters:
BstrAlarmName | The sensor's name
dMinVal | The minimum value
dMaxVal | The maximum value
Returns:
Errorcode
Remarks:
If the sensor's value is not within these bounds, the associated alarm will be fired.

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::SoftReboot ( [out, retval] BOOL * pbSuccess )

Reboots the remote host (the machine on which the service is running).

Returns:
true if the soft reboot was initiated successfully; if this method returns false and the watchdog manager is not disabled, then a hardware reboot will occur

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::Status ( [out, retval] long * pVal )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::TimeOut ( [in] long newVal )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl::TimeOut ( [out, retval] long * pVal )

Returns:
the connection time-out in milliseconds

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2 Interface Reference

VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2

VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2 Interface Reference

This ActiveX control allows to remotely query and control real time video capture parameters as the bandwidth configured, the bandwidth used, the framerate,... on equipments with preconfigured video inputs. See the VWVideoSvrCtrl2 sample for a small example in Visual Basic on how to use it. More...

import "VWServerController.idl";

Inherits IDispatch.

List of all members.

Public Member Functions

HRESULT | Blocking ([in] BOOL Blocking)
HRESULT | Blocking ([out, retval] BOOL *Blocking)
HRESULT | Connect ([out, retval] long *Result)
HRESULT | Disconnect ()
HRESULT | ExtractBoolean ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue)
HRESULT | ExtractInteger ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue)
HRESULT | ExtractNumber ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] float *pfValue)
HRESULT | ExtractString ([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BSTR *pbstrValue)
HRESULT | GetFields ([in] long lSourceId,[out, retval] short *pnFields)
HRESULT | GetFPS ([in] long lSourceId,[out, retval] short *pnFps)
HRESULT | GetFrameSize ([in] long lSourceId,[out, retval] short *pnFrameSize)
HRESULT | GetFramesLost ([in] long lSourceId,[out, retval] long *plFramesLost)
HRESULT | GetId ([out, retval] long *pInterface)
HRESULT | GetLastError ([out, retval] long *plLastError)
HRESULT | GetMaxFrameSize ([in] long lSourceId,[out, retval] short *pnMaxFrameSize)
HRESULT | GetMaxRate ([in] long lSourceId,[out, retval] short *pnMaxRate)
HRESULT | GetParams ([in, defaultvalue(-1)] long lSourceId,[out, retval] BSTR *pbstrParams)
HRESULT | GetQuality ([in] long lSourceId,[out, retval] short *pnQuality)
HRESULT | GetRate ([in] long lSourceId,[out, retval] short *pnRate)
HRESULT | GetStat ([in, defaultvalue(-1)] long lSourceId,[out, retval] BSTR *pbstrStat)
HRESULT | GetTemporalLevel ([in, defaultvalue(-1)] long lSourceId,[out, retval] short *pnTemporalLevel)
HRESULT | GetVideoFormat ([in] long lSourceId,[out, retval] short *pnVf)
HRESULT | GetVideoFormat2 ([in] long lSourceId,[out, retval] BSTR *pnVf)
HRESULT | GetVideoInfo ([in] long lSourceId,[out] short *pnVidX,[out] short *pnVidY,[out] short *pnVf,[out] short *pnFps,[out] short *pnFields,[out, retval] long *plError)
HRESULT | GetVideoInfo2 ([in] long lSourceId,[out] short *pnVidX,[out] short *pnVidY,[out] BSTR *pbstrVf,[out] short *pnFps,[out] short *pnFields,[out, retval] long *plError)
HRESULT | GetVidX ([in] long lSourceId,[out, retval] short *pnVidX)
HRESULT | GetVidY ([in] long lSourceId,[out, retval] short *pnVidY)
HRESULT | Port ([in] long Port)
HRESULT | Port ([out, retval] long *Port)
HRESULT | PurgeArchive ([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError)
HRESULT | Rehash ([out, retval] long *Result)
HRESULT | RehashServer ([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError)
HRESULT | RestartServer ([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError)
HRESULT | SaveState ([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError)
HRESULT | Server ([in] BSTR Hostname)
HRESULT | Server ([out, retval] BSTR *Hostname)
HRESULT | SetFPS ([in] long lSourceId,[in] short nFps,[out, retval] long *plError)
HRESULT | SetLastError ([in] long lLastError)
HRESULT | SetMaxFrameSize ([in] long lSourceId,[in] short nFrameSize,[out, retval] long *plError)
HRESULT | SetParams ([in] BSTR bstrParams,[in, defaultvalue(-1)] long lSourceId,[out, retval] long *plError)
HRESULT | SetQuality ([in] long lSourceId,[in] short nQuality,[out, retval] long *plError)
HRESULT | SetRate ([in] long lSourceId,[in] short nRate,[out, retval] long *plError)
HRESULT | StartArchive ([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError)
HRESULT | StartArchiveEx ([in] BSTR bstrName,[in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError)
HRESULT | Status ([out, retval] long *Status)
HRESULT | StopArchive ([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError)
HRESULT | TimeOut ([in] long Timeout)
HRESULT | TimeOut ([out, retval] long *Timeout)
HRESULT | VideoSignal ([in] long lSourceId,[in, defaultvalue(0)] short nPeriod,[out, retval] short *pnBlack)

Detailed Description

This ActiveX control allows to remotely query and control real time video capture parameters as the bandwidth configured, the bandwidth used, the framerate,... on equipments with preconfigured video inputs. See the VWVideoSvrCtrl2 sample for a small example in Visual Basic on how to use it.

Member Function Documentation

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::Blocking ( [in] BOOL Blocking )

Sets the connection mode.

Parameters:
Blocking Connection mode (false: non-blocking, true: blocking)

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::Blocking ( [out, retval] BOOL * Blocking )

Returns:
the connection mode
Return values:
false | The connection to the remote manager is non-blocking
true | The connection to the remote manager is blocking

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::Connect ( [out, retval] long * Result )

Connects to the remote manager whose host and port are specified by the Server and Port properties.

Remarks:
If the control is already connected to a manager, this method will disconnect it first.

In non-blocking mode, the LinkDown and LinkUp events are fired when the connection fails or succeeds.

The LinkDown event is also fired when an established connection (in blocking or non-blocking mode) goes down.

Returns:
operation result.
Return values:
0 | blocking connection successful or non-blocking connection attempted
-1 | blocking connection failed (that is, no answer was received from the manager for the amount of time specified by the TimeOut property)
See also:
Server

Port

TimeOut

Blocking

Status

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::Disconnect ( )

Disconnects from the remote manager.

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::ExtractBoolean | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] long * | plValue
 | ) |

Extracts a boolean value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
boolean value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::ExtractInteger | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] long * | plValue
 | ) |

Extracts an integer value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
integer value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::ExtractNumber | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] float * | pfValue
 | ) |

Extracts a floating-point value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
floating-point value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::ExtractString | ( | [in] BSTR | bstrParameter,
 |  | [in] BSTR | bstrParams,
 |  | [out, retval] BSTR * | pbstrValue
 | ) |

Extracts a string value from a comma-separated list of name=value pairs.

Parameters:
bstrParameter | Parameter name
bstrParams | comma-separated list of name=value pairs
Returns:
string value of the parameter

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::GetId ( [out, retval] long * pInterface )

Should be used only by VisioWave engineers.

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::GetParams | ( | [in, defaultvalue(-1)] long | lSourceId,
 |  | [out, retval] BSTR * | pbstrParams
 | ) |

Gets various video setting parameters for a video source. To extract a particular parameter's value, use the ExtractXXX methods. Available video source parameters:

  • Id [string] : video equipment (chassis) id.
  • Type [string] : Access Manager type, "Video" or "Audio". In our case, must be "Video".
  • Driver [string] : VisioWave Codec Board type. Can be one of the following strings, depends on the chassis: "VisioWave1" (Power Plus), "PCI2" (Power Plus and Discovery 300), "CPCI4" (CPCI4 based Evolution chassis) or "CPCI4-B" (CPCI4-B based Evolution chassis).
  • Channel [integer] : video channel number in the chassis.
  • InputConnector [string] : input connector type, depends on the VisioWave Codec board used and if an input sequence was defined in the Access Manager part of the VisioWave Central Configuration Server interface. If a sequence was defined, it will be set to "sequence", otherwise to one of the following values:
    • "svideo" or "composite" (VisioWave 1 and PCI2 based chassis).
    • "CompositeA/B/C" (CPCI4 and CPCI4-B based chassis).
  • CompositeAOrder [integer] : position of Composite A in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • CompositeBOrder [integer] : position of Composite B in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • CompositeCOrder [integer] : position of Composite C in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • CompositeADisplayMs [integer]: time in ms during which Composite A will be displayed in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • CompositeBDisplayMs [integer]: time in ms during which Composite B will be displayed in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • CompositeCDisplayMs [integer]: time in ms during which Composite C will be displayed in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • VideoFormat [string] : input video format used for capture. Possible values:
    • "NTSC_M"
    • "NTSC_N"
    • "NTSC_443"
    • "NTSC_JP"
    • "BW_60"
    • "PAL_BGHI"
    • "PAL_N"
    • "PAL_M"
    • "PAL_443"
    • "PAL_D"
    • "BW_50"
    • "SECAM_L"
  • Vidx [integer] : video width in pixels.
  • Vidy [integer] : video height in pixels.
  • ScaleLevel [string] : sampling resolution, "FULL", "CIF" or "QCIF".
  • TemporalLevel [integer] : temporal compression level, 0 (no compression) or 2 (GOP of 4 fields).
  • MaxFrameSize [integer] : max field size in KBytes, -1 means constant quality mode.
  • RangeMaxFrameSize [integer] : the frame size range delimits the field size. Max value in KBytes.
  • RangeMinFrameSize [integer] : the frame size range delimits the field size. Min value in KBytes.
  • Quality [integer] : video stream quality, -1 means constant bandwidth mode. Possible values are:
    • 64 (LOW)
    • 96 (MEDIUM)
    • 112 (AVERAGE)
    • 128 (GOOD)
    • 192 (HIGH)
  • Skip [integer] : number of fields to skip. Set it to 0 to receive all the fields from the stream.
  • Fps [integer] : fields per second, multiplied by 100. Fps is calculated as follow: Fps = (Video_Standard_Fps*100)/(1+Skip) where Video_Standard_Fps depends on the VideoFormat (ex: PAL_BGHI captures at 50 Fps).
  • FpsNumerator [integer] : fraction numerator used to calculate the real value of Fps (not multiplied by 100). For example, FpsNumerator=5000 and FpsDenominator=200 will give Fps=25.
  • FpsDenominator [integer] : fraction denominator used to calculate the real value of Fps (not multiplied by 100). For example, FpsNumerator=5000 and FpsDenominator=200 will give Fps=25.
  • UdpEnable [boolean] : UDP connections enabled.
  • UdpMtu [integer] : maximum Ethernet packet size.
  • UdpSourcePort [integer] : used for port base QoS.
  • UdpInterface [integer] : UDP sending interface number.
  • UdpPrecedence [integer] : in case QoS is used, TOS field value, from 0 to 256.
  • IpmEnable [boolean] : IPM connections enabled.
  • IpmMtu [integer] : maximum Ethernet packet size.
  • IpmGroupAddress [string] : multicast group address.
  • IpmTtl [integer] : time-to-live for IPM packets.
  • IpmInterface [integer] : IPM sending interface number.
  • IpmPrecedence [integer] : in case QoS is used, TOS field value, from 0 to 256.
  • IpmPort [integer] : multicast group port.
  • AtmEnable [boolean] : ATM connections enabled.
  • AtmMtu [integer] : maximum AAL5 packet size.
  • AtmInterface [integer] : ATM sending interface number.
  • AtmQosClass [string] : ATM service class, "ubr", "cbr" or "vbr".
  • AtmPcrScrRatio [integer] : ATM PCR/SCR ratio.
  • AtmMulticastEnabled [boolean]: enables the server to be ATM multicast root.

Parameters:
lSourceId Source identifier (returned by the AddSource function of the VWActiveXComponent control, in this case the source must be connected) or -1 (in this case the control must be connected).
Returns:
A comma-separated list of name=value pairs (video source parameters).
Return values:
"" Failure (connection to the Access Manager failed).
See also:
SetParams

GetStat

ExtractInteger

ExtractString

ExtractBoolean

ExtractNumber

IVWActiveXComponent

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::GetStat | ( | [in, defaultvalue(-1)] long | lSourceId,
 |  | [out, retval] BSTR * | pbstrStat
 | ) |

Gets various video statistics parameters. To extract a particular parameter's value, use the ExtractXXX methods. Available video statistics parameters:

  • SequencePriority [integer] : actual input connector priority.
  • Skip [integer] : number of fields skipped.
  • Fps [integer] : fields per second, multiplied by 100. Fps is calculated as follow: Fps = (Video_Standard_Fps*100)/(1+Skip) where Video_Standard_Fps depends on the VideoFormat (ex: PAL_BGHI captures at 50 Fps).
  • MaxFrameSize [integer] : max field size in KBytes, -1 means constant quality mode.
  • MaxBandwidth [integer] : max bandwidth in Kbits/s.
  • FrameSize [integer] : momentary frame size in Bytes.
  • Bandwidth [integer] : momentary bandwidth in KBits/s.
  • Quality [integer] : video stream quality, -1 means constant bandwidth mode. Possible values are:
    • 64 (LOW)
    • 96 (MEDIUM)
    • 112 (AVERAGE)
    • 128 (GOOD)
    • 192 (HIGH)
  • Sync [boolean] : presence of video signal.
  • Storages [integer] : number of storages (defined in the VisioWave Central Configuration Server interface or created with the VWStorageManagerCtrl ActiveX control) associated with the remote Access Manager.
  • StorageId[index] [string] : Id of the equipment (as defined in the VisioWave Central Configuration interface) on which the storage is done. Index is a number between 0 and the number of storages minus one.
  • StorageFps[index] [integer] : number of fields per second. Index is a number between 0 and the number of storages minus one.
  • StorageState[index] [boolean]: false if the storage is inactive and true if it is active. Index is a number between 0 and the number of storages minus one.

Parameters:
lSourceId Source identifier (returned by the AddSource function of the VWActiveXComponent control, in this case the source must be connected) or -1 (in this case the control must be connected).
Returns:
A comma-separated list of name=value pairs (video source statistics).
Return values:
"" Failure (connection to the Access Manager failed).
See also:
SetParams

GetParams

ExtractInteger

ExtractString

ExtractBoolean

ExtractNumber

IVWActiveXComponent

IVWStorageManagerCtrl

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::Port ( [in] long Port )

Sets the TCP port number of the remote manager.

Parameters:
Port the TCP port number of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::Port ( [out, retval] long * Port )

Returns:
the TCP port number of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::Server ( [in] BSTR Hostname )

Sets the host name or IP address of the remote manager.

Parameters:
Hostname the host name or IP address of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::Server ( [out, retval] BSTR * Hostname )

Returns:
the host name or IP address of the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::SetParams | ( | [in] BSTR | bstrParams,
 |  | [in, defaultvalue(-1)] long | lSourceId,
 |  | [out, retval] long * | plError
 | ) |

Sets various video setting parameters for a video source. To extract a particular parameter's value, use the ExtractXXX methods. Available video source parameters:

  • InputConnector [string] : input connector type, depends on the VisioWave Codec board used. Possible values:
    • "default" to reset the input connector to its default value as defined in the VisioWave Central Configuratoin interface.
    • "svideo" or "composite" (VisioWave 1 and PCI2 based chassis).
    • "CompositeA/B/C" (CPCI4 and CPCI4-B based chassis).
    • "sequence" for cycling through the three Composite video entries (CPCI4 and CPCI4-B based chassis).
  • CompositeAOrder [integer] : position of Composite A in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • CompositeBOrder [integer] : position of Composite B in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • CompositeCOrder [integer] : position of Composite C in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • CompositeADisplayMs [integer]: time in ms during which Composite A will be displayed in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • CompositeBDisplayMs [integer]: time in ms during which Composite B will be displayed in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • CompositeCDisplayMs [integer]: time in ms during which Composite C will be displayed in a CPCI4/CPCI4-B input connector sequence (only if InputConnector is set to "sequence").
  • SequencePriority [integer] : input connector priority (0 if not set). Sets priority when choosing input connector. An input connector can be changed only if the new input priority is superior or equal to the actual one.
  • MaxFrameSize [integer] : sets the max field size in KBytes.
  • Bandwidth [integer] : sets the max bandwidth in KBits/s.
  • Quality [integer] : sets the video stream quality. Ranges from 0 (low quality) to 255 (high quality).
  • Skip [integer] : number of fields to skip. Set it to 0 to receive all the fields from the stream. Applicable only if the video source does not use temporal compression.
  • Fps [integer] : fields per second, multiplied by 100. Fps is calculated as follow: Fps = (Video_Standard_Fps*100)/(1+Skip) where Video_Standard_Fps depends on the VideoFormat (ex: PAL_BGHI captures at 50 Fps). Applicable only if the video source does not use temporal compression.
  • FpsNumerator [integer] : fraction numerator used to calculate the real value of Fps (not multiplied by 100). For example, FpsNumerator=5000 and FpsDenominator=200 will give Fps=25. If this parameter is set, "FpsDenominator" must be set too otherwise it is ignored. Applicable only if the video source does not use temporal compression.
  • FpsDenominator [integer] : fraction denominator used to calculate the real value of Fps (not multiplied by 100). For example, FpsNumerator=5000 and FpsDenominator=200 will give Fps=25. If this parameter is set, "FpsNumerator" must be set too otherwise it is ignored. Applicable only if the video source does not use temporal compression.

Parameters:
bstrParams | A comma-separated list of name=value pairs (parameters to set).
lSourceId | Source identifier (returned by the AddSource function of the VWActiveXComponent control, in this case the source must be connected) or -1 (in this case the control must be connected).
See also:
SetParams

GetStat

IVWActiveXComponent

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::Status ( [out, retval] long * Status )

Returns:
the connection status
Return values:
0 | Not connected to the remote manager
1 | Connecting to the remote manager
2 | Connected to the remote manager

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::TimeOut ( [in] long Timeout )

Sets the connection time-out.

Parameters:
Timeout the connection time-out in milliseconds

HRESULT VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2::TimeOut ( [out, retval] long * Timeout )

Returns:
the connection time-out in milliseconds

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Hierarchical Index

VisioWave SDK Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • XVWDISPLAYLib::_IVWActiveXComponentEvents
  • VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents
  • VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents
  • XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents
  • VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents
  • VWEVENTCONTROLLERLib::_IVWEventCtrlEvents
  • VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events
  • VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events
  • VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents
  • VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents
  • VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents
  • VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents
  • XVWTIMELINELib::_IVWTimeLineEvents
  • VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents
  • VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events
  • XVWDISPLAYLib::IVWActiveXComponent
  • VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
  • XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
  • VWEVENTCONTROLLERLib::IVWEventCtrl
  • VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
  • VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • XVWTIMELINELib::IVWTimeLine
  • VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AcknowledgeAlarm() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • AcknowledgeSoftAlarm() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • AddFile() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • AddFileSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddHardSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddHardSourceEx() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddNetworkSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddQueryResults() : XVWTIMELINELib::IVWTimeLine
  • AddQueryTimeSpan() : XVWTIMELINELib::IVWTimeLine
  • AddSource() : XVWDISPLAYLib::IVWActiveXComponent
  • AddSourceOSD() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddSourceOSD2() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddSourceOSD3() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddSourceOSDAtIndex() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddSourceOSDEx() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddSourceOSDEx2() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddStorage() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • AddToGroupAndConnect() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • Alarm() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • AlarmLogQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • AlarmNamesQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • AttachSoundSourceId() : XVWDISPLAYLib::IVWActiveXComponent
  • AttachSourceOsdId() : XVWDISPLAYLib::IVWActiveXComponent
  • AutoSize() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • KeyDown() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • KeyUp() : XVWDISPLAYLib::_IVWActiveXComponentEvents


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • LButtonDblClk() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • LButtonDown() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • LButtonUp() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Left() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • LeftMarkerReached() : XVWTIMELINELib::_IVWTimeLineEvents
  • LinkDown() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents, VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents, VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents, VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents, VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events, VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events, VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents, VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events, VWEVENTCONTROLLERLib::_IVWEventCtrlEvents, VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents, VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents, VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents
  • LinkUp() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents, VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents, VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents, VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents, VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events, VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events, VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents, VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events, VWEVENTCONTROLLERLib::_IVWEventCtrlEvents, VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents, VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents, VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents
  • ListPlugins() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • LoadCustomCycle() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • LoadCycle() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • LoadPicture() : XVWDISPLAYLib::IVWActiveXComponent
  • LoadWinSock2() : XVWDISPLAYLib::IVWActiveXComponent
  • LocalAAMBoard() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • LocalAAMPort() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • LocalCopy() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • LocalToUtc() : XVWTIMELINELib::IVWTimeLine
  • Loop() : XVWDISPLAYLib::IVWActiveXComponent
  • LoopPlayback() : XVWTIMELINELib::IVWTimeLine


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • MButtonDblClk() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • MButtonDown() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • MButtonUp() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • MouseMove() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • MouseWheel() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Move2() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • MoveZoom() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • NextSource() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • OpenLocalAAM() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • OutputToVWBoardOff() : XVWDISPLAYLib::IVWActiveXComponent
  • OutputToVWBoardOn() : XVWDISPLAYLib::IVWActiveXComponent
  • OutputToVWBoardOnEx() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • Zoom() : XVWTIMELINELib::IVWTimeLine, XVWDISPLAYLib::IVWActiveXComponent
  • Zoom2() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • ZoomIn() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • ZoomOut() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • BackColor() : XVWDISPLAYLib::IVWActiveXComponent
  • BeginCustomCycle() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • BeginHardStorages() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • BeginNetworkStorages() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • Blocking() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • BufferingRecordOn() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CallMCLFunction() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • CaptureScreen() : XVWDISPLAYLib::IVWActiveXComponent
  • CenterZoom() : XVWDISPLAYLib::IVWActiveXComponent
  • Char() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Clear() : XVWTIMELINELib::IVWTimeLine
  • ClearOsd() : XVWDISPLAYLib::IVWActiveXComponent
  • ClearSourceOSDAtIndex() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • CloseLocalAAM() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • Connect() : XVWDISPLAYLib::_IVWActiveXComponentEvents, XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents, VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
  • ConnectId() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • DatabaseQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • DecoderColorMode() : XVWDISPLAYLib::IVWActiveXComponent
  • DecoderMode() : XVWDISPLAYLib::IVWActiveXComponent
  • DecoderParity() : XVWDISPLAYLib::IVWActiveXComponent
  • DecoderSize() : XVWDISPLAYLib::IVWActiveXComponent
  • DeleteFromGroup() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • DetachSoundSourceId() : XVWDISPLAYLib::IVWActiveXComponent
  • DetachSourceOsdId() : XVWDISPLAYLib::IVWActiveXComponent
  • DigitalInputStatus() : VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
  • Disconnect() : XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents, VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
  • DisconnectId() : XVWDISPLAYLib::IVWActiveXComponent
  • DisplayModes() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • DisplayOsd() : XVWDISPLAYLib::IVWActiveXComponent
  • Down() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • DownLeft() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • DownRight() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • DragAcceptFiles() : XVWDISPLAYLib::IVWActiveXComponent
  • DropFiles() : XVWDISPLAYLib::_IVWActiveXComponentEvents


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EndCustomCycle() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • EndStorages() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • EnumSourcesIdsBegin() : XVWDISPLAYLib::IVWActiveXComponent
  • EnumSourcesIdsEnd() : XVWDISPLAYLib::IVWActiveXComponent
  • EnumSourcesIdsNext() : XVWDISPLAYLib::IVWActiveXComponent
  • Eof() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Erase() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • EraseBkgnd() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Error() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Event() : VWEVENTCONTROLLERLib::_IVWEventCtrlEvents
  • EventEx() : VWEVENTCONTROLLERLib::_IVWEventCtrlEvents
  • ExtractBoolean() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • ExtractInteger() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • ExtractNumber() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • ExtractString() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FlushGroup() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • FocusAuto() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • FocusFar() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • FocusManual() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • FocusNear() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • ForbidBlocking() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • Frame() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • FreezeEvents() : XVWDISPLAYLib::IVWActiveXComponent
  • FullScreenOff() : XVWDISPLAYLib::IVWActiveXComponent
  • FullScreenOn() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GetActiveSourceId() : XVWDISPLAYLib::IVWActiveXComponent
  • GetAlarmName() : XVWTIMELINELib::IVWTimeLine
  • GetAlarms() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetAlarmThresholds() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetAttachedCount() : XVWDISPLAYLib::IVWActiveXComponent
  • GetAudioPortsStats() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetBitsPerSample() : XVWDISPLAYLib::IVWActiveXComponent
  • GetChannels() : XVWDISPLAYLib::IVWActiveXComponent
  • GetChunk() : XVWDISPLAYLib::IVWActiveXComponent
  • GetConfig() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • GetCurrentPosition() : XVWTIMELINELib::IVWTimeLine
  • GetCycleItemInfo() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • GetDC() : XVWDISPLAYLib::IVWActiveXComponent
  • GetDiskInfos() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetEnd() : XVWTIMELINELib::IVWTimeLine
  • GetErrorText() : XVWDISPLAYLib::IVWActiveXComponent
  • GetFields() : XVWDISPLAYLib::IVWActiveXComponent
  • GetFirstTimeSpan() : XVWTIMELINELib::IVWTimeLine
  • GetFPS() : XVWTIMELINELib::IVWTimeLine, XVWDISPLAYLib::IVWActiveXComponent
  • GetFrame() : XVWDISPLAYLib::IVWActiveXComponent
  • GetFrameSize() : XVWDISPLAYLib::IVWActiveXComponent
  • GetFramesLost() : XVWDISPLAYLib::IVWActiveXComponent
  • GetFramesLostEx() : XVWDISPLAYLib::IVWActiveXComponent
  • GetHost() : XVWTIMELINELib::IVWTimeLine
  • GetId() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • GetInfo() : XVWDISPLAYLib::IVWActiveXComponent
  • GetLastError() : XVWDISPLAYLib::IVWActiveXComponent, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • GetLeftMarker() : XVWTIMELINELib::IVWTimeLine
  • GetMaxEnd() : XVWTIMELINELib::IVWTimeLine
  • GetMaxFrameSize() : XVWDISPLAYLib::IVWActiveXComponent
  • GetMaxRate() : XVWDISPLAYLib::IVWActiveXComponent
  • GetMinStart() : XVWTIMELINELib::IVWTimeLine
  • GetModuleInfos() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetName() : XVWTIMELINELib::IVWTimeLine
  • GetNetworkAdapterInfos() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetNetworkAdapterStats() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetNext() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • GetNextTimeSpan() : XVWTIMELINELib::IVWTimeLine
  • GetNumberOfAlarms() : XVWTIMELINELib::IVWTimeLine
  • GetNumberOfCycleItems() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • GetNumberOfSources() : XVWTIMELINELib::IVWTimeLine
  • GetNumberPrepos() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • GetPanSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • GetParams() : VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
  • GetParamsOf() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • GetPluginInfos() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetPort() : XVWTIMELINELib::IVWTimeLine
  • GetPropertyBag() : XVWDISPLAYLib::IVWActiveXComponent
  • GetQuality() : XVWDISPLAYLib::IVWActiveXComponent
  • GetRaidStatus() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetRate() : XVWDISPLAYLib::IVWActiveXComponent
  • GetRateEx() : XVWDISPLAYLib::IVWActiveXComponent
  • GetRealFPS() : XVWDISPLAYLib::IVWActiveXComponent
  • GetRightMarker() : XVWTIMELINELib::IVWTimeLine
  • GetSampleRate() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSkippedFields() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSmartStatus() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetSoftAlarms() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetSoftAlarmThresholds() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetSoundInfo() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSource() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceCategory() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceId() : XVWTIMELINELib::IVWTimeLine
  • GetSourcePort() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceProtocol() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceType() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceURL() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceURLEx() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • GetStart() : XVWTIMELINELib::IVWTimeLine
  • GetStat() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • GetStatOf() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • GetStats() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetStatusOf() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • GetStream() : XVWTIMELINELib::IVWTimeLine
  • GetSystemHealthStats() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetSystemID() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetSystemInfos() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetTemporalLevel() : XVWDISPLAYLib::IVWActiveXComponent
  • GetTiltSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • GetTime() : XVWDISPLAYLib::IVWActiveXComponent, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetTotalBytes() : XVWDISPLAYLib::IVWActiveXComponent
  • GetTotalFrames() : XVWDISPLAYLib::IVWActiveXComponent
  • GetTotalFramesEx() : XVWDISPLAYLib::IVWActiveXComponent
  • GetTotalTime() : XVWDISPLAYLib::IVWActiveXComponent
  • GetTotalTimeEx() : XVWDISPLAYLib::IVWActiveXComponent
  • GetType() : XVWTIMELINELib::IVWTimeLine
  • GetTypeEx() : XVWTIMELINELib::IVWTimeLine
  • GetUptime() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetVideoCircuits() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetVideoFormat() : XVWDISPLAYLib::IVWActiveXComponent
  • GetVideoInfo() : XVWDISPLAYLib::IVWActiveXComponent
  • GetVideoPortsStats() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetVidX() : XVWDISPLAYLib::IVWActiveXComponent
  • GetVidY() : XVWDISPLAYLib::IVWActiveXComponent
  • GetVisibleRangeLeft() : XVWTIMELINELib::IVWTimeLine
  • GetVisibleRangeRight() : XVWTIMELINELib::IVWTimeLine
  • GetVWBoards() : XVWDISPLAYLib::IVWActiveXComponent
  • GetWindow() : XVWDISPLAYLib::IVWActiveXComponent
  • GetZoom() : XVWDISPLAYLib::IVWActiveXComponent
  • GetZoomSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • GUI() : XVWTIMELINELib::IVWTimeLine


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HasSync() : XVWDISPLAYLib::IVWActiveXComponent
  • Home() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • Iris() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • IrisAuto() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • IrisClose() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • IrisOpen() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • IsAttached() : XVWDISPLAYLib::IVWActiveXComponent
  • IsConnected() : XVWDISPLAYLib::IVWActiveXComponent
  • IsFullScreen() : XVWDISPLAYLib::IVWActiveXComponent
  • IsHighlighted() : XVWTIMELINELib::IVWTimeLine
  • IsLooping() : XVWDISPLAYLib::IVWActiveXComponent
  • IsPaused() : XVWTIMELINELib::IVWTimeLine
  • IsPlayingVWBoard() : XVWDISPLAYLib::IVWActiveXComponent
  • IsProtected() : XVWTIMELINELib::IVWTimeLine
  • IsRecording() : XVWDISPLAYLib::IVWActiveXComponent
  • IsValidId() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • Pause() : XVWTIMELINELib::IVWTimeLine, XVWDISPLAYLib::IVWActiveXComponent, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • Picture() : XVWDISPLAYLib::IVWActiveXComponent
  • Play() : XVWTIMELINELib::IVWTimeLine
  • Port() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • PreviousSource() : XVWDISPLAYLib::IVWActiveXComponent
  • PrintScreen() : XVWDISPLAYLib::IVWActiveXComponent
  • Protect() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • ProtectedLogQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RButtonDblClk() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • RButtonDown() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • RButtonUp() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Reboot() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • RecallMemory() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • RecordOff() : XVWDISPLAYLib::IVWActiveXComponent
  • RecordOn() : XVWDISPLAYLib::IVWActiveXComponent
  • RecordOnEx() : XVWDISPLAYLib::IVWActiveXComponent
  • Refresh() : XVWTIMELINELib::IVWTimeLine, XVWDISPLAYLib::IVWActiveXComponent
  • Rehash() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • RehashGroup() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • RelayOutputStatus() : VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
  • ReleaseDC() : XVWDISPLAYLib::IVWActiveXComponent
  • ReleaseQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • RemoteCopy() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • RemoveAlarmByDate() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • RemoveAlarmByInterval() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • RemoveOsd() : XVWDISPLAYLib::IVWActiveXComponent
  • RemoveQueryTimeSpan() : XVWTIMELINELib::IVWTimeLine
  • RemoveSourceId() : XVWDISPLAYLib::IVWActiveXComponent
  • RemoveText() : XVWDISPLAYLib::IVWActiveXComponent
  • ResetGroup() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • ResetMonitor() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • ResetSource() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • Resume() : XVWDISPLAYLib::IVWActiveXComponent, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • Right() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • RightMarkerReached() : XVWTIMELINELib::_IVWTimeLineEvents
  • Running() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • Seek() : XVWTIMELINELib::IVWTimeLine
  • SeekFrame() : XVWDISPLAYLib::IVWActiveXComponent
  • SeekTime() : XVWDISPLAYLib::IVWActiveXComponent
  • SelectMonitoredChannel() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • Server() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetActiveSourceId() : XVWDISPLAYLib::IVWActiveXComponent
  • SetAlarmEnabled() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • SetAlarmThresholds() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • SetBackLight() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetBoardID() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • SetConnectionMode() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • SetDynamicOSD() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetFileBackupSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetFileSource() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetFocusSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetGoingHighEvent() : VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
  • SetGoingLowEvent() : VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
  • SetGUIParams() : XVWTIMELINELib::IVWTimeLine
  • SetHardBackupSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetHardSource() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetId() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • SetIrisSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetLastError() : XVWDISPLAYLib::IVWActiveXComponent
  • SetLatency() : XVWTIMELINELib::IVWTimeLine
  • SetLeftMarker() : XVWTIMELINELib::IVWTimeLine
  • SetLocalAAM_AtmConfig() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetLocalAAM_IpmConfig() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetLocalAAM_UdpConfig() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetMonitorOSD() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetNetSource() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetNetworkBackupSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetOSDFormat() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetPanSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetParams() : VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetParamsOf() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetPlayRate() : XVWTIMELINELib::IVWTimeLine
  • SetPort() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • SetQuality() : XVWDISPLAYLib::IVWActiveXComponent
  • SetQueue() : XVWDISPLAYLib::IVWActiveXComponent
  • SetRate() : XVWDISPLAYLib::IVWActiveXComponent
  • SetRightMarker() : XVWTIMELINELib::IVWTimeLine
  • SetServer() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • SetSoftAlarmEnabled() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • SetSoftAlarmThresholds() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • SetSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetSystemID() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • SetTiltSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetTime() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • SetTimeout() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • SetTimeOut() : XVWTIMELINELib::IVWTimeLine
  • SetVideoFormat() : XVWDISPLAYLib::IVWActiveXComponent
  • SetVisibleRange() : XVWTIMELINELib::IVWTimeLine
  • SetZoomSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • ShowCursor() : XVWDISPLAYLib::IVWActiveXComponent
  • Signal() : VWEVENTCONTROLLERLib::IVWEventCtrl
  • SignalEx() : VWEVENTCONTROLLERLib::IVWEventCtrl
  • SoftReboot() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • SourcesQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • Start() : XVWDISPLAYLib::IVWActiveXComponent
  • StartStorages() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • Status() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
  • Step() : XVWTIMELINELib::IVWTimeLine
  • Stop() : XVWDISPLAYLib::IVWActiveXComponent
  • StopFocus() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • StopIris() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • StopMvt() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • StopStorages() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • StopZoom() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • StoreMemory() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • StreamFiles() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • StreamMic() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • StringToParam() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • Subscribe() : VWEVENTCONTROLLERLib::IVWEventCtrl
  • SwitchToNextSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SwitchToPreviousSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SwitchToSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • Synchronize() : XVWDISPLAYLib::IVWActiveXComponent
  • SyncPlayback() : XVWTIMELINELib::IVWTimeLine
  • SysKeyDown() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • SysKeyUp() : XVWDISPLAYLib::_IVWActiveXComponentEvents


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TextOut() : XVWDISPLAYLib::IVWActiveXComponent
  • TextOutEx() : XVWDISPLAYLib::IVWActiveXComponent
  • TimedOut() : VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events
  • TimeOut() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • TimeZone() : XVWTIMELINELib::IVWTimeLine


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UnloadWinSock2() : XVWDISPLAYLib::IVWActiveXComponent
  • Unprotect() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • UnsetBackLight() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • Unsubscribe() : VWEVENTCONTROLLERLib::IVWEventCtrl
  • Up() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • UpdateOsd() : XVWDISPLAYLib::IVWActiveXComponent
  • UpdateStatus() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • UpLeft() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • UpRight() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • UtcToLocal() : XVWTIMELINELib::IVWTimeLine


VisioWave SDK: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • Version() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • VideoHeight() : XVWDISPLAYLib::IVWActiveXComponent
  • VideoMode() : XVWDISPLAYLib::IVWActiveXComponent
  • VideoWidth() : XVWDISPLAYLib::IVWActiveXComponent
  • VideoZoom() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members - Functions

- a -

  • AcknowledgeAlarm() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • AcknowledgeSoftAlarm() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • AddFile() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • AddFileSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddHardSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddHardSourceEx() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddNetworkSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddQueryResults() : XVWTIMELINELib::IVWTimeLine
  • AddQueryTimeSpan() : XVWTIMELINELib::IVWTimeLine
  • AddSource() : XVWDISPLAYLib::IVWActiveXComponent
  • AddSourceOSD() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddSourceOSD2() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddSourceOSD3() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddSourceOSDAtIndex() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddSourceOSDEx() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddSourceOSDEx2() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • AddStorage() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • AddToGroupAndConnect() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • Alarm() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • AlarmLogQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • AlarmNamesQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • AttachSoundSourceId() : XVWDISPLAYLib::IVWActiveXComponent
  • AttachSourceOsdId() : XVWDISPLAYLib::IVWActiveXComponent
  • AutoSize() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members - Functions

- k -

  • KeyDown() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • KeyUp() : XVWDISPLAYLib::_IVWActiveXComponentEvents


VisioWave SDK: Class Members - Functions

- l -

  • LButtonDblClk() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • LButtonDown() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • LButtonUp() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Left() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • LeftMarkerReached() : XVWTIMELINELib::_IVWTimeLineEvents
  • LinkDown() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents, VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents, VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents, VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents, VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events, VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events, VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents, VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events, VWEVENTCONTROLLERLib::_IVWEventCtrlEvents, VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents, VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents, VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents
  • LinkUp() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents, VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents, VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents, VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents, VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events, VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events, VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents, VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events, VWEVENTCONTROLLERLib::_IVWEventCtrlEvents, VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents, VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents, VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents
  • ListPlugins() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • LoadCustomCycle() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • LoadCycle() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • LoadPicture() : XVWDISPLAYLib::IVWActiveXComponent
  • LoadWinSock2() : XVWDISPLAYLib::IVWActiveXComponent
  • LocalAAMBoard() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • LocalAAMPort() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • LocalCopy() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • LocalToUtc() : XVWTIMELINELib::IVWTimeLine
  • Loop() : XVWDISPLAYLib::IVWActiveXComponent
  • LoopPlayback() : XVWTIMELINELib::IVWTimeLine


VisioWave SDK: Class Members - Functions

- m -

  • MButtonDblClk() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • MButtonDown() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • MButtonUp() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • MouseMove() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • MouseWheel() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Move2() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • MoveZoom() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members - Functions

- n -

  • NextSource() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members - Functions

- o -

  • OpenLocalAAM() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • OutputToVWBoardOff() : XVWDISPLAYLib::IVWActiveXComponent
  • OutputToVWBoardOn() : XVWDISPLAYLib::IVWActiveXComponent
  • OutputToVWBoardOnEx() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members - Functions

- z -

  • Zoom() : XVWTIMELINELib::IVWTimeLine, XVWDISPLAYLib::IVWActiveXComponent
  • Zoom2() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • ZoomIn() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • ZoomOut() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2


VisioWave SDK: Class Members - Functions

- b -

  • BackColor() : XVWDISPLAYLib::IVWActiveXComponent
  • BeginCustomCycle() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • BeginHardStorages() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • BeginNetworkStorages() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • Blocking() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • BufferingRecordOn() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members - Functions

- c -

  • CallMCLFunction() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • CaptureScreen() : XVWDISPLAYLib::IVWActiveXComponent
  • CenterZoom() : XVWDISPLAYLib::IVWActiveXComponent
  • Char() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Clear() : XVWTIMELINELib::IVWTimeLine
  • ClearOsd() : XVWDISPLAYLib::IVWActiveXComponent
  • ClearSourceOSDAtIndex() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • CloseLocalAAM() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • Connect() : XVWDISPLAYLib::_IVWActiveXComponentEvents, XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents, VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
  • ConnectId() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members - Functions

- d -

  • DatabaseQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • DecoderColorMode() : XVWDISPLAYLib::IVWActiveXComponent
  • DecoderMode() : XVWDISPLAYLib::IVWActiveXComponent
  • DecoderParity() : XVWDISPLAYLib::IVWActiveXComponent
  • DecoderSize() : XVWDISPLAYLib::IVWActiveXComponent
  • DeleteFromGroup() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • DetachSoundSourceId() : XVWDISPLAYLib::IVWActiveXComponent
  • DetachSourceOsdId() : XVWDISPLAYLib::IVWActiveXComponent
  • DigitalInputStatus() : VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
  • Disconnect() : XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents, VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
  • DisconnectId() : XVWDISPLAYLib::IVWActiveXComponent
  • DisplayModes() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • DisplayOsd() : XVWDISPLAYLib::IVWActiveXComponent
  • Down() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • DownLeft() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • DownRight() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • DragAcceptFiles() : XVWDISPLAYLib::IVWActiveXComponent
  • DropFiles() : XVWDISPLAYLib::_IVWActiveXComponentEvents


VisioWave SDK: Class Members - Functions

- e -

  • EndCustomCycle() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • EndStorages() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • EnumSourcesIdsBegin() : XVWDISPLAYLib::IVWActiveXComponent
  • EnumSourcesIdsEnd() : XVWDISPLAYLib::IVWActiveXComponent
  • EnumSourcesIdsNext() : XVWDISPLAYLib::IVWActiveXComponent
  • Eof() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Erase() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • EraseBkgnd() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Error() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Event() : VWEVENTCONTROLLERLib::_IVWEventCtrlEvents
  • EventEx() : VWEVENTCONTROLLERLib::_IVWEventCtrlEvents
  • ExtractBoolean() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • ExtractInteger() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • ExtractNumber() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • ExtractString() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl


VisioWave SDK: Class Members - Functions

- f -

  • FlushGroup() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • FocusAuto() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • FocusFar() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • FocusManual() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • FocusNear() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • ForbidBlocking() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • Frame() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • FreezeEvents() : XVWDISPLAYLib::IVWActiveXComponent
  • FullScreenOff() : XVWDISPLAYLib::IVWActiveXComponent
  • FullScreenOn() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members - Functions

- g -

  • GetActiveSourceId() : XVWDISPLAYLib::IVWActiveXComponent
  • GetAlarmName() : XVWTIMELINELib::IVWTimeLine
  • GetAlarms() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetAlarmThresholds() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetAttachedCount() : XVWDISPLAYLib::IVWActiveXComponent
  • GetAudioPortsStats() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetBitsPerSample() : XVWDISPLAYLib::IVWActiveXComponent
  • GetChannels() : XVWDISPLAYLib::IVWActiveXComponent
  • GetChunk() : XVWDISPLAYLib::IVWActiveXComponent
  • GetConfig() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • GetCurrentPosition() : XVWTIMELINELib::IVWTimeLine
  • GetCycleItemInfo() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • GetDC() : XVWDISPLAYLib::IVWActiveXComponent
  • GetDiskInfos() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetEnd() : XVWTIMELINELib::IVWTimeLine
  • GetErrorText() : XVWDISPLAYLib::IVWActiveXComponent
  • GetFields() : XVWDISPLAYLib::IVWActiveXComponent
  • GetFirstTimeSpan() : XVWTIMELINELib::IVWTimeLine
  • GetFPS() : XVWTIMELINELib::IVWTimeLine, XVWDISPLAYLib::IVWActiveXComponent
  • GetFrame() : XVWDISPLAYLib::IVWActiveXComponent
  • GetFrameSize() : XVWDISPLAYLib::IVWActiveXComponent
  • GetFramesLost() : XVWDISPLAYLib::IVWActiveXComponent
  • GetFramesLostEx() : XVWDISPLAYLib::IVWActiveXComponent
  • GetHost() : XVWTIMELINELib::IVWTimeLine
  • GetId() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • GetInfo() : XVWDISPLAYLib::IVWActiveXComponent
  • GetLastError() : XVWDISPLAYLib::IVWActiveXComponent, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • GetLeftMarker() : XVWTIMELINELib::IVWTimeLine
  • GetMaxEnd() : XVWTIMELINELib::IVWTimeLine
  • GetMaxFrameSize() : XVWDISPLAYLib::IVWActiveXComponent
  • GetMaxRate() : XVWDISPLAYLib::IVWActiveXComponent
  • GetMinStart() : XVWTIMELINELib::IVWTimeLine
  • GetModuleInfos() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetName() : XVWTIMELINELib::IVWTimeLine
  • GetNetworkAdapterInfos() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetNetworkAdapterStats() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetNext() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • GetNextTimeSpan() : XVWTIMELINELib::IVWTimeLine
  • GetNumberOfAlarms() : XVWTIMELINELib::IVWTimeLine
  • GetNumberOfCycleItems() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • GetNumberOfSources() : XVWTIMELINELib::IVWTimeLine
  • GetNumberPrepos() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • GetPanSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • GetParams() : VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
  • GetParamsOf() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • GetPluginInfos() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetPort() : XVWTIMELINELib::IVWTimeLine
  • GetPropertyBag() : XVWDISPLAYLib::IVWActiveXComponent
  • GetQuality() : XVWDISPLAYLib::IVWActiveXComponent
  • GetRaidStatus() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetRate() : XVWDISPLAYLib::IVWActiveXComponent
  • GetRateEx() : XVWDISPLAYLib::IVWActiveXComponent
  • GetRealFPS() : XVWDISPLAYLib::IVWActiveXComponent
  • GetRightMarker() : XVWTIMELINELib::IVWTimeLine
  • GetSampleRate() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSkippedFields() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSmartStatus() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetSoftAlarms() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetSoftAlarmThresholds() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetSoundInfo() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSource() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceCategory() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceId() : XVWTIMELINELib::IVWTimeLine
  • GetSourcePort() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceProtocol() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceType() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceURL() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSourceURLEx() : XVWDISPLAYLib::IVWActiveXComponent
  • GetSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • GetStart() : XVWTIMELINELib::IVWTimeLine
  • GetStat() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • GetStatOf() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • GetStats() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetStatusOf() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • GetStream() : XVWTIMELINELib::IVWTimeLine
  • GetSystemHealthStats() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetSystemID() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetSystemInfos() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetTemporalLevel() : XVWDISPLAYLib::IVWActiveXComponent
  • GetTiltSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • GetTime() : XVWDISPLAYLib::IVWActiveXComponent, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • GetTotalBytes() : XVWDISPLAYLib::IVWActiveXComponent
  • GetTotalFrames() : XVWDISPLAYLib::IVWActiveXComponent
  • GetTotalFramesEx() : XVWDISPLAYLib::IVWActiveXComponent
  • GetTotalTime() : XVWDISPLAYLib::IVWActiveXComponent
  • GetTotalTimeEx() : XVWDISPLAYLib::IVWActiveXComponent
  • GetType() : XVWTIMELINELib::IVWTimeLine
  • GetTypeEx() : XVWTIMELINELib::IVWTimeLine
  • GetUptime() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetVideoCircuits() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetVideoFormat() : XVWDISPLAYLib::IVWActiveXComponent
  • GetVideoInfo() : XVWDISPLAYLib::IVWActiveXComponent
  • GetVideoPortsStats() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • GetVidX() : XVWDISPLAYLib::IVWActiveXComponent
  • GetVidY() : XVWDISPLAYLib::IVWActiveXComponent
  • GetVisibleRangeLeft() : XVWTIMELINELib::IVWTimeLine
  • GetVisibleRangeRight() : XVWTIMELINELib::IVWTimeLine
  • GetVWBoards() : XVWDISPLAYLib::IVWActiveXComponent
  • GetWindow() : XVWDISPLAYLib::IVWActiveXComponent
  • GetZoom() : XVWDISPLAYLib::IVWActiveXComponent
  • GetZoomSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • GUI() : XVWTIMELINELib::IVWTimeLine


VisioWave SDK: Class Members - Functions

- h -

  • HasSync() : XVWDISPLAYLib::IVWActiveXComponent
  • Home() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2


VisioWave SDK: Class Members - Functions

- i -

  • Iris() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • IrisAuto() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • IrisClose() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • IrisOpen() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • IsAttached() : XVWDISPLAYLib::IVWActiveXComponent
  • IsConnected() : XVWDISPLAYLib::IVWActiveXComponent
  • IsFullScreen() : XVWDISPLAYLib::IVWActiveXComponent
  • IsHighlighted() : XVWTIMELINELib::IVWTimeLine
  • IsLooping() : XVWDISPLAYLib::IVWActiveXComponent
  • IsPaused() : XVWTIMELINELib::IVWTimeLine
  • IsPlayingVWBoard() : XVWDISPLAYLib::IVWActiveXComponent
  • IsProtected() : XVWTIMELINELib::IVWTimeLine
  • IsRecording() : XVWDISPLAYLib::IVWActiveXComponent
  • IsValidId() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members - Functions

- p -

  • Pause() : XVWTIMELINELib::IVWTimeLine, XVWDISPLAYLib::IVWActiveXComponent, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • Picture() : XVWDISPLAYLib::IVWActiveXComponent
  • Play() : XVWTIMELINELib::IVWTimeLine
  • Port() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • PreviousSource() : XVWDISPLAYLib::IVWActiveXComponent
  • PrintScreen() : XVWDISPLAYLib::IVWActiveXComponent
  • Protect() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • ProtectedLogQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl


VisioWave SDK: Class Members - Functions

- r -

  • RButtonDblClk() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • RButtonDown() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • RButtonUp() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • Reboot() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • RecallMemory() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • RecordOff() : XVWDISPLAYLib::IVWActiveXComponent
  • RecordOn() : XVWDISPLAYLib::IVWActiveXComponent
  • RecordOnEx() : XVWDISPLAYLib::IVWActiveXComponent
  • Refresh() : XVWTIMELINELib::IVWTimeLine, XVWDISPLAYLib::IVWActiveXComponent
  • Rehash() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • RehashGroup() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • RelayOutputStatus() : VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
  • ReleaseDC() : XVWDISPLAYLib::IVWActiveXComponent
  • ReleaseQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • RemoteCopy() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • RemoveAlarmByDate() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • RemoveAlarmByInterval() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • RemoveOsd() : XVWDISPLAYLib::IVWActiveXComponent
  • RemoveQueryTimeSpan() : XVWTIMELINELib::IVWTimeLine
  • RemoveSourceId() : XVWDISPLAYLib::IVWActiveXComponent
  • RemoveText() : XVWDISPLAYLib::IVWActiveXComponent
  • ResetGroup() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • ResetMonitor() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • ResetSource() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • Resume() : XVWDISPLAYLib::IVWActiveXComponent, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • Right() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • RightMarkerReached() : XVWTIMELINELib::_IVWTimeLineEvents
  • Running() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Class Members - Functions

- s -

  • Seek() : XVWTIMELINELib::IVWTimeLine
  • SeekFrame() : XVWDISPLAYLib::IVWActiveXComponent
  • SeekTime() : XVWDISPLAYLib::IVWActiveXComponent
  • SelectMonitoredChannel() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • Server() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetActiveSourceId() : XVWDISPLAYLib::IVWActiveXComponent
  • SetAlarmEnabled() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • SetAlarmThresholds() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • SetBackLight() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetBoardID() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • SetConnectionMode() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • SetDynamicOSD() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetFileBackupSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetFileSource() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetFocusSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetGoingHighEvent() : VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
  • SetGoingLowEvent() : VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
  • SetGUIParams() : XVWTIMELINELib::IVWTimeLine
  • SetHardBackupSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetHardSource() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetId() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • SetIrisSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetLastError() : XVWDISPLAYLib::IVWActiveXComponent
  • SetLatency() : XVWTIMELINELib::IVWTimeLine
  • SetLeftMarker() : XVWTIMELINELib::IVWTimeLine
  • SetLocalAAM_AtmConfig() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetLocalAAM_IpmConfig() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetLocalAAM_UdpConfig() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetMonitorOSD() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetNetSource() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetNetworkBackupSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetOSDFormat() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SetPanSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetParams() : VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetParamsOf() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • SetPlayRate() : XVWTIMELINELib::IVWTimeLine
  • SetPort() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • SetQuality() : XVWDISPLAYLib::IVWActiveXComponent
  • SetQueue() : XVWDISPLAYLib::IVWActiveXComponent
  • SetRate() : XVWDISPLAYLib::IVWActiveXComponent
  • SetRightMarker() : XVWTIMELINELib::IVWTimeLine
  • SetServer() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • SetSoftAlarmEnabled() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • SetSoftAlarmThresholds() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • SetSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetSystemID() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • SetTiltSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • SetTime() : VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
  • SetTimeout() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • SetTimeOut() : XVWTIMELINELib::IVWTimeLine
  • SetVideoFormat() : XVWDISPLAYLib::IVWActiveXComponent
  • SetVisibleRange() : XVWTIMELINELib::IVWTimeLine
  • SetZoomSpeed() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • ShowCursor() : XVWDISPLAYLib::IVWActiveXComponent
  • Signal() : VWEVENTCONTROLLERLib::IVWEventCtrl
  • SignalEx() : VWEVENTCONTROLLERLib::IVWEventCtrl
  • SoftReboot() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
  • SourcesQuery() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • Start() : XVWDISPLAYLib::IVWActiveXComponent
  • StartStorages() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • Status() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
  • Step() : XVWTIMELINELib::IVWTimeLine
  • Stop() : XVWDISPLAYLib::IVWActiveXComponent
  • StopFocus() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • StopIris() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • StopMvt() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • StopStorages() : VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
  • StopZoom() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • StoreMemory() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • StreamFiles() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • StreamMic() : VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • StringToParam() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • Subscribe() : VWEVENTCONTROLLERLib::IVWEventCtrl
  • SwitchToNextSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SwitchToPreviousSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • SwitchToSource() : VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
  • Synchronize() : XVWDISPLAYLib::IVWActiveXComponent
  • SyncPlayback() : XVWTIMELINELib::IVWTimeLine
  • SysKeyDown() : XVWDISPLAYLib::_IVWActiveXComponentEvents
  • SysKeyUp() : XVWDISPLAYLib::_IVWActiveXComponentEvents


VisioWave SDK: Class Members - Functions

- t -

  • TextOut() : XVWDISPLAYLib::IVWActiveXComponent
  • TextOutEx() : XVWDISPLAYLib::IVWActiveXComponent
  • TimedOut() : VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events
  • TimeOut() : VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, VWEVENTCONTROLLERLib::IVWEventCtrl, VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
  • TimeZone() : XVWTIMELINELib::IVWTimeLine


VisioWave SDK: Class Members - Functions

- u -

  • UnloadWinSock2() : XVWDISPLAYLib::IVWActiveXComponent
  • Unprotect() : VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
  • UnsetBackLight() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • Unsubscribe() : VWEVENTCONTROLLERLib::IVWEventCtrl
  • Up() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • UpdateOsd() : XVWDISPLAYLib::IVWActiveXComponent
  • UpdateStatus() : XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
  • UpLeft() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • UpRight() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • UtcToLocal() : XVWTIMELINELib::IVWTimeLine


VisioWave SDK: Class Members - Functions

- v -

  • Version() : VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
  • VideoHeight() : XVWDISPLAYLib::IVWActiveXComponent
  • VideoMode() : XVWDISPLAYLib::IVWActiveXComponent
  • VideoWidth() : XVWDISPLAYLib::IVWActiveXComponent
  • VideoZoom() : XVWDISPLAYLib::IVWActiveXComponent


VisioWave SDK: Member List

VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl Member List

This is the complete list of members for VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl, including all inherited members.

AddToGroupAndConnect([out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
Blocking([out, retval] BOOL *Blocking) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
Blocking([in] BOOL Blocking) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
CloseLocalAAM() | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
DeleteFromGroup([in] BSTR Name,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
ExtractBoolean([in] BSTR Parameter,[in] BSTR Params,[out, retval] BOOL *Value) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
ExtractInteger([in] BSTR Parameter,[in] BSTR Params,[out, retval] long *Value) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
ExtractNumber([in] BSTR Parameter,[in] BSTR Params,[out, retval] double *Value) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
ExtractString([in] BSTR Parameter,[in] BSTR Params,[out, retval] BSTR *Value) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
FlushGroup() | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
GetId([out, retval] long *pInterface) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
GetParamsOf([in] BSTR Name,[out, retval] BSTR *Params) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
GetStatOf([in] BSTR bstrName,[out, retval] BSTR *Params) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
GetStatusOf([in] BSTR Name,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
LocalAAMBoard([out, retval] long *LocalBoard) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
LocalAAMPort([out, retval] long *LocalPort) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
OpenLocalAAM([in] long Port,[in] BSTR Connector,[in] long Board,[in] long TargetRate,[in] BSTR Id,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
Port([out, retval] long *Port) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
Port([in] long Port) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
Rehash([in] BSTR Name,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
RehashGroup() | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
ResetGroup() | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
ResetSource() | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
Server([out, retval] BSTR *Hostname) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
Server([in] BSTR Hostname) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
SetFileSource([in] BSTR FileSource) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
SetHardSource([in] long CardNumber,[in] BSTR Connector,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
SetLocalAAM_AtmConfig([in] BOOL Available,[in] BOOL Multicast,[in] BSTR QOS,[in] long OfInterface,[in] long Chunk,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
SetLocalAAM_IpmConfig([in] BOOL Available,[in] long OfInterface,[in] long Precedence,[in] BSTR Addr,[in] long Port,[in] long TTL,[in] long MTU,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
SetLocalAAM_UdpConfig([in] BOOL Available,[in] long OfInterface,[in] long Precedence,[in] long SourcePort,[in] long MTU,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
SetNetSource([in] BSTR Proto,[in] BSTR Host,[in] long Port,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
SetParams([in] BSTR Params) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
SetParamsOf([in] BSTR Name,[in] BSTR Params,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
StreamFiles([in] BSTR Files,[in] BOOL Looping,[out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
StreamMic([out, retval] long *Result) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
TimeOut([out, retval] long *Timeout) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl
TimeOut([in] long Timeout) | VWAUDIOOUTPUTCONTROLLERLib::IVWAudioOutputCtrl


VisioWave SDK: Member List

VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents Member List

This is the complete list of members for VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents, including all inherited members.

LinkDown([in] BSTR Name,[in] BSTR TextError) | VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents
LinkUp([in] BSTR Name) | VWAUDIOOUTPUTCONTROLLERLib::_IVWAudioOutputCtrlEvents


VisioWave SDK: Member List

VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl Member List

This is the complete list of members for VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl, including all inherited members.

Blocking([out, retval] BOOL *Blocking) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
Blocking([in] BOOL Blocking) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
Connect([out, retval] long *Result) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
Disconnect() | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
GetId([out, retval] long *pInterface) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
Port([out, retval] long *Port) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
Port([in] long Port) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
Rehash([out, retval] long *Result) (defined in VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
RelayOutputStatus([out, retval] long *state) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
RelayOutputStatus([in] long state) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
Server([out, retval] BSTR *Hostname) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
Server([in] BSTR Hostname) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
Status([out, retval] long *Status) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
TimeOut([out, retval] long *Timeout) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl
TimeOut([in] long Timeout) | VWDIGITALIOCONTROLLERLib::IVWRelayOutputCtrl


VisioWave SDK: Member List

VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents Member List

This is the complete list of members for VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents, including all inherited members.

LinkDown([in] BSTR TextError) | VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents
LinkUp() | VWDIGITALIOCONTROLLERLib::_IVWRelayOutputCtrlEvents


VisioWave SDK: Member List

VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl Member List

This is the complete list of members for VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl, including all inherited members.

Blocking([out, retval] BOOL *Blocking) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
Blocking([in] BOOL Blocking) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
Connect([out, retval] long *Result) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
DigitalInputStatus([out, retval] long *DigitalInputStatus) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
Disconnect() | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
GetId([out, retval] long *pInterface) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
Port([out, retval] long *Port) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
Port([in] long Port) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
Rehash([out, retval] long *Result) (defined in VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
Server([out, retval] BSTR *Hostname) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
Server([in] BSTR Hostname) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
SetGoingHighEvent([in] BSTR EventName,[out, retval] long *Result) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
SetGoingLowEvent([in] BSTR EventName,[out, retval] long *Result) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
Status([out, retval] long *Status) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
TimeOut([out, retval] long *Timeout) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl
TimeOut([in] long Timeout) | VWDIGITALIOCONTROLLERLib::IVWDigitalInputCtrl


VisioWave SDK: Member List

VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents Member List

This is the complete list of members for VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents, including all inherited members.

LinkDown([in] BSTR TextError) | VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents
LinkUp() | VWDIGITALIOCONTROLLERLib::_IVWDigitalInputCtrlEvents


VisioWave SDK: Member List

VWEVENTCONTROLLERLib::IVWEventCtrl Member List

This is the complete list of members for VWEVENTCONTROLLERLib::IVWEventCtrl, including all inherited members.

Blocking([out, retval] BOOL *pVal) | VWEVENTCONTROLLERLib::IVWEventCtrl
Blocking([in] BOOL newVal) | VWEVENTCONTROLLERLib::IVWEventCtrl
Connect([out, retval] long *pResult) | VWEVENTCONTROLLERLib::IVWEventCtrl
Disconnect() | VWEVENTCONTROLLERLib::IVWEventCtrl
ExtractBoolean([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BOOL *Result) | VWEVENTCONTROLLERLib::IVWEventCtrl
ExtractInteger([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] long *Result) | VWEVENTCONTROLLERLib::IVWEventCtrl
ExtractNumber([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] double *Result) | VWEVENTCONTROLLERLib::IVWEventCtrl
ExtractString([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BSTR *Result) | VWEVENTCONTROLLERLib::IVWEventCtrl
GetId([out, retval] long *pInterface) | VWEVENTCONTROLLERLib::IVWEventCtrl
Port([out, retval] long *pVal) | VWEVENTCONTROLLERLib::IVWEventCtrl
Port([in] long newVal) | VWEVENTCONTROLLERLib::IVWEventCtrl
Rehash([out, retval] long *pResult) (defined in VWEVENTCONTROLLERLib::IVWEventCtrl) | VWEVENTCONTROLLERLib::IVWEventCtrl
Server([out, retval] BSTR *pVal) | VWEVENTCONTROLLERLib::IVWEventCtrl
Server([in] BSTR newVal) | VWEVENTCONTROLLERLib::IVWEventCtrl
Signal([in] BSTR bstrEvent) | VWEVENTCONTROLLERLib::IVWEventCtrl
SignalEx([in] BSTR bstrEvent,[in] BSTR bstrData) | VWEVENTCONTROLLERLib::IVWEventCtrl
Status([out, retval] long *pVal) | VWEVENTCONTROLLERLib::IVWEventCtrl
Subscribe([in] BSTR bstrEvent,[out, retval] long *plEventId) | VWEVENTCONTROLLERLib::IVWEventCtrl
SubscribeEx([in] BSTR bstrEvent,[in] BSTR bstrHost,[out, retval] long *plEventId) (defined in VWEVENTCONTROLLERLib::IVWEventCtrl) | VWEVENTCONTROLLERLib::IVWEventCtrl
TimeOut([out, retval] long *pVal) | VWEVENTCONTROLLERLib::IVWEventCtrl
TimeOut([in] long newVal) | VWEVENTCONTROLLERLib::IVWEventCtrl
Unsubscribe([in] long lEventId) | VWEVENTCONTROLLERLib::IVWEventCtrl


VisioWave SDK: Member List

VWEVENTCONTROLLERLib::_IVWEventCtrlEvents Member List

This is the complete list of members for VWEVENTCONTROLLERLib::_IVWEventCtrlEvents, including all inherited members.

Event([in] BSTR bstrEvent) | VWEVENTCONTROLLERLib::_IVWEventCtrlEvents
EventEx([in] BSTR bstrEvent,[in] BSTR bstrData) | VWEVENTCONTROLLERLib::_IVWEventCtrlEvents
LinkDown([in] BSTR TextError) | VWEVENTCONTROLLERLib::_IVWEventCtrlEvents
LinkUp() | VWEVENTCONTROLLERLib::_IVWEventCtrlEvents


VisioWave SDK: Member List

VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2 Member List

This is the complete list of members for VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2, including all inherited members.

AddFileSource([in] BSTR bstrFileName,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddHardSource([in] long lCard,[in, defaultvalue(0x1206)] long lVideoFormat,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddHardSourceEx([in] long lCard, BSTR bstrVideoFormat,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddNetworkSource([in] BSTR bstrProto,[in] BSTR bstrHost,[in] long lPort,[in, defaultvalue(5000)] long lTimeOut,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddSource([in] BSTR bstrProto,[in] short nCard,[in] long lTime,[in] BSTR bstrName,[in] BSTR bstrServer,[in] long lPort,[out, retval] short *pnRet) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddSourceId([in] long lId,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddSourceOSD([in] BSTR bstrText,[in, defaultvalue(0)] BOOL bAlert) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddSourceOSD2([in] BSTR bstrText,[in, defaultvalue(0)] BOOL bAlert,[in, defaultvalue(18)] long lTextSize) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddSourceOSD3([in] long lX,[in] long lY,[in] BSTR bstrText,[in] long lTextColor,[in] long lBackgroundColor,[in, defaultvalue(18)] long lTextSize,[out, retval] long *plResult) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddSourceOSDAtIndex([in] long lSourceIndex,[in] BOOL bMainSource,[in] long lX,[in] long lY,[in] BSTR bstrText,[in] long lTextColor,[in] long lBackColor,[in] long lBackTransparency,[in] long lTextSize,[out, retval] long *plError) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddSourceOSDEx([in] long lX,[in] long lY,[in] BSTR bstrText,[in] long lTextColor,[in] long lTextFlags) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
AddSourceOSDEx2([in] long lX,[in] long lY,[in] BSTR bstrText,[in] long lTextColor,[in] long lTextFlags,[in, defaultvalue(18)] long lTextSize) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
BeginCustomCycle([in] BSTR bstrCycleMode,[in, defaultvalue(0)] long lNoAutoSwitch) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Blocking([out, retval] BOOL *pBlocking) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Blocking([in] BOOL newBlocking) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
ClearSourceOSD() (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
ClearSourceOSDAtIndex([in] long lSourceIndex,[in] BOOL bMainSource,[out, retval] long *plError) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Connect([out, retval] short *pnRet) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Disconnect() | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
EndCustomCycle() | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
ExtractBoolean([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
ExtractInteger([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
ExtractNumber([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] float *pfValue) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
ExtractString([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BSTR *pbstrValue) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
GetCardsCount([out, retval] short *pnCount) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
GetConfigsList([out, retval] BSTR *pbstrCfgs) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
GetCycleItemInfo([in] long lSourceIndex,[out, retval] BSTR *pbstrCycleItem) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
GetId([out, retval] long *pInterface) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
GetLastError([out, retval] long *plLastError) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
GetNumberOfCycleItems([out, retval] long *plNumberOfCycleItems) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
GetOSD([in] short nCard,[out, retval] BSTR *pbstrOSD) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
GetSourcesList([in] short nCard,[out, retval] short *pnRet) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
GetStat([out, retval] BSTR *pbstrStat) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
LoadConfig([in] BSTR bstrName,[out, retval] short *pnRet) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
LoadCustomCycle() | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
LoadCycle([in] BSTR bstrCycleName) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Pause() | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Port([out, retval] long *pPort) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Port([in] long newPort) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Rehash() (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
ResetCard([in] short nCard,[out, retval] short *pnRet) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
ResetCardAndSetOSD([in] short nCard,[in] BSTR bstrText,[out, retval] long *plError) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
ResetMonitor() | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Resume() | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SaveConfig([in] BSTR bstrName,[out, retval] short *pnRet) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SaveCycle([in] BSTR bstrCycleName,[in, defaultvalue(0)] long lAsDefault) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Server([out, retval] BSTR *pServer) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Server([in] BSTR newServer) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetBackupSourceId([in] long lId) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetDynamicOSD([in] BSTR bstrProto,[in] BSTR bstrHost,[in] long lPort,[in, defaultvalue(0)] long lPriorityThreshold,[in, defaultvalue(5000)] long lTimeOut,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetFileBackupSource([in] BSTR bstrFileName,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetHardBackupSource([in] long lCard,[in, defaultvalue(0x1206)] long lVideoFormat,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetLastError([in] long lLastError) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetMonitorOSD([in] BSTR bstrOSD) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetNetworkBackupSource([in] BSTR bstrProto,[in] BSTR bstrHost,[in] long lPort,[in, defaultvalue(5000)] long lTimeOut,[in, defaultvalue(-1)] long lTimeAlive,[in, defaultvalue(0)] long lSwitchingTime) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetOSD([in] short nCard,[in] long lXPos,[in] long lYPos,[in] short lfR,[in] short lfG,[in] short lfB,[in] short lbR,[in] short lbG,[in] short lbB,[in] BSTR bstrText,[out, retval] long *plLastError) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetOSDFormat([in] long lX,[in] long lY,[in] BSTR bstrText,[in] long lTextColor,[in] long lBackgroundColor,[in, defaultvalue(18)] long lTextSize,[out, retval] long *plResult) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetSource([in] BSTR bstrProto,[in] short nCard,[in] long lTime,[in] BSTR bstrName,[in] BSTR bstrServer,[in] long lPort,[out, retval] short *pnRet) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SetSourceEx([in] short nCard,[in] long lTime,[in] BSTR bstrName,[in] BSTR bstrVideoProto,[in] BSTR bstrVideoServer,[in] long lVideoPort,[in] BSTR bstrAudioProto,[in] BSTR bstrAudioServer,[in] long lAudioPort,[out, retval] short *pnRet) (defined in VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
Status([out, retval] long *pStatus) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SwitchToNextSource([in, defaultvalue(FALSE)] BOOL bBlocking,[out, retval] long *plStatus) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SwitchToPreviousSource([in, defaultvalue(FALSE)] BOOL bBlocking,[out, retval] long *plStatus) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
SwitchToSource([in] long lSourceIndex,[in, defaultvalue(FALSE)] BOOL bBlocking,[out, retval] long *plStatus) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
TimeOut([out, retval] long *pTimeOut) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2
TimeOut([in] long newTimeOut) | VWMONITORMANAGERCONTROLLERLib::IVWMonitorManagerCtrl2

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events Member List

This is the complete list of members for VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events, including all inherited members.

Connect() (defined in VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events) | VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events
LinkDown() | VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events
LinkUp() | VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events
TimedOut() (defined in VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events) | VWMONITORMANAGERCONTROLLERLib::_IVWMonitorManagerCtrl2Events


VisioWave SDK: Member List

VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl Member List

This is the complete list of members for VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl, including all inherited members.

AcknowledgeSoftAlarm([in] BSTR BstrAlarmName,[out, retval] long *plErrorCode) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Blocking([out, retval] BOOL *pVal) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Blocking([in] BOOL newVal) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Connect([out, retval] long *pResult) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Disconnect() | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
ExtractBoolean([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BOOL *pbValue) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
ExtractInteger([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
ExtractNumber([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] double *pdValue) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
ExtractString([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BSTR *pbstrValue) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
GetId([out, retval] long *pInterface) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
GetModuleInfos([out, retval] BSTR *bstrModuleInfos) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
GetSoftAlarms([out, retval] BSTR *pBstrAlarms) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
GetSoftAlarmThresholds([out, retval] BSTR *pBstrAlarmThresholds) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
GetStats([out, retval] BSTR *pBstrStats) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
GetSystemID([out, retval] BSTR *pBstrSystemID) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
GetTime([out, retval] BSTR *pBstrTime) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Port([out, retval] long *pVal) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Port([in] long newVal) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Reboot([out, retval] long *plErrorCode) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Rehash([out, retval] long *pResult) (defined in VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Server([out, retval] BSTR *pVal) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Server([in] BSTR newVal) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
SetBoardID([in] long lBoardID,[out, retval] long *plErrorCode) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
SetSoftAlarmEnabled([in] BSTR BstrAlarmName,[in] long lEnabled,[out, retval] long *plErrorCode) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
SetSoftAlarmThresholds([in] BSTR bstrAlarmName,[in] double dMinVal,[in] double dMaxVal,[out, retval] long *plErrorCode) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
SetSystemID([in] BSTR bstrSystemID,[out, retval] long *plErrorCode) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
SetTime([in] long lYear,[in] long lMonth,[in] long lDay,[in] long lHour,[in] long lMinute,[out, retval] long *plErrorCode) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
Status([out, retval] long *pVal) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
TimeOut([out, retval] long *pVal) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl
TimeOut([in] long newVal) | VWREMOTEMONITORINGCONTROLLERLib::IVWRemoteMonitoringCtrl

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents Member List

This is the complete list of members for VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents, including all inherited members.

LinkDown([in] BSTR TextError) | VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents
LinkUp() | VWREMOTEMONITORINGCONTROLLERLib::_IVWRemoteMonitoringCtrlEvents

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2 Member List

This is the complete list of members for VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2, including all inherited members.

Blocking([out, retval] BOOL *Blocking) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
Blocking([in] BOOL Blocking) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
Connect([out, retval] long *Result) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
Disconnect() | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
ExtractBoolean([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
ExtractInteger([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
ExtractNumber([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] float *pfValue) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
ExtractString([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BSTR *pbstrValue) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetFields([in] long lSourceId,[out, retval] short *pnFields) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetFPS([in] long lSourceId,[out, retval] short *pnFps) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetFrameSize([in] long lSourceId,[out, retval] short *pnFrameSize) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetFramesLost([in] long lSourceId,[out, retval] long *plFramesLost) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetId([out, retval] long *pInterface) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetLastError([out, retval] long *plLastError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetMaxFrameSize([in] long lSourceId,[out, retval] short *pnMaxFrameSize) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetMaxRate([in] long lSourceId,[out, retval] short *pnMaxRate) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetParams([in, defaultvalue(-1)] long lSourceId,[out, retval] BSTR *pbstrParams) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetQuality([in] long lSourceId,[out, retval] short *pnQuality) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetRate([in] long lSourceId,[out, retval] short *pnRate) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetStat([in, defaultvalue(-1)] long lSourceId,[out, retval] BSTR *pbstrStat) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetTemporalLevel([in, defaultvalue(-1)] long lSourceId,[out, retval] short *pnTemporalLevel) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetVideoFormat([in] long lSourceId,[out, retval] short *pnVf) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetVideoFormat2([in] long lSourceId,[out, retval] BSTR *pnVf) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetVideoInfo([in] long lSourceId,[out] short *pnVidX,[out] short *pnVidY,[out] short *pnVf,[out] short *pnFps,[out] short *pnFields,[out, retval] long *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetVideoInfo2([in] long lSourceId,[out] short *pnVidX,[out] short *pnVidY,[out] BSTR *pbstrVf,[out] short *pnFps,[out] short *pnFields,[out, retval] long *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetVidX([in] long lSourceId,[out, retval] short *pnVidX) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
GetVidY([in] long lSourceId,[out, retval] short *pnVidY) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
Port([out, retval] long *Port) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
Port([in] long Port) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
PurgeArchive([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
Rehash([out, retval] long *Result) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
RehashServer([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
RestartServer([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
SaveState([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
Server([out, retval] BSTR *Hostname) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
Server([in] BSTR Hostname) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
SetFPS([in] long lSourceId,[in] short nFps,[out, retval] long *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
SetLastError([in] long lLastError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
SetMaxFrameSize([in] long lSourceId,[in] short nFrameSize,[out, retval] long *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
SetParams([in] BSTR bstrParams,[in, defaultvalue(-1)] long lSourceId,[out, retval] long *plError) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
SetQuality([in] long lSourceId,[in] short nQuality,[out, retval] long *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
SetRate([in] long lSourceId,[in] short nRate,[out, retval] long *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
StartArchive([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
StartArchiveEx([in] BSTR bstrName,[in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
Status([out, retval] long *Status) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
StopArchive([in, defaultvalue(-1)] long lSourceId,[out, retval] short *plError) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
TimeOut([out, retval] long *Timeout) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
TimeOut([in] long Timeout) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2
VideoSignal([in] long lSourceId,[in, defaultvalue(0)] short nPeriod,[out, retval] short *pnBlack) (defined in VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2) | VWSERVERCONTROLLERLib::IVWVideoSvrCtrl2

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2 Member List

This is the complete list of members for VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2, including all inherited members.

Blocking([out, retval] BOOL *pVal) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Blocking([in] BOOL newVal) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
CallMCLFunction([in] BSTR FunctionName,[in] BSTR Parameters,[out, retval] BSTR *Result) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
CameraId([out, retval] short *pCameraId) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
CameraId([in] short newCameraId) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Connect([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Disconnect() | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Down([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
DownLeft([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
DownRight([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
ExtractBoolean([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BOOL *Result) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
ExtractInteger([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] long *Result) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
ExtractNumber([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] double *Result) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
ExtractString([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BSTR *Result) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
FocusAuto([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
FocusFar([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
FocusManual([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
FocusNear([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
GetId([out, retval] long *pInterface) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
GetNumberPrepos([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
GetPanSpeed([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
GetSpeed([out, retval] short *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
GetTiltSpeed([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
GetZoomSpeed([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Home([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Iris([in] short vIris,[out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
IrisAuto([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
IrisClose([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
IrisOpen([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Left([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
MonitorId([out, retval] short *pMonitorId) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
MonitorId([in] short newMonitorId) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Move([in] short vPan,[in] short vTilt,[out, retval] long *pnRet) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Move2([in] short vPan,[in] short vTilt,[in] short vZoom,[out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Port([out, retval] long *pVal) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Port([in] long newVal) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
RawEnd([in] BSTR bstrCommand) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
RawInstant([in] BSTR bstrCommand) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
RawStart([in] BSTR bstrCommand) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
RecallMemory([in] short nPos,[out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Right([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Server([out, retval] BSTR *pVal) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Server([in] BSTR newVal) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
SetBackLight([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
SetFocusSpeed([in] short vFocus) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
SetIrisSpeed([in] short vIris) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
SetPanSpeed([in] short vPan) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
SetSpeed([in] short vPan,[in] short vTilt) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
SetTiltSpeed([in] short vTilt) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
SetZoomSpeed([in] short vZoom) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Status([out, retval] BOOL *pVal) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
StepByStep([out, retval] BOOL *pStepByStep) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
StepByStep([in] BOOL newStepByStep) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
StopFocus([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
StopIris([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
StopMvt([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
StopZoom([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
StoreMemory([in] short nPos,[out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
StringToParam([in] BSTR String,[out, retval] BSTR *Result) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
TimeOut([out, retval] short *pVal) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
TimeOut([in] short newVal) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
UnsetBackLight([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Up([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
UpLeft([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
UpRight([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Version([out, retval] BSTR *version) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Zoom([in] short nStep,[in] short nDir) (defined in VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
Zoom2([in] short vZoom,[out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
ZoomIn([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2
ZoomOut([out, retval] long *pnRet) | VWSERVERCONTROLLERLib::IVWMobCamSvrCtrl2

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events Member List

This is the complete list of members for VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events, including all inherited members.

Connect() | VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events
LinkDown(BSTR TextError) | VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events
LinkUp() | VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events
TimedOut([in] BOOL bStatus) | VWSERVERCONTROLLERLib::_IVWMobCamSvrCtrl2Events

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events Member List

This is the complete list of members for VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events, including all inherited members.

Connect() (defined in VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events) | VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events
LinkDown() | VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events
LinkUp() | VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events
TimedOut() (defined in VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events) | VWSERVERCONTROLLERLib::_IVWVideoSvrCtrl2Events

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWSERVERCONTROLLERLib::IVWAudioSvrCtrl Member List

This is the complete list of members for VWSERVERCONTROLLERLib::IVWAudioSvrCtrl, including all inherited members.

Blocking([out, retval] BOOL *Blocking) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
Blocking([in] BOOL Blocking) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
Connect([out, retval] long *Result) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
Disconnect() | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
ExtractBoolean([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] long *Result) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
ExtractInteger([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] long *Result) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
ExtractNumber([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] float *Result) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
ExtractString([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BSTR *Result) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
GetId([out, retval] long *Result) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
GetParams([in, defaultvalue(-1)] long SourceId,[out, retval] BSTR *Result) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
GetStat([in, defaultvalue(-1)] long SourceId,[out, retval] BSTR *Result) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
Port([out, retval] long *Port) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
Port([in] long Port) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
Rehash([out, retval] long *Result) (defined in VWSERVERCONTROLLERLib::IVWAudioSvrCtrl) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
Server([out, retval] BSTR *Hostname) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
Server([in] BSTR Hostname) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
SetParams([in] BSTR Params,[in, defaultvalue(-1)] long SourceId,[out, retval] long *Result) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
Status([out, retval] long *Status) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
TimeOut([out, retval] long *Timeout) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl
TimeOut([in] long Timeout) | VWSERVERCONTROLLERLib::IVWAudioSvrCtrl

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents Member List

This is the complete list of members for VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents, including all inherited members.

LinkDown() | VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents
LinkUp() | VWSERVERCONTROLLERLib::_IVWAudioSvrCtrlEvents

Generated on Tue Oct 3 18:24:20 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl Member List

This is the complete list of members for VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl, including all inherited members.

AddFile([in] BSTR FileName,[in] BSTR DiskSpaceName,[in] BSTR SourceName,[in] BSTR AlarmName,[in] BSTR StartDate,[out, retval] long *ErrorCode) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Alarm([in] BSTR SourceName,[in] long Fps,[in] BSTR AlarmName,[in] BSTR AlarmIncidentDate,[in] BSTR AlarmIntervalStart,[in] BSTR AlarmIntervalEnd,[out, retval] long *Res) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
AlarmLogQuery([in] BSTR SourceName,[in] long Fps,[out, retval] long *QueryId) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
AlarmNamesQuery([out, retval] long *QueryId) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Blocking([out, retval] BOOL *Blocking) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Blocking([in] BOOL Blocking) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Connect([out, retval] long *Result) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
DatabaseQuery([in] BSTR Criteria,[out, retval] long *QueryId) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Disconnect() | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Erase([in] BSTR SourceName,[in] long Fps,[in] BSTR EraseIntervalStart,[in] BSTR EraseIntervalEnd,[out, retval] long *Res) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
ExtractInteger([in] BSTR Parameter,[in] BSTR Params,[out, retval] long *Value) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
ExtractString([in] BSTR Parameter,[in] BSTR Params,[out, retval] BSTR *Value) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
GetId([out, retval] long *pInterface) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
GetLastError([out, retval] BSTR *LastError) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
GetNext([in] long QueryId,[out, retval] BSTR *Item) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
LocalCopy([in] BSTR SourceName,[in] long Fps,[in] BSTR BackupPath,[in] BSTR BackupStartDate,[in] BSTR BackupEndDate,[out, retval] long *Result) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Port([out, retval] long *Port) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Port([in] long Port) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Protect([in] BSTR SourceName,[in] long Fps,[in] BSTR ProtectedIntervalStart,[in] BSTR ProtectedIntervalEnd,[in] BSTR ValidityIntervalStart,[in] BSTR ValidityIntervalEnd,[in] BSTR Details,[out, retval] long *Res) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
ProtectedLogQuery([in] BSTR SourceName,[in] long Fps,[out, retval] long *QueryId) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Rehash([out, retval] long *Result) (defined in VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
ReleaseQuery([in] long QueryId) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
RemoteCopy([in] BSTR SourceName,[in] long Fps,[in] BSTR BackupPath,[in] BSTR BackupStartDate,[in] BSTR BackupEndDate,[out, retval] long *Result) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
RemoveAlarmByDate([in] BSTR SourceName,[in] long Fps,[in] BSTR AlarmName,[in] BSTR AlarmIncidentDate,[out, retval] long *Res) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
RemoveAlarmByInterval([in] BSTR SourceName,[in] long Fps,[in] BSTR AlarmName,[in] BSTR AlarmIntervalStart,[in] BSTR AlarmIntervalEnd,[out, retval] long *Res) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Server([out, retval] BSTR *Hostname) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Server([in] BSTR Hostname) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
SourcesQuery([out, retval] long *QueryId) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Status([out, retval] long *Status) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
TimeOut([out, retval] long *Timeout) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
TimeOut([in] long Timeout) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl
Unprotect([in] BSTR SourceName,[in] long Fps,[in] BSTR ProtectedIntervalStart,[in] BSTR ProtectedIntervalEnd,[out, retval] long *Res) | VWSTORAGEACCESSCONTROLLERLib::IVWStorageAccessCtrl

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents Member List

This is the complete list of members for VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents, including all inherited members.

LinkDown(BSTR TextError) | VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents
LinkUp() | VWSTORAGEACCESSCONTROLLERLib::_IVWStorageAccessCtrlEvents

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl Member List

This is the complete list of members for VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl, including all inherited members.

AddStorage([in] BSTR Parameters,[out, retval] long *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
BeginHardStorages([in] BSTR Source,[in] long Channel,[in] BSTR Parameters,[out, retval] long *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
BeginNetworkStorages([in] BSTR Protocol,[in] BSTR Hostname,[in] long Port,[in] long TimeOut,[out, retval] long *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
Blocking([out, retval] BOOL *Blocking) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
Blocking([in] BOOL Blocking) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
Connect([out, retval] long *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
Disconnect() | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
EndStorages([out, retval] long *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
ExtractBoolean([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BOOL *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
ExtractInteger([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] long *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
ExtractNumber([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] double *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
ExtractString([in] BSTR Parameter,[in] BSTR Parameters,[out, retval] BSTR *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
GetConfig([out, retval] BSTR *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
GetId([out, retval] long *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
GetStat([out, retval] BSTR *Stat) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
Port([out, retval] long *Port) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
Port([in] long Port) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
Rehash([out, retval] long *Result) (defined in VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
Server([out, retval] BSTR *Server) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
Server([in] BSTR Server) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
StartStorages([out, retval] BSTR *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
Status([out, retval] long *Status) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
StopStorages([in] BSTR Ids,[out, retval] BSTR *Result) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
TimeOut([out, retval] long *TimeOut) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl
TimeOut([in] long TimeOut) | VWSTORAGECONTROLLERLib::IVWStorageManagerCtrl

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents Member List

This is the complete list of members for VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents, including all inherited members.

LinkDown([in] BSTR TextError) | VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents
LinkUp() | VWSTORAGECONTROLLERLib::_IVWStorageManagerCtrlEvents

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl Member List

This is the complete list of members for VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl, including all inherited members.

AcknowledgeAlarm([in] BSTR BstrAlarmName,[out, retval] long *plErrorCode) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
Blocking([out, retval] BOOL *pVal) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
Blocking([in] BOOL newVal) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
Connect([out, retval] long *pResult) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
Disconnect() | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
ExtractBoolean([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BOOL *pbValue) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
ExtractInteger([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] long *plValue) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
ExtractNumber([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] double *pdValue) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
ExtractString([in] BSTR bstrParameter,[in] BSTR bstrParams,[out, retval] BSTR *pbstrValue) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetAlarms([out, retval] BSTR *pBstrAlarms) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetAlarmThresholds([out, retval] BSTR *pBstrAlarmThresholds) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetAudioPortsStats([out, retval] BSTR *pBstrAudioPortsStats) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetDiskInfos([out, retval] BSTR *pBstrDiskInfos) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetId([out, retval] long *pInterface) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetNetworkAdapterInfos([out, retval] BSTR *pBstrNetworkAdapterInfos) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetNetworkAdapterStats([in] long lIndex,[out, retval] BSTR *pBstrNetworkAdapterStats) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetPluginInfos([in]BSTR bstrPluginId,[out, retval] BSTR *pBstrPluginInfos) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetRaidStatus([in] long lIndex,[out, retval] BSTR *pBstrRaidStatus) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetSmartStatus([in] long lIndex,[out, retval] BSTR *pBstrSmartStatus) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetSystemHealthStats([out, retval] BSTR *pBstrSystemHealthStats) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetSystemInfos([out, retval] BSTR *pBstrSystemInfos) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetUptime([out, retval] BSTR *pBstrUptime) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetVideoCircuits([out, retval] BSTR *pBstrVideoCircuits) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
GetVideoPortsStats([out, retval] BSTR *pBstrVideoPortsStats) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
ListPlugins([out, retval] BSTR *pBstrPlugins) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
Port([out, retval] long *pVal) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
Port([in] long newVal) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
Rehash([out, retval] long *pResult) (defined in VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
SelectMonitoredChannel([in] long lEnabled,[out, retval] BOOL *pbSuccess) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
Server([out, retval] BSTR *pVal) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
Server([in] BSTR newVal) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
SetAlarmEnabled([in] BSTR BstrAlarmName,[in] long lEnabled,[out, retval] long *plErrorCode) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
SetAlarmThresholds([in] BSTR BstrAlarmName,[in] double dMinVal,[in] double dMaxVal,[out, retval] long *plErrorCode) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
SoftReboot([out, retval] BOOL *pbSuccess) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
Status([out, retval] long *pVal) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
TimeOut([out, retval] long *pVal) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl
TimeOut([in] long newVal) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::IVWVideoEquipmentManagerCtrl

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents Member List

This is the complete list of members for VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents, including all inherited members.

LinkDown([in] BSTR TextError) | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents
LinkUp() | VWVIDEOEQUIPMENTMANAGERCONTROLLERLib::_IVWVideoEquipmentManagerCtrlEvents

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl Member List

This is the complete list of members for XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl, including all inherited members.

ForbidBlocking() | XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
SetConnectionMode([in] BOOL Blocking) | XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
SetId([in] long Id) | XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
SetPort([in] long Port) | XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
SetServer([in] BSTR Server) | XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
SetTimeout([in] long TimeOut) | XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl
UpdateStatus() | XVWCONNECTIONCONTROLLERLib::IVWConnectionCtrl

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents Member List

This is the complete list of members for XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents, including all inherited members.

Connect(BOOL bBlocking) | XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents
Disconnect() | XVWCONNECTIONCONTROLLERLib::_IVWConnectionCtrlEvents

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

XVWDISPLAYLib::IVWActiveXComponent Member List

This is the complete list of members for XVWDISPLAYLib::IVWActiveXComponent, including all inherited members.

AddSource([in] BSTR bstrURL,[out, retval] long *plSourceId) | XVWDISPLAYLib::IVWActiveXComponent
AttachSoundSourceId([in] long lVideoSourceId,[in] long lSoundSourceId,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
AttachSourceOsdId([in] long lVideoSourceId,[in] long lOsdSourceId,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
AutoSize([out, retval]VARIANT_BOOL *pbool) | XVWDISPLAYLib::IVWActiveXComponent
AutoSize([in]VARIANT_BOOL vbool) (defined in XVWDISPLAYLib::IVWActiveXComponent) | XVWDISPLAYLib::IVWActiveXComponent
BackColor([out, retval] OLE_COLOR *pVal) | XVWDISPLAYLib::IVWActiveXComponent
BackColor([in] OLE_COLOR newVal) (defined in XVWDISPLAYLib::IVWActiveXComponent) | XVWDISPLAYLib::IVWActiveXComponent
BufferingRecordOn([in] long lSourceId,[in] short sType,[in] double RealFPS,[in] BSTR bstrName,[in] BSTR bstrFormat,[in] long lNBuffers,[in] long lBuffersSize,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
CaptureScreen([in] BSTR bstrPath,[in] BSTR bstrName,[in] BSTR bstrFormat,[in] short sQuality,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
CenterZoom([out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
ClearOsd([in] short sNumber) | XVWDISPLAYLib::IVWActiveXComponent
ConnectId([in] long lSourceId,[in] short sType,[in] BOOL bBlocking,[in] long lTimeOut,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
DecoderColorMode([out, retval] long *pVal) | XVWDISPLAYLib::IVWActiveXComponent
DecoderColorMode([in] long newVal) (defined in XVWDISPLAYLib::IVWActiveXComponent) | XVWDISPLAYLib::IVWActiveXComponent
DecoderMode([out, retval] long *pVal) | XVWDISPLAYLib::IVWActiveXComponent
DecoderMode([in] long newVal) (defined in XVWDISPLAYLib::IVWActiveXComponent) | XVWDISPLAYLib::IVWActiveXComponent
DecoderParity([out, retval] long *pVal) | XVWDISPLAYLib::IVWActiveXComponent
DecoderParity([in] long newVal) (defined in XVWDISPLAYLib::IVWActiveXComponent) | XVWDISPLAYLib::IVWActiveXComponent
DecoderSize([out, retval] long *pVal) | XVWDISPLAYLib::IVWActiveXComponent
DecoderSize([in] long newVal) (defined in XVWDISPLAYLib::IVWActiveXComponent) | XVWDISPLAYLib::IVWActiveXComponent
DetachSoundSourceId([in] long lVideoSourceId,[in] long lSoundSourceId,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
DetachSourceOsdId([in] long lSourceId,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
DisconnectId([in] long lSourceId,[in] short sType,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
DisplayOsd([in] BSTR bstrText,[in] long lX,[in] long lY,[in] OLE_COLOR TextClr,[in] OLE_COLOR BackClr,[in] short sAlpha,[in] short sNumber,[out, retval] long *plOsdId) | XVWDISPLAYLib::IVWActiveXComponent
DragAcceptFiles([in] BOOL bAccept,[out, retval] BOOL *pWasAccepted) | XVWDISPLAYLib::IVWActiveXComponent
EnumSourcesIdsBegin([out, retval] long *plSourcesIdsCount) | XVWDISPLAYLib::IVWActiveXComponent
EnumSourcesIdsEnd(void) | XVWDISPLAYLib::IVWActiveXComponent
EnumSourcesIdsNext([out, retval] long *plSourceId) | XVWDISPLAYLib::IVWActiveXComponent
FreezeEvents([in] BOOL bFreeze,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
FullScreenOff([out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
FullScreenOn([in] short sMode,[in] BOOL bSync,[in] short iWidth,[in] short iHeight,[in] short iFreq,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
GetActiveSourceId([out, retval] long *pVal) | XVWDISPLAYLib::IVWActiveXComponent
GetAttachedCount([in] long lSourceId,[out, retval] long *plSources) | XVWDISPLAYLib::IVWActiveXComponent
GetBitsPerSample([in] long lSourceId,[out, retval] short *pnBitsPerSample) | XVWDISPLAYLib::IVWActiveXComponent
GetChannels([in] long lSourceId,[out, retval] short *pnChannels) | XVWDISPLAYLib::IVWActiveXComponent
GetChunk([in] long lSourceId,[out, retval] short *pnChunk) | XVWDISPLAYLib::IVWActiveXComponent
GetDC([out, retval] long *plDC) | XVWDISPLAYLib::IVWActiveXComponent
GetErrorText([in] long lErrorCode,[out, retval] BSTR *pbstrErrorText) | XVWDISPLAYLib::IVWActiveXComponent
GetFields([in] long lSourceId,[out, retval] short *pnFields) | XVWDISPLAYLib::IVWActiveXComponent
GetFPS([in] long lSourceId,[out, retval] short *psFPS) | XVWDISPLAYLib::IVWActiveXComponent
GetFrame([out, retval] long *plFrame) | XVWDISPLAYLib::IVWActiveXComponent
GetFrameSize([in] long lSourceId,[out, retval] short *pnFS) | XVWDISPLAYLib::IVWActiveXComponent
GetFramesLost([out, retval] long *plFL) | XVWDISPLAYLib::IVWActiveXComponent
GetFramesLostEx([in] long lSourceId,[out, retval] long *plFL) | XVWDISPLAYLib::IVWActiveXComponent
GetInfo([in] BSTR bstrCommand,[out, retval] long *psInfo) | XVWDISPLAYLib::IVWActiveXComponent
GetLastError([out, retval] long *plLastErrori) | XVWDISPLAYLib::IVWActiveXComponent
GetMaxFrameSize([in] long lSourceId,[out, retval] short *pnMFS) | XVWDISPLAYLib::IVWActiveXComponent
GetMaxRate([in] long lSourceId,[out, retval] long *plMaxRate) | XVWDISPLAYLib::IVWActiveXComponent
GetPropertyBag([in] long lSourceId,[in] short sType,[out, retval] BSTR *pbstrProperties) | XVWDISPLAYLib::IVWActiveXComponent
GetQuality([in] long lSourceId,[out, retval] short *pnQuality) | XVWDISPLAYLib::IVWActiveXComponent
GetRate([out, retval] long *plRate) | XVWDISPLAYLib::IVWActiveXComponent
GetRateEx([in] long lSourceId,[out, retval] long *plRate) | XVWDISPLAYLib::IVWActiveXComponent
GetRealFPS([out, retval] float *pfRealFPS) | XVWDISPLAYLib::IVWActiveXComponent
GetSampleRate([in] long lSourceId,[out, retval] long *plSampleRate) | XVWDISPLAYLib::IVWActiveXComponent
GetSkippedFields([in] long lSourceId,[out] long *plVFields,[out] long *plAFields,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
GetSoundInfo([in] long lSourceId,[out] long *plSampleRate,[out] short *pnChannels,[out] short *pnBitsPerSample,[out] short *pnChunk,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
GetSource([in] long lSourceId,[in] short sSource,[out, retval] long *plSourceId) | XVWDISPLAYLib::IVWActiveXComponent
GetSourceCategory([in] short sType,[in] long lSourceId,[out, retval] short *psSourceCat) | XVWDISPLAYLib::IVWActiveXComponent
GetSourcePort([in] short sType,[in] long lSourceId,[out, retval] short *pPort) | XVWDISPLAYLib::IVWActiveXComponent
GetSourceProtocol([in] short sType,[in] long lSourceId,[out, retval] short *psSourceProto) | XVWDISPLAYLib::IVWActiveXComponent
GetSourceType([in] long lSourceId,[out, retval] short *psSourceType) | XVWDISPLAYLib::IVWActiveXComponent
GetSourceURL([in] long lSourceId,[out, retval] BSTR *pVal) | XVWDISPLAYLib::IVWActiveXComponent
GetSourceURLEx([in] short sType,[in] long lSourceId,[out, retval] BSTR *pBSTR) | XVWDISPLAYLib::IVWActiveXComponent
GetTemporalLevel([in] long lSourceId,[out, retval] short *pnTemporalLevel) | XVWDISPLAYLib::IVWActiveXComponent
GetTime([out, retval] float *pfTime) | XVWDISPLAYLib::IVWActiveXComponent
GetTotalBytes([in] long lSourceId,[out, retval] long *plBytes) | XVWDISPLAYLib::IVWActiveXComponent
GetTotalFrames([out, retval] long *plFrames) | XVWDISPLAYLib::IVWActiveXComponent
GetTotalFramesEx([in] long lSourceId,[out, retval] long *plFrames) | XVWDISPLAYLib::IVWActiveXComponent
GetTotalTime([out, retval] float *pfTime) | XVWDISPLAYLib::IVWActiveXComponent
GetTotalTimeEx([in] long lSourceId,[out, retval] float *pfTime) | XVWDISPLAYLib::IVWActiveXComponent
GetVideoFormat([in] long lSourceId,[out, retval] short *pnVf) | XVWDISPLAYLib::IVWActiveXComponent
GetVideoInfo([in] long lSourceId,[out] short *pnVidX,[out] short *pnVidY,[out] short *pnVf,[out] short *pnFps,[out] short *pnFields,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
GetVidX([in] long lSourceId,[out, retval] short *pnVidX) | XVWDISPLAYLib::IVWActiveXComponent
GetVidY([in] long lSourceId,[out, retval] short *pnVidY) | XVWDISPLAYLib::IVWActiveXComponent
GetVWBoards([out, retval] short *psNumber) | XVWDISPLAYLib::IVWActiveXComponent
GetWindow([out, retval] long *plWindow) | XVWDISPLAYLib::IVWActiveXComponent
GetZoom([out, retval] float *pfZoom) | XVWDISPLAYLib::IVWActiveXComponent
HasSync([in] short nNumber,[out, retval] short *pnHasSync) | XVWDISPLAYLib::IVWActiveXComponent
IsAttached([in] long lSourceId,[out, retval] long *plSources) | XVWDISPLAYLib::IVWActiveXComponent
IsConnected([in] long lSourceId,[out, retval] short *piConnected) | XVWDISPLAYLib::IVWActiveXComponent
IsFullScreen([out, retval] short *psMode) | XVWDISPLAYLib::IVWActiveXComponent
IsLooping([out, retval] BOOL *pbLooping) | XVWDISPLAYLib::IVWActiveXComponent
IsPlayingVWBoard([in] short sNumber,[out, retval] long *plSourceId) | XVWDISPLAYLib::IVWActiveXComponent
IsRecording([in] long lSourceId,[out, retval] short *piRecording) | XVWDISPLAYLib::IVWActiveXComponent
IsValidId([in] long lSourceId,[out, retval] BOOL *pbValid) | XVWDISPLAYLib::IVWActiveXComponent
LoadPicture([in] BSTR bstrURL,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
LoadWinSock2(void) | XVWDISPLAYLib::IVWActiveXComponent
Loop([in] BOOL bLoop) | XVWDISPLAYLib::IVWActiveXComponent
MoveZoom([in] long lxPos,[in] long lyPos,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
NextSource([out, retval] long *lSourceId) | XVWDISPLAYLib::IVWActiveXComponent
OutputToVWBoardOff([in] short sNumber,[out, retval] long *plSourceId) | XVWDISPLAYLib::IVWActiveXComponent
OutputToVWBoardOn([in] long lSourceId,[in] short sNumber,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
OutputToVWBoardOnEx([in] long lSourceId,[in] short sNumber,[in] short nVideoFormat,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
Pause([in] short sType,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
Picture([in]IPictureDisp *pPicture) | XVWDISPLAYLib::IVWActiveXComponent
Picture([in]IPictureDisp *pPicture) (defined in XVWDISPLAYLib::IVWActiveXComponent) | XVWDISPLAYLib::IVWActiveXComponent
Picture([out, retval]IPictureDisp **ppPicture) (defined in XVWDISPLAYLib::IVWActiveXComponent) | XVWDISPLAYLib::IVWActiveXComponent
PreviousSource([out, retval] long *lSourceId) | XVWDISPLAYLib::IVWActiveXComponent
PrintScreen([in] long lDisplaySetup,[in] BSTR bstrDocName,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
RecordOff([in] long lSourceId,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
RecordOn([in] long lSourceId,[in] short sType,[in] double RealFPS,[in] BSTR bstrName,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
RecordOnEx([in] long lSourceId,[in] short sType,[in] double RealFPS,[in] BSTR bstrName,[in] BSTR bstrFormat,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
Refresh(void) | XVWDISPLAYLib::IVWActiveXComponent
ReleaseDC([in] long lDC,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
RemoveOsd([in] long lOsdId) | XVWDISPLAYLib::IVWActiveXComponent
RemoveSourceId([in] long lSourceId,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
RemoveText([in] long lTextId) | XVWDISPLAYLib::IVWActiveXComponent
Resume([in] short sType,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
Running([out, retval] short *pVal) | XVWDISPLAYLib::IVWActiveXComponent
SeekFrame([in] long lFrame,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
SeekTime([in] float fTime,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
SetActiveSourceId([in] long newVal,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
SetLastError([in] long lLastError) | XVWDISPLAYLib::IVWActiveXComponent
SetQuality([in] long lSourceId,[in] short nQuality,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
SetQueue([in] long lSourceId,[in] short sType,[in] short sQueue,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
SetRate([in] float fRate,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
SetVideoFormat([in] long lSourceId,[in] short nVf,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
ShowCursor([in] BOOL bShow) | XVWDISPLAYLib::IVWActiveXComponent
Start([in] short sType,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
Stop([in] short sType,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
Synchronize([in] BOOL bSync,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent
TextOut([in] BSTR bstrText,[in] long lX,[in] long lY,[in] OLE_COLOR BackClr,[in] OLE_COLOR TextClr,[out, retval] long *plTextId) | XVWDISPLAYLib::IVWActiveXComponent
TextOutEx([in] BSTR bstrText,[in] long lX,[in] long lY,[in] OLE_COLOR BackClr,[in] OLE_COLOR TextClr,[in, defaultvalue("")] BSTR bstrFontName,[in, defaultvalue(0)] long lPointSize,[in, defaultvalue(FALSE)] BOOL bBold,[in, defaultvalue(FALSE)] BOOL bItalic,[in, defaultvalue(FALSE)] BOOL bUnderline,[in, defaultvalue(FALSE)] BOOL bStrikeOut,[out, retval] long *plTextId) | XVWDISPLAYLib::IVWActiveXComponent
UnloadWinSock2(void) | XVWDISPLAYLib::IVWActiveXComponent
UpdateOsd([in] long lOsdId,[in] BSTR bstrText,[in] OLE_COLOR TextClr,[in] OLE_COLOR BackClr,[in] short sAlpha) | XVWDISPLAYLib::IVWActiveXComponent
VideoHeight([out, retval] short *pVal) | XVWDISPLAYLib::IVWActiveXComponent
VideoMode([out, retval] long *pVal) | XVWDISPLAYLib::IVWActiveXComponent
VideoMode([in] long newVal) (defined in XVWDISPLAYLib::IVWActiveXComponent) | XVWDISPLAYLib::IVWActiveXComponent
VideoWidth([out, retval] short *pVal) | XVWDISPLAYLib::IVWActiveXComponent
VideoZoom([out, retval] long *pVal) | XVWDISPLAYLib::IVWActiveXComponent
VideoZoom([in] long newVal) (defined in XVWDISPLAYLib::IVWActiveXComponent) | XVWDISPLAYLib::IVWActiveXComponent
Zoom([in] float fScale,[out, retval] long *plError) | XVWDISPLAYLib::IVWActiveXComponent

Generated on Tue Oct 3 18:24:22 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

XVWDISPLAYLib::_IVWActiveXComponentEvents Member List

This is the complete list of members for XVWDISPLAYLib::_IVWActiveXComponentEvents, including all inherited members.

Char([in] short cKey) | XVWDISPLAYLib::_IVWActiveXComponentEvents
Connect([in] long lSourceId,[in] short sType) | XVWDISPLAYLib::_IVWActiveXComponentEvents
DisplayModes([in] long lMode) | XVWDISPLAYLib::_IVWActiveXComponentEvents
DropFiles([in] long lCount,[in] long lIndex,[in] BSTR bstrFile,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
Eof() | XVWDISPLAYLib::_IVWActiveXComponentEvents
EraseBkgnd() | XVWDISPLAYLib::_IVWActiveXComponentEvents
Error([in] long lCode,[in] long lSourceId,[in] short sType) | XVWDISPLAYLib::_IVWActiveXComponentEvents
Frame() | XVWDISPLAYLib::_IVWActiveXComponentEvents
KeyDown([in] short cKey) | XVWDISPLAYLib::_IVWActiveXComponentEvents
KeyUp([in] short cKey) | XVWDISPLAYLib::_IVWActiveXComponentEvents
LButtonDblClk([in] short sFlag,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
LButtonDown([in] short sFlag,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
LButtonUp([in] short sFlag,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
MButtonDblClk([in] short sFlag,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
MButtonDown([in] short sFlag,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
MButtonUp([in] short sFlag,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
MouseMove([in] short sFlag,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
MouseWheel([in] short sFlag,[in] long lxPos,[in] long lyPos,[in] short sRot) | XVWDISPLAYLib::_IVWActiveXComponentEvents
RButtonDblClk([in] short sFlag,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
RButtonDown([in] short sFlag,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
RButtonUp([in] short sFlag,[in] long lxPos,[in] long lyPos) | XVWDISPLAYLib::_IVWActiveXComponentEvents
SysKeyDown([in] short cKey) | XVWDISPLAYLib::_IVWActiveXComponentEvents
SysKeyUp([in] short cKey) | XVWDISPLAYLib::_IVWActiveXComponentEvents

Generated on Tue Oct 3 18:24:21 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

XVWTIMELINELib::IVWTimeLine Member List

This is the complete list of members for XVWTIMELINELib::IVWTimeLine, including all inherited members.

AddQueryResults([in] BSTR Host,[in] long Port,[in] long QueryId,[out, retval] long *Error) | XVWTIMELINELib::IVWTimeLine
AddQueryTimeSpan([in] BSTR Host,[in] long Port,[in] BSTR Name,[in] long FPS,[in, defaultvalue("")] BSTR Start,[in, defaultvalue("")] BSTR End,[out, retval] long *Result) | XVWTIMELINELib::IVWTimeLine
Clear() | XVWTIMELINELib::IVWTimeLine
GetAlarmName([in] long TimeSpanId,[in] long AlarmNumber,[out, retval] BSTR *AlarmName) | XVWTIMELINELib::IVWTimeLine
GetCurrentPosition([out, retval] BSTR *CurrentPosition) | XVWTIMELINELib::IVWTimeLine
GetEnd([in] long Id,[out, retval] BSTR *End) | XVWTIMELINELib::IVWTimeLine
GetFirstTimeSpan([in] long SourceId,[in, defaultvalue("")] BSTR Start,[in, defaultvalue("")] BSTR End,[out, retval] long *Result) | XVWTIMELINELib::IVWTimeLine
GetFPS([in] long SourceId,[out, retval] long *FPS) | XVWTIMELINELib::IVWTimeLine
GetHost([in] long SourceId,[out, retval] BSTR *Host) | XVWTIMELINELib::IVWTimeLine
GetLeftMarker([out, retval] BSTR *LeftMarker) | XVWTIMELINELib::IVWTimeLine
GetMaxEnd([out, retval] BSTR *MaxEnd) | XVWTIMELINELib::IVWTimeLine
GetMinStart([out, retval] BSTR *MinStart) | XVWTIMELINELib::IVWTimeLine
GetName([in] long SourceId,[out, retval] BSTR *Name) | XVWTIMELINELib::IVWTimeLine
GetNextTimeSpan([in] long TimeSpanId,[out, retval] long *Error) | XVWTIMELINELib::IVWTimeLine
GetNumberOfAlarms([in] long TimeSpanId,[out, retval] long *NumberOfAlarms) | XVWTIMELINELib::IVWTimeLine
GetNumberOfSources([out, retval] long *NumberOfSources) | XVWTIMELINELib::IVWTimeLine
GetPort([in] long SourceId,[out, retval] long *Port) | XVWTIMELINELib::IVWTimeLine
GetRightMarker([out, retval] BSTR *RightMarker) | XVWTIMELINELib::IVWTimeLine
GetSourceId([in] long Source,[out, retval] long *Result) | XVWTIMELINELib::IVWTimeLine
GetStart([in] long Id,[out, retval] BSTR *Start) | XVWTIMELINELib::IVWTimeLine
GetStream([in] long SourceId,[out, retval] long *Stream) | XVWTIMELINELib::IVWTimeLine
GetType([in] long SourceId,[out, retval] long *Type) | XVWTIMELINELib::IVWTimeLine
GetTypeEx([in] long SourceId,[out, retval] long *Type) | XVWTIMELINELib::IVWTimeLine
GetVisibleRangeLeft([out, retval] BSTR *VisibleRangeLeft) | XVWTIMELINELib::IVWTimeLine
GetVisibleRangeRight([out, retval] BSTR *VisibleRangeRight) | XVWTIMELINELib::IVWTimeLine
GUI([out, retval] BOOL *GUI) | XVWTIMELINELib::IVWTimeLine
GUI([in] BOOL GUI) | XVWTIMELINELib::IVWTimeLine
IsHighlighted([in] long TimeSpanId,[out, retval] BOOL *Highlighted) | XVWTIMELINELib::IVWTimeLine
IsPaused([out, retval] BOOL *Paused) | XVWTIMELINELib::IVWTimeLine
IsProtected([in] long TimeSpanId,[out, retval] BOOL *Protected) | XVWTIMELINELib::IVWTimeLine
LocalToUtc([in] BSTR LocalTime,[out, retval] BSTR *UtcTime) | XVWTIMELINELib::IVWTimeLine
LoopPlayback([out, retval] BOOL *LoopPlayback) | XVWTIMELINELib::IVWTimeLine
LoopPlayback([in] BOOL LoopPlayback) | XVWTIMELINELib::IVWTimeLine
Pause([out, retval] long *Error) | XVWTIMELINELib::IVWTimeLine
Play([in, defaultvalue(TRUE)] BOOL Resume,[out, retval] long *Error) | XVWTIMELINELib::IVWTimeLine
Refresh() | XVWTIMELINELib::IVWTimeLine
RemoveQueryTimeSpan([in] long SourceId,[in, defaultvalue("")] BSTR Start,[in, defaultvalue("")] BSTR End,[out, retval] long *Error) | XVWTIMELINELib::IVWTimeLine
Seek([in] BSTR Position,[out, retval] long *Error) | XVWTIMELINELib::IVWTimeLine
SetGUIParams([in] BSTR Parameters,[out, retval] long *Error) | XVWTIMELINELib::IVWTimeLine
SetLatency([in] long Latency,[out, retval] long *Error) | XVWTIMELINELib::IVWTimeLine
SetLeftMarker([in] BSTR LeftMarker) | XVWTIMELINELib::IVWTimeLine
SetPlayRate([in] long Numerator,[in] long Denominator,[out, retval] long *Error) | XVWTIMELINELib::IVWTimeLine
SetRightMarker([in] BSTR RightMarker) | XVWTIMELINELib::IVWTimeLine
SetTimeOut([in] long TimeOut) | XVWTIMELINELib::IVWTimeLine
SetVisibleRange([in] BSTR Start,[in] BSTR End) | XVWTIMELINELib::IVWTimeLine
Step([out, retval] long *Error) | XVWTIMELINELib::IVWTimeLine
SyncPlayback([out, retval] BOOL *SyncPlayback) | XVWTIMELINELib::IVWTimeLine
SyncPlayback([in] BOOL SyncPlayback) | XVWTIMELINELib::IVWTimeLine
TimeZone([out, retval] BSTR *TimeZone) | XVWTIMELINELib::IVWTimeLine
TimeZone([in] BSTR TimeZone) | XVWTIMELINELib::IVWTimeLine
UtcToLocal([in] BSTR UtcTime,[out, retval] BSTR *LocalTime) | XVWTIMELINELib::IVWTimeLine
Zoom([in] long ZoomFactor) | XVWTIMELINELib::IVWTimeLine

Generated on Tue Oct 3 18:24:23 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Member List

XVWTIMELINELib::_IVWTimeLineEvents Member List

This is the complete list of members for XVWTIMELINELib::_IVWTimeLineEvents, including all inherited members.

LeftMarkerReached([in] BSTR LeftMarker) | XVWTIMELINELib::_IVWTimeLineEvents
RightMarkerReached([in] BSTR RightMarker) | XVWTIMELINELib::_IVWTimeLineEvents

Generated on Tue Oct 3 18:24:22 2006 for VisioWave SDK by doxygen 1.4.3


VisioWave SDK: Main Page

VisioWave SDK Documentation

2.2 SP6

Generated on Tue Oct 3 18:24:18 2006 for VisioWave SDK by doxygen 1.4.3